Morphs from G3 to G8

1394042444571

Comments

  • RedzRedz Posts: 1,459

    In order to be sure, I recreated your mistake. And I can say, with certainty, I still have no idea what an implementation error is.

    I can't replicate that. But it sounds bad. Best guess, you aren't using studio 4.10? You are running something not compatible, with your version, either G8 or my script?

    That said, you are missing a step. Given that youmay have the wronf Studio version, doing it right may not help, but I don't know that for sure. But:
    "general\dzscene.cpp(5707): Index out of range in DzScene::getSelectedNode()

    Script Error: Line 685
    TypeError: Result of expression 'oSrcNode' [null] is not an object.

    " Means you haven't selected both figures. Select the figure you are transfering FROM first. Then CTRL click (Command click for silly mac people) the second figure. Also, it probably doesn't matter, but maybe it does. In fact, assume it does. You shouldn't move or pose the figures.

    I'm using 4.10 and I am trying to go from G8 to G3, which I thought was supported.  Let me try again.

    G8 to G3 is supported. As I said, the qwidget errors I can't replicate. I'm not sure they are related to the script. Maybe, maybe not.

    The error in red is a result of not having both figures selected.

    Redz said:

    Also, I just tried various Morpheus morphs, and can’t get those to transfer either. They give the same error as Gades. This is strange, because I must have managed to transfer his body morphs with some older version of the script. (Only the body shapes had transferred though, not the head and face morphs that are in different sub-folders. 

    I've put together a basic script to pull the data. You can run it in the script IDE or copy the results from the log file. It will tell me what the script is seeing when it runs. You only need one figure selected to run this tester. It's named Gades, but it will test anything for this problem. Probably belaboring the point, but you do need to select the favorite to tell it which morph to test, and it will probably test multiple morphs at the same time.

    EDIT: Changed the order of steps to be sure it doesn't error out before generating some data at 11:12 my time. 8 minutes past the post time stamp.

    Okay. I loaded G8M, favourited  Gades and ran the script. This is the log file

    2018-02-09 17:34:42.781 Loaded file: Genesis 8 Basic Male.duf
    2018-02-09 17:34:46.150 Loaded image G8MBaseLegsMapD_1003.jpg
    2018-02-09 17:34:46.442 Loaded image G8MBaseEyesMap02D_1007.jpg
    2018-02-09 17:34:47.316 Loaded image G8MBaseArmsMapD_1004.jpg
    2018-02-09 17:34:47.643 Loaded image G8MBaseMouthMapD_1005.jpg
    2018-02-09 17:34:48.514 Loaded image G8MBaseFaceMapD01_1001.jpg
    2018-02-09 17:34:49.352 Loaded image G8MBaseTorsoMapD_1002.jpg
    2018-02-09 17:34:49.610 Loaded image G8MBaseEyelashesMapTR_1006.jpg
    2018-02-09 17:34:55.206 Loaded image GadesFBM.png
    2018-02-09 17:34:55.216 Loaded image GadesFBM.png
    2018-02-09 17:35:02.172 WARNING: cloud\dzcloudtasknotifier.cpp(178): peer performed orderly shutdown errno=0
    2018-02-09 17:35:16.996 Loading script: E:/My DAZ 3D Library/Scripts/Morph Transfer Prototype/GadesTester.dsa
    2018-02-09 17:35:17.386 DEBUG: {"objectName":"Gades","name":"Gades","elementID":3220,"assetUri":{},"assetSource":{},"assetId":"Gades","assetAuthor":{},"assetFileRevision":{},"assetModifiedDate":"2018-02-06T17:24:17.000Z"}
    2018-02-09 17:35:17.387 DEBUG: Name: Gades
    2018-02-09 17:35:17.398 DEBUG: URI: E:/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Male/Morphs/Guruvar/Gades/Gades.dsf
    2018-02-09 17:35:17.399 DEBUG: Vendor: Guruvar
    2018-02-09 17:35:17.399 DEBUG: Product: Gades
    2018-02-09 17:35:17.495 Script executed successfully: E:/My DAZ 3D Library/Scripts/Morph Transfer Prototype/GadesTester.dsa

     

  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018

    I hesitate to bring this up, but I will in hopes that it helps. I'm getting the same error as @Redz no matter which figure I try to transfer from G3F to G8F. I've yet to be successful in running the script.

    2018-02-09 11:29:44.364 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 11:29:44.449 WARNING: Script Error: Line 2502018-02-09 11:29:44.449 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.2018-02-09 11:29:44.449 WARNING: Stack Trace:    <anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:2502018-02-09 11:29:44.458 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

     

    I've followed the instructions and have my "My Daz 3D Library" as my first folder on Content Directory Manager > Daz Studio Format.

    This is where I've saved the script:

    W:\DAZ RESOURCES\My DAZ 3D Library\Scripts\Morph Transfer Prototype

    I've also attempted:

    • favoring multiple morphs vs only one morph = same error.
    • I've loaded the figures from DazConnect as an actor = same error.
    • I've tried loading the G3 basic female then adding the shape via My Daz 3D Library = same error.
    • I've tried loading the G3 basic female then dialing the shape = same error.

    The figures I've tried transferring to G8F are:

    1. FW Sushmita HD for Victoria 7

    2. FW Brooke HD for Victoria 7

    3. Mika 7
    ContentLibrary.PNG
    1543 x 904 - 48K
    Post edited by FenixPhoenix on
  • RbugRbug Posts: 136

    Remove the files.

    This is probably going to sound mean, but this is not something I can handhold you through.

    Based on the way this script works it can't create duplicate formulas that I know of. That said, if it did, I'd like to troubleshoot it because that needs to be fixed.

    That said, this is an at your own risk script. If all you want out of it is a quick transfer and see ya, that's fine. But in that case, it's up to you to locate the files and remove them if it goes wrong. All the information you need to do that is in the Daz documentation center for the Bethany 7 product under the file list link. The only thing is where the docs say Genesis 3 you will look for Genesis 8.

    On the other hand, if you want to help development, post up your log and I'll see what I can do.

    To be clear, I'm not claiming the script didn't break stuff. That's the risk. But the most likely cause is that you have another copy of Bethany 7 already transfered via different means. The second most likely cause is a basic product conflict. The only thing that has an obvious potential to generate duplicate IDs is a transfer to G3F, but there's always potential for the unexpected. But the answer to "how do I fix this," is "look up where the files went and delete the files." The answer to "how do I help you prevent this," is my making a better script and telling you how to fix your issue while I'm at it.

    OK well I located the file it created and for some reason it had an odd name to it. like in this case Rbug/Alt_Eva7. now i do have the alt eva7 files but in there was nothing that would indicate that this was the issue. So I deleted the Rbug folder and everything in there and it corrected the problem. Thanks for your help

     

  • RedzRedz Posts: 1,459

    I hesitate to bring this up, but I will in hopes that it helps. I'm getting the same error as @Redz no matter which figure I try to transfer from G3F to G8F. I've yet to be successful in running the script.

    2018-02-09 11:29:44.364 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 11:29:44.449 WARNING: Script Error: Line 2502018-02-09 11:29:44.449 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.2018-02-09 11:29:44.449 WARNING: Stack Trace:    <anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:2502018-02-09 11:29:44.458 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

     

    I've followed the instructions and have my "My Daz 3D Library" as my first folder on Content Directory Manager > Daz Studio Format.

    This is where I've saved the script:

    W:\DAZ RESOURCES\My DAZ 3D Library\Scripts\Morph Transfer Prototype

    I've also attempted:

    • favoring multiple morphs vs only one morph = same error.
    • I've loaded the figures from DazConnect as an actor = same error.
    • I've tried loading the G3 basic female then adding the shape via My Daz 3D Library = same error.
    • I've tried loading the G3 basic female then dialing the shape = same error.

    The figures I've tried transferring to G8F are:

    1. FW Sushmita HD for Victoria 7

    2. FW Brooke HD for Victoria 7

    3. Mika 7

    Mika 7 transfers for me. Have you tried the script with just Mika 7 favorited? I don’t own the other two characters to test. 

  • I've made some changes to the ops around that step. Hopefully that will make a difference. Gotta say, I'm stumped because based on the data, the script should work and there's no reason sVendorProduct should be null. The test script is literally a pared down version fo the base script, and the statement that generated this:

    2018-02-09 17:35:17.399 DEBUG: Vendor: Guruvar
    2018-02-09 17:35:17.399 DEBUG: Product: Gades

    Are:

    //print("Vendor: "+sVendorProduct[1]);

    //print("Product: "+sVendorProduct[2]);

    and appear at line 261 and 262. I've triple checked the code and this only comes up once for Gades. There shouldn't be anything else to loop through.

    As a question, is the happening only on multiple selections? I haven't tested that myself in a while.

    Anyway, I'm putting up the changed file now. I was working on other stuff as I'd found that the expressions loop for G8/G3 was misfiring badly turning every expression into a palsy. That was down to too much data in support files causing the script to flip numeric signs mor often than was proper. So I fixed all that. But I also redid the suspect code on this issue, and tested it to the extent I can. During one test I actually had the png issue, but I couldn't get it to repeat.

  • RedzRedz Posts: 1,459

    No it’s happening with a single ‘Gades’ morph favorited. I still don’t get the png files copying on any of the transfers either.  

  • RedzRedz Posts: 1,459

    I haven’t tested expressions, as I fear overwriting the original ones which I suspect may be named the same, but I’ll see if I have any non DO expressions to test. 

  • RedzRedz Posts: 1,459

    By Gades! Whatever you changed there, Gades now transfers over, as does Morpheus, though for him it’s necessary to star the head body and face morphs individually as the morpheus morphs are all in individual sub-folders and only the relevenat subfolder transfers. 

  • Rbug said:

    Remove the files.

    This is probably going to sound mean, but this is not something I can handhold you through.

    Based on the way this script works it can't create duplicate formulas that I know of. That said, if it did, I'd like to troubleshoot it because that needs to be fixed.

    That said, this is an at your own risk script. If all you want out of it is a quick transfer and see ya, that's fine. But in that case, it's up to you to locate the files and remove them if it goes wrong. All the information you need to do that is in the Daz documentation center for the Bethany 7 product under the file list link. The only thing is where the docs say Genesis 3 you will look for Genesis 8.

    On the other hand, if you want to help development, post up your log and I'll see what I can do.

    To be clear, I'm not claiming the script didn't break stuff. That's the risk. But the most likely cause is that you have another copy of Bethany 7 already transfered via different means. The second most likely cause is a basic product conflict. The only thing that has an obvious potential to generate duplicate IDs is a transfer to G3F, but there's always potential for the unexpected. But the answer to "how do I fix this," is "look up where the files went and delete the files." The answer to "how do I help you prevent this," is my making a better script and telling you how to fix your issue while I'm at it.

    OK well I located the file it created and for some reason it had an odd name to it. like in this case Rbug/Alt_Eva7. now i do have the alt eva7 files but in there was nothing that would indicate that this was the issue. So I deleted the Rbug folder and everything in there and it corrected the problem. Thanks for your help

    If the script is saving morphs it was not instructed to, it would be important to figure out how it did that. The script can't rewrite filenames. I can imagine ways it might place them in the wrong folders, but it will never change their names. 

     

  • Redz said:

    Mika 7 transfers for me. Have you tried the script with just Mika 7 favorited? I don’t own the other two characters to test. 

    Yes, I tried only favoring Mika, then only Mika's head, then only Mika's body, but I get the same result.

    @Singular Blues, I did test, for the first time, your previous script (where you transfer only one morph) with FW Phoenix HD for Victoria 7 and it was a success! I did try transferring her before with your latest script, but I got the same error as with the other figures (if you just changed the file for the newest script just now, I haven't updated it yet).

  • Singular BluesSingular Blues Posts: 735
    edited February 2018
    Redz said:

    I haven’t tested expressions, as I fear overwriting the original ones which I suspect may be named the same, but I’ll see if I have any non DO expressions to test. 

    It's safe to run on any 3rd party expressions. It's not safe on basic expressions and the standard expression expansion pack. Many of the base expressions have different names, which is what the expression code is actually for. It updates 3rd party files to call those names to call the correct files after transfer.

    But some have the same names and would get overwritten and stuff would break. Badly. Because the script might rewrite the internal references on those files.

    It's definitely a major point, as GenX might, depending on what you did and how you did it, copy core expression files if a file you selected referenced them, but the script can only do that if your tell it transfer a core file. Which is now my next project. Telling it to ignore core files.

    Oh, and if you are still getting no PNG, try this. Run the script, and then immediately run it again. I do a lot of cyclic testing like that, and that might be why I'm not seeing the issue.

    Post edited by Singular Blues on
  • Redz said:

    Mika 7 transfers for me. Have you tried the script with just Mika 7 favorited? I don’t own the other two characters to test. 

    Yes, I tried only favoring Mika, then only Mika's head, then only Mika's body, but I get the same result.

    @Singular Blues, I did test, for the first time, your previous script (where you transfer only one morph) with FW Phoenix HD for Victoria 7 and it was a success! I did try transferring her before with your latest script, but I got the same error as with the other figures (if you just changed the file for the newest script just now, I haven't updated it yet).

    I updated about 20-25 minutes ago, from this post. try it now.

  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018
    Redz said:

    Mika 7 transfers for me. Have you tried the script with just Mika 7 favorited? I don’t own the other two characters to test. 

    Yes, I tried only favoring Mika, then only Mika's head, then only Mika's body, but I get the same result.

    @Singular Blues, I did test, for the first time, your previous script (where you transfer only one morph) with FW Phoenix HD for Victoria 7 and it was a success! I did try transferring her before with your latest script, but I got the same error as with the other figures (if you just changed the file for the newest script just now, I haven't updated it yet).

    I updated about 20-25 minutes ago, from this post. try it now.

    Okay, I did the update, closed studio and reload it. I tried again with FW Sushmita HD for Victoria 7. I added only one morph as a favorite, but got the same error still:

    2018-02-09 12:37:47.202 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 12:37:47.291 WARNING: Script Error: Line 2542018-02-09 12:37:47.291 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.2018-02-09 12:37:47.291 WARNING: Stack Trace:	<anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:2542018-02-09 12:37:47.295 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

     

    Just to be certain I'm not making a mistake:

    1. Loaded Sushmita and gave one morph the heart.
    2. Loaded Basic Gen8 female (or should I load the dev version?).
    3. Selected Sushmita then ctrl-click Gen8.
    4. Clicked on the Prototype script.
    5. Got the error right away, checked the log.

    Here are some screenshots of the scene (dressed the girls just for the screenshot) and the product itself (had to upload this to a cloud service, since the page wasn't allowing me to attach them):

    The parameter settings was when I tried to transfer Sushimita, rather than just her body (as above).

     

    Post edited by FenixPhoenix on
  • Oh. Right. Don't load character presets. It's not necessary. Load basic.

    The script depends on being able to find stuff. Sometimes, when you change a thing, that thing loses information. I don't know why, but it's normal for Studio. By loading the character, the state comes in modified and assetUri is invalid.

    Always use base. don't move the figures. Just load. You can deselect after loading because sometimes studio does weird stuff when you load a second figure with a first selected, but don't move them, don't pose them and don't dial anything.

  • RedzRedz Posts: 1,459

    The third party expressions I tested seem to transfer perfectly. And I am now seeing png images for some of the most recent transfers (Gades and Morpheus). For some reason the Morpheus morphs ported over without limits enabled, but that’s not a big deal. Sakura transfers too, (though custom eyes would be an issue, not that that’s within the script’s remit) 

  • If the limits aren't on, then Morpheus didn't transfer right. The rigging wouldn't have come over.

    I've figured out what's up with that, and I have an idea how to fix it. Just trying to make sure I don't break anything doing it.

  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018

    Oh. Right. Don't load character presets. It's not necessary. Load basic.

    The script depends on being able to find stuff. Sometimes, when you change a thing, that thing loses information. I don't know why, but it's normal for Studio. By loading the character, the state comes in modified and assetUri is invalid.

    Always use base. don't move the figures. Just load. You can deselect after loading because sometimes studio does weird stuff when you load a second figure with a first selected, but don't move them, don't pose them and don't dial anything.

    Ok, I've:

    1. Loaded the basic G3F.
    2. Then adding Sushmita as a favorite (didn't dial her in this time).
    3. Then I loaded Basic G8F (kept her in position this time).
    4. Deselected everything.
    5. Selected G3F then crtl-click on G8F.
    6. Ran the "Prototype" script and got the same error. :(
    7. Tried the "PrototypeVerbose" script as well (in case I was using the wrong one), but also got the error.
    2018-02-09 13:40:42.470 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 13:40:42.559 WARNING: Script Error: Line 2542018-02-09 13:40:42.559 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.2018-02-09 13:40:42.559 WARNING: Stack Trace:	<anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:2542018-02-09 13:40:42.563 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 13:40:44.936 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/PrototypeVerbose.dse2018-02-09 13:40:44.946 DEBUG: /data/DAZ 3D/Genesis 8/Female/2018-02-09 13:40:44.946 DEBUG: W:/DAZ RESOURCES/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Female/Morphs2018-02-09 13:40:45.025 WARNING: Script Error: Line 2502018-02-09 13:40:45.026 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.2018-02-09 13:40:45.026 WARNING: Stack Trace:	<anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/PrototypeVerbose.dse:2502018-02-09 13:40:45.029 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/PrototypeVerbose.dse

     

    Screenshot of the scene (dressed G8 just for the purpose of taking the screenshot):

    Ok, next thing I'm gonna try (a bit of a long shot, but want to see): I'm going to find the script and data files and delete them. Then I'm going to put them in again (just in case a file didn't copy correctly when I replaced them earlier).

    Update: Did the above and tried to transfer Mika7, but still have the error:

    2018-02-09 14:01:44.362 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 14:01:44.476 WARNING: Script Error: Line 254
    2018-02-09 14:01:44.476 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.
    2018-02-09 14:01:44.476 WARNING: Stack Trace:
        <anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:254
    2018-02-09 14:01:44.480 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    SushmitaFail2.PNG
    4081 x 1922 - 711K
    Post edited by FenixPhoenix on
  • I am very confused. I tried using the script to transfer a G3M to a G8M this time. For the most part, doesn't matter who I try, I get the same error:

    2018-02-09 15:02:26.386 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:02:36.168 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:02:36.227 WARNING: Script Error: Line 254
    2018-02-09 15:02:36.227 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.
    2018-02-09 15:02:36.227 WARNING: Stack Trace:
        <anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:254
    2018-02-09 15:02:36.235 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    BUT I was successful in transferring two rendo characters (both by the same vendor Sithlordsims) Benicio and Alex.

    2018-02-09 14:54:41.323 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 14:54:41.657 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:41.657 Loaded file: GNXARC.dsf
    2018-02-09 14:54:41.667 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:41.667 Loaded file: GNXARC.dsf
    2018-02-09 14:54:42.655 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:42.659 Loaded file: benicio_head4.dsf
    2018-02-09 14:54:42.702 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:42.702 Loaded file: benicio_body1.dsf
    2018-02-09 14:54:43.296 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    I next successfully managed to transfer Shadowborn by our very own @Redz (another character purchased over at rendo, btw).

    2018-02-09 15:10:33.889 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:10:34.272 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:34.272 Loaded file: GNXARC.dsf
    2018-02-09 15:10:34.280 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:34.280 Loaded file: GNXARC.dsf
    2018-02-09 15:10:35.281 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.281 Loaded file: ShadowBorn_Head.dsf
    2018-02-09 15:10:35.290 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.294 Loaded file: MCMRedzShadowBornFaceCorrective.dsf
    2018-02-09 15:10:35.302 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.302 Loaded file: Ashkevron Elf Ears.dsf
    2018-02-09 15:10:35.334 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.334 Loaded file: Ashkevron Body.dsf
    2018-02-09 15:10:35.983 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    So it seems that characters purchased elsewhere I can transfer fine with this new scripts. But characters purchased here give me the error.

  • RedzRedz Posts: 1,459

    I am very confused. I tried using the script to transfer a G3M to a G8M this time. For the most part, doesn't matter who I try, I get the same error:

    2018-02-09 15:02:26.386 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:02:36.168 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:02:36.227 WARNING: Script Error: Line 254
    2018-02-09 15:02:36.227 WARNING: TypeError: Result of expression 'sVendorProduct' [null] is not an object.
    2018-02-09 15:02:36.227 WARNING: Stack Trace:
        <anonymous>()@W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse:254
    2018-02-09 15:02:36.235 Error in script execution: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    BUT I was successful in transferring two rendo characters (both by the same vendor Sithlordsims) Benicio and Alex.

    2018-02-09 14:54:41.323 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 14:54:41.657 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:41.657 Loaded file: GNXARC.dsf
    2018-02-09 14:54:41.667 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:41.667 Loaded file: GNXARC.dsf
    2018-02-09 14:54:42.655 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:42.659 Loaded file: benicio_head4.dsf
    2018-02-09 14:54:42.702 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 14:54:42.702 Loaded file: benicio_body1.dsf
    2018-02-09 14:54:43.296 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    I next successfully managed to transfer Shadowborn by our very own @Redz (another character purchased over at rendo, btw).

    2018-02-09 15:10:33.889 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse
    2018-02-09 15:10:34.272 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:34.272 Loaded file: GNXARC.dsf
    2018-02-09 15:10:34.280 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:34.280 Loaded file: GNXARC.dsf
    2018-02-09 15:10:35.281 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.281 Loaded file: ShadowBorn_Head.dsf
    2018-02-09 15:10:35.290 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.294 Loaded file: MCMRedzShadowBornFaceCorrective.dsf
    2018-02-09 15:10:35.302 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.302 Loaded file: Ashkevron Elf Ears.dsf
    2018-02-09 15:10:35.334 Loaded Morph Deltas in 0 min 0.0 sec.
    2018-02-09 15:10:35.334 Loaded file: Ashkevron Body.dsf
    2018-02-09 15:10:35.983 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    So it seems that characters purchased elsewhere I can transfer fine with this new scripts. But characters purchased here give me the error.

    I’m not sure why that should be, unless it’s related to Daz Connect somehow? I always use DIM. Hopefully Singular Blues will have suggestions. 

  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018

    I think it must be connect related too, but I still went ahead and tried other rendo characters, but this time for G3F.

    When I tried Annora, I couldn't get it to work. It didn't give me an error, but it didn't show up either. When I checked the log I found:

    2018-02-09 16:05:40.816 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 16:05:42.182 WARNING: scripting\dsfile.cpp(2248): DzFile::write to W:/DAZ RESOURCES/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Female/Morphs/Maddelirium/MDD Annora/MDDCtrlAnnoraBody.dsf failed with error OpenError2018-02-09 16:05:42.184 WARNING: scripting\dsfile.cpp(2248): DzFile::write to W:/DAZ RESOURCES/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Female/Morphs/Maddelirium/MDD Annora/MDDCtrlAnnoraEars.dsf failed with error OpenError2018-02-09 16:05:42.192 WARNING: scripting\dsfile.cpp(2248): DzFile::write to W:/DAZ RESOURCES/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Female/Morphs/Maddelirium/MDD Annora/MDDCtrlAnnoraFull.dsf failed with error OpenError2018-02-09 16:05:42.195 WARNING: scripting\dsfile.cpp(2248): DzFile::write to W:/DAZ RESOURCES/My DAZ 3D Library/data/DAZ 3D/Genesis 8/Female/Morphs/Maddelirium/MDD Annora/MDDCtrlAnnoraHead.dsf failed with error OpenError2018-02-09 16:05:42.203 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    This is Annora's G3 path (tried tranferring only one morph, but they didn't work. Didn't get an error, but the log shows it was unable to create a path for G8 in my data folder):

    W:\DAZ RESOURCES\My DAZ 3D Library\data\DAZ 3D\Genesis 3\Female\Morphs\Maddelirium\MDD Annora

    Phillipa for V7 transferred almost perfectly:

    2018-02-09 16:09:22.851 Loading script: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse2018-02-09 16:09:23.100 Loaded Morph Deltas in 0 min 0.0 sec.2018-02-09 16:09:23.100 Loaded file: GNXARC.dsf2018-02-09 16:09:23.110 Loaded Morph Deltas in 0 min 0.0 sec.2018-02-09 16:09:23.110 Loaded file: GNXARC.dsf2018-02-09 16:09:24.106 Loaded Morph Deltas in 0 min 0.0 sec.2018-02-09 16:09:24.106 Loaded file: Phillipa Nails.dsf2018-02-09 16:09:24.125 Loaded Morph Deltas in 0 min 0.0 sec.2018-02-09 16:09:24.125 Loaded file: FHM Phillipa.dsf2018-02-09 16:09:24.638 Script executed successfully: W:/DAZ RESOURCES/My DAZ 3D Library/Scripts/Morph Transfer Prototype/Prototype.dse

    This is the data path for that product:

    W:\DAZ RESOURCES\My DAZ 3D Library\data\DAZ 3D\Genesis 3\Female\Morphs\Anagord\PhillipaV7

    Though Phillipa's nails didn't transfer successfully:

    PhillipasNails.PNG
    2001 x 1277 - 403K
    Post edited by FenixPhoenix on
  • It would probably help if posted up the entire log. Attached it as a file. That these files might be connect related is an important detail.

    These snippets of information are not enough.

  • Singular BluesSingular Blues Posts: 735
    edited February 2018

    Please run this script and report the complete results in the log.

    To run the script, load the source figure, and select as favorite one of the morphs that failed. Only one. Nothing wrong with selecting more than one, but the script will either crash on the first one or generate potentially a large amount of data as cycles through. This script, like the previous Gades script, will not do anything in particular to the figure. It will tell me what the Prototype script is seeing when it fails. It also contains code that will tell me if alternate means will solve the issue. Thus it is important to see the complete log data, even if a section seems irrelevant. Most useful would be the log attached as a file. Otherwise, all logging from the start of the studio session.

    zip
    zip
    GadesTester (2).zip
    2K
    Post edited by Singular Blues on
  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018

    Please run this script and report the complete results in the log.

    To run the script, load the source figure, and select as favorite one of the morphs that failed. Only one. Nothing wrong with selecting more than one, but the script will either crash on the first one or generate potentially a large amount of data as cycles through. This script, like the previous Gades script, will not do anything in particular to the figure. It will tell me what the Prototype script is seeing when it fails. It also contains code that will tell me if alternate means will solve the issue. Thus it is important to see the complete log data, even if a section seems irrelevant. Most useful would be the log attached as a file. Otherwise, all logging from the start of the studio session.

    Ok, I've tested FW Aran HD for Genesis 3 Male (selected the body as favorite) with this script. I also went ahead and tried to use the prototype script on him so I could get that error into the log. I'm attaching it. I seem to be getting a lot of warnings when I load G83 basic. So maybe I have something in my library that's conflicting with the script?

    txt
    txt
    log-Tester.txt
    1M
    Post edited by FenixPhoenix on
  • Okay. This might be something I can fix. At least it is something I can test.

    There's an issue with regular expressions. My guess is they are running case sensitive, thought they should not be. But this tells me the exact point where the script is breaking down, and shows it is pulling the correct info from connect. the issue is reading the line of data, and (As I said) I thought I'd covered that. This is first real piece of connect data I've seen, so it will help me pin down what I assumed incorrectly.

  • Okay. This might be something I can fix. At least it is something I can test.

    There's an issue with regular expressions. My guess is they are running case sensitive, thought they should not be. But this tells me the exact point where the script is breaking down, and shows it is pulling the correct info from connect. the issue is reading the line of data, and (As I said) I thought I'd covered that. This is first real piece of connect data I've seen, so it will help me pin down what I assumed incorrectly.

    Let me know if I can do anything else to help from my end!

  • Singular BluesSingular Blues Posts: 735
    edited February 2018

    Okay. This might be something I can fix. At least it is something I can test.

    There's an issue with regular expressions. My guess is they are running case sensitive, thought they should not be. But this tells me the exact point where the script is breaking down, and shows it is pulling the correct info from connect. the issue is reading the line of data, and (As I said) I thought I'd covered that. This is first real piece of connect data I've seen, so it will help me pin down what I assumed incorrectly.

    Let me know if I can do anything else to help from my end!

    There is!

    Find attached replacements for Prototype and PrototypeVerbose.

    Replace your current prototype.dse with both of these files. Set up a previously failed transfer and run PrototypeVerbose.dse (I'm expecting failure but I want to see what fails). Post up log, even if it works. If it does work, you can continue testing with Prototype.dse to save your poor log file.

    FYI, it will be a while before I can hope to tackle the nail issue.

    Post edited by Singular Blues on
  • FenixPhoenixFenixPhoenix Posts: 2,553
    edited February 2018

    Okay. This might be something I can fix. At least it is something I can test.

    There's an issue with regular expressions. My guess is they are running case sensitive, thought they should not be. But this tells me the exact point where the script is breaking down, and shows it is pulling the correct info from connect. the issue is reading the line of data, and (As I said) I thought I'd covered that. This is first real piece of connect data I've seen, so it will help me pin down what I assumed incorrectly.

    Let me know if I can do anything else to help from my end!

    There is!

    Find attached replacements for Prototype and PrototypeVerbose.

    Replace your current prototype.dse with both of these files. Set up a previously failed transfer and run PrototypeVerbose.dse (I'm expecting failure but I want to see what fails). Post up log, even if it works. If it does work, you can continue testing with Prototype.dse to save your poor log file.

    FYI, it will be a while before I can hope to tackle the nail issue.

    I tested again FW Aran HD for Genesis 3 Male (selected the body as favorite) with the verbose script (didn't transfer. Gave me: "An error ocurred while reading the file"). I'm attaching the log. Let me know if you'd like me to try it with another product (in case you need the extra data).

    Regarding Phillipa's nails, the good thing is that they are actually a separate morph, so anyone's still able to use her fine :).

    Post edited by FenixPhoenix on
  • Okay, I'm just going to say it.  This has fantastic potential.  A lot of us don't want to commit to G8 stuff because there's some much we've invested in G1, G2, and G3...but we wouldn't mind using some G8 morphs.  Why not polish this thing so it's more efficient and sell it?  Obviously you have people who are willing to buy this, me included.

  • Singular BluesSingular Blues Posts: 735
    edited February 2018

    (EDIT: I Spoke too soon.)

    Post edited by Singular Blues on
  • jardinejardine Posts: 1,150

    hi, singular...

    i've lost track of the number of times i've drafted thank yous to you on this thread, and deleted them unposted because they sounded so incredibly inadequate.

    ***

    i've just reinstalled the clone files from the script base, and installed the new Prototype/PrototypeVerbose scripts, and run that version of the Verbose script twice. 

    earlier log entries are from the previous version of the script.

    the parse error on line 793 seems to turn up consistently for me when either version of the script runs.  but sometimes i am getting an immediate error popup instead.

    hope the log helps some.  let me know if i can be of any help.

    and..thank you!

    j

     

     

    zip
    zip
    j-log.zip
    39K
Sign In or Register to comment.