Morphs from G3 to G8

1404143454670

Comments

  • Singular BluesSingular Blues Posts: 729
    edited February 2018
    jardine said:

    hi, singular...

    i've lost track of the number of times i've drafted thank yous to you on this thread, and deleted them unposted because they sounded so incredibly inadequate.

    ***

    i've just reinstalled the clone files from the script base, and installed the new Prototype/PrototypeVerbose scripts, and run that version of the Verbose script twice. 

    earlier log entries are from the previous version of the script.

    the parse error on line 793 seems to turn up consistently for me when either version of the script runs.  but sometimes i am getting an immediate error popup instead.

    hope the log helps some.  let me know if i can be of any help.

    and..thank you!

    j

    Yeah. there was typo in that one too. And another. And more. And I figured out why the pngs wouldn't copy and then would. So I fixed that too.

    Okay, I'm just going to say it.  This has fantastic potential.  A lot of us don't want to commit to G8 stuff because there's some much we've invested in G1, G2, and G3...but we wouldn't mind using some G8 morphs.  Why not polish this thing so it's more efficient and sell it?  Obviously you have people who are willing to buy this, me included.

    That's what this is. This is the alpha test of the product. Finding things out like the fingernails inexplicably go in the wrong direction, and figuring out if it can be fixed. Finding out that it still gimps out on connect, and why (because the Regular Expression was still case sensitive, btw. I was using the wrong format). I still expect the connect to fail because I expect there are more things I don't know about connect. Obviously, the easiest thing to do would be to buy some connect stuff, but I can't afford to buy anything so I'm relying on this kind of testing to work the bugs out. And frankly, if I can't solve the fingernail issue, there's no product to sell. And right now, I'm not sure that issue can be solved. The only idea I have is literally a shot in the dark.

    As with old one, this is not product ready. The old one is fundamentally flawed. It cannot be made ready. This one can. 

    I hope.

    Anyway, the current problem should be, what is the next issue from Daz Connect. Here are the updated scripts. 

    Edit: These updates are now in the trunk package.

    Post edited by Singular Blues on
  • Buy Connect stuff? Basically anything can be installed through Connect IIRC, you shouldn't have to get anything new.

  • barbultbarbult Posts: 18,523

    Buy Connect stuff? Basically anything can be installed through Connect IIRC, you shouldn't have to get anything new.

    That's basically right. You can't install plugins or Daz Studio itself with Daz Connect. Some scripts don't work right after installing with Daz Connect. A few other products have problems. But 99% of your purchases should be able to be installed with Daz Connect, including all figures except Generation 4, as far as I know.

  • Singular BluesSingular Blues Posts: 729
    edited February 2018

    I also don't wanna use DazConnect if I can avoid it :D

    I'll burn that bridge if I get to it. As of now, there's a chance I fixed everything. As it is, I've gotten way more useful info from these tests than I did my own, just because I don't really collect that much, and certainly not the esoteric stuff.

    Edit: if you wonder why I do this at all, the answer is that way back when I noticed G3F and G8F were, essentially, the same mesh, I wondered if it could be done. 90% of the things I waste my life on are almost pointless but, to me anyway, interesting problems.

    Post edited by Singular Blues on
  • barbultbarbult Posts: 18,523
    edited February 2018

    I tried the latest version posted at 5:43 pm. It fails with script error line 779. 

    1. I installed Nyarai (a G3F character) with DIM.
    2. I loaded Nyarai.
    3. I marked Nyarai Head as the favorite.
    4. I loaded G8F.
    5. I selected Nyarai.
    6. I CTRL-Selected G8F.
    7. I ran PrototypeVerbose.dse.
    8. An error message popped up.
    9. Only the PNG files were copied, no morphs.
    10. The log is attached.
    txt
    txt
    G3F to G8F error log.txt
    82K
    Post edited by barbult on
  • nonesuch00nonesuch00 Posts: 16,410

    I had to install the Measure Metric product using DAZ Connect to get it to work again. It used to work only installed via DIM but I guess no longer.

  • Singular BluesSingular Blues Posts: 729
    edited February 2018
    barbult said:

    I tried the latest version posted at 5:43 pm. It fails with script error line 779. 

    1. I installed Nyarai (a G3F character) with DIM.
    2. I loaded Nyarai.
    3. I marked Nyarai Head as the favorite.
    4. I loaded G8F.
    5. I selected Nyarai.
    6. I CTRL-Selected G8F.
    7. I ran PrototypeVerbose.dse.
    8. An error message popped up.
    9. Only the PNG files were copied, no morphs.
    10. The log is attached.

    Did you install the base package in my signature.  The attachment on this page is just the core script. There are a number of support files it needs. The error it crashed on is it can't find the clone shape for the source figure. So my first guess is the clone isn't installed. It's possible the issue arises from loading a character, but this is unlikely. That said, loading character can cause the script to malfunction, too. I'm working on that. For now, the way to make it work is load only base figures.

    Right now the core script in the base package runs right except on Connect and it will fail to copy pngs unless the script is run twice (it turns out it was trying to copy files before the file path existed and DzFile.copy() can't do that.) I figured it out and fixed it in the updated scripts here.

    If you haven't downloaded and installed the base pack, you should do so. THe script errored out before clean up but after copy start, so there are some temprorary files on your hard drive in N:/DAZ 3D/Studio/My DIM Library/data/Architect/GenNext/Holding

    Of course, you can just go delete those files, but you'll also want to remove N:/DAZ 3D/Studio/My DIM Library/data/DAZ 3D/Genesis 8/Female/Morphs/Saiyaness/Nyarai for Genesis 3 Female/ in that case.

    Post edited by Singular Blues on
  • barbultbarbult Posts: 18,523
    barbult said:

    I tried the latest version posted at 5:43 pm. It fails with script error line 779. 

    1. I installed Nyarai (a G3F character) with DIM.
    2. I loaded Nyarai.
    3. I marked Nyarai Head as the favorite.
    4. I loaded G8F.
    5. I selected Nyarai.
    6. I CTRL-Selected G8F.
    7. I ran PrototypeVerbose.dse.
    8. An error message popped up.
    9. Only the PNG files were copied, no morphs.
    10. The log is attached.

    Did you install the base package in my signature.  The attachment on this page is just the core script. There are a number of support files it needs. The error it crashed on is it can't find the clone shape for the source figure. So my first guess is the clone isn't installed. It's possible the issue arises from loading a character, but this is unlikely. That said, loading character can cause the script to malfunction, too. I'm working on that. For now, the way to make it work is load only base figures.

    Right now the core script in the base package runs right except on Connect and it will fail to copy pngs unless the script is run twice (it turns out it was trying to copy files before the file path existed and DzFile.copy() can't do that.) I figured it out and fixed it in the updated scripts here.

    If you haven't downloaded and installed the base pack, you should do so. THe script errored out before clean up but after copy start, so there are some temprorary files on your hard drive in N:/DAZ 3D/Studio/My DIM Library/data/Architect/GenNext/Holding

    Of course, you can just go delete those files, but you'll also want to remove N:/DAZ 3D/Studio/My DIM Library/data/DAZ 3D/Genesis 8/Female/Morphs/Saiyaness/Nyarai for Genesis 3 Female/ in that case.

    No, I didn't install the "base". I didn't realize the latest files were not all I need. I'll try again. Thanks.

  • barbultbarbult Posts: 18,523

    Question: Am I not even supposed to dial in the source character morph? Do I just favorite it at value 0?

  • nonesuch00nonesuch00 Posts: 16,410
    edited February 2018
    barbult said:

    Question: Am I not even supposed to dial in the source character morph? Do I just favorite it at value 0?

    You are supposed to load the base G8F or G8M or G3F or G3M and leave both the position and morph / pose / other dials & settings untouched.

    There are a couple of morphs that load dialed in on some of the base Genesis figures though, like the navel. Should those be dialed out to the unmorphed value?

    Post edited by nonesuch00 on
  • Singular BluesSingular Blues Posts: 729
    edited February 2018
    barbult said:

    Question: Am I not even supposed to dial in the source character morph? Do I just favorite it at value 0?

    For now yes. Technical reason is a property has two states. Modified and unmodified. When modified, properties sometimes shift their link from assetUri to assetSource. This can cause the script to fail, though I've taken steps to prevent that. I'm just not sure I've taken all the steps, so fr now, don't dial in the morph.

    The script gets the morph data from the source, so it's never necessary to dial it. In the end this pesk don't change things issue will, hopefully, also be eliminated, but I need to do a more careful survey of all the points where that can come up in the script and make sure those bases are covered, As of now, I only have two of them.

    Edit: To be clear, this is don't change anything about the figure, no always have the figure at 0. If you changed something an changed it back, the state is still modified. Load at base. Select, mark favorite. THat's it. if you did anything else it may fail. and the only way to be sure you are starting fresh is to close Studio and reopen. The way studio caches data leads to weird things happening if you don't restart. I've had issues with it even after opening new scenes. 

    Post edited by Singular Blues on
  • barbultbarbult Posts: 18,523
    edited February 2018

    OK, following all the instructions, I got the Nyarai morphs to transfer. smileyThe PNG files were created, but they do not show up on the morphs, because of a naming conflict.

    G3 to G8 problem.JPG
    1296 x 527 - 195K
    Post edited by barbult on
  • Singular BluesSingular Blues Posts: 729
    edited February 2018

    The conflict is one that will likely remain, in this case. It's something I have considered, but the nature of the DSF file structure means there;s always an opportunity for something like this to crop up when the base figure name gets stuffed into a product name. Browsing the doc center shows it just doesn't happen enough to try to make working around it priority. Maybe at some point.

    Right now, if you change the folder name, the images will appear after reload.

    Edit: to be clear, "product name" here refers to the internal file name system Studio uses, not the title on the sales page. For example, the product name for Lizzie for Genesis 3 Female is just "Lizzie".

    Post edited by Singular Blues on
  • barbultbarbult Posts: 18,523
    edited February 2018

    I have now successfully transferred Kalea 7 also.

    This is the successful procedure:

    1. I installed Kalea 7 with DIM.
    2. I loaded Genesis 3 Female and made no changes to her.
    3. I marked Kalea 7 Head as the favorite. It is NOT dialed in.
    4. I loaded Genesis 8 Female and made no changes to her.
    5. I selected Genesis 3 Female.
    6. I CTRL-Selected Genesis 8 Female.
    7. I ran Prototype.dse.

    Here is my G8F Kalea.

    G8F Kalea 7.png
    1600 x 2000 - 4M
    Post edited by barbult on
  • jardine said:

    hi, singular...

    i've lost track of the number of times i've drafted thank yous to you on this thread, and deleted them unposted because they sounded so incredibly inadequate.

    ***

    i've just reinstalled the clone files from the script base, and installed the new Prototype/PrototypeVerbose scripts, and run that version of the Verbose script twice. 

    earlier log entries are from the previous version of the script.

    the parse error on line 793 seems to turn up consistently for me when either version of the script runs.  but sometimes i am getting an immediate error popup instead.

    hope the log helps some.  let me know if i can be of any help.

    and..thank you!

    j

    Yeah. there was typo in that one too. And another. And more. And I figured out why the pngs wouldn't copy and then would. So I fixed that too.

    Okay, I'm just going to say it.  This has fantastic potential.  A lot of us don't want to commit to G8 stuff because there's some much we've invested in G1, G2, and G3...but we wouldn't mind using some G8 morphs.  Why not polish this thing so it's more efficient and sell it?  Obviously you have people who are willing to buy this, me included.

    That's what this is. This is the alpha test of the product. Finding things out like the fingernails inexplicably go in the wrong direction, and figuring out if it can be fixed. Finding out that it still gimps out on connect, and why (because the Regular Expression was still case sensitive, btw. I was using the wrong format). I still expect the connect to fail because I expect there are more things I don't know about connect. Obviously, the easiest thing to do would be to buy some connect stuff, but I can't afford to buy anything so I'm relying on this kind of testing to work the bugs out. And frankly, if I can't solve the fingernail issue, there's no product to sell. And right now, I'm not sure that issue can be solved. The only idea I have is literally a shot in the dark.

    As with old one, this is not product ready. The old one is fundamentally flawed. It cannot be made ready. This one can. 

    I hope.

    Anyway, the current problem should be, what is the next issue from Daz Connect. Here are the updated scripts. 

    Edit: replace the Prototype.dse and PrototypeVerbose.dse with the contents of this attachment. this does not contain the whole package. I'll update the package after getting feedback on this.

    I can confirm whatever you changed made the transfer of FW Aran HD for Genesis 3 Male successful to G8! I'm attaching the log file for that! I've tested the morph and it works perfectly!

    txt
    txt
    AranTest2-VerboseLOG-Success.txt
    1M
  • That's a nice render for an off the cuff job. Well done.

    Btw, I'm not dismissing the issue with the pngs. I have some ideas how to adress it. But it's complicated, and I know if I persue it now, I'll waste time on it, and considering that it looks like an odd man out case, it's not the smartest choice to work on. I'm too much a sucker for problem like that against a problem I have figured out but need to do the work to implement. And I really need to settle down and do at least the ground work on Genesis and Genesis 2. Because they are much different, there will be some real boring tedious investigation and matching work before I run across and interesting problem to solve.

  • HaruchaiHaruchai Posts: 1,508

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

  • Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

  • dracorndracorn Posts: 2,308

    Okay, I'm just going to say it.  This has fantastic potential.  A lot of us don't want to commit to G8 stuff because there's some much we've invested in G1, G2, and G3...but we wouldn't mind using some G8 morphs.  Why not polish this thing so it's more efficient and sell it?  Obviously you have people who are willing to buy this, me included.

    I would buy it the second it comes out, even if they price it high.
  • dracorn said:

    Okay, I'm just going to say it.  This has fantastic potential.  A lot of us don't want to commit to G8 stuff because there's some much we've invested in G1, G2, and G3...but we wouldn't mind using some G8 morphs.  Why not polish this thing so it's more efficient and sell it?  Obviously you have people who are willing to buy this, me included.

     

    I would buy it the second it comes out, even if they price it high.

    I'm working on it. It has to be right, though. Fool proof.

    Not perfect. Perfect never happens. But I still need to solve the major issues.

  • HaruchaiHaruchai Posts: 1,508
    edited February 2018
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    txt
    txt
    log.txt
    223K
    Transfer.jpg
    381 x 397 - 33K
    Post edited by Haruchai on
  • nonesuch00nonesuch00 Posts: 16,410
    Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    I think you are supposed to extra DAZ Studio and then start it again for the transfers to show. At least that is the case when I install new products via DIM.

  • HaruchaiHaruchai Posts: 1,508
    edited February 2018
    Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    I think you are supposed to extra DAZ Studio and then start it again for the transfers to show. At least that is the case when I install new products via DIM.

    Thanks, but during my attempts I have shut down and restarted Studio several times with no effect on the status of the available morphs. My log file above is from a fresh start of Studio having attempted to transfer three different character morphs on three seperate occasions.

    Post edited by Haruchai on
  • nonesuch00nonesuch00 Posts: 16,410
    Haruchai said:
    Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    I think you are supposed to extra DAZ Studio and then start it again for the transfers to show. At least that is the case when I install new products via DIM.

    Thanks, but during my attempts I have shut down and restarted Studio several times with no effect on the status of the available morphs.

    You should add then then as step 8 and check the morph availability as step 9

  • barbultbarbult Posts: 18,523

    Just guessing - Try favoriting the Arabella 7 Head or Arabella 7 Body morph instead of the Actor/People Arabella 7. The Actor/People "morph" is just a controller to dial head and body morphs, not a "real" morph.

  • HaruchaiHaruchai Posts: 1,508
    Haruchai said:
    Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    I think you are supposed to extra DAZ Studio and then start it again for the transfers to show. At least that is the case when I install new products via DIM.

    Thanks, but during my attempts I have shut down and restarted Studio several times with no effect on the status of the available morphs.

    You should add then then as step 8 and check the morph availability as step 9

    Yes, tried that with no result.

  • nonesuch00nonesuch00 Posts: 16,410
    Haruchai said:
    Haruchai said:
    Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

     

    I think you are supposed to extra DAZ Studio and then start it again for the transfers to show. At least that is the case when I install new products via DIM.

    Thanks, but during my attempts I have shut down and restarted Studio several times with no effect on the status of the available morphs.

    You should add then then as step 8 and check the morph availability as step 9

    Yes, tried that with no result.

    Do what Barbult said - others have had similar problems.

  • Haruchai said:
    Haruchai said:

     

     

    Haruchai said:

    Thanks for this script it is fantastic. I have successfully transferred Bethany 7 character morphs to Genesis 8 Female as a test.


    Rookie question. How do I now save this so the morphs are preserved on the next load of Genesis 8?

    You don't. In fact, if you are using the morphs right after running the script, they aren't loaded correctly.

    The morphs are already saved to the figure when script completes. Saving them afterward will either do nothing but waste disk space if you're lucky or break them entirely if you aren't.

    Interesting.

    A few failed attempts later. Following the process as I see it worked above.

    1) Load Genesis 3 Female

    2) Favourite Arabella 7 morph (under actor-people)

    3) Load Genesis 8 Female

    4) Ctrl click to highlight Genesis 8 Female (Genesis 3 Female already highlighted)

    5) Run Prototype script (dated 9th February)

    6) A tab opens showing the transfer (screenshot attached)

    7) Delete both figures and reload Genesis 8 Female. No new morphs are present.

     

    I have attached the log file. Any help in trackng down why this is not working would be appreciated.

    It works for me and the only thing I'm doing differently from you is:

    1 - I selected as favorite a body or a head, not the actor.

    2- After selecting the morph as a favorite, I deselected Gen3. Then I loaded Basic G8. I selected Gen3 first, then Gen8.

    @Singular Blues did mentioned before to make sure to "deselect Gen3" before selecting both G3 and G8 (in that order if you're transferring from G3 to 8). 

    Might be a shot in the dark, but you can always try if it fixes it. Also, remember to download the package (that contain the data folder with the clones) in Singular Blue's signature, not just the latest script.

  • HaruchaiHaruchai Posts: 1,508
    edited February 2018

    OK, thanks to everyone for their input, really appreciate the support.

     

    Revised process below. I tried it with a new morph so as not to get mixed up with previous attempts.

    1) Start Studio

    2) Load Genesis 3 Female

    3) Favourite Gia 7 head morph (under actor-head-people (see attached Gia01)

    3) Load Genesis 8 Female

    4) Deselect both figures

    5) Click to select Genesis 3 Female then Ctrl click to also select Genesis 8 Female

    6) Run the script (installed today from the package in Singularity Blues signature)

    6) A tab opens showing the transfer

    7) Delete both figures and restart Studio

    8) Load Genesis 8 Female and check for morphs. No luck (see Gia02)

     

    I have run this process now with three different morphs without any luck. I even tried deselecting Genesis 3 Female before loading Genesis 8 Female in case that made a difference, sadly no. If anyone has Gia 7 could they try the above process and see if it works so I can at least test if it is the process I am following that is at fault.

    When the tab says it is 'Writing assets' what and where is it writing to please? I am guessing that it should be updating the Genesis 8 Female dsf in the data-DAZ 3D-Genesis 8-Female folder or putting some morphs somewhere for it to read, none of which appears to be happening. These are guesses of course as I don't know what the script is attempting to write.

    Gia02.jpg
    1039 x 331 - 71K
    Gia01.jpg
    1030 x 323 - 72K
    Post edited by Haruchai on
  • Singular BluesSingular Blues Posts: 729
    edited February 2018

    Since the Prototype.dse was used and not PrototypeVerbose.dse, there's not a lot in the log file. That said, I don't think it would make much difference because the script completed successfully. So that tells me the files were created.

    Further, the log shows that Studio is reading the created files, however the error is "Cannot find parent." This tells me that parent data line for the modifiers is not as Studio expects.

    My first recommendation is to make sure you have all of the most current files. First install the package in my signature, then replace the Prototype.dse script with the scripts found here.

    Beyond that, I wonder if perhaps you've modified your Genesis 8 Female, which might also cause this issue. In all of my tests, only Genesis 3 Female is picky about exactly what the parent data line says, however you are clearly having parent mismatch. Since it seems to be just you, this is the first thing that comes to mind.

    Baring in mind, I could completely wrong since this is inferred from the logs (and again, while the Verbose script might help, I know what it prints, and it's likely it wouldn't add much to this case as the script appears to have done what it should do). Perhaps someone else could attampt to move Arabella 7 to Genesis 8, and report if the have similar issues. I'd not expect it, but it could happen.

    Post edited by Singular Blues on
Sign In or Register to comment.