ManFriday's Render Queue (the old one from 2019) [Commercial]

11213141618

Comments

  • DoctorJellybeanDoctorJellybean Posts: 8,127

    lamoid_5f20d3e469 said:

    Yes DS closes.  There is nothing else to see on the screen.  The log indicates that it tries to reopen DS repeatedly, 30 times, then gives up. Here are the relevant lines from "C:\Users\xxxxxxxx\AppData\Roaming\DAZ 3D\Studio4\log.txt" that I posted above on 6 March:

    2021-03-05 06:30:30.109 RenderQueue: Entering  restartDazStudioOrThrow(): restart mode is 1
    2021-03-05 06:30:30.109 RenderQueue:   calling dzApp->quit()
    2021-03-05 06:30:30.109 RenderQueue:   spawning stock restart script
    2021-03-05 06:30:30.109 RenderQueue:     creating restart batch file
    2021-03-05 06:30:30.121 RenderQueue:     batch file is “C:\Users\xxxxxxxx\AppData\Local\Temp\mfrq-restart.bat”
    2021-03-05 06:30:30.145 RenderQueue:     ShellExecute() returned HINSTANCE 42
    2021-03-05 06:30:30.145 RenderQueue:     GetLastError() reported: 0
    2021-03-05 06:30:30.145 RenderQueue: Leaving  restartDazStudioOrThrow(): restart mode is 1

    Here are the relevant lines from the log when I ran it earlier today

    2021-06-17 18:20:33.709 RenderQueue: Entering advancing to state 5 (S5_RENDER_DONE)
    2021-06-17 18:20:33.709 RenderQueue: Leaving advancing to state 5 (S5_RENDER_DONE)
    2021-06-17 18:20:33.709 RenderQueue: Entering advanceToState5_RenderDone()
    2021-06-17 18:20:33.709 RenderQueue: Leaving advanceToState5_RenderDone()
    2021-06-17 18:20:33.712 RenderQueue:   all visible cameras mode
    2021-06-17 18:20:33.714 RenderQueue:     saving queue
    2021-06-17 18:20:33.714 RenderQueue:     clearing scene
    2021-06-17 18:20:47.441 *** Scene Cleared ***
    2021-06-17 18:20:47.441 RenderQueue:     advancing to next state: restart daz
    2021-06-17 18:20:47.441 RenderQueue: Entering advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-17 18:20:47.441 RenderQueue: Leaving advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-17 18:20:47.441 RenderQueue: Entering advanceToState6_RestartDazCountdown()
    2021-06-17 18:20:47.441 RenderQueue: Leaving advanceToState6_RestartDazCountdown()
    2021-06-17 18:20:47.442 RenderQueue:   starting timer
    2021-06-17 18:20:47.442 RenderQueue: done with state 6
    2021-06-17 18:20:47.442 RenderQueue: done with state 5
    2021-06-17 18:20:47.445 Finished Rendering
    2021-06-17 18:20:47.591 RenderQueue: done with state 4

    Then the following repeats 30 times

    2021-06-17 18:20:48.434 RenderQueue: Entering timer event for 'restart daz'
    2021-06-17 18:20:48.434 RenderQueue:   whenDone = 0
    2021-06-17 18:20:48.434 RenderQueue: Leaving timer event for 'restart daz'

    Then finally

    2021-06-17 18:21:17.429 RenderQueue: Entering  restartDazStudioOrThrow(): restart mode is 1
    2021-06-17 18:21:17.429 RenderQueue:   calling dzApp->quit()
    2021-06-17 18:21:17.430 RenderQueue:   spawning stock restart script
    2021-06-17 18:21:17.430 RenderQueue:     creating restart batch file
    2021-06-17 18:21:17.436 RenderQueue:     batch file is “C:\Users\xxxxxxxx\AppData\Local\Temp\mfrq-restart.bat”
    2021-06-17 18:21:17.486 RenderQueue:     ShellExecute() returned HINSTANCE 42
    2021-06-17 18:21:17.486 RenderQueue:     GetLastError() reported: 0
    2021-06-17 18:21:17.486 RenderQueue: Leaving  restartDazStudioOrThrow(): restart mode is 1
    2021-06-17 18:21:17.486 RenderQueue: Leaving timer event for 'restart daz'

    RQ cannot restart DS. If I manually restaart it then DS acts just like it would had RQ restarted it. The RQ dialog comes up and the next render is performed. When it is over DS closes and the script tries 30 times to open DS then gives up.

    Ok, could you please bring up Task Manager and check that there is no instance of DS running. Leaving Task Manager open, start DS and the Render Queue. When Render Queue completes the first render and closes DS down, check in Task Manager if there is an instance of DS running. Check at least for a min or so, depending on your restart settings in RQ.

  • Thank you, Doctor. Will do.

  • lamoid_5f20d3e469lamoid_5f20d3e469 Posts: 291
    edited June 2021

    I did what you suggested, Doctor. I made sure that no instance of DS was running. Then I started it. It immediately appeared once in the task manager. The I loaded a simple scene -- A 4m ground plane textured with the nobiax iray wooden slats texture and a 0.25 x 0.5 x 1.0m cuboid textured with nobiax iray rough concrete. Both the plane and the base of the cuboid were centered at the origin The render size was 1024 x 512 (w x h) . It was illuminanted with two spotlights, one at (x,y,z) = (-100, 100, 100) and the other at (100, -100, 100) both spotlights were directed at the origin.  I set up 8 cameras arrayed around the scene at 45-deg increments. I set up RQ selecting the option for one render per camera. I saved the RQ setup then started the render. The first render proceded. When completed, the RQ window reappeared starting a 30s countdown waiting to start DS. When it reached 1 second. It sat there for 10 seconds before closing DS. When all the DS windows closed, its entry in the task manager vansihed.  DS did not restart.  When I restarted it manually, RQ started back up, It waited 30 s to load the scene then waited another 30 to start the render. Then everything proceded as before. DS did not automatically restart..

    The log shows after the render was complete:

    2021-06-22 10:43:06.290 Saved image: K:\Daz 3D\Renders\RenderQue\Render Queue Test_Camera 2.png
    2021-06-22 10:43:06.292 RenderQueue: Entering advancing to state 5 (S5_RENDER_DONE)
    2021-06-22 10:43:06.292 RenderQueue: Leaving advancing to state 5 (S5_RENDER_DONE)
    2021-06-22 10:43:06.292 RenderQueue: Entering advanceToState5_RenderDone()
    2021-06-22 10:43:06.292 RenderQueue: Leaving advanceToState5_RenderDone()
    2021-06-22 10:43:06.293 RenderQueue:   all visible cameras mode
    2021-06-22 10:43:06.293 RenderQueue:     saving queue
    2021-06-22 10:43:06.293 RenderQueue:     clearing scene
    2021-06-22 10:43:06.317 *** Scene Cleared ***
    2021-06-22 10:43:06.317 RenderQueue:     advancing to next state: restart daz
    2021-06-22 10:43:06.318 RenderQueue: Entering advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-22 10:43:06.318 RenderQueue: Leaving advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-22 10:43:06.318 RenderQueue: Entering advanceToState6_RestartDazCountdown()
    2021-06-22 10:43:06.318 RenderQueue: Leaving advanceToState6_RestartDazCountdown()
    2021-06-22 10:43:06.318 RenderQueue:   starting timer
    2021-06-22 10:43:06.318 RenderQueue: done with state 6
    2021-06-22 10:43:06.318 RenderQueue: done with state 5
    2021-06-22 10:43:06.320 Finished Rendering
    2021-06-22 10:43:06.345 RenderQueue: done with state 4

    Then it repeats the following 3 lines 30 times:

    2021-06-22 10:43:07.307 RenderQueue: Entering timer event for 'restart daz'
    2021-06-22 10:43:07.307 RenderQueue:   whenDone = 0
    2021-06-22 10:43:07.307 RenderQueue: Leaving timer event for 'restart daz'

    Those are followed by:

    2021-06-22 10:58:11.609 RenderQueue: Entering timer event for 'restart daz'
    2021-06-22 10:58:11.609 RenderQueue:   timer done, stopping timer
    2021-06-22 10:58:11.609 RenderQueue:   whenDone = 0
    2021-06-22 10:58:11.609 RenderQueue: Entering  restartDazStudioOrThrow(): restart mode is 1
    2021-06-22 10:58:11.609 RenderQueue:   calling dzApp->quit()
    2021-06-22 10:58:11.609 RenderQueue:   spawning stock restart script
    2021-06-22 10:58:11.609 RenderQueue:     creating restart batch file
    2021-06-22 10:58:11.609 RenderQueue:     batch file is “C:\Users\xxxxxxxx\AppData\Local\Temp\mfrq-restart.bat”
    2021-06-22 10:58:11.633 RenderQueue:     ShellExecute() returned HINSTANCE 42
    2021-06-22 10:58:11.633 RenderQueue:     GetLastError() reported: 0
    2021-06-22 10:58:11.633 RenderQueue: Leaving  restartDazStudioOrThrow(): restart mode is 1
    2021-06-22 10:58:11.634 RenderQueue: Leaving timer event for 'restart daz'
    2021-06-22 10:58:11.634 Saving custom actions...
    2021-06-22 10:58:11.637 Saving session actions...
    2021-06-22 10:58:11.645 Saving session menus...
    2021-06-22 10:58:11.661 Saving session toolbars...
    2021-06-22 10:58:11.668 Begin Application cleanup...
    2021-06-22 10:58:11.668 Shutting down Asset Manager...
    2021-06-22 10:58:11.732 Clearing Delayed Delete Stack...
    2021-06-22 10:58:11.732 Shutting down Plugin Manager...
    2021-06-22 10:58:11.938 Iray [INFO] - IRT:RENDER ::   1.25  IRT    rend info : Shutting down irt render plugin.
    2021-06-22 10:58:12.035 Cleaning up Thread Pool...
    2021-06-22 10:58:12.035 Deleting Inverse Kinematics Manager...
    2021-06-22 10:58:12.035 Deleting OpenGL Manager...
    2021-06-22 10:58:12.038 Deleting Script Engine...
    2021-06-22 10:58:12.039 Deleting Importer Manager...
    2021-06-22 10:58:12.039 Deleting Exporter Manager...
    2021-06-22 10:58:12.039 Deleting File IO Preset Manager...
    2021-06-22 10:58:12.039 Deleting Save Filter Manager...
    2021-06-22 10:58:12.039 Deleting Asset IO Manager...
    2021-06-22 10:58:12.039 Deleting Image Manager...
    2021-06-22 10:58:12.039 Deleting Help Manager...
    2021-06-22 10:58:12.040 Deleting Multimedia Manager...
    2021-06-22 10:58:12.040 Deleting Cloud Manager...
    2021-06-22 10:58:12.040 Deleting Asset Manager...
    2021-06-22 10:58:12.040 Shutting down Content Manager...
    2021-06-22 10:58:12.041 Deleting Content Manager...
    2021-06-22 10:58:12.041 Shutting down Render Manager...
    2021-06-22 10:58:12.041 Deleting Render Manager...
    2021-06-22 10:58:12.041 Shutting down Simulation Manager...
    2021-06-22 10:58:12.041 Deleting Simulation Manager...
    2021-06-22 10:58:12.041 Deleting Texture Converter Manager...
    2021-06-22 10:58:12.042 Deleting Texture Baker Manager...
    2021-06-22 10:58:12.042 Deleting Device Manager...
    2021-06-22 10:58:12.042 Deleting CallBack Manager...
    2021-06-22 10:58:12.042 Clearing Undo Stack...
    2021-06-22 10:58:12.042 Deleting Scene...
    2021-06-22 10:58:12.043 *** Scene Cleared ***
    2021-06-22 10:58:12.043 Deleting Undo Stack...
    2021-06-22 10:58:12.043 Deleting Authentication Manager...
    2021-06-22 10:58:12.043 Deleting Main Window...
    2021-06-22 10:58:12.114 Deleting Viewport Manager...
    2021-06-22 10:58:12.134 Deleting Action Manager...
    2021-06-22 10:58:12.135 DEBUG: End DAZ Studio to Hexagon Bridge log...
    2021-06-22 10:58:12.138 Deleting Pane Manager...
    2021-06-22 10:58:12.234 Performing cleanup...
    2021-06-22 10:58:12.235 Deleting Plugin Manager...
    2021-06-22 10:58:12.235 Deleting Application Settings Manager...
    2021-06-22 10:58:21.669 --------------- DAZ Studio 4.15.0.2 exited ------------------
    2021-06-22 10:58:21.669 ~

    DS does not restart.

    Thank you again, Doctor Jellybean, for your help!

     

     

     

    Post edited by lamoid_5f20d3e469 on
  • DoctorJellybeanDoctorJellybean Posts: 8,127

    lamoid_5f20d3e469 said:

    I did what you suggested, Doctor. I made sure that no instance of DS was running. Then I started it. It immediately appeared once in the task manager. The I loaded a simple scene -- A 4m ground plane textured with the nobiax iray wooden slats texture and a 0.25 x 0.5 x 1.0m cuboid textured with nobiax iray rough concrete. Both the plane and the base of the cuboid were centered at the origin The render size was 1024 x 512 (w x h) . It was illuminanted with two spotlights, one at (x,y,z) = (-100, 100, 100) and the other at (100, -100, 100) both spotlights were directed at the origin.  I set up 8 cameras arrayed around the scene at 45-deg increments. I set up RQ selecting the option for one render per camera. I saved the RQ setup then started the render. The first render proceded. When completed, the RQ window reappeared starting a 30s countdown waiting to start DS. When it reached 1 second. It sat there for 10 seconds before closing DS. When all the DS windows closed, its entry in the task manager vansihed.  DS did not restart.  When I restarted it manually, RQ started back up, It waited 30 s to load the scene then waited another 30 to start the render. Then everything proceded as before. DS did not automatically restart..

    The log shows after the render was complete:

    2021-06-22 10:43:06.290 Saved image: K:\Daz 3D\Renders\RenderQue\Render Queue Test_Camera 2.png
    2021-06-22 10:43:06.292 RenderQueue: Entering advancing to state 5 (S5_RENDER_DONE)
    2021-06-22 10:43:06.292 RenderQueue: Leaving advancing to state 5 (S5_RENDER_DONE)
    2021-06-22 10:43:06.292 RenderQueue: Entering advanceToState5_RenderDone()
    2021-06-22 10:43:06.292 RenderQueue: Leaving advanceToState5_RenderDone()
    2021-06-22 10:43:06.293 RenderQueue:   all visible cameras mode
    2021-06-22 10:43:06.293 RenderQueue:     saving queue
    2021-06-22 10:43:06.293 RenderQueue:     clearing scene
    2021-06-22 10:43:06.317 *** Scene Cleared ***
    2021-06-22 10:43:06.317 RenderQueue:     advancing to next state: restart daz
    2021-06-22 10:43:06.318 RenderQueue: Entering advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-22 10:43:06.318 RenderQueue: Leaving advancing to state 6 (S6_RESTART_DAZ_COUNTDOWN)
    2021-06-22 10:43:06.318 RenderQueue: Entering advanceToState6_RestartDazCountdown()
    2021-06-22 10:43:06.318 RenderQueue: Leaving advanceToState6_RestartDazCountdown()
    2021-06-22 10:43:06.318 RenderQueue:   starting timer
    2021-06-22 10:43:06.318 RenderQueue: done with state 6
    2021-06-22 10:43:06.318 RenderQueue: done with state 5
    2021-06-22 10:43:06.320 Finished Rendering
    2021-06-22 10:43:06.345 RenderQueue: done with state 4

    Then it repeats the following 3 lines 30 times:

    2021-06-22 10:43:07.307 RenderQueue: Entering timer event for 'restart daz'
    2021-06-22 10:43:07.307 RenderQueue:   whenDone = 0
    2021-06-22 10:43:07.307 RenderQueue: Leaving timer event for 'restart daz'

    Those are followed by:

    2021-06-22 10:58:11.609 RenderQueue: Entering timer event for 'restart daz'
    2021-06-22 10:58:11.609 RenderQueue:   timer done, stopping timer
    2021-06-22 10:58:11.609 RenderQueue:   whenDone = 0
    2021-06-22 10:58:11.609 RenderQueue: Entering  restartDazStudioOrThrow(): restart mode is 1
    2021-06-22 10:58:11.609 RenderQueue:   calling dzApp->quit()
    2021-06-22 10:58:11.609 RenderQueue:   spawning stock restart script
    2021-06-22 10:58:11.609 RenderQueue:     creating restart batch file
    2021-06-22 10:58:11.609 RenderQueue:     batch file is “C:\Users\xxxxxxxx\AppData\Local\Temp\mfrq-restart.bat”
    2021-06-22 10:58:11.633 RenderQueue:     ShellExecute() returned HINSTANCE 42
    2021-06-22 10:58:11.633 RenderQueue:     GetLastError() reported: 0
    2021-06-22 10:58:11.633 RenderQueue: Leaving  restartDazStudioOrThrow(): restart mode is 1
    2021-06-22 10:58:11.634 RenderQueue: Leaving timer event for 'restart daz'
    2021-06-22 10:58:11.634 Saving custom actions...
    2021-06-22 10:58:11.637 Saving session actions...
    2021-06-22 10:58:11.645 Saving session menus...
    2021-06-22 10:58:11.661 Saving session toolbars...
    2021-06-22 10:58:11.668 Begin Application cleanup...
    2021-06-22 10:58:11.668 Shutting down Asset Manager...
    2021-06-22 10:58:11.732 Clearing Delayed Delete Stack...
    2021-06-22 10:58:11.732 Shutting down Plugin Manager...
    2021-06-22 10:58:11.938 Iray [INFO] - IRT:RENDER ::   1.25  IRT    rend info : Shutting down irt render plugin.
    2021-06-22 10:58:12.035 Cleaning up Thread Pool...
    2021-06-22 10:58:12.035 Deleting Inverse Kinematics Manager...
    2021-06-22 10:58:12.035 Deleting OpenGL Manager...
    2021-06-22 10:58:12.038 Deleting Script Engine...
    2021-06-22 10:58:12.039 Deleting Importer Manager...
    2021-06-22 10:58:12.039 Deleting Exporter Manager...
    2021-06-22 10:58:12.039 Deleting File IO Preset Manager...
    2021-06-22 10:58:12.039 Deleting Save Filter Manager...
    2021-06-22 10:58:12.039 Deleting Asset IO Manager...
    2021-06-22 10:58:12.039 Deleting Image Manager...
    2021-06-22 10:58:12.039 Deleting Help Manager...
    2021-06-22 10:58:12.040 Deleting Multimedia Manager...
    2021-06-22 10:58:12.040 Deleting Cloud Manager...
    2021-06-22 10:58:12.040 Deleting Asset Manager...
    2021-06-22 10:58:12.040 Shutting down Content Manager...
    2021-06-22 10:58:12.041 Deleting Content Manager...
    2021-06-22 10:58:12.041 Shutting down Render Manager...
    2021-06-22 10:58:12.041 Deleting Render Manager...
    2021-06-22 10:58:12.041 Shutting down Simulation Manager...
    2021-06-22 10:58:12.041 Deleting Simulation Manager...
    2021-06-22 10:58:12.041 Deleting Texture Converter Manager...
    2021-06-22 10:58:12.042 Deleting Texture Baker Manager...
    2021-06-22 10:58:12.042 Deleting Device Manager...
    2021-06-22 10:58:12.042 Deleting CallBack Manager...
    2021-06-22 10:58:12.042 Clearing Undo Stack...
    2021-06-22 10:58:12.042 Deleting Scene...
    2021-06-22 10:58:12.043 *** Scene Cleared ***
    2021-06-22 10:58:12.043 Deleting Undo Stack...
    2021-06-22 10:58:12.043 Deleting Authentication Manager...
    2021-06-22 10:58:12.043 Deleting Main Window...
    2021-06-22 10:58:12.114 Deleting Viewport Manager...
    2021-06-22 10:58:12.134 Deleting Action Manager...
    2021-06-22 10:58:12.135 DEBUG: End DAZ Studio to Hexagon Bridge log...
    2021-06-22 10:58:12.138 Deleting Pane Manager...
    2021-06-22 10:58:12.234 Performing cleanup...
    2021-06-22 10:58:12.235 Deleting Plugin Manager...
    2021-06-22 10:58:12.235 Deleting Application Settings Manager...
    2021-06-22 10:58:21.669 --------------- DAZ Studio 4.15.0.2 exited ------------------
    2021-06-22 10:58:21.669 ~

    DS does not restart.

    Thank you again, Doctor Jellybean, for your help!

    I did a quick test, it works for me. Unfortunately, I'm out of ideas\suggestions. Hopefully @ManFriday can shed some light.

  • barbultbarbult Posts: 23,514

    I don't know if it would matter, but is your Daz Studio installed in a non-standard location? Are you running the 32-bit Daz Studio instead of 64-bit, or anything unusual like that?

  • Yes, Barbult. My installations are in non-standard locations. But RenderQueue worked until the 14.15.0.2 update of DS. Moreover everything else works just fine. I am using Windows 10 64bit and the 64-bit version of Daz Studio 14.15.0.2.

  • barbultbarbult Posts: 23,514

    lamoid_5f20d3e469 said:

    Yes, Barbult. My installations are in non-standard locations. But RenderQueue worked until the 14.15.0.2 update of DS. Moreover everything else works just fine. I am using Windows 10 64bit and the 64-bit version of Daz Studio 14.15.0.2.

    I'm afraid I don't know if anything changed in 4.15.0.2 to make a non-standard installation location not work. You would have to know what API call Render Queue uses and then you could investigate whether 4.15.0.2 changed that SDK API. The change log shows several API changes, but I don't know whether any of those are related. 

    You could download and install the 4.15.0.14 Public Beta and try that. Render Queue works fine for me in that Beta, but I have a standard C:/Program Files installation of Daz Studio. 

     

  • Thnk you for trying to help me, Dr. Jellybean and Barbult.  I would love to hear from ManFriday himself on this. I have no idea how to contact him directly.

  • ManFridayManFriday Posts: 560

    Hi lamoid! I am sorry the RQ is not working for you. This is the first time I'm seeing such a report for the new version, which seems to be working fine for everyone else (I redesigned the restart code for that very reason). I'll have a closer look at the look to try and figure out what's going on. Thank you for the detailed report!

  • ManFridayManFriday Posts: 560

    Just one thing to be absolutely sure that the install manager installed the correct version: what does "Help" -> "About plugins" say under "ManFriday's Render Queue"? Sometimes DIM gets confused if multiple copies of Daz Studio are installed.

  • ManFriday! You are my Daz Studio Rockstar! Your plugins are the most useful tools I have with DS. I use MeshGrabber everytime I set up a figure. I've gotten pretty good at it, too. Thank you for adressing my RenderQueue problem.  Here's what "About Plugins" says about RenderQueue:


    Filename : C:/Program Files/DAZ 3D/DAZStudio4/plugins/MF_renderq.dll
    Name : ManFriday's Render Queue
    Author : ManFriday
    Version : 2.0.0.0

    I'm not surprised that I'm the only known person to have this problem. (I have a special relationship with Windows 10 -- I hate it and it hates me.)

    Here's another bit of information that may be useful: If I uninstall RQ using the Daz Install manager (with DS not running) RQ actually does not go away. When I start DS again, RQ is still there. It shows up as an installed plugin, is still available under the Render menu, and still runs.  It, however does not appear under the IM install tab and does appear in its ready to install tab. So at least in my installation, IM does not uninstall it correctly. I do not know if this is another symptom of the same problem. How can I manually uninstall it? Maybe if I were to do that successfully and then reinstall it, it will work. Maybe not.  These could be two separate Windows annoyances. (How in the world did MS get to be so big? Most of their software is garbage.) 

    Any ideas?

    Thank you again!!!

     

  • N00b4EverN00b4Ever Posts: 293

    Hi ManFriday;

    Hope things are well with you. I have few questions regarding your product before and go ahead I buy it.

    1. Can it render multiple selected cameras in a single scene rather than single or all cameras? I think you answered this as a yes (by making cameras visible/invisible), but my dummy brain sometimes needs baby steps (think of Oscar explaining Michael Scott what a surplus is with the Lemonade stand analogy).

    2. Can it render selected keyframes of the timeline in a single scene?

    2a. If yes, can I select different cameras on each keyframe?

    3. Can it render using local camera settings rather than general settings?

    3a. If yes, can it use both local and general settings on the same scene? E.g. Camera A general settings and Camera B local settings.

    Thanks in advance.

    Cheers.

     

    YARN | Why don't you explain this to me like I'm five? | The Office (2005)  - S05E09 The Surplus | Video gifs by quotes | 71257ee5 | 紗

  • barbultbarbult Posts: 23,514

    N00b4Ever said:

    Hi ManFriday;

    Hope things are well with you. I have few questions regarding your product before and go ahead I buy it.

    1. Can it render multiple selected cameras in a single scene rather than single or all cameras? I think you answered this as a yes (by making cameras visible/invisible), but my dummy brain sometimes needs baby steps (think of Oscar explaining Michael Scott what a surplus is with the Lemonade stand analogy).

    2. Can it render selected keyframes of the timeline in a single scene?

    2a. If yes, can I select different cameras on each keyframe?

    3. Can it render using local camera settings rather than general settings?

    3a. If yes, can it use both local and general settings on the same scene? E.g. Camera A general settings and Camera B local settings.

    Thanks in advance.

    Cheers.

    I can answer some of your questions from having used Render Queue a lot, until ManFriday can give you an official answer.

    1. Yes, in Render Queue you have the choice to select the current camera or all visible cameras. When you choose all visible cameras, the cameras that are rendered are the ones with the "eye" icon showing the open eye in the Scene pane. The cameras with the closed eye in the Scene pane will not be rendered. (See my annotated screenshot of the Render Queue Scene Options dialog attached.)

    2.  Render Queue supports still images, not animation. It will render the one keyframe that is currently selected in the scene. I don't know any way to tell it to render a different keyframe. Of course you could save different scenes - one for each keyframe you want to render and then queue up all the scenes. Maybe someone could write a script to save each keyframe as a separate scene. It is easy to queue up a lot of scenes. You can select them all at once. You don't have to select each scene individually. I really appreciate this feature.

    2a.. I think that is only possible if you save separate scenes and queue them all, as I mentioned in 2.

    3. Yes.

    3a. Yes.

     

    Render Queue camera mode.png
    726 x 386 - 42K
  • N00b4EverN00b4Ever Posts: 293

    Hi barbult;

    Thanks for your answers. It looks promising then. Maybe it's because I'm still learning how to set things up and speed up my workflow, but I typically have in a single scene dozens of keyframes that moves the story forward (as still images) and I set three or four cameras for each keyframe. Therefore each keyframe has a different set of cameras (I still don't know how to set a camera to move and remeber its settings on each keyframe).

    I can see that what I'm hoping for maybe is too complicated (at least based on my limited knowledge), in terms of choosing cameras per keyframe. The other thing I didn't consider is that any dforce asset will be messed up every keyframe I need it to simulate. So I guess the workaround you mentioned for Q2 at this stage is the best option. At least until RiverSoft releases the dForce2Morpth tool.

    Let's see if ManFriday has anything to add.

    Thanks again.

    Cheers.

  • This is a followup ro my June 22 comments where I explained that renderqueue no longer works for me.  I just today installed the public beta DS 4.15.0.14. Render Queue does not work for me in the new beta in exactly the same way it doesn't work in release version 4.15.0.2.

    ManFriday?

  • Hi, I currently have 500 scenes but I want to render a recent scene that I added and I don't want to remove all scenes. I have to click move up button 500 times. I don't want to click every times. any solution?

  • This may be the dumbest of all dumbest question lol... But for the program to restart do I have to disable the password to my CPU? (like when I lock my screen so my 3yrd old son won't mess with my CPU) This program seems like its perfect for me because of my schedule just need to know if I need to unlock my CPU to use the restart and start back after each render feature
  • Shockwave said:

    This may be the dumbest of all dumbest question lol... But for the program to restart do I have to disable the password to my CPU? (like when I lock my screen so my 3yrd old son won't mess with my CPU) This program seems like its perfect for me because of my schedule just need to know if I need to unlock my CPU to use the restart and start back after each render feature

    It doesn't actually restart the computer, just DAZ Studio. So you should be good.

  • Shockwave said:

    This may be the dumbest of all dumbest question lol... But for the program to restart do I have to disable the password to my CPU? (like when I lock my screen so my 3yrd old son won't mess with my CPU) This program seems like its perfect for me because of my schedule just need to know if I need to unlock my CPU to use the restart and start back after each render feature

    It doesn't actually restart the computer, just DAZ Studio. So you should be good.

    Okay great! Always thought for daz renders to work properly (performance wise) you needed to restart your computer when finishing a render and restarting another. But if all you have to do is just close Daz then this good.
  • Okay. I just purchased this product but can't seem to find it. Is it in the Daz 3D application? When I set it up it did it through the install manager and then I manually download the manual. It seems like it didn't create a desktop shortcut.
  • barbultbarbult Posts: 23,514

    Shockwave said:

    Okay. I just purchased this product but can't seem to find it. Is it in the Daz 3D application? When I set it up it did it through the install manager and then I manually download the manual. It seems like it didn't create a desktop shortcut.

    It is not a desktop application. It is a plugin that runs inside Daz Studio.

  • Yea that is what I'm realizing now. Seems like it is not installing. Everytime I try to Install a pop-up comes up saying that this file may be harmful. I press except anyway but it still just wont install.

    Install failed.jpg
    3840 x 2160 - 927K
    Why question mark for Unistall.jpg
    3840 x 2160 - 1M
  • duckbombduckbomb Posts: 585

    Shockwave said:

    Yea that is what I'm realizing now. Seems like it is not installing. Everytime I try to Install a pop-up comes up saying that this file may be harmful. I press except anyway but it still just wont install.

    I just had this issue, so I went to my library and downloaded the manual installation and that worked fine.  Maybe that works?

  • Okay thanks. Finally got it to work
  • ManFridayManFriday Posts: 560

    I apologize for my tardiness in replying lately. I'm back at the computer now and ready to answer questions again in case things are not running smoothly!

  • j.d.wj.d.w Posts: 5

    hello,

    I have a problem with the queue. A few days ago I aborted the render queue while it was restarting daz studio (the command window was open.). The problem now is that the software won't restart Daz studio at all. I can start the render queue in daz studio, then after the first render is done and it closes Daz studio nothing happens and Daz studio won't start up again. but when I start up daz studio manually the render queue continues with the second render in the queue so it seems that the plugin won't start the "startup sequence" of daz studio. I have reinstalled daz studio and reinstalled the plugin but still nothing. I hope that someone can help me because i loved the render queue a lot. I let my PC run when I sleep to render but I can't do this anymore. I am pretty sure that it was something I did since it started when I interrupted the startup cmd window once. I really hope somebody can help me.

  • ManFridayManFriday Posts: 560

    j.d.w said:

    hello,

    I have a problem with the queue. A few days ago I aborted the render queue while it was restarting daz studio (the command window was open.). The problem now is that the software won't restart Daz studio at all. I can start the render queue in daz studio, then after the first render is done and it closes Daz studio nothing happens and Daz studio won't start up again. but when I start up daz studio manually the render queue continues with the second render in the queue so it seems that the plugin won't start the "startup sequence" of daz studio. I have reinstalled daz studio and reinstalled the plugin but still nothing. I hope that someone can help me because i loved the render queue a lot. I let my PC run when I sleep to render but I can't do this anymore. I am pretty sure that it was something I did since it started when I interrupted the startup cmd window once. I really hope somebody can help me.

    I've never heard of this problem, but possibly there are some broken configuration settings in the render queue. All of RQ's configuration options, including the queue of scenes itself, are stored in the Registry. You can edit or delete them using Windows' own Registry Editor: press the Windows key and type "regedit" in the search field.

    You should find them under Computer\HKEY_CURRENT_USER\SOFTWARE\DAZ\Studio4\Render Queue Plugin (assuming you're using the regular Daz Studio release; replace "Studio4" with "Studio4PublicBuild" if you are using the beta). If nothing else works, delete everything that is in there, which will reset the RQ to default settings. (That will delete everything that is currently in the queue; the queue is stored under the "scene_files" key.)

    Hope this helps!

  • lamoid_5f20d3e469lamoid_5f20d3e469 Posts: 291
    edited October 2021

    The problem that j.d.w pointed out is exactly the same one I've had for months and posted about above. I will try deleting the registry entries to see if that solves the problem and let you know here.

    ... Two hours later. No that did not solve the problem.

    Post edited by lamoid_5f20d3e469 on
  • j.d.wj.d.w Posts: 5

    ManFriday said:

    I've never heard of this problem, but possibly there are some broken configuration settings in the render queue. All of RQ's configuration options, including the queue of scenes itself, are stored in the Registry. You can edit or delete them using Windows' own Registry Editor: press the Windows key and type "regedit" in the search field.

    You should find them under Computer\HKEY_CURRENT_USER\SOFTWARE\DAZ\Studio4\Render Queue Plugin (assuming you're using the regular Daz Studio release; replace "Studio4" with "Studio4PublicBuild" if you are using the beta). If nothing else works, delete everything that is in there, which will reset the RQ to default settings. (That will delete everything that is currently in the queue; the queue is stored under the "scene_files" key.)

    Hope this helps!

    Hello ManFriday.

    Thank you for answering my post. I tried you suggestion and it didn't work. it still closes down saz studio. and the render queue windows where it says restarting Daz studio does the countdown. when it closes Daz studio the windows goes into (Not responding) I get the windows loading circle for three to four seconds and the render queue window shuts down and nothing happens. 

    his is what is in the registry editor I don't know if it helps but I thought just write it down:

    (default)                            REG_SZ             (value not set)

    c_scenes_total                 REG_DWORD    0x00000003 (3)

    current_camera_idx         REG_DWORD    0x00000000 (0)

    daz_studio_quit_mode     REG_DWORD    0x00000001 (1)

    Keep_on_top                    REG_SZ             true

    last_scene_dir                  REG_SZ              F:/daz test folder mans script

    output_dir                         REG_SZ              F\ daz test folder mans script/render

    restart_custom_script     REG_SZ                @@Echo OFFREM This batch file gets called by the...

    scene_files                     REG_SZ                [{"cam":1,"file":F\\daz test folder mans script?\\1.d

    secs_initial_countdown  REG_DWORD      0x0000003c (60)

    secs_killtimeout             REG_DWORD       0x0000003c (60)

    secs_restart1                 REG_DOWRD       0x0000000a (10)

    secs_restart2                 REG_DWORD       0x0000003c (60)

    secs_to_settle_down    REG_DWORD       0x0000000a (10)

    we_restarted_DS         REG_SZ                 true

    win_size_conf              REG_SZ                 AdnQywABAAAAAAUcAAABrgAACFQAAAOkAAA

     

     

  • ManFridayManFriday Posts: 560

    j.d.w said:

    ManFriday said:

    I've never heard of this problem, but possibly there are some broken configuration settings in the render queue. All of RQ's configuration options, including the queue of scenes itself, are stored in the Registry. You can edit or delete them using Windows' own Registry Editor: press the Windows key and type "regedit" in the search field.

    You should find them under Computer\HKEY_CURRENT_USER\SOFTWARE\DAZ\Studio4\Render Queue Plugin (assuming you're using the regular Daz Studio release; replace "Studio4" with "Studio4PublicBuild" if you are using the beta). If nothing else works, delete everything that is in there, which will reset the RQ to default settings. (That will delete everything that is currently in the queue; the queue is stored under the "scene_files" key.)

    Hope this helps!

    Hello ManFriday.

    Thank you for answering my post. I tried you suggestion and it didn't work. it still closes down saz studio. and the render queue windows where it says restarting Daz studio does the countdown. when it closes Daz studio the windows goes into (Not responding) I get the windows loading circle for three to four seconds and the render queue window shuts down and nothing happens. 

    his is what is in the registry editor I don't know if it helps but I thought just write it down:

    (default)                            REG_SZ             (value not set)

    c_scenes_total                 REG_DWORD    0x00000003 (3)

    current_camera_idx         REG_DWORD    0x00000000 (0)

    daz_studio_quit_mode     REG_DWORD    0x00000001 (1)

    Keep_on_top                    REG_SZ             true

    last_scene_dir                  REG_SZ              F:/daz test folder mans script

    output_dir                         REG_SZ              F\ daz test folder mans script/render

    restart_custom_script     REG_SZ                @@Echo OFFREM This batch file gets called by the...

    scene_files                     REG_SZ                [{"cam":1,"file":F\\daz test folder mans script?\\1.d

    secs_initial_countdown  REG_DWORD      0x0000003c (60)

    secs_killtimeout             REG_DWORD       0x0000003c (60)

    secs_restart1                 REG_DOWRD       0x0000000a (10)

    secs_restart2                 REG_DWORD       0x0000003c (60)

    secs_to_settle_down    REG_DWORD       0x0000000a (10)

    we_restarted_DS         REG_SZ                 true

    win_size_conf              REG_SZ                 AdnQywABAAAAAAUcAAABrgAACFQAAAOkAAA

     

    I still don't know for certain what's going wrong, but there's two things I'm spotting here:

    -- The 'output_dir' does not seem to be a valid path: there is "F" followed immediately by a backslash. That should probably be "F:\". Unless this is a typo from when you posted this, can you try changing the output directory in the Render Queue?

    -- Your output directory contains spaces. I think the RQ handles spaces correctly, but could you try renaming the test folder to something without spaces and using that in the render queue instead?

    Thank you for your patience!

     

Sign In or Register to comment.