Hexagon BETA - version 2.5.2.137! (*UPDATED*)

Daz SoftwareDaz Software Posts: 15
edited June 13 in Hexagon Discussion

Daz 3D is pleased to announce Hexagon BETA - version 2.5.2.137!

 

Below are highlights that pertain to the current Public Build of Hexagon. Our plans for Hexagon in 2018 (and the future) are for it to be a key and growing component of our free software offering.

  • The Public Build can be installed and co-exist along side the General Release
  • Separate application and content packages can be downloaded/installed using Daz Install Manager (DIM)
    • BETA versions must be downloaded and installed using Install Manager; BETA versions are not available as a standalone installers

 



 

Highlights:

 

2.5.2.137 (June 13, 2018)

  • File IO
    • Fixed export to Carrara (*.car) format
  • General User Interface
    • The Splash screen now displays bit architecture of the application
    • The About screen now displays bit architecture of the application
    • The Help > Hexagon News command now causes the Hexagon News dialog to be displayed instead of opening a browser to the Documentation Center; each news item already contains a link
    • Improved the display of news items in the Hexagon News dialog; they are now visually separated and more easily distinguishable as individual items
    • Made tweaks to the "Preference Editor" and "Shortcut Editor" commands in the Edit menu; they now display ellipsis ("...") to signify that additional user input is required
    • Added visual separation between the Custom Palette command and the Preference/Shortcut Editor commands on the Edit menu
    • Made minor tweaks/corrections to various text elements

2.5.2.133 (June 4, 2018)

  • 64-bit Support
    • Windows
      • Can be installed and co-exist along side the 32-bit version
      • Support for DWG is not available in the 64-bit version
    • Mac
      • Not yet available - still under development
  • Stability
    • Many changes have been made to the core code that are targeted specifically at improving stability
    • Identified and eliminated various crashes
    • Identified and eliminated various memory leaks
    • Performed static code analysis and code maintenance
  • General User Interface
    • Updated various English language text entries
    • Corrected icon inconsistencies between the application and documentation
  • Windows Specific
    • Updated compiler version
  • Mac Specific
    • Made preparations for 64-bit support
    • Updated OS SDK version
    • Updated compiler version
    • Plugins are now included within the application bundle as individual files in ./Contents/PlugIns
  • Packaging
    • Updated Install Manager packages
    • Updated standalone installers; not available until General Release

 

Post edited by rbtwhiz on
«1

Comments

  • 3D-GHDesign3D-GHDesign Posts: 366

    64-bit :D THANK YOU!!!!!

  • StezzaStezza Posts: 3,532

    Save as Carrara file still not working!

  • Thanks for the update!!. Loving Hexagon again. I'm using it more than Maya at work at the moment :D ... 

  • MaxHancockMaxHancock Posts: 155

    any Beta testing needed on the Mac side? If bug fixes aren't addressed on the Mac yet, I can wait for general release? 

  • ChoholeChohole Posts: 28,069
    Stezza said:

    Save as Carrara file still not working!

     Carrara has not been the focus of this update, 64-bit support has.

  • Miss Bad WolfMiss Bad Wolf Posts: 17,654

    Way cool!  Hexagon is being worked on!  Also a major update to Dim! What next?  Bryce?

  • Richard HaseltineRichard Haseltine Posts: 43,896
    Stezza said:

    Save as Carrara file still not working!

    That wasn't listed as an issue that had been addressed in this build (which doesn't mean it won't be, in future).

  • ProPoseProPose Posts: 242

    I don't see a 64-bit installer.  Am I missing something?

  • ShawnDriscollShawnDriscoll Posts: 235
    edited June 6
    ProPose said:

    I don't see a 64-bit installer.  Am I missing something?

    Public Build is what you should have checked in your download filter for DIM.

    Post edited by ShawnDriscoll on
  • marblemarble Posts: 2,956
    edited June 6

    The 64 bit version installed via DIM but the 64bit has no Hexagon executable. The 32 bit does have the exe file and does start normally.

     

    EDIT: Uninstalled and re-installed. Fixed now.

     

    Post edited by marble on
  • ghosty12ghosty12 Posts: 921
    edited June 6

    Not seeing it in DiM either and have all the required boxes ticked that should make it show up.. Strange even though I own Hexagon, I had to go to the beta store page and put it into my cart and free pruchase it, to make it show up in DiM..

    Quote

    Post edited by ghosty12 on
  • marblemarble Posts: 2,956
    edited June 6

    Unfortunately, the 64 bit version crashes DAZ Studio if I use the Hexagon bridge. I've attempted it several times - crashes every time.

     

    Capture.JPG
    626 x 239 - 34K
    Post edited by marble on
  • Cris PalominoCris Palomino Posts: 4,013
    marble said:

    Unfortunately, the 64 bit version crashes DAZ Studio if I use the Hexagon bridge. I've attempted it several times - crashes every time.

     

    Did you do as the popup suggests?

  • marblemarble Posts: 2,956

    Nope but I will when I try it again.

  • TaozTaoz Posts: 5,411

    Great, thanks!

  • TaozTaoz Posts: 5,411
    edited June 6
    marble said:

    Unfortunately, the 64 bit version crashes DAZ Studio if I use the Hexagon bridge. I've attempted it several times - crashes every time.

    Working OK here, both ways.

    EDIT: Windows 10 Pro, version 1709

    Post edited by Taoz on
  • ProPoseProPose Posts: 242
    ProPose said:

    I don't see a 64-bit installer.  Am I missing something?

    Public Build is what you should have checked in your download filter for DIM.

    Thanks!! Got it!

  • marblemarble Posts: 2,956
    edited June 6
    Taoz said:
    marble said:

    Unfortunately, the 64 bit version crashes DAZ Studio if I use the Hexagon bridge. I've attempted it several times - crashes every time.

    Working OK here, both ways.

    EDIT: Windows 10 Pro, version 1709

    A bit more testing and it turns out to be a 3rd. Party Anatomical Elements geograft causing the crash. It does not crash when a plain-vanilla G3F is sent over the bridge. I don't think I will need to modify figures with that geograft in place so it might not be a problem. 

    One thing that is a problem though - some of the character skins don't display in the Hex viewport. The basic Jeane is fine but most of those I've tried, including several using the G3F UV and also Bethany 7 and Mei Lin 7, will only display in wireframe - no solid options (which just result in the figure disappearing if selected).

     

    ML7_Skin.JPG
    892 x 1220 - 103K
    Post edited by marble on
  • marblemarble Posts: 2,956
    edited June 6

    Just to confirm that texture problem: I switched from the 64 but version to the 32 bit and tried again ... this is the Victoria 7 skin on G3F (still no solid option).

    Vic7_Skin.JPG
    1119 x 1206 - 130K
    Post edited by Chohole on
  • marblemarble Posts: 2,956

    Also, the Hexagon bridge just stops working for no apparent reason. It will work several times in a row and then stop - requiring stopping and starting DAZ Studio. 

     

  • HighElfHighElf Posts: 138

    Yay 64bit. :D Thank you.

    I will give it a run this weekend. :)

  • Studio94Studio94 Posts: 18

    Mac: 

    1. is there any way to make Studio send to the public beta Hexagon on the mac?

     - I've tried lauching Hexagon before Studio but when I hit send-to-hexagon, it just causes the old version to be launched (prob. just a lauch manager issue, but..)

    FWIW:

    2. the missing solid colours is possibly a bridge/studio issue - it occurs for me with studio 4.10.133 + Hexagon 2.5.109 

     - actually, the solid colours are not actually missing, but the transparency is set to 1.  If you edit that down to a sensible value, back in business.

    3/ the bridge also randomly stops working with S4.10.133 + H2.5.109

  • ChoholeChohole Posts: 28,069
    edited June 6
    1.) In Hexagon, Edit > Preference Editor : Import/Export > Daz Studio Bridge > Daz Studio location > ...
    ---
    In Daz Studio, Edit > Preferences... : Bridges > Hexagon > Location > ...
    -----
    2.) http://docs.daz3d.com/doku.php/public/software/dazstudio/4/change_log#4_11_0_101
    Post edited by Richard Haseltine on
  • marblemarble Posts: 2,956
    Chohole said:
    1.) In Hexagon, Edit > Preference Editor : Import/Export > Daz Studio Bridge > Daz Studio location > ...
    ---
    In Daz Studio, Edit > Preferences... : Bridges > Hexagon > Location > ...
    -----
    2.) http://docs.daz3d.com/doku.php/public/software/dazstudio/4/change_log#4_11_0_101

    Took a while of searching but I think this is the snippet of information we are supposed to glean from that endless list:

    • Source maintenance

    • Build system tweaks

    • Fixed an issue with transparency when using Iray Uber shader and transfering to Hexagon via bridge

    DAZ Studio : Incremented build number to 4.11.0.101

    As far as I am aware, I am using the latest General Relaease of DAZ Studio (4.10.0.123) so I guess there'll be a wait until 4.11 is released.

  • Studio94Studio94 Posts: 18

    OK update on the 32b Mac version -  some good, some not so good ..

    1. (using the beta) thanks, I shoulda figured that one out...

    2. 4.11.0.101 bridge / transparency fix; in the meantime a work-around is simply to set the transparency to whatever you want in Hexagon once the item is imported from Studio (on the Mac it's a one-time change, remembered in back/forward moves of the object).

    3. no more info. 

    4. So I used the beta to make a "little black dress" (from a cylinder) as attached, all OK including dForce modifier.

    5. Hexagon 2.5 crashes quite often during exit .. but the application puts up the standard Crashreporter output (which sends the crash report to Apple) .. So I kept a copy - is there somewhere you'd like me to send it? (or should I raise a "normal" bug report?). 

     

    LittleBlackDress-Hexagon-test.png
    1024 x 1024 - 1M
  • Studio94Studio94 Posts: 18

    6. plugins - I note the comment

    • PlugIns are now included within the application bundle as individual files in ./Contents/PlugIns

    is that an indication that it might be possible (at some stage) for 3rd parties to author plugins for Hexagon? ... I, for one, would be interested in authoring plugins to sanitise meshes for dForce (in some cases, I have had to take [other people's] meshes out to blender etc. to fix) .. maybe this is subject for some different thread/forum.

     

  • Studio94Studio94 Posts: 18

    7. Displacement tool "cursor" issue.

    For the tools like "soften" the "cursor" (i.e representation of the area and strength of influence for the tool) is not being erased when the mouse moves, so leaves a trail which obscures the model making it hard to work with.  AFAICT, the tools are behaving correctly - but the interface experience is, erm, not the best...

     

     

    hexagon-screen-shot-133-a.png
    1609 x 1170 - 415K
  • Little_DragonLittle_Dragon Posts: 11

    7. Displacement tool "cursor" issue.

    Try disabling "local redraw" in Preference Editor / 3D Display / Advanced.

  • Richard HaseltineRichard Haseltine Posts: 43,896

    6. plugins - I note the comment

    • PlugIns are now included within the application bundle as individual files in ./Contents/PlugIns

    is that an indication that it might be possible (at some stage) for 3rd parties to author plugins for Hexagon? ... I, for one, would be interested in authoring plugins to sanitise meshes for dForce (in some cases, I have had to take [other people's] meshes out to blender etc. to fix) .. maybe this is subject for some different thread/forum.

    It'sd a bit of tidying up, so that the Mac version works as the Windows version does - it also means that Mac users could now disable a plug-in to aid in trouble-shooting.

  • Richard HaseltineRichard Haseltine Posts: 43,896
    5. Hexagon 2.5 crashes quite often during exit .. but the application puts up the standard Crashreporter output (which sends the crash report to Apple) .. So I kept a copy - is there somewhere you'd like me to send it? (or should I raise a "normal" bug report?).

    Open a Technical Support ticket and attach the crash report.

Sign In or Register to comment.