Daz Studio Pro BETA - version 4.20.0.17! (*UPDATED*)

12728303233

Comments

  • ahuckleahuckle Posts: 0

    Sifting through these comments, it looks like I'm not the only one having lighting issues? I went to make more renders of a well-lit scene that I already got a few renders for, except now I've got a bunch of fireflies that I cannot get rid of, even when using the firefly filter and post denoiser. I don't suppose there's anywhere you can find a previous version download of Daz? I guess I learned my lesson of backing up files the hard way...

  • jbowlerjbowler Posts: 582

    ahuckle said:

    Sifting through these comments, it looks like I'm not the only one having lighting issues? I went to make more renders of a well-lit scene that I already got a few renders for, except now I've got a bunch of fireflies that I cannot get rid of, even when using the firefly filter and post denoiser. I don't suppose there's anywhere you can find a previous version download of Daz? I guess I learned my lesson of backing up files the hard way...

    It's a known bug, reported by @jag11.  Here's my analysis:

    https://www.daz3d.com/forums/discussion/comment/7365481/#Comment_7365481

    So light is leaking through opaque surfaces.  Exactly why this causes fireflies in well lit scenes is mysterious; this is what @jag11 observed originally but my tests, while they clearly demonstrated the light leak, didn't seem to result in fireflies/convergence problems if I had sufficient illumination.  However I wasn't really testing for that - I was only checking for the leak and that is clearly there.

  • ahuckleahuckle Posts: 0

    jbowler said:

    ahuckle said:

    Sifting through these comments, it looks like I'm not the only one having lighting issues? I went to make more renders of a well-lit scene that I already got a few renders for, except now I've got a bunch of fireflies that I cannot get rid of, even when using the firefly filter and post denoiser. I don't suppose there's anywhere you can find a previous version download of Daz? I guess I learned my lesson of backing up files the hard way...

    It's a known bug, reported by @jag11.  Here's my analysis:

    https://www.daz3d.com/forums/discussion/comment/7365481/#Comment_7365481

    So light is leaking through opaque surfaces.  Exactly why this causes fireflies in well lit scenes is mysterious; this is what @jag11 observed originally but my tests, while they clearly demonstrated the light leak, didn't seem to result in fireflies/convergence problems if I had sufficient illumination.  However I wasn't really testing for that - I was only checking for the leak and that is clearly there.

    I see, thank you for the clarification, that was an interesting read. I guess all there is to do is hold off on renders until the bug gets patched out. 

  • nonesuch00nonesuch00 Posts: 16,730
    edited March 23

    Hey Beta Bug testers,

    There is a bug that a normal from the New York City Stores product by Aurelio that DAZ Studio Public Beta 4.20.0.8 keeps saying it is processing 13Dirtnormal.jpg over & over for over a day non-stop now.

    If it is not that product then it is the i13 Theatre with Poses

    See attached at the app status bar on the bottom.

     

     

    Bug.png
    1916 x 1023 - 2M
    Post edited by nonesuch00 on
  • jbowlerjbowler Posts: 582

    jbowler said:

    So light is leaking through opaque surfaces.  Exactly why this causes fireflies in well lit scenes is mysterious; this is what @jag11 observed originally but my tests, while they clearly demonstrated the light leak, didn't seem to result in fireflies/convergence problems if I had sufficient illumination.  However I wasn't really testing for that - I was only checking for the leak and that is clearly there.

    There's another instance which doesn't involve a light leak reported here:

    https://www.daz3d.com/forums/discussion/comment/7331201/#Comment_7331201

    It's sort-of similar; in both examples there is a very bright light (sun-sky or the ghost light) which is reduced massively in actual luminance, either by the obstruction blocking the light or, in the ghost light case, the cutout opacity reducing the actual luminance. 

  • ImagoImago Posts: 4,213

    Just found another bug: When filtering the Parameters, if I go with the mouse on the parameter I want to see in the GraphMate pane I see the value that's listed in same position in non-filtered list.

    I'll explain better, if I filter, for example, "Smile" and it's the first of the filtered list, if I go with the mouse over it, in the GrapMate pane I see "Translation X" line instead of the "Smile" line since it's the first in the non-filtered list.

  • Richard HaseltineRichard Haseltine Posts: 83,942

    Imago said:

    Just found another bug: When filtering the Parameters, if I go with the mouse on the parameter I want to see in the GraphMate pane I see the value that's listed in same position in non-filtered list.

    I'll explain better, if I filter, for example, "Smile" and it's the first of the filtered list, if I go with the mouse over it, in the GrapMate pane I see "Translation X" line instead of the "Smile" line since it's the first in the non-filtered list.

    Do you literally mean Keymate, or are you looking at teh dopesheet of the Timeline? Keymate (and Graphmate) are now integrated into the Timeline, the standalone versions are not being further developed.

  • ImagoImago Posts: 4,213

    Richard Haseltine said:

    Imago said:

    Just found another bug: When filtering the Parameters, if I go with the mouse on the parameter I want to see in the GraphMate pane I see the value that's listed in same position in non-filtered list.

    I'll explain better, if I filter, for example, "Smile" and it's the first of the filtered list, if I go with the mouse over it, in the GrapMate pane I see "Translation X" line instead of the "Smile" line since it's the first in the non-filtered list.

    Do you literally mean Keymate, or are you looking at teh dopesheet of the Timeline? Keymate (and Graphmate) are now integrated into the Timeline, the standalone versions are not being further developed.

    Both of them, it doesn't work in GraphMate standalone nor in the intregrated one.

  • Richard HaseltineRichard Haseltine Posts: 83,942

    Imago said:

    Richard Haseltine said:

    Imago said:

    Just found another bug: When filtering the Parameters, if I go with the mouse on the parameter I want to see in the GraphMate pane I see the value that's listed in same position in non-filtered list.

    I'll explain better, if I filter, for example, "Smile" and it's the first of the filtered list, if I go with the mouse over it, in the GrapMate pane I see "Translation X" line instead of the "Smile" line since it's the first in the non-filtered list.

    Do you literally mean Keymate, or are you looking at teh dopesheet of the Timeline? Keymate (and Graphmate) are now integrated into the Timeline, the standalone versions are not being further developed.

    Both of them, it doesn't work in GraphMate standalone nor in the intregrated one.

    Well, the one that is part of the Timeline should certainly get a report.

  • ImagoImago Posts: 4,213

    Richard Haseltine said:

    Well, the one that is part of the Timeline should certainly get a report.

    Yes, please, it's another colossal obstacle to animations. Also, please, tell them about the unmovable triangles and impossible to copy-paste keyframes in timeline, perhaps the devs will listen to you more than me.

    I would really love to try Filament and other new stuff for real but until all the bugs on the animation tools aren't fixed I have to stay with DAZ Studio 4.12.

  • takezo_3001takezo_3001 Posts: 1,564

    Imago said:

    Richard Haseltine said:

    Well, the one that is part of the Timeline should certainly get a report.

    Yes, please, it's another colossal obstacle to animations. Also, please, tell them about the unmovable triangles and impossible to copy-paste keyframes in timeline, perhaps the devs will listen to you more than me.

    I would really love to try Filament and other new stuff for real but until all the bugs on the animation tools aren't fixed I have to stay with DAZ Studio 4.12.

    You know you can have version 4.12 and 4.20 installed simultaneously, that includes the general release and the beta... There is no need to be stuck with that version only. 

  • ImagoImago Posts: 4,213

    I have 4.12 and the latest 4.20 beta installed together, but 4.20 has so many bugs and so destructive for animation workflow that's impossible to work on it.

    So I can't use the latest releases for my work and keep 4.12 until all the bugs are fixed. I keep reporting them since the release of 4.14 but nothing changed until today.

    Last hope is Richard reporting them directly to the devs, who will finally make some fixes.

  • sandmanmaxsandmanmax Posts: 989

    Has anybody else noticed that when you load an old scene and try to save it, 4.20 wants to File/Save-As?  I literally loaded it in 4.16.0.3, rendered and save at 10:34 am.  Did the same thing in 4.20.0.6 and it pops up the Filtered Save dialog instead of overwriting it automatically.  When I saved it under a new name in 4.20, it loade3d and saved correctly.  Just to make sure 4.16 isn't doing the same thing, I loaded a file from 2015.  It saved just fine in 4.16.

  • jbowlerjbowler Posts: 582

    sandmanmax said:

    Has anybody else noticed that when you load an old scene and try to save it, 4.20 wants to File/Save-As?

    I don't think that's new in 4.20, though it may be.  It strikes me as reasonable to change to a "save as..." if the file format has changed in a significant way and the addition of the UI to not save the render/background settings allows 4.20 to save a file which is radically different to the one 4.16 saved (because it doesn't have render/background settings if that is switched off).

  • Richard HaseltineRichard Haseltine Posts: 83,942

    It will behave as if save was save as if the author nema in the scene does not match the current author name (Edit>Preferences, Daz Studio>Preferences on a Mac)

  • jbowlerjbowler Posts: 582

    Richard Haseltine said:

    It will behave as if save was save as if the author nema in the scene does not match the current author name (Edit>Preferences, Daz Studio>Preferences on a Mac)

    That may be it - I checked and I have slightly different author names in the General Release and Public Builds.

  • sandmanmaxsandmanmax Posts: 989

    jbowler said:

    sandmanmax said:

    Has anybody else noticed that when you load an old scene and try to save it, 4.20 wants to File/Save-As?

    I don't think that's new in 4.20, though it may be.  It strikes me as reasonable to change to a "save as..." if the file format has changed in a significant way and the addition of the UI to not save the render/background settings allows 4.20 to save a file which is radically different to the one 4.16 saved (because it doesn't have render/background settings if that is switched off).

    That makes sense.  That's what 4.16 did when I loaded an old .daz file.

  • takezo_3001takezo_3001 Posts: 1,564

    Imago said:

    I have 4.12 and the latest 4.20 beta installed together, but 4.20 has so many bugs and so destructive for animation workflow that's impossible to work on it.

    So I can't use the latest releases for my work and keep 4.12 until all the bugs are fixed. I keep reporting them since the release of 4.14 but nothing changed until today.

    Last hope is Richard reporting them directly to the devs, who will finally make some fixes.

    Oh, ok, well I hope DAZ finally squashes those bugs once and for all, especially since we're getting close to DS5! 

  • nonesuch00 said:

    Hey Beta Bug testers,

    There is a bug that a normal from the New York City Stores product by Aurelio that DAZ Studio Public Beta 4.20.0.8 keeps saying it is processing 13Dirtnormal.jpg over & over for over a day non-stop now.

    If it is not that product then it is the i13 Theatre with Poses

    See attached at the app status bar on the bottom.

     

    I'm trying to contact Aurelio for a quote from a custom asset.
    Does anyone have his contact?

  • nonesuch00nonesuch00 Posts: 16,730

    marcelocaparoz said:

    nonesuch00 said:

    Hey Beta Bug testers,

    There is a bug that a normal from the New York City Stores product by Aurelio that DAZ Studio Public Beta 4.20.0.8 keeps saying it is processing 13Dirtnormal.jpg over & over for over a day non-stop now.

    If it is not that product then it is the i13 Theatre with Poses

    See attached at the app status bar on the bottom.

     

    I'm trying to contact Aurelio for a quote from a custom asset.
    Does anyone have his contact?

    I don't. You must contact DAZ 3D Customer Support via their Help Ticket system and ask them if he has supplied them with a direct support channel. Most PAs don't I think.

  • So what does 4.20.0.11 fix compared to 4.20.0.8?

    From my cursory examination of the changelog, it doesn't mention anything related to Iray.

    Richard, did you perhaps report the Caustic Sampler bug I described here?

  • jbowlerjbowler Posts: 582

    johndoe_36eb90b0 said:

    So what does 4.20.0.11 fix compared to 4.20.0.8?

    From my cursory examination of the changelog, it doesn't mention anything related to Iray.

    I don't think there's anything there, at least not in the change log.  There does seem to be a major change wrt memory management for plug-ins but apart from that the main change seems to be for finding asset information via the SDK.  That strikes me as potentially very interesting for the character-load issue; it suggests that it might be relatively easy to produce a CMS environment containing exactly the products used in a scene, thus masssively decreasing scene load time and maybe even increasing edit-time performance significantly.

    The projection morph PA product that was recently released may also help with edit-time performance; I've been battling with a ridiculously simple scene which has the property that if I change a character pose everything is fine until I release the (anibones) drag then I have time to brew a cup of coffee while DAZ Studio recomputes something...  (Well, there's a 3-5 second delay before the UI responds again.)

  • ImagoImago Posts: 4,213

    This souncds interesting: Extended DzScene SDK API; added protectSceneSourceFileByAuthor()

    It means I can lock scenes to avoid third parties to extract my models?

  • jbowlerjbowler Posts: 582

    Imago said:

    This souncds interesting: Extended DzScene SDK API; added protectSceneSourceFileByAuthor()

    It means I can lock scenes to avoid third parties to extract my models?

    It's not yet documented:

    http://docs.daz3d.com/doku.php/public/software/dazstudio/4/referenceguide/scripting/api_reference/object_index/scene_dz

  • GedanGedan Posts: 2

    Hi folks,

    Question for you, about ghostlights. I've set up a scene, used four planes, ran that ghostlight script, Daz user was kind enough to make. Set  luminence units to KCD and turned on two sided light (It's the only way I can get them to work).

    Only it was cranking out so much light, it was bouncing off a lamp cover that i didn't want to incude, sort like gave away the render was using a G/L. So I tried something , I turned down the luminosity  and thought I clicked on the lamp surface and turned off user limits and increased cutout opacity uptill 10, in the hopes it would dampen down the light. Only it turns out I'd clicked on the Ghost light, So the short of it is lumen was set at 60.00 and cutout opacity on the ghost light was set initally at 10, if you increase the cutout opacity it also increases the ghost light brightness, I'm stumped as to why it's doing this, anybody got an answer??? Tia,

    The Ghost light is above the sitting room.

     

    GLtest Base Lum 60.00 Cutout 1.00.jpg
    1519 x 988 - 686K
    GLtest Base Lum 60.00 Cutout 10.00.jpg
    1519 x 988 - 822K
    GLtest Base Lum 60.00 Cutout 25.00.jpg
    1519 x 988 - 877K
  • barbultbarbult Posts: 19,377

    in DS 4.20 version of Iray, opacity and luminance are multiplied together to determing the light output. I assume that is why the light gets brighter it you increase opaccity.

  • skboaskboa Posts: 54

    johndoe_36eb90b0 said:

    -

    Richard, did you perhaps report the Caustic Sampler bug I described here?

    I wouldn't expect that to happen. He has made it clear a few times that, if we don't report bugs ourselves via support ticket, they will most likely never reach the devs.

  • GedanGedan Posts: 2

    @ barbult ,

    Thanks for this, that makes sense - kinda weird though increasing opacity increases brightness, cheers anyway

  • skboa said:

    johndoe_36eb90b0 said:

    -

    Richard, did you perhaps report the Caustic Sampler bug I described here?

    I wouldn't expect that to happen. He has made it clear a few times that, if we don't report bugs ourselves via support ticket, they will most likely never reach the devs.

    Doesn't matter, I am not going to update past 4.16.0.3 General Release anyway.

    New features (guided sampling, volumetric stuff) simply aren't worth the broken emissive lighting and caustics in 4.20.

  • jbowlerjbowler Posts: 582

    Gedan said:

    Thanks for this, that makes sense - kinda weird though increasing opacity increases brightness, cheers anyway

    That's why it's actually called "alpha"; it is not the opacity of an object, it is the amount of an object that is actually there.  If you set opacity to 0.5 the object is only half there; it only interacts with half the colour, the other half goes unmolested.  In DAZ true opacity seems to be the surface "refraction weight" property; the amount of colour that actually goes through the surface rather than being reflected.

Sign In or Register to comment.