Missing shadows in reflections

I just did a test scene with a few balls on a beach surface for reflections and such. I noticed that although the quality was impressive... it was missing something. Then I realized the shadows were not being reflected on mirrored surfaces. What could I have done or not done to cause that? My guess is that the HDRI map does not accept shadows. I am using a shader setting someone told me to use to get shadows with HDRI environments. Since they are not normal shadows, would this be why shadows do not show up in reflections?

5 balls.jpg
600 x 600 - 103K

Comments

  • WendyLuvsCatzWendyLuvsCatz Posts: 28,557

    in the reflection part of the shader there is a value for ray depth, default is only 2, crank that up

  • TimBoTimBo Posts: 147

    Thanks. I set it from 2 all the way to 32 and saw no improvement

  • WendyLuvsCatzWendyLuvsCatz Posts: 28,557

    sad

    must be some setting we are overlooking

  • TimBoTimBo Posts: 147

    Maybe someone out there knows what to do......

  • Richard HaseltineRichard Haseltine Posts: 65,907
    edited October 14

    Is that an actual ground, or is it the shadow-catcher from the environment floor?

    Post edited by Richard Haseltine on
  • DartanbeckDartanbeck Posts: 16,502

    Is that an actual ground, or is it the shadow-catcher from the environment floor?

    Good call, Richard! 

    If this is the issue, just try putting in a small prop to act as the floor and see if that makes a difference - it should.

    There is also a ray depth setting in the Render Room, but I think you probably already know that. If none of the above are working, maybe try using Indirect Lighting along with the Sky light and see if that solves it.

  • TimBoTimBo Posts: 147

    I tried a box beneath the spheres and disabled the shadow catcher plane. The shadows did come through and reflected as they were expected to do. But enabling the shadow catcher place removed the shadows. I already was using Indirect lighting and Skylight. I disabled them but it didn't fix the problem of missing shadows.

  • DartanbeckDartanbeck Posts: 16,502
    TimBo said:

    I tried a box beneath the spheres and disabled the shadow catcher plane. The shadows did come through and reflected as they were expected to do. But enabling the shadow catcher place removed the shadows. I already was using Indirect lighting and Skylight. I disabled them but it didn't fix the problem of missing shadows.

    Perhaps there's a setting in the Shadow Catcher shader that can enable them? If not, you'll have to use something of a prop (or other solid-shader geometry).

  • StezzaStezza Posts: 5,786
    edited October 15

    mmm

    I used a hdri for the background and used grid mesh textured to try and match the hdri image

    balls.png
    640 x 480 - 375K
    Post edited by Stezza on
  • SileneUKSileneUK Posts: 1,702

    Stezza, nice HDRI, where did you get that one?  I have a lot, but they never look quite right for what I need.  heart Silene

  • UnifiedBrainUnifiedBrain Posts: 2,712
    Stezza said:

    mmm

    I used a hdri for the background and used grid mesh textured to try and match the hdri image

    A good solution, Stezza!  In other words, don't use a shadow catcher if you want reflected shadows.  Just lay down a mesh in the forground that matches the HDR.  Of course, you have to know enough about Carrara to be able to accurately texture that mesh. :)

  • TimBoTimBo Posts: 147

    yes indeed. I'm afraid I don't know that much detail about Carrara. I suppose I will have dig a little deeper myself.

  • StezzaStezza Posts: 5,786
    SileneUK said:

    Stezza, nice HDRI, where did you get that one?  I have a lot, but they never look quite right for what I need.  heart Silene

    free from this site

    HDRI haven... I just play around with the light settings in the background tab where you load the hdr file.. This particular one I upped the intensity to 200% but I have gone up to 400%+ for some.. wink

  • DartanbeckDartanbeck Posts: 16,502

    Just out of curiousity, TimBo, did you have "Catch Global Illumination" and that jazz turned on in the shadow catcher?

  • SileneUKSileneUK Posts: 1,702
    Stezza said:
    SileneUK said:

    Stezza, nice HDRI, where did you get that one?  I have a lot, but they never look quite right for what I need.  heart Silene

    free from this site

    HDRI haven... I just play around with the light settings in the background tab where you load the hdr file.. This particular one I upped the intensity to 200% but I have gone up to 400%+ for some.. wink

    yesheart  SIlene

Sign In or Register to comment.