What features would you like to see appear in dazstudio 5?

1818283848587»

Comments

  • I might have overlooked it, but a panel with products currently used in the scene would be nice. Or a filter tickbox, like "show products currently used" in the Smart Content panel. Makes switching between products way faster

  • DiomedeDiomede Posts: 11,880
    edited December 2020

    nicstt said:

    I would like version 5 to include all the tools available for PAs.

    I would like about 20 more canvasses.  See Carrara's list of multipasses for specifics

    I would also like many of the plugins to be incorporated as regular features.  Some of these include

    - Ultrascatter Pro

    - all plugins that add functionality or convenience to the geometry editor

     

    How much are you prepared to pay for PA only features?

    Nothing is inherently PA only.  Nothing.  Whether or not something is PA only is entirely within the discretion of Daz3D.  The joint editor could be PA only if they so desired.  They chose to make the joint editor accessible to users because it enhances the usefulness of users who buy their content.  Same concept applies to every current and potential feature.

    So, please rephrase your question

    Post edited by Diomede on
  • Mark_e593e0a5 said:

    I might have overlooked it, but a panel with products currently used in the scene would be nice. Or a filter tickbox, like "show products currently used" in the Smart Content panel. Makes switching between products way faster

    It's a script, so modal, but http://docs.daz3d.com/doku.php/public/software/dazstudio/4/referenceguide/scripting/api_reference/samples/metadata/list_products_used/start

  • I would like to know for certain all of my existing content and plug-ins would still work, so that I would not feel terrified to upgrade and take advantage of and interest in the newer abilities of Daz - as I am now, not daring to upgrade past 4.10, knowing there is no way to go back if something gets broken :-(  If it isn't reasonable to ask Daz to guarantee continued operation of past products, then I don't think it is unreasonable to ask for past iterations of Daz to be made available to people who own plug-ins that are no longer supported or updated that they still wish to use.

  • jmtbank said:

    I would like 2+ smoothing modifier targets.

    YES!!!  Even just 2 would make so many things possible; character and one other piece of clothing, or an object, or whatever...

  • Richard HaseltineRichard Haseltine Posts: 69,969
    edited December 2020

    Misselthwaite said:

    I would like to know for certain all of my existing content and plug-ins would still work, so that I would not feel terrified to upgrade and take advantage of and interest in the newer abilities of Daz - as I am now, not daring to upgrade past 4.10, knowing there is no way to go back if something gets broken :-(  If it isn't reasonable to ask Daz to guarantee continued operation of past products, then I don't think it is unreasonable to ask for past iterations of Daz to be made available to people who own plug-ins that are no longer supported or updated that they still wish to use.

    Copy the isntallers for DS and its plug-ins from the DIM Downloads folder to a safe location, then if you need to revert put DIM in Offline mode, copy the older zips on top of the newer, delete the matching .dsx files from that folder (not the oesn in the manifests folder), and you should be able to install the older version in place of the newer.

    We can be fairly sure that all plug-ins will need updating, which means some will no longer be usable, in DS 5 if not before because of the need to modify the code for compatibility with MacOS Big Sur (this will affect Windows users too).

    Post edited by Richard Haseltine on
  •  Except I have 'delete after installation' checked on my DIM, so I do not have the old zip files anymore.  :-(    Thank you for the process, though :-)

    Richard Haseltine said:

    Misselthwaite said:

    I would like to know for certain all of my existing content and plug-ins would still work, so that I would not feel terrified to upgrade and take advantage of and interest in the newer abilities of Daz - as I am now, not daring to upgrade past 4.10, knowing there is no way to go back if something gets broken :-(  If it isn't reasonable to ask Daz to guarantee continued operation of past products, then I don't think it is unreasonable to ask for past iterations of Daz to be made available to people who own plug-ins that are no longer supported or updated that they still wish to use.

    Copy the isntallers for DS and its plug-ins from the DIM Downloads folder to a safe location, then if you need to revert put DIM in Offline mode, copy the older zips on top of the newer, delete the matching .dsx files from that folder (not the oesn in the manifests folder), and you should be able to install the older version in place of the newer.

    We can be fairly sure that all plug-ins will need updating, which means some will no longer be usable, in DS 5 if not before because of the need to modify the code for compatibility with MacOS Big Sur (this will affect Windows users too).

  • Richard Haseltine said:

    Mark_e593e0a5 said:

    I might have overlooked it, but a panel with products currently used in the scene would be nice. Or a filter tickbox, like "show products currently used" in the Smart Content panel. Makes switching between products way faster

    It's a script, so modal, but http://docs.daz3d.com/doku.php/public/software/dazstudio/4/referenceguide/scripting/api_reference/samples/metadata/list_products_used/start

    Thanks a lot, Richard. Helps a bit, but I would rather have a kind of quick access to the items I am using in my current scene. Like, if you find out the hair colour that seemed okay for the plain character does not look too good in the whole scene, then having a shortcut back to the hair material would be nice. And, no, smart content cannot help here, as the quality of metadata usually beggars description. 

  • Richard Haseltine said:

    Misselthwaite said:

    I would like to know for certain all of my existing content and plug-ins would still work, so that I would not feel terrified to upgrade and take advantage of and interest in the newer abilities of Daz - as I am now, not daring to upgrade past 4.10, knowing there is no way to go back if something gets broken :-(  If it isn't reasonable to ask Daz to guarantee continued operation of past products, then I don't think it is unreasonable to ask for past iterations of Daz to be made available to people who own plug-ins that are no longer supported or updated that they still wish to use.

    Copy the isntallers for DS and its plug-ins from the DIM Downloads folder to a safe location, then if you need to revert put DIM in Offline mode, copy the older zips on top of the newer, delete the matching .dsx files from that folder (not the oesn in the manifests folder), and you should be able to install the older version in place of the newer.

    We can be fairly sure that all plug-ins will need updating, which means some will no longer be usable, in DS 5 if not before because of the need to modify the code for compatibility with MacOS Big Sur (this will affect Windows users too).

    It would be really helpful if plugins that are only usable in a given version or operating system are marked as such. I had to return an item because it did not state that is was 32bit binaries only. CS did initiate the refund really fast, but I think that ticket could have been avoided. On the other hand, testing all my plugins on 4.14. did not go too bad so far laugh

  • ChumlyChumly Posts: 313

    I don't know if this has already been mentioned (as the thread is 87 pages)

    But I would hope that Daz v5 would move toward maximizing the use of multi-threads for use with CPU with a ton of cores that are now out, and or coming out.

    Just curious, but I wonder if the morph loading process (which bogs my load time down) could benefit from multi-threads... if incorperated into v5?

    Just askin'

  • SevrinSevrin Posts: 5,352

    My experience with Daz Studio would be much improved if products purchased at the Daz store could be relied on to work correctly, and metadata was assigned properly.  They couldn't even manage that for the 8.1 rollout, mixing up male and female Smart Content.

  • Sevrin said:

    My experience with Daz Studio would be much improved if products purchased at the Daz store could be relied on to work correctly, and metadata was assigned properly.  They couldn't even manage that for the 8.1 rollout, mixing up male and female Smart Content.

    Plus the Summers End outfit textures from today's addon section end up in Lost and Found. Neverending story. How complicated is it to categorize a product that only contains ONE category: materials? Granted, it contains materials for 3DLight and IRay.

  • inquireinquire Posts: 1,505

    Just what is Genesis 8.1? Any links? And, can you use the G 8 figures, or do you have to buy all new characters?

  • Robert FreiseRobert Freise Posts: 3,217

    inquire said:

    Just what is Genesis 8.1? Any links? And, can you use the G 8 figures, or do you have to buy all new characters?

     https://www.daz3d.com/genesis-8-1

  • A color picker eyedropper!!!

  • kyoto kidkyoto kid Posts: 35,016

    ...+1

  • IvyIvy Posts: 6,789
    edited January 21

    Misselthwaite said:

    I would like to know for certain all of my existing content and plug-ins would still work, so that I would not feel terrified to upgrade and take advantage of and interest in the newer abilities of Daz - as I am now, not daring to upgrade past 4.10, knowing there is no way to go back if something gets broken :-(  If it isn't reasonable to ask Daz to guarantee continued operation of past products, then I don't think it is unreasonable to ask for past iterations of Daz to be made available to people who own plug-ins that are no longer supported or updated that they still wish to use.

     I agree it be nice not to have to keep updating plugins with every new daz studio version. or worry if the $49+ plugin you bought 2 weeks prior to the new release will still work when you update to a new release version of daz. I can not tell you the amount of times that has happened. that required me to send in a fix it ticket. and the wait time for support getting back to you if ever is getting beyond insane.     And from my few recent experiences . Rolling back to your old version of daz does not always mean it will ever work the same again after you installed a new version of daz,  sometime some of those new version files still linger & reside in the Appdata folder and the Registry. even after uninstalling and reinstalling your daz version. ,  which means you need to go hunt for those files manually.

    My top wishlist changes

    1) Stop breaking plugins with new daz updates.

    2) a better IK/Fk with Hard surface solutions.

    3) built-in Easy plug and play dock for connecting Daz studio to any type render farms other than Iray beta, So we can Dock to like renderman tractor,   vray or metal ray chaos servers.  without having to use a virtual server or Virtual desk top app to do it ( I am tired of being timed out with Virtual apps.) a direct dock would be awesome.

    4) Aoptions for changing UI font size.

    It cost no more to dream big

    Post edited by Ivy on
  • inquireinquire Posts: 1,505

    Robert Freise said:

    inquire said:

    Just what is Genesis 8.1? Any links? And, can you use the G 8 figures, or do you have to buy all new characters?

     https://www.daz3d.com/genesis-8-1

    Thanks for this post. Not clear to me: Would I have to "rebuild" a character I've saved onto an 8.1? Would I be able to add the 8.1 HD Add-On to a character I've already saved?

  • Robert FreiseRobert Freise Posts: 3,217

    inquire said:

    Robert Freise said:

    inquire said:

    Just what is Genesis 8.1? Any links? And, can you use the G 8 figures, or do you have to buy all new characters?

     https://www.daz3d.com/genesis-8-1

    Thanks for this post. Not clear to me: Would I have to "rebuild" a character I've saved onto an 8.1? Would I be able to add the 8.1 HD Add-On to a character I've already saved?

    Not sure but I think yes to the first but an absolute no to the second as it's not backwards compataible 

  • pluplu Posts: 0

    TxFilmaker said:

    Wildcard search. When I am looking for anything like grass, bucket, whatever if I do not put the full name of the item it does not find it. With a wildcard search I can find all grass objects the right click and open the prodIIuct to use the grass or whatever else might interest me

    I second this request.

    In Smart Content, either file or products, when I search Shirt, I can't find 'Intimates V-Neck Shirt' unless I would add Shirt as a Tag to it.

    A DB search with LIKE (instead of =) allowing to search for %shirt% should make that possible and the code can stay the same if no wildcards are being used.

    If Content Library search can do it, why not in Smart Content also?

Sign In or Register to comment.