G8F: Height changing body morphs break IK. Figure jumps up or down when moving body parts

DrHemulenDrHemulen Posts: 72
edited December 2017 in Daz Studio Discussion

I'm having a bit of a weird issue with Genesis 8 and some of the full body morphs. Some of the full body morphs that change the height of the figure seems to break IK functionality. Example:

  1. Load G8F
  2. Apply height full body morph (or character like V8 that alters height)
  3. Select hand
  4. Move hand up or down.

The instance I move the hand , the whole character jumps upwards in the viewport. The amount of jumping is proportional to the amount of height change by the morph. If I make the character smaller, it jumps downwards. If I try to move it again, it jumps a step more. This makes posing almost impossible.


  • Bones seem to scale fine with the size of the figure
  • XYZ translations for the entire figure are unchanged by the jumpt
  • The problemissue does not come from all size changing morphs. Height changing morphs from here https://www.daz3d.com/hfs-ultimate-shapes-for-genesis-8-female work fine.
  • I do not see the same issue with G7 and the official height morph or any of the characters.
  • Restoring pose to zero moves the figure back down to the ground

Things I have tried:

  • Uninstalling and reinstalling G8 base products
  • Upgrading DAZ to

I have attached a GIF of the issue with V8.

ny suggestions?


Post edited by DrHemulen on


  • People have reported this jumping behaviour, though in less detail. Please make a bug report (Technical Support ticket https://www.daz3d.com/help/help-contact-us ) with that very useful step-by-step guide to reproducing the issue.

  • Thanks I will do that. I thought it was me having a bad setting somewhere, and not a "real" bug, as I couldn't find anything about it.

  • nonesuch00nonesuch00 Posts: 15,122

    so its these morphs causing that?


  • Yes, more specifically the "height" morph. As I mentioned, I also get the effect with the Victoria 8 morph. This does not activeate the height morph, but I wonder if the morph wasn't used in its creation. From the V8 characters I have, the following have the issue:

    • Elizabeth
    • Rebekah
    • Victoria8

    These are all heigher than the standard G8F model.

    These work:

    • Alondra
    • Daphne
    • Genesis 8F
    • Laverne
    • Monique8
    • Phoebe
    • Olympia
    • Sarah
    • Kallisto

    None of these make the base G8F heigher, so that fits the theory.

    Interestingly Laverne and Monique make the model less tall, but don't exhibit the jumping effect I get when I use the "height" morph to make them smaller.


  • I've found an effective way of dealing with this is pinning the hips when moving the feet and pinning the chest when moving the hands. A bit of a hassle, but such does prevent the jumping for me.

  • nonesuch00nonesuch00 Posts: 15,122


  • Yeah thanks, that works for me too, and might also point towards the root cause of the issue. Do you guys also see the issue with figures with altered height and not, for instance, the standard Genesis 8 Female?

  • nonesuch00nonesuch00 Posts: 15,122

    I can tell you it didn't happen with the Genesis 8 Male scaled to 101.8% size and Lucas 8 Body dialed in 100% however height was at 0%

    But if I morph the Genesis 8 Male to be taller and do a translate with the translate gizmo in the viewport the G8M jumps like the G8F does. But I also get the jump effect, only downwards, when the character is made shorter. At 100% Height no jump. I think it might have something to do with IK follow is what I think they call it.

    However, I cannot test much to help you as DAZ Studio 4.10.x has broken the usability of all the Viewport Gizmos for me as there seems to be some I/O bound usuability problem in the UI of the viewport for me and an Intel HD Graphics 4000 with textured shading. I have opened a ticket about that bug though & it's been accepted as a problem they are looking into.




  • did a bit of testing on this one and it appears to be something with changing the hip translation.

    when you get the jump check the hip translation, i was getting a jump of 13.5 per jump, was always a multiple of 13.5 depending on number of jumps.

    this correlated to the value on y translation of the hip in the DSF, FBMHeight.DSF, when i set that value to 0 it became a more stable.

    Eliminating the link between the height dial and the hip translation, deleting the lines of code, or just deleting it in the dial properties, eliminated the problem all together.

    BUT, G8F is now floating about 14.34 y translation, above the ground.

    Ctrl+d puts her back on the ground.

    relinking the dials, via erc freeze, doesn't cause the issue to reappear unless i have some value in the y translation and then it will start jumping in multiples of what ever value i have in it.


    I'm gonna do some more testing to see if there's something linked to the hip translation that is causing this or not.


  • Thanks! That's a bit above my level at this point :)


  • Mephisto3Mephisto3 Posts: 28

    Hi all - was this problem ever solved? I am experiencing it today... roughly half a year later... can you help?

  • DrHemulenDrHemulen Posts: 72

    No, I contacted support, but they just suggested pinning the hips like Denmisun suggest. It's not terribly elegant, but it works.

  • Richard HaseltineRichard Haseltine Posts: 71,724

    It does, however, have a fix in a forthvcoming version of DS - see the change log for version, which both explains the issue and reports the fix  http://docs.daz3d.com/doku.php/public/software/dazstudio/4/change_log#4_11_0_148

  • mikmodmikmod Posts: 26
    edited August 2018

    The bug is apparently present also with the Height morph of Genesis 8 Male Body Morphs set.



    Post edited by mikmod on
  • maxikg said:

    The bug is apparently present also with the Height morph of Genesis 8 Male Body Morphs set.

    In the 4.11 Public Beta? If it's 4.10 then that is unsurprising, it wasn't a figure-specific issue.

  • RezzerRezzer Posts: 10

    For those who are still experiencing this problem, here's a quick guide on how to "fix" this issue while we wait for the official fix in the next DAZ release

    * Select your figure and go to the Property Hierachy Pane.
    * Navigate to Bones -> Hip -> Controllers -> 1st Stage
      - Any of the items in this list may cause this problem. So, I'm afraid this will be trial-and-error.
    * Select one of the properties
      - In the example I'm providing here, PBMLegsLength is the morph that was causing trouble.
    * Right click on the property -> Remove Selected
    * Try moving the figure. If the problem persists, select another property and remove it until you find the right one.
      - If you already know which morphs/shapes you've applied to your figure, then it's going to be one of those.

    What happens after I remove this property?

    These properties are used to move the Hip of the figure so that the feet remain on the ground in the zero position. For instance, in my case, PBMLegsLength was used to keep the figure on the ground while the legs increase or decrease in size. After removing this property, the feet either grow below the ground or the figure starts hovering above it.

    How do I fix it?

    Ctrl+D will reset the figure's position to the ground. Or manually move the Hip to keep the feet where they should be.

    849 x 1564 - 326K
    849 x 1564 - 432K
    849 x 1564 - 453K
  • They need to fix this asap. This lock the hip does NOT work if you have a pose where the hip shall move with the character. Like in animation.

  • Seven193Seven193 Posts: 691
    edited January 2019

    I never use the Translate Tool with figures.  The ActivePose Tool is more natural for moving character limbs.  Translate Tool is good for static objects like props, but I have never noticed this problem.

    Post edited by Seven193 on
  • JpegerJpeger Posts: 12
    edited January 2019

    Quick fix for me was to use the Rezzer method above, but instead of removing the PBMLegsLength line, I removed the "height" one.

    Another option is to set the height value to 0 before posing, and then returning it to the previous value, but that's not optimal.

    Post edited by Jpeger on
Sign In or Register to comment.