New install problems with DIM

I just purchased a new Mac and am having trouble installing DAZ studio. I began by installing DIM and then installed the current version of Daz which is 4.22 using DIM to do so. My next step was to install all the essential downloads as shown on DIM.

This done I decided to check that everything was working okay.

The path to content via DIM is users/shared/My DAZ 3D Library. I opened studio and checked that the Content Directory Manager was set to the correct path for Connect. Data and also Studio and Poser formats. 

Most everything that I have tried so far seems to work except for G3F and G3M. Both these were installed when the DIM was used for setting up things.

I cannot get the G3 figures to load at all. I have tried downloading the files and manually installing them, only to find of course that all the relevant folders are already present. The attached images show both G3 /G8 and G9 folders in studio content, so its all there as you can see.

I only get involved with CDM because to be honest, I don’t have much idea about any other of the options available, for example mapped directories, or CMS. I have a back up of the old content but I am sure there are corrupt files on that, and wanted to begin again from new with this computer.

Is there anything I can do to resolve this problem.

Screenshot 2024-02-23 at 13.27.11.png
773 x 322 - 59K
Screenshot 2024-02-23 at 13.27.24.png
770 x 220 - 47K
Screenshot 2024-02-23 at 13.27.40.png
787 x 310 - 83K


  • What are the full paths for the files, and from which pane and container are you trying to load?

  • deeahr2169deeahr2169 Posts: 449

    A little lost on the terminology here.

    Trying to load into the viewprt pane from the content pane. As below

    Content library/MyDaz3Dlibrary/People.Genesis 3 female (male)

    Files loaded into are

    Data/Runtime/support/textures/people/genesis 3 female (male)

    As shown on attached screne shots.

    Hope this helps


    Screenshot 2024-02-23 at 17.30.15.png
    1235 x 585 - 234K
  • OK, and if you go to the Genesis 3 folder the icons are there bu the product won't load? Do you work online of offline in Daz Studio?

  • deeahr2169deeahr2169 Posts: 449


    As you say in the genesis 3 folder the icons are there.

    I suppose this sounds a bit stupid, but to be honest I dont really know if I work online or offline. I suppose its offline because I dont log into DAZ or use Daz connect, though I can open that while i have studio open. The content is limited and the Gen 3 still does not appear...

  • Well, does the Connect menu have Login... enabled and Work Offline disabled (greyed out) or vice versa?

  • deeahr2169deeahr2169 Posts: 449

    Attached screen shot might help answer that question. Hope so because I have no idea myself....sorry

    Screenshot 2024-02-23 at 23.21.37.png
    868 x 672 - 76K
  • OK, that means you have installed through Daz Studio itself - so the DIM installs don't do anything, except take up space. Presuambly it is those thata re not working - perhaps you installed that way before updating the Connect data path. One option is simply to uninstall the Connect version (right-click on Products>G>Genesis 3 Starter Essentials and select Uninstall) then try loading from the Daz Studio Formats>My Daz 3d Library folder.

  • deeahr2169deeahr2169 Posts: 449

    More and more confusion my end. I actually can’t follow what you are advising here. Do you mean that the version of DIM which I downloaded from the Daz web site is not compatible with the actual version of Daz 4.22  which I also downloaded from the same source.

    As far as I can tell this is the only way to download Daz studio and so if this is what you mean it doesn’t make much sense to me. 

    I have deleted Studio and DIM from every location on my machine and begun again with a fresh and as far as I am aware a clean version. I deleted the Gen 3 folders and content from my library and then manually installed them from downloaded files from the DS website, nothing works. The essential files which were the only ones apart from studio itself that I installed vis DIM are shown on the screen shot, as is the error when trying the manual install from the website.

    I also discovered a link on my content page on the website that allowed me to download a version of Studio 4.5 (22) which I tried to install but ran into problems with the content management part and the entire install failed.

    So far I have tried everything suggested but nothing works, it appears that Genesis 3 will not load on studio any longer. Please forgive my ignorance regarding terminology and even technology, but this has me going round in circles and getting nowhere...

    Screenshot 2024-02-24 at 13.47.34.png
    410 x 892 - 134K
    Screenshot 2024-02-24 at 22.19.31.png
    467 x 255 - 39K
  • I wasn't saying anythign about DIM. If you install through daz Studio, which you have for those prioducts listed under Content library>Daz Studio Formats>Daz Connect, then the files placed by DIM for those products are ignored. If you did as I suggested you would have removed the (apparently non-functional or missing) Connect install and allowed daz Studio to use the DIM-installed version. If you deleted everything then you deleted the content, the record of what was installed, and your preferences for DIM and Daz Studio, at least to an extent - of course it's also possible that some parts are left and some have been deleted, which may compound the confusion.

    Daz Studio 4.5 is included with the SDK, it uses the old Valentina database. You probably don't want anything to do with that, unless you are a C++ develoiper wanting to write plug-ins.

  • deeahr2169deeahr2169 Posts: 449

    Me again and I have to admit to feeling somewhat intimidated because of my obvious technological limitations. I completely fail to follow the steps outlined by Richard to sort out this problem, maybe its time to go through the install process one more time and try and find a way to avoid the online Daz connect route.

    Richard said…

    perhaps you installed that way before updating the Connect data path. One option is simply to uninstall the Connect version (right-click on Products>G>Genesis 3 Starter Essentials and select Uninstall) then try loading from the Daz Studio Formats>My Daz 3d Library folder.

    I wasn’t aware that I updated the connect data path, I wasn’t even  ware there was such an option. I cannot simply uninstall the Connect version or follow any of the steps suggested because I have no idea where to even begin. I am quite honestly lost…

    However while the problem does still exist, I have stumbled upon a resolution of sorts. If I simple double click on the G3F base icon I get the error file does not exist, the same as always despite of course the file actually being on my HD. If however I choose to merge it into the scene I have no problems, and can load those items that previously would not, and still will not load in the ordinary way.

    It’s clunky and only applies to some content, for example everything related to G8 loads normally.

    I feel that I am being completely obtuse in not understanding the steps or indeed the terminology offered to me here…

    Wouldn’t it be nice if those of us who just use this as a hobby were smarter!

  • In the Content Library pane, is the file you are trying to load under Daz Connect>People>Genesis 3 Female (as it was in the revious screenshots) or is it now being accessed from My Daz 3d Library>People>Genesis 3 Female?

  • deeahr2169deeahr2169 Posts: 449

    In the content library pane under Daz Connect there are icons for G3 which can be loaded only by using the merge into scene option. In the My Daz Library the same thing applies. If as i think you suggested I should delete the Daz connect then I am hapy to do that, but have no clue how to manage that.

  • Below Daz Studio Formats, Poser Formats, and Other Import Formats you will see a products "folder" - these are not folders on disc so we call them Containers, which is what I referred to above. If you epand the Products container, then the G container within that, you should find a container for Genesis 3 Starter Essentials - right-click that and there should be an Uninstall option, select it. Having done this the Connect-installed files will have been removed, but the ones placed by Install Manager will remain. Click Connect>Work Offline, if it isa vailable, to make sure you are not connected to the store. Now go up to Daz Studio Formats>My Daz 3d Library>People>Genesis 3 Female and try loading the base figue by double-click - does that now work, or Daz Studio log-in again and start downloading the files?

  • deeahr2169deeahr2169 Posts: 449

    Now they load properly. Could not figure out how to follow the process of deletions until you gave this step by step guide, which once it was written out was very simple to follow. Trouble is that these things are far from intuitive and and its easy for an expert to perhaps forget that what might be obvious to them is not so obvious to the average user. I have to thank you Richard for your patience and help with this problem. Hopefully it is now resolved...

  • Ideally you want to do the same with everything that appears under Daz Studio Formats>Daz Connect, or uninstall those things from DIM (just click the button next to them in the Installed tab of Install Manager).The files go in different places, so if you end up with both types of installation you are just using twice as much disc space as necessary. Personally I find Connect more convenient, but plenty of others will urge you to stick with Install Manager.

Sign In or Register to comment.