Daz Studio Pro BETA - version 4.9.0.36!

2

Comments

  • BurstAngelBurstAngel Posts: 723
    edited November 2015

    Once I make a Catagory, how do I make it show up in Smart Tab. Sometimes it does atomatically, sometimes it doesn't.

     

    Nevermind I think I figured it out.

    Post edited by BurstAngel on
  • MBuschMBusch Posts: 533
    JDStrider said:

    Yet another annoying behavior discovered in the DAZ supplied Meta Data.

    I have just spent the last few evenings and most a Saturday cleaning up my categories and fixing the Smart Content up to match the DAZ Studio documented: DAZ Studio Default Categories:

    http://docs.daz3d.com/doku.php/public/dson_spec/format_description/metadata/categories/start

    I had no choice but to un-install the 'Cloud' version of a number of products in order to accompish this task. Each of the products had to be re-installed via the DIM so that I could setup the Products correctly. I managed to remove all of the products that had items listed in the /Default/Presets/..." Category, as that is not a valid category according to the documentation. Once I completed this laborious task, I tried an experiement. The Beta showed all of the products that I had uninstalled from the 'Cloud' on the Available tab as one would expect. I installed one of them to see if my User meta data would override the 'Cloud' meta data. Thankfully, I only tried one, as the installer put back all of the garbage information that I had just removed and therefore did not respect the fact that I had created my own meta data at all.

    Am I alone in thinking that publishing invalid and incorrect meta data is doing more harm that good in Daz3D's attempt to get people to use this otherwise powerful and very effective tool?

    I would really like to hear what other users that like the Smart Content concept think of this issue.

    It is this users opinion that publishing a high volume of BAD meta data is much worse than publishing much less, HIGH QUALITY meta data. I have even had problems with the meta data for Michael 7 products, I fine it shocking that new products are being published with incorrect or missing meta data...

    You are not alone. I reported this in the previous beta thread and to the customer support. The answer was that is working as designed. The main problem is that cloud metadata have precedence over your local metadata, so any user fixes or customizations will not show. The only way I found to preserve my metadata was not use DAZ Connect. If you connect, the store metadata will be fetched automatically.

  • kitakoredazkitakoredaz Posts: 3,526
    edited November 2015

    >MBusch

    mm,,hope to  ask from quriosity (though I have no plan to use Croud meta data at current), 

    you can not overwrite product (cloud) meta-data by exported user-data? or you can not overwrite assets category which included in Cloud meta-data?

     

    And before if you hope so, you can make original product meta-data from same assets.

    then same assets are  at same time belong to two  prodcut meta-data.

    (original, and user made product meta-data), then you can export your original product meta-data, as one package to keep it them.

     

    but, it can not work about daz Cloud ?  and you can not un-install the daz offered  meta-data then import your original product meta-data ?

    (maybe to check up-date or installed etc, ds need to check the original product meta-data for DAZ cloud work?)

     

    Post edited by kitakoredaz on
  • icecrmn said:

    I'm getting an error when I try to drag-n-drop stuff into the Smart Content Pane now.

    from the log:

    WARNING: dzpostgresqlobjectdatabase.cpp(39): db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    I am very curious about where you are draging things FROM? I have only been able to drag & drop items that are already in the Smart Content between the Categories that are already associated with the product. The error messages above indicate that you are dropping an item into the Smart Content that doesn't already exist in the data structure. (Sadly, I can read that jibberish) The DB rational is preventing the addition of new data due to the fact that a required record is not present, so again I ask, where are you draging items from?

  • IceCrMnIceCrMn Posts: 949
    JDStrider said:
    icecrmn said:

    I'm getting an error when I try to drag-n-drop stuff into the Smart Content Pane now.

    from the log:

    WARNING: dzpostgresqlobjectdatabase.cpp(39): db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    I am very curious about where you are draging things FROM? I have only been able to drag & drop items that are already in the Smart Content between the Categories that are already associated with the product. The error messages above indicate that you are dropping an item into the Smart Content that doesn't already exist in the data structure. (Sadly, I can read that jibberish) The DB rational is preventing the addition of new data due to the fact that a required record is not present, so again I ask, where are you draging items from?

    from the Content Library, it's been a feature in Studio for sometime now.

    I understand what the error means :) I've seen it on my linux installs before,

    I don't know where the db config file is kept on a  Windows based machine, or if I can even edit it after I find it, so I thought I would post here in case others were seeing the same problem.

    It's working on the release version, just not the beta.

  • Well I did not backup Daz 4.8 properly i guess, I had to manually install content from DAZ and other stores on some of them.

    It seemed no matter how i uninstalled and downloaded from the Daz site they refused to show up in Daz studio.

    G3 no longer works in 4.8 at all, quit using it because of that. 4.9 is good but it takes a long long time to render in Iray.

    This in at a loss, I am running 8 core cpu, GTX 970 4gb graphics card from Nvidia, I attempted to render a 1280 x 1080 screen and 8 hours later i was at 15% before i cancelled. 3 Delight still works fast, just issues with being slow

  • lxlx Posts: 2,869

    Well I did not backup Daz 4.8 properly i guess, I had to manually install content from DAZ and other stores on some of them.

    It seemed no matter how i uninstalled and downloaded from the Daz site they refused to show up in Daz studio.

    G3 no longer works in 4.8 at all, quit using it because of that. 4.9 is good but it takes a long long time to render in Iray.

    This in at a loss, I am running 8 core cpu, GTX 970 4gb graphics card from Nvidia, I attempted to render a 1280 x 1080 screen and 8 hours later i was at 15% before i cancelled. 3 Delight still works fast, just issues with being slow

    You may need to tell 4.9 where your libraries are / reimport the metadata manually if it isn't finding any of them.

    Did you set Iray to use your Nvidia card in 4.9? It defaulted back to cpu for me when I first installed it.

  • Well I did not backup Daz 4.8 properly i guess, I had to manually install content from DAZ and other stores on some of them.

    It seemed no matter how i uninstalled and downloaded from the Daz site they refused to show up in Daz studio.

    Is this the first time you've used a beta version? Recent beta versions do not use the same settings file as the previous full release — your content is still there, it's just that the beta version hasn't been told where it is. Check the Content Directory Management settings for both D|S Formats and Poser Formats and make sure the settings in the 4.9 beta are the same as the ones in 4.8.

    Extremely important note, do not do this the wrong way round — the 4.8 settings will be right, the 4.9 settings might be wrong or incomplete.

  • MBuschMBusch Posts: 533

    >MBusch

    mm,,hope to  ask from quriosity (though I have no plan to use Croud meta data at current), 

    you can not overwrite product (cloud) meta-data by exported user-data? or you can not overwrite assets category which included in Cloud meta-data?

     

    And before if you hope so, you can make original product meta-data from same assets.

    then same assets are  at same time belong to two  prodcut meta-data.

    (original, and user made product meta-data), then you can export your original product meta-data, as one package to keep it them.

     

    but, it can not work about daz Cloud ?  and you can not un-install the daz offered  meta-data then import your original product meta-data ?

    (maybe to check up-date or installed etc, ds need to check the original product meta-data for DAZ cloud work?)

     

    No, you cannot overwrite cloud metadata. It is fetched automatically always you use DAZ Connect. There is no option to stop it. In my experience your metadata will live besides the cloud metadata, so your fixed or custom metadata does not override the store metadata. While you can fix the categories using the categorize option in the contextual menu, the process is slow and does not solves compatibities issues. You will just changing the category without fixing any compatibility problems.

    You can delete the store metadata, but it will be fetched again when you use DAZ Connect. While I like the DAZ Connect idea, I cannot give me the luxury to trash all hard work putted in fix obsolete and/or wrong metadata. So, for now I am giving up DAZ Connect.

    I try to create metadata using DS 4.9 and was unable to get it working using my current workflow. I post about the issue in a previous thread and someone reported a similar issue. Anyway, I am thinking that posting at this theads is pointless, as nobody answered my questions. I get some feedback reporting the issues as bug to zendesk customer support, but as I said, the answer is that this issues are not bugs because they are working as designed. In a perfect world, all we would need is correct metadata provided for DAZ, but unfortunately is not the case. I know DAZ has added a librarian to their staff to help fix that metadata, but still, there is a long run to get all fixed. After 3 years, there are a lot of products with obsolete metadata or none at last.

  • lxlx Posts: 2,869

    So general concensus of the new update is that Smart Content / Connect will be a big improvement for brand new users and those who don't dig into settings, but worse for those that actually want to customise everything? Personally I'm fine because I only use categories via content library but that's the general vibe I'm getting from all the reports.

  • kitakoredazkitakoredaz Posts: 3,526
    MBusch said:

    No, you cannot overwrite cloud metadata. It is fetched automatically always you use DAZ Connect. There is no option to stop it. In my experience your metadata will live besides the cloud metadata, so your fixed or custom metadata does not override the store metadata. While you can fix the categories using the categorize option in the contextual menu, the process is slow and does not solves compatibities issues. You will just changing the category without fixing any compatibility problems.

    You can delete the store metadata, but it will be fetched again when you use DAZ Connect. While I like the DAZ Connect idea, I cannot give me the luxury to trash all hard work putted in fix obsolete and/or wrong metadata. So, for now I am giving up DAZ Connect.

    I try to create metadata using DS 4.9 and was unable to get it working using my current workflow. I post about the issue in a previous thread and someone reported a similar issue. Anyway, I am thinking that posting at this theads is pointless, as nobody answered my questions. I get some feedback reporting the issues as bug to zendesk customer support, but as I said, the answer is that this issues are not bugs because they are working as designed. In a perfect world, all we would need is correct metadata provided for DAZ, but unfortunately is not the case. I know DAZ has added a librarian to their staff to help fix that metadata, but still, there is a long run to get all fixed. After 3 years, there are a lot of products with obsolete metadata or none at last.

    thnak you to tell me detail, To be frankly said, even though DAZ can release new ds 4.9 product ver, without many problem, at least I can not believe daz really offer reliable meta-data for all daz products. it seems not problem no longer,(though how many times I have complained, after all, DAZ can only release their product meta-data, then we needed to correct by our sefls.. and many smart content user have done so with frastration. But If the user aproach to correct DAZ product meta-data by oursefls, can not work well about DAZ connect installed item and data, I never try to use DAZ connect. I remember, daz up-dated same shader product 5 or more times just for correct one meta data, (category or compatibility)then everytime it is something wrong, then over write my modified product data , by DIM . after that, I simply make new product data then export as different name. then I simply delete daz offered foolish meta-data. why I can believe, DAZ 5 times missed to up-date meta-data but finally daz did it , then it will be reliable than my first meta-data^^; Smart content usability is mostly depend on, meta-data. if it is not good, nothing smart.
  • kitakoredazkitakoredaz Posts: 3,526

    The smart contents can be smart when data is sorted (filtered) with Compatiblity . if I just use category,and find items,

    Actually there seems no merit to use Smart content   It is not only about daz offered product. sometimes

    I hope to add compatiblity with  product files for   original files in smart content.

     

    eg,  I modify auto-fit clothing ,  "daz_shut.dsf"  for better fit (add rig ,tweak mesh, add new morph etc)  then save it as new figure.  as "my_shut.dsf."

      I already bought the  material  sets product for "daz shut" .  then I hope to use all mat files,

    "daz_shut_mat1 to 10 .duf"  for the "my_shut.dsf" too. it is naturall. 

     

    if user can change product meta-data compatibility, I just need to add new "compatibility base" root,  for  "my_shut" .

    maybe I can do it in ds 4.9.    but next I need to add new compatibility for "daz_matfiles 1 to 10 .duf." 

    then when I select the "new shut" , "daz_matfiles 1 to 10"   can be shown, then I can easy find and apply it on "new shut" as same as "daz shut."  

      if it work so, smart content is sitll smart at least  for me.

     

    But Is there way to do it in ds 4.9 , about daz connect installed items and product meta-data?

    or I need to save all mat files another name again, then add compatibility with for new shut?   it simply kill time ,and just make duplicate files.

    not smart at all.

  • LeggyBlondLeggyBlond Posts: 124
    edited November 2015

    Since I installed version 4.9.0.36 there seems to be a very major issue with older hair props converted to Iray.  They look fine when they have been fitted to a figure and converted but when the figure is reopened on a later occassion the hair has become a grey symetical object that doesn't even have any surfaces.  Furthermore and understandably - it doesn't appear in the render!!

    But There's more!!............... I've edited this as I've just Auto Fitted some V4 Clothes to Eva7 and Guess what...exactly the same issue..In other words any Auto Fit V4 'Cr' prop is simply non functional on G3F anymore

    Ths only seems to apply to as an example to V4 'Cr' props fitted to G3F/V7 figures using the 'Auto Fit' panel. If hair (Cr) sas an example, is loaded and the Auto Fit panel dismissed or Fit to - None is selected, manualy fitted therafter then it's ok - but whats the point of the Auto-Fit if it no longer functions properely!

    Whatever way it has seriously peed me off!!!

    The Images below clearly Show what is happening - Ijust used 'Cr typer hair but any Cr Vy clothes etc have exactly the same issue
    Image 1 was rendered immediately after loading and selecting the appropriate parameters in the Auto Fit Panel.

    Image 2 is a screen capture after reopening DS and loading the saved ready figures/cene

    Image 3 shows how the hair has become invisible

    I do so hope this is corrected because otherwise it will have effectively written off many old V4 'Cr' props and whatever else it has this effect on.

    NB. THIS IS NOT AN ISSUE IN DS 4.8!!

    1. V7 With V4 Hair Before Saving.jpg
    500 x 500 - 68K
    2. V7 With V4 Hair After Saving (Screen Capture.JPG
    858 x 848 - 66K
    3. V7 With V4 Hair After Saving.jpg
    500 x 500 - 45K
    Post edited by LeggyBlond on
  • IceCrMnIceCrMn Posts: 949

    You just found a bug, good job beta tester :) Well done. Now we just need you to report your findings so it can get fixed.

    When you find bugs, please post your log file of the event, include what product you used, and how you found the bug :)

    Being a test pilot isn't for everyone.It's not intended to make you mad or anything like that.
    Try to remember, while flying the experimental aircraft, things can get messy.Try to keep a cool head, and a steady hand on the stick.

  • aspinaspin Posts: 218

    Well... a beta is called a beta, because it's ... a beta.

  • ChoholeChohole Posts: 28,069

    Report bugs by filing a help request, to tech support, heading it as bug report.

  • jag11jag11 Posts: 747

    Since I installed version 4.9.0.36 there seems to be a very major issue with older hair props converted to Iray.  They look fine when they have been fitted to a figure and converted but when the figure is reopened on a later occassion the hair has become a grey symetical object that doesn't even have any surfaces.  Furthermore and understandably - it doesn't appear in the render!!

    But There's more!!............... I've edited this as I've just Auto Fitted some V4 Clothes to Eva7 and Guess what...exactly the same issue..In other words any Auto Fit V4 'Cr' prop is simply non functional on G3F anymore

    Ths only seems to apply to as an example to V4 'Cr' props fitted to G3F/V7 figures using the 'Auto Fit' panel. If hair (Cr) sas an example, is loaded and the Auto Fit panel dismissed or Fit to - None is selected, manualy fitted therafter then it's ok - but whats the point of the Auto-Fit if it no longer functions properely!

    Whatever way it has seriously peed me off!!!

    The Images below clearly Show what is happening - Ijust used 'Cr typer hair but any Cr Vy clothes etc have exactly the same issue
    Image 1 was rendered immediately after loading and selecting the appropriate parameters in the Auto Fit Panel.

    Image 2 is a screen capture after reopening DS and loading the saved ready figures/cene

    Image 3 shows how the hair has become invisible

    I do so hope this is corrected because otherwise it will have effectively written off many old V4 'Cr' props and whatever else it has this effect on.

    NB. THIS IS NOT AN ISSUE IN DS 4.8!!

    I'm having the same issue with some hair... just to give more information, before I installed DS, I removed everything, even CMS and related files and have been installing all my content using DAZ Connect. No 4.8 installed at the same time here also.

  • kitakoredazkitakoredaz Posts: 3,526
    edited November 2015

    The auto-fit problem is  loosen weight map. it should be same about cr2 figures (or hairs shoes) which  auto fitted with Genesis figures.

    http://www.daz3d.com/forums/discussion/66285/latest-version-of-ds-trouble#latest

     

    because when you use auto-fit, and save the scene,  these cr2 figures are changed , then stored in data/auto-adapted about ds 4.8.

    but current beta seems can not read it well.  maybe new DAZ connect change the way to read these auto-fitted or transfered then saved user file.

    this bugs are already reported. then I hope the private build can remove the bug.

    • Fixed Auto-Fit and Transfer Utility to work with cloud content and multiple mapped directories

    DAZ Studio : Incremented build number to 4.9.0.38

    though I got reply , thecnical staff can not re-produce this  bug, then said me to offer more detail.  then I send same report with actuall product name again. with link of this topic.

    I am afraid this problem only happen if user not use daz default directory as content directory. like me.

    because, if this problem ahppen for every beta user,, I feel more report will come about same problem.

    anyway, daz seems understand this bug, and may be removed in private build already.

    (I just hope to re-install 4.9.0.29,,, is there way to re-download it?  I did not keep copy about beta,, )

     

     

     

     

     

    Post edited by kitakoredaz on
  • IceCrMnIceCrMn Posts: 949

    beta version 4.9.0.29 is a dead end.

    There is no reason to continue distributing obsolete versions of a test build.It will never be used  again, it was after all, a beta version meant for testing.

    If you did find a way to reinstall it, any bugs or issues you find would not be addressed,because it isn't the most recent version.

    All software beta testing is done like this.

    Fun facts :) ;

    The GIT repository for Debian unstable( the "beta" version of the  Debian Linux Desktop Operating System) is updated every 6 hours. You could  be installing code that is was being written , quite literally,only minutes before you downloaded it.

  • nicsttnicstt Posts: 6,814
    lx said:

    So general concensus of the new update is that Smart Content / Connect will be a big improvement for brand new users and those who don't dig into settings, but worse for those that actually want to customise everything? Personally I'm fine because I only use categories via content library but that's the general vibe I'm getting from all the reports.

    It restricts those from doing what they might have learnt how to do; it removes options, never a good thing for an artist.

  • icecrmn said:
    JDStrider said:
    icecrmn said:

    I'm getting an error when I try to drag-n-drop stuff into the Smart Content Pane now.

    from the log:

    WARNING: dzpostgresqlobjectdatabase.cpp(39): db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    db fetch error: ERROR:  insert or update on table "category_content" violates foreign key constraint "category_content_content_id_fkey"
    DETAIL:  Key (content_id)=(27812) is not present in table "content".
    CONTEXT:  SQL statement "INSERT INTO category_content (content_id, category_id, is_vendor)
                SELECT product_content.new_id, data_row."fldCategory", data_row."fldIsVendor"
                WHERE NOT EXISTS ( SELECT 1 FROM category_content WHERE content_id = product_content.new_id AND category_id = data_row."fldCategory" )"
    PL/pgSQL function migrate_category_content_process("tblCategoriesContent") line 13 at SQL statement
    SQL statement "SELECT migrate_category_content_process(NEW)"
    PL/pgSQL function migrate_category_content_trigger() line 7 at PERFORM
    SQL statement "INSERT INTO "tblCategoriesContent" ( "fldContent","fldCategory","fldIsVendor" )        

            VALUES ( "vfldContent","vfldCategory","vfldIsVendor" )

            RETURNING "RecID", "fldContent","fldCategory","fldIsVendor", TRUE"
    PL/pgSQL function "tblCategoriesContentFindOrCreate"(bigint,bigint,boolean) line 9 at SQL statement

    I am very curious about where you are draging things FROM? I have only been able to drag & drop items that are already in the Smart Content between the Categories that are already associated with the product. The error messages above indicate that you are dropping an item into the Smart Content that doesn't already exist in the data structure. (Sadly, I can read that jibberish) The DB rational is preventing the addition of new data due to the fact that a required record is not present, so again I ask, where are you draging items from?

    from the Content Library, it's been a feature in Studio for sometime now.

    I understand what the error means :) I've seen it on my linux installs before,

    I don't know where the db config file is kept on a  Windows based machine, or if I can even edit it after I find it, so I thought I would post here in case others were seeing the same problem.

    It's working on the release version, just not the beta.

    Thanks, I was not aware of that functionality and I had never tried. I will need to fiddle with my tab arrangment so both tabs are visible at the same time so I can give that a try.

    Does the feature create any Category, Product or Compatibility_Base>Item entries automatically?

  • ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

  • IceCrMnIceCrMn Posts: 949
    edited November 2015

    it can't do that :)

    you are dropping things into the default "Categories>Default" database found on the Content Library pane.Thats where Smart Content gets it's info from.

    I would suggest making your own folder structure under "Categories" and making custom changes there. "Categories>Default" can and, from the looks of it , will be altered by DIM and Connect.

    Your new category will show up on the Smart Content pane once you start populating it with content.So you can just drop stuff into your custom database and skip using the default one.

    Remember to export your user_data often so you have a current backup of all your work in the event you need to re-install it for some reason.

    I think the beta had some early framework for doing compatibility tagging from drag-n-drop, but it's broken at the moment, or so it would seem, I've not had time to mess with it anymore yet.

    You can always use the database editor on the Content Library pane to fix items by hand until that gets sorted out.Right click the tab for "Content Library" and select "Content db editor".

    There will be two options editor and maintenance.

    Maintenance does the exporting/importing and other type stuff.

    The editor allows you to edit the items metadata directly.

    Studio really does have a very nice GUI for managing a database.Once you've had a chance to play with it for a bit, you'll wonder how you lived without for so long :)

    Post edited by IceCrMn on
  • JigSaw73 said:

    ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

    There isn't currenlty a way to "auto-login" but it's on the to do list. We are tackling the bigger bugs right now so this probably won't be in the first release but it is planned for a follow up point release.

  • kitakoredazkitakoredaz Posts: 3,526

    there is clear reason for user, when some important tool  has problem in current beta, but the past-release  beta include new iray (daz default render) version.

    DAZ studio is after all,  aprication to sell daz items for daz.   if old  beta is good than current beta version, user hope to use it. where is problem?

     

    then,   I can not understand at all.  

    why  If I could  find a way to download old beta (practically, just daz keep some version as zip untill they release final prodcut ver, then offer user who need it)

    , any bugs or issues would not be addressed ?   who decide it is the rule for beta testinig?   and beta shold be so?

     

    Why User and customer should keep such foolish  rule too ? (I think so),

     there is no actuall problem, offer old beta for user who want to use too.   because they are join testing the beta already.

    then real tester  (iwho just hope to keep test this  beta )  can download new beta.

     

    frankly said, I do not believe DAZ offer old beta at all,   but if they can, it is good for user. 

  • DAZ_Vince said:
    JigSaw73 said:

    ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

    There isn't currenlty a way to "auto-login" but it's on the to do list. We are tackling the bigger bugs right now so this probably won't be in the first release but it is planned for a follow up point release.

    OK - Thank you!

  • CypherFOXCypherFOX Posts: 3,294

    Greetings,

    if old  beta is good than current beta version, user hope to use it. where is problem?

    Beta's are not versions for general use.  They are for finding bugs in the current development branch of the code.  If you're looking for the stable version it's thataway -> 4.8.

    You don't downgrade a beta, because you want a more stable version.  If you need a stable version, use THE stable version.

    why  If I could  find a way to download old beta (practically, just daz keep some version as zip untill they release final prodcut ver, then offer user who need it)

    , any bugs or issues would not be addressed ?   who decide it is the rule for beta testinig?   and beta shold be so?

    Because they may have already been addressed.  Visualize, if you will, an infinite (or at least huge) number of beta versions that different users have decided to 'stick' with, each having to have their own special snowflake of bugfixes applied.

    No.  Just absolutely, positively, no.  Software development doesn't work like that, and can't work like that.

    frankly said, I do not believe DAZ offer old beta at all,   but if they can, it is good for user. 

    But it'd be awful for DAZ, because users would report bugs that have been fixed in the more recent betas.

    Don't encourage folks to use old betas; if the new one is out, upgrade.  Being part of beta testing isn't about getting cool new features early, it's about *TESTING* the application, and making sure that in the large number of cases that DAZ can't simulate internally, that the software works for everyone.  Supporting and allowing old beta releases absolutely undermines that concept.

    --  Morgan

     

  • nicsttnicstt Posts: 6,814
    JigSaw73 said:

    ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

    Can make it so never have to log in, but not noticed other way (and frankly not interested).

  • IceCrMnIceCrMn Posts: 949
    nicstt said:
    JigSaw73 said:

    ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

    Can make it so never have to log in, but not noticed other way (and frankly not interested).

    You don't have to.

    Check the "work offline" box, and the "Don't show me this again" box and you shouldn't see the login UI again.

  • nicsttnicstt Posts: 6,814
    icecrmn said:
    nicstt said:
    JigSaw73 said:

    ...silly question...

    I have to "Login" every time I open up Daz Studio 4.9. Is there a way to stay always logged in? I don't log out when I quit.

    If there is an option for this, I apologize, but I am completelly overlooking it. Thank you.

     

    Can make it so never have to log in, but not noticed other way (and frankly not interested).

    You don't have to.

    Check the "work offline" box, and the "Don't show me this again" box and you shouldn't see the login UI again.

    Yup have. Don't log in anymore. I'm going to restore from a disk image to strip all the connect files from computer. Then I wont be using. The render increases are nice; connect not.

Sign In or Register to comment.