Morph not behaving as intended

So, I loaded a Michael 6 character and put underwear on him. Then I sent the underwear to Hexagon and created a pull down morph and sent it back to Daz Studio. I didn't change the location of the underwear, just pulled down some faces. When I apply the morph in Daz Studio, the underwear leave the character's body. Maybe I'm too naive, but the whole reason I purchased Hexagon was because it advertised as seemlessly integrating with Daz Studio. (I've hidden the naughty bit for the faint of heart :)  )

Any help anyone can offer would be greatly appreciated.

hexagon_morph.jpg
1920 x 1080 - 590K
dazstudio_morph.jpg
1920 x 1080 - 473K

Comments

  • Hmmm...so I just wondered what happened if I sent it back as an object instead of a morph. I deleted the underwear in studio and then, in Hexagon, sent the underwear back to Studio. Voila! The morph is as it should be.

  • patience55patience55 Posts: 6,988

    Michael 6 is Genesis 2 so load a fresh Genesis 2 in D/S. Load the clothing "fit to and parented on". Select G2M and send it over the bridge to Hexagon.

    In Hexagon "freeze" G2M [option in the scene tree] and select the clothing. Morph it as desired.

    In D/S select the "clothing".

    In Hexagon select and send the clothing back over the bridge to D/S.

    Now the morph can be made and should it work as desired, save the morph. File > Save As > Morph Asset .... will land somewhere on the Parameters Tab under Morphs unless you direct it otherwise.

  • patience55patience55 Posts: 6,988

    Hmmm...so I just wondered what happened if I sent it back as an object instead of a morph. I deleted the underwear in studio and then, in Hexagon, sent the underwear back to Studio. Voila! The morph is as it should be.

    Except that is not a morph, no longer a clothing item either.

  • MorkonanMorkonan Posts: 215

    So, I loaded a Michael 6 character and put underwear on him. Then I sent the underwear to Hexagon and created a pull down morph and sent it back to Daz Studio. I didn't change the location of the underwear, just pulled down some faces. When I apply the morph in Daz Studio, the underwear leave the character's body. Maybe I'm too naive, but the whole reason I purchased Hexagon was because it advertised as seemlessly integrating with Daz Studio. (I've hidden the naughty bit for the faint of heart :)  )

    Any help anyone can offer would be greatly appreciated.

     

    I don't know much of anything about DS and don't use the Hexagon bridge to it. However... :)

    Did you "Parent" the object or otherwise Conform it to the figure? If your workflow is as you say it is, above, in that you did not change the object's x,y,x coordinates from the original object's x,y,z coords, then it's likely you didn't parent/conform the clothing item and, because its dimensions have changed, DS recalculated the item's "object center", using the object center of the morphed object. By using patience55's instructions and having the item conformed/parented to a base figure, I suppose the Bridge exports the item using its default coordinates, so that tricky Bridging work doesn't get fouled up. Since you're basically just reimporting the morph, and it started in Hex with its default coords, there's usually no issue with object centers getting fouled up.

Sign In or Register to comment.