Trouble creating morph for Gen9 using Blender 3.4

Apologies if I'm stretching this newb thing too far. I'm hoping someone can spot what I'm doing wrong trying to load a morph I created using Blender 3.4. I consistently get the "Geometry did not match, failed to create morph" message. At first I was able to load the morph I created, but I probably wasn't importing/exporting with the correct settings. Toggling the morph on, instead of creating some grooves in the leg, caused the whole figure to essentially melt. I went back through and paid much closer attention to the settings I was using, double checked that I was doing my best to get as close to the tutorial I was following as possible, but now it simply won't load.

I'm following a tutorial found in https://www.daz3d.com/how-to-create-a-new-custom-daz-studio-character, but they use blender 2.8 on a Gen8 model and I'm probably missing something fairly important. Here's what I did:

  • Exported Gen9 base model in normal res and 0 subdivisions to an .obj file using the Daz Studio scale.
  • Imported in Blender using Wavefront (legacy) option - it looked closer to 2.8's presets - with "Keep Vert Order" and Poly Groups checked.
  • Created the Shape Keys for Base and my Morph, dialed the Morph key up to 1. 
  • Used the sculpting tool to make some changes to the legs
  • Exported as Wavefront (legacy) with Selection Only, OBJ Objects checked in the Include section, and Apply Modifiers, Write Normals, Include UVs, Write Materials, Polygroups, and Keep Vertex Order checked.
  • Back in Daz, selected the Gen9, opened Morph Loader Pro, loaded the new .obj in the Morph Files, still using the Daz Studio scale. Load Morphs For is set to Primary Figure (Vertex Only).

If anyone has any tips on what I might be doing wrong, might save what's left of my sanity. 

 

Comments

  • 3WC3WC Posts: 1,098

    Might want to check your sculpt settings, sometimes that will dynamically add topology and therefore mess up your vertex order.

  • lilweeplilweep Posts: 2,254

    his.royal.duckness said:

    • Exported Gen9 base model in normal res and 0 subdivisions to an .obj file using the Daz Studio scale.

    Any attachments like eyes and mouth present on your export? You cant have those present on Gen 9, those need to be morphed separately using follower morph. (See youtube tutorials on making eye and mouth morphs for Gen 9)

    Does "Base model in normal res and 0 subdivisions" mean "Resolution Level: Base"? It needs to be set to "Base".

     

  • lilweeplilweep Posts: 2,254

    his.royal.duckness said:

    • Imported in Blender using Wavefront (legacy) option - it looked closer to 2.8's presets - with "Keep Vert Order" and Poly Groups checked.

     

    That setting is fine. However,  for peace of mind, you dont actually need to use Legacy options for import and export in 3.2+.

    You can just use the normal obj importer in the latest Blender versions and they will automatically preserve vertex order, so you dont need to worry about reading vert groups etc, just leave everything logical unchecked and it will work fine for creating and exporting morphs. 

  • lilweeplilweep Posts: 2,254

    his.royal.duckness said:

    • Used the sculpting tool to make some changes to the legs

    Only use the sculpting tools that preserve geometry.  Most of them do preserve geometry, i.e., they just push/pull vertices around, but some random ones like Snake Hook brush will sometimes add new vertices.

  • lilweep said:

    his.royal.duckness said:

    • Imported in Blender using Wavefront (legacy) option - it looked closer to 2.8's presets - with "Keep Vert Order" and Poly Groups checked.

     

    That setting is fine. However,  for peace of mind, you dont actually need to use Legacy options for import and export in 3.2+.

    You can just use the normal obj importer in the latest Blender versions and they will automatically preserve vertex order, so you dont need to worry about reading vert groups etc, just leave everything logical unchecked and it will work fine for creating and exporting morphs. 

    Awesome, thanks! After a lot of trial and errror I eventually figured out how to import using the legacy one by checking "OBJ Groups", but knowing that the newer obj importer does the job makes it much simpler. 

  • lilweeplilweep Posts: 2,254

    Well...i dont think you need to click OBJ Groups when exporting with the legacy one anyway.  But glad that allegedly worked for you...

  • None of this actually works ....

  • jussir said:

    None of this actually works ....

    So you export at base resolution and with no attachments, make sure that the Blender options are set to preserve vertex order on Import and export, and use tools which do not add or remove geometry but solely move it around? How and where is it failing?

  • josiahmora20josiahmora20 Posts: 41
    edited March 13

    I'm having the same problem with G9F to blender. I've watched every possible tutorial and tried what feels like every combination of import and export settings. I even tried importing to blender then saving an obj without changing anything or sculpting and i get this error. I even tried importing the original obj from Daz right back into the Morph loader and get this error....

     

    Post edited by josiahmora20 on
  • josiahmora20josiahmora20 Posts: 41
    edited March 13

    I just noticed that in Daz my model has 1 million + verticies but when imported to blender that number changes to 34,654..?

     

    confirmed in the log:

    Vertex count mismatch in Morph Loader

    Post edited by josiahmora20 on
  • Richard HaseltineRichard Haseltine Posts: 97,501

    The count in DS is with SubD, but the morph needs to be on the base resolution - the reduced count would be correct. However, it looks too high which suggests you are including the additional fitted elements (eyes etc.) in the OBJ.

  • The count in DS is with SubD, but the morph needs to be on the base resolution - the reduced count would be correct. However, it looks too high which suggests you are including the additional fitted elements (eyes etc.) in the OBJ.

    Got it, but still, there seems to be some problem as to why Daz thinks the vertex count is off. And nope, base resolution on and I removed everything, eyes ,eyelashes, hair, mouth etc. I ensured I export at 1% scale also. Not sure what else to try as like I said it won't even let me re-import the newly exported obj without even modifying it in blender.
  • Richard HaseltineRichard Haseltine Posts: 97,501

    Please post a screenshot of your OBJ export settings.

  • lilweeplilweep Posts: 2,254
    edited March 13

    josiahmora20 said:

    Richard Haseltine said:

    The count in DS is with SubD, but the morph needs to be on the base resolution - the reduced count would be correct. However, it looks too high which suggests you are including the additional fitted elements (eyes etc.) in the OBJ.

    Got it, but still, there seems to be some problem as to why Daz thinks the vertex count is off. And nope, base resolution on and I removed everything, eyes ,eyelashes, hair, mouth etc. I ensured I export at 1% scale also. Not sure what else to try as like I said it won't even let me re-import the newly exported obj without even modifying it in blender.

    Scale does not effect geometry mismatch error.  Vert Order issues does not cause geometry mismatch error either usually (instead, it results in mangled morph).  Geometry mismatch is usually because the geometry count is off, usually because at some stage you either did not export base geometry, included excess geometries, or added geometry when sculpting.

    Note:  Gen 9 Base is 25.1k verts, not 34k. 

    Test:

    1. Load Devload G9F figure in Daz

    2. In Parameters, set resolution to Base

    3. Export as obj (you can leave scale as default 100%)

    4. Import obj in Blender, ensuring it is the one you just exported. In latest versions of Blender, it will naturally preserve Vert Order.  So there is no special option you need to select.  You can leave Blender scale as default 1.0, assuming you left it as default when you exported from Daz.

    5. It should be 25.1k vertices. You should only have G9F mesh in your scene.

    5. Morph using any standard Sculpt tool like grab brush

    6. Export as obj (can leave settings as default 1.0, assuming you have left as default on previous import and export steps)

    7. Load as morph using morph loader pro

    Post edited by lilweep on
  • lilweep said:

    josiahmora20 said:

    Richard Haseltine said:

    The count in DS is with SubD, but the morph needs to be on the base resolution - the reduced count would be correct. However, it looks too high which suggests you are including the additional fitted elements (eyes etc.) in the OBJ.

    Got it, but still, there seems to be some problem as to why Daz thinks the vertex count is off. And nope, base resolution on and I removed everything, eyes ,eyelashes, hair, mouth etc. I ensured I export at 1% scale also. Not sure what else to try as like I said it won't even let me re-import the newly exported obj without even modifying it in blender.

    Scale does not effect geometry mismatch error.  Vert Order issues does not cause geometry mismatch error either usually (instead, it results in mangled morph).  Geometry mismatch is usually because the geometry count is off, usually because at some stage you either did not export base geometry, included excess geometries, or added geometry when sculpting.

    Note:  Gen 9 Base is 25.1k verts, not 34k. 

    Test:

    1. Load Devload G9F figure in Daz

    2. In Parameters, set resolution to Base

    3. Export as obj (you can leave scale as default 100%)

    4. Import obj in Blender, ensuring it is the one you just exported. In latest versions of Blender, it will naturally preserve Vert Order.  So there is no special option you need to select.  You can leave Blender scale as default 1.0, assuming you left it as default when you exported from Daz.

    5. It should be 25.1k vertices. You should only have G9F mesh in your scene.

    5. Morph using any standard Sculpt tool like grab brush

    6. Export as obj (can leave settings as default 1.0, assuming you have left as default on previous import and export steps)

    7. Load as morph using morph loader pro

    Thanks for the help guys. So Richard, I did what you suggested, started a new project and loaded the base gen 9 figure- it works. I can bring it back from Blender through Morph Loader Pro no problem! So now I'm trying to understand why it doesn't work for the character I've been building.

    - I deffinetly exported just the base geometry. I hid eyes, eyelashes, mouth etc (everything but "genesis 9," see image attached).

    - Not sure what would constitute as excess geometry. I'm using a body morph sliders from multiple genesis 9 characters to get a base figure i like, could that be the problem?

    - And there's not been any sculpting to the character, everything made in Daz.

    2.jpg
    335 x 431 - 47K
  • lilweeplilweep Posts: 2,254
    When exporting as obj, use the filter option in the dialogue to get what you want, i.e., just root. Morphs dont effect geometry count/vert order. As i mentioned, you can check vert count in blender after exporting, it will be 25.1k for gen9. If it's not, then you obviously exported something else. Only you can check what you did wrong. Excess geometry = other random stuff in scene like clothing and geografts.
  • Richard HaseltineRichard Haseltine Posts: 97,501

    What settings did you have in the OBJ export dialogue? If you reload the OBJ is it just the base Genesis 9, without any additions?

  • josiahmora20josiahmora20 Posts: 41
    edited March 14

    Richard Haseltine said:

    What settings did you have in the OBJ export dialogue? If you reload the OBJ is it just the base Genesis 9, without any additions?

    Thank you for the suggestion, I exported the obj with the settings in the first attached image (including base resolution in parameters), selected only genesis 9 again from the scene tab and try to import through Morph Loader Pro and get the error (Warning: Geometry did not match, failed to create morph).

    So I did what you suggested and imported the obj into a new project (see second attached image), and i can clearly see there are no addons. Then I tried adding the same obj as a morph and it works (only in this new project). So i deleted my character and in the same new project added a base genesis 9 character and tried adding the obj morph and get the error.

    I've included more attached images for other export settings I've tried.

     

     

     

     

    primary.jpg
    452 x 481 - 67K
    selected roots.jpg
    448 x 480 - 66K
    bl.jpg
    450 x 485 - 66K
    Post edited by josiahmora20 on
  • lilweep said:

    When exporting as obj, use the filter option in the dialogue to get what you want, i.e., just root. Morphs dont effect geometry count/vert order. As i mentioned, you can check vert count in blender after exporting, it will be 25.1k for gen9. If it's not, then you obviously exported something else. Only you can check what you did wrong. Excess geometry = other random stuff in scene like clothing and geografts.

    yes, blender essures I have the correct amount of vertices (see attached image)

    ddd.jpg
    167 x 146 - 12K
  • barbultbarbult Posts: 23,278
    Your figure image will probably be removed for violation of the nudity TOS. There is something strange by the crotch, though. What is causing that black area near her left thigh?
  • josiahmora20josiahmora20 Posts: 41
    edited March 14

    barbult said:

    Your figure image will probably be removed for violation of the nudity TOS. There is something strange by the crotch, though. What is causing that black area near her left thigh?

    Oh thank you, I re-upplaoded a censored version! and you're actually seeing through her body because I'm using Golden Palace (3rd party genitalia addon) and when I remove it to export i creates a hole- wait..

    THAT WAS IT.

    the Golden Palace addon once actually deleted from my scene deleted the mesh hole and the morph imports correctly!

    If I export with Golden Palace ON it doesnt work, if i just hide Golden Palace it does not work.

    Post edited by josiahmora20 on
  • barbultbarbult Posts: 23,278

    When a geograft is "fit to" a figure, the underlying figure polygons are not active. You can probably just unfit the Golden Palace from the figure (fit to none), and hide Golden Palace in the scene when exporting, rather than deleting it completely. But deleting it is a sure way to overcome this problem. Congratulations on resolving the problem!

    It looks like you are still not completely in compliance with the forum rules on nudity. Please read the sticky thread on Acceptable Ways of Handling Nudity.

  • barbult said:

    When a geograft is "fit to" a figure, the underlying figure polygons are not active. You can probably just unfit the Golden Palace from the figure (fit to none), and hide Golden Palace in the scene when exporting, rather than deleting it completely. But deleting it is a sure way to overcome this problem. Congratulations on resolving the problem!

    It looks like you are still not completely in compliance with the forum rules on nudity. Please read the sticky thread on Acceptable Ways of Handling Nudity.

    Thanks! Can you explain how to "unfit" Golden Palace? 

  • Richard HaseltineRichard Haseltine Posts: 97,501

    josiahmora20 said:

    barbult said:

    When a geograft is "fit to" a figure, the underlying figure polygons are not active. You can probably just unfit the Golden Palace from the figure (fit to none), and hide Golden Palace in the scene when exporting, rather than deleting it completely. But deleting it is a sure way to overcome this problem. Congratulations on resolving the problem!

    It looks like you are still not completely in compliance with the forum rules on nudity. Please read the sticky thread on Acceptable Ways of Handling Nudity.

    Thanks! Can you explain how to "unfit" Golden Palace? 

    Either select it and then use the Fit to button in the parameters pane (under the Constraints group) or right-click on it in the Viewport and select Fit "Item name" To. In the dialogue that opens select None.

  • lilweeplilweep Posts: 2,254

    josiahmora20 said:

    barbult said:

    Your figure image will probably be removed for violation of the nudity TOS. There is something strange by the crotch, though. What is causing that black area near her left thigh?

     

    If I export with Golden Palace ON it doesnt work, if i just hide Golden Palace it does not work.

    It was explained many times not to include additional geometry, specifically geografts. 

  • crosswindcrosswind Posts: 4,901
    edited March 15

    josiahmora20 said:

    barbult said:

    When a geograft is "fit to" a figure, the underlying figure polygons are not active. You can probably just unfit the Golden Palace from the figure (fit to none), and hide Golden Palace in the scene when exporting, rather than deleting it completely. But deleting it is a sure way to overcome this problem. Congratulations on resolving the problem!

    It looks like you are still not completely in compliance with the forum rules on nudity. Please read the sticky thread on Acceptable Ways of Handling Nudity.

    Thanks! Can you explain how to "unfit" Golden Palace? 

    Yes, geo-grafts are the culprits but you don't have to unfit GP and other grafts if there's any. A trick : press Alt Shift + G (Geometry Editor) before exporting to OBJ. With Geometry Editor activated, all geo-grafts turn into floating geometry that won't be merged with exported OBJ.

    Then remember to Alt Shift + U or T... after export, so as to be back to Universal or Translation tool...

    Post edited by crosswind on
  • barbultbarbult Posts: 23,278

    lilweep said:

    josiahmora20 said:

    barbult said:

    Your figure image will probably be removed for violation of the nudity TOS. There is something strange by the crotch, though. What is causing that black area near her left thigh?

     

    If I export with Golden Palace ON it doesnt work, if i just hide Golden Palace it does not work.

    It was explained many times not to include additional geometry, specifically geografts. 

    We are in the New Users forum here. He did hide the geometry, as told. Unfortunately, I don't think anyone mentioned that geografts need more than hiding. I certainly didn't think about it at first.

  • josiahmora20josiahmora20 Posts: 41
    edited March 15

    I seriously appreciate all your help guys, thank you.

    Post edited by josiahmora20 on
Sign In or Register to comment.