dForce Royal Armor Outfit issues?

paulawp (marahzen)paulawp (marahzen) Posts: 1,187
edited March 2023 in The Commons

I have found this item to be rather quirky. This render came out of initial testing yesterday, when I tossed a Daz Horse 3 "Thoroughbred Male" in the scene and tested the newly acquired Royal Armor Outfit. I really bought it just for the tack, so I put on the bridle and saddle, picked a random pose and simulated ... and the reins melted off the horse into a pile of taffy goo. I subsequently found that I had to simulate with the entire kit in place, then remove (or make invisible) the parts I didn't need/want for my scene.

I went back this morning to make a more thorough test of the product and confirmed that I had to have the Clothing Body to prevent the reins (and the Clothing Saddle) from just falling off during simulation. However, I couldn't even get it to simulate in the base pose with the Thoroughbred. It worked fine in the base horse. It wasn't the Thoroughbred shape, as I dialed that up in the base horse (no problem) and dialed it down in the Thoroughbred male (still wouldn't simulate). The problem appeared to be in the Clothing Body, which was gearing up for a massive explosion about 2% in. Then, suddenly, for no outwardly obvious reason, on the nth time that I tried, the simulation worked in the Thoroughbred male. I had been trying different poses and pose combinations (I use Pose Blender a lot) and had been switching back and forth from the Base to the Thoroughbred, but made no dforce-related config changes between "not working" and "working."

I work with software IRL and have software testing, QA, documentation and support on my resume. So, "keep trying random stuff until it works, randomly" is not an acceptable solution. I went back and tried some more. I found that if I loaded the base horse, then the Thoroughbred male, and put the armor on both, it's the base horse that won't simulate. (Also, interestingly, the hair from the Thoroughbred is relocated to the base horse.) If I loaded the Thoroughbred male and then the base horse, it's the Thoroughbred male that won't simulate. The relocation of the hair was a clue. I deleted all of the hair on the Thoroughbred male and it did simulate. That finally led to a reproducible solution, if you want to use this armor with the Thoroughbred. Load the Thoroughbred* and the armor into the scene; delete all of the hair items. Simulate, which should work. Undo the delete of the hair, then simulating should work, with the complete Thoroughbred. Also after this step, you should be able to simulate the bridle alone, without the Clothing Body. (*The Thoroughbred Female is similarly affected and the same steps worked for me with it.)

 

 

dForce Royal Armor Outfit for Daz Horse 3 | Daz 3D

Inclement.jpg
1300 x 1300 - 1M
Post edited by paulawp (marahzen) on

Comments

  • Thank you for this paulawp I was pulling my hair out over this issue. I do wish the reins were posable so i could just put them in the hands of the rider though.

Sign In or Register to comment.