[Released] Turbo Loader Booster Utilities [Commercial]

RiverSoftArtRiverSoftArt Posts: 5,320

Do you love the Turbo Loader products? Boost your productivity to an even greater level with the Turbo Loader Booster Utilities!

The Turbo Loader series of products turbocharges Daz Studio for users with large content libraries. By disabling unneeded morphs for your figures, you can see dramatic speed increases in loading scenes and figures, and even clearing scenes. However, it can still be a bit cumbersome to set up morphs for Daz Studio as you work with content and scenes. The Turbo Loader Booster Utilities help manage all the different Turbo Loader products as well as provide on-demand enabling of morphs when loading assets!*

  • Enable morphs on-demand when loading assets!* Simply select a figure asset or scene asset and click Turbo Loader Open File or Turbo Loader Merge File.  Turbo Loader Booster Utilities will quickly scan the asset for morphs used by the asset (and morphs used by those morphs, which are used by those morphs, etc.), enable all needed morphs, aliases, and properties,** and then load the asset!
  • Create configurations for assets without loading them into your scene. Turbo Loader Inspector will automatically create a Turbo Loader configuration by scanning asset(s) (and dependent morphs).**  Simply select your assets and start Turbo Loader Inspector.
  • Enable All Morphs found by all installed Turbo Loader products without loading each Turbo Loader Manager separately.
  • Disable All Morphs found by all installed Turbo Loader products without loading each Turbo Loader Manager separately.
  • Execute the current configurations (what is checked and unchecked) for all installed Turbo Loader products without loading each Turbo Loader Manager separately.

* On-demand loading of morphs will not work for shape assets, as shape assets do not actually trigger Daz Studio to create properties (like character presets and scene presets). Turbo Loader Booster Utilities will enable the morphs referenced in shape assets but the morphs are not available until a new figure is loaded.

** JCMs will not be found by scanning assets and need to be enabled beforehand.

Turbo Loader Booster Utilities is an add-on to the Turbo Loader series of products and requires at least ONE of them installed.

turbo-loader-booster-utilities-00-main-daz3d.jpg
1000 x 1300 - 483K
popup_1.jpg
1640 x 1575 - 561K
popup_2.jpg
1640 x 1575 - 527K
popup_3.jpg
1500 x 1143 - 441K
popup_4.jpg
1640 x 1575 - 511K
Post edited by RiverSoftArt on
«1

Comments

  • Thomas63Thomas63 Posts: 31

    These turboloader products are a real game-changer for those of us with large content libraries. Thank you so much for developing them. Looking forward to the 'enable morphs on demand' feature when loading an asset! smiley

  • RiverSoftArtRiverSoftArt Posts: 5,320

    Thomas63 said:

    These turboloader products are a real game-changer for those of us with large content libraries. Thank you so much for developing them. Looking forward to the 'enable morphs on demand' feature when loading an asset! smiley

    You're welcome!  And I completely agree.  I had a scene where I loaded 4 figures yesterday.  It looked so strange as I used to avoid those types of scenes, but now it doesn't feel like a sacrifice.  And I have started looking at buying G8 characters again.  smiley

  • HatBHatB Posts: 71

    I am anxiously awaiting this product. Sounds fantastic as I have all three of the Turbo Loaders already.

  • Mark_e593e0a5Mark_e593e0a5 Posts: 1,302

    HatB said:

    I am anxiously awaiting this product. Sounds fantastic as I have all three of the Turbo Loaders already.

    I had the honor to test that product, and I can asure you, it does not only sound perfect. It is THE perfect add-on for any of the TurboLoaders.

    Whant to add a character you have disabled? Really easy now. Select the character file in your content library or smart content, and use "Merge". The character morphs will be enabled and the character merged into your scene. You can even replace an existing character that way (only same generations, but that is a DS limit). Blazing fast.

    The everyday use has re-enabled too many of your characters, slowing down your system again? Use "Disable all" and with your next scene, you are starting from a clean slate.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    HatB said:

    I am anxiously awaiting this product. Sounds fantastic as I have all three of the Turbo Loaders already.

    I am glad you like the idea.  And thank you so much for your support!

  • RiverSoftArtRiverSoftArt Posts: 5,320

    Mark_e593e0a5 said:

    HatB said:

    I am anxiously awaiting this product. Sounds fantastic as I have all three of the Turbo Loaders already.

    I had the honor to test that product, and I can asure you, it does not only sound perfect. It is THE perfect add-on for any of the TurboLoaders.

    Whant to add a character you have disabled? Really easy now. Select the character file in your content library or smart content, and use "Merge". The character morphs will be enabled and the character merged into your scene. You can even replace an existing character that way (only same generations, but that is a DS limit). Blazing fast.

    The everyday use has re-enabled too many of your characters, slowing down your system again? Use "Disable all" and with your next scene, you are starting from a clean slate.

    Thanks @Mark_e593e0a5!  He really helped a lot in testing the v1.1 update and the Booster Utilities.

  • evacynevacyn Posts: 806
    Looks like a must buy :) Do expressions count as scene assets?
  • RiverSoftArtRiverSoftArt Posts: 5,320

    evacyn said:

    Looks like a must buy :) Do expressions count as scene assets?

    Sorry, expressions are not currently supported.  Even when I add "support" for preset_pose types, they would work exactly like preset_shape files (i.e., they don't except with the TL Inspector), as they do not actually trigger Daz Studio to create properties (like character presets and scene presets).  .  

  • HatBHatB Posts: 71

    It's here and I got it.   THANKS for the extra discount. Can't wait until tomorrow to use it. THANKS so much for all of this.

  • TATSU 3DTATSU 3D Posts: 214

    This was an instabuy for me! I'm puzzled though, I've installed it via DIM, but on loading Studio, I can't see any new options, such as the 'TL Open' and 'TL Merge' options?  It's also not in the favourites dropdown.  Where do I find it?

  • Thomas63Thomas63 Posts: 31

    TATSU 3D said:

    This was an instabuy for me! I'm puzzled though, I've installed it via DIM, but on loading Studio, I can't see any new options, such as the 'TL Open' and 'TL Merge' options?  It's also not in the favourites dropdown.  Where do I find it?

    I think you need to find the product in your Content Library and then click on the 'Turbo Loader Install Custom Actions' icon. This gives you the options of adding it to your favourites and your toolbar. Worked for me!

  • TATSU 3DTATSU 3D Posts: 214

    Thomas63 said:

    TATSU 3D said:

    This was an instabuy for me! I'm puzzled though, I've installed it via DIM, but on loading Studio, I can't see any new options, such as the 'TL Open' and 'TL Merge' options?  It's also not in the favourites dropdown.  Where do I find it?

    I think you need to find the product in your Content Library and then click on the 'Turbo Loader Install Custom Actions' icon. This gives you the options of adding it to your favourites and your toolbar. Worked for me!

     

    Cool, will give that a try, thanks!

  • Dim ReaperDim Reaper Posts: 668

    I saw the new product in the store this morning and realised that I had somehow missed all of the previous Turbo Loader products.  I was a bit confused over the difference between this product and the previous ones, but after watching two of your Youtube videos, that was made very clear.

    On the basis of those videos, I bought Turbo Loader Booster Utilities and Turbo Loader for Genssis 8 and 8.1.  Just trying them out now and they are all that was promised.  Default Genesis 8 female on my system took between 44 and 53 seconds to load.  After using the Turbo Loader products, it took 2 seconds.  The first load of Genesis 8 after use brought up three "missing file" errors (must be morphs on my default Gen 8F figure), but because of the search function in Turbo Booster, I was quickly able to locate them, re-enable them and forget about them.

    What a fantastic product.  Something that has been sorely needed for a long time in DS. 

    Thank you for releasing these.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    And it is released!

  • RiverSoftArtRiverSoftArt Posts: 5,320

    HatB said:

    It's here and I got it.   THANKS for the extra discount. Can't wait until tomorrow to use it. THANKS so much for all of this.

    You're welcome!  And thank you so much for your support!

  • RiverSoftArtRiverSoftArt Posts: 5,320

    Thomas63 said:

    TATSU 3D said:

    This was an instabuy for me! I'm puzzled though, I've installed it via DIM, but on loading Studio, I can't see any new options, such as the 'TL Open' and 'TL Merge' options?  It's also not in the favourites dropdown.  Where do I find it?

    I think you need to find the product in your Content Library and then click on the 'Turbo Loader Install Custom Actions' icon. This gives you the options of adding it to your favourites and your toolbar. Worked for me!

    Thanks for the help @Thomas63!  smiley  Exactly what he said.  You need to run the Turbo Loader Install Custom Actions script.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    Dim Reaper said:

    I saw the new product in the store this morning and realised that I had somehow missed all of the previous Turbo Loader products.  I was a bit confused over the difference between this product and the previous ones, but after watching two of your Youtube videos, that was made very clear.

    On the basis of those videos, I bought Turbo Loader Booster Utilities and Turbo Loader for Genssis 8 and 8.1.  Just trying them out now and they are all that was promised.  Default Genesis 8 female on my system took between 44 and 53 seconds to load.  After using the Turbo Loader products, it took 2 seconds.  The first load of Genesis 8 after use brought up three "missing file" errors (must be morphs on my default Gen 8F figure), but because of the search function in Turbo Booster, I was quickly able to locate them, re-enable them and forget about them.

    What a fantastic product.  Something that has been sorely needed for a long time in DS. 

    Thank you for releasing these.

    You're welcome!  I am so glad you like them!

  • markusmaternmarkusmatern Posts: 390
    edited May 15

    RiverSoftArt said:

    And it is released!

    This was an instant buy for me. Can't imagine working without Turbo Loader anymore!

    However when I first tried it to load a scene via the Content Manager pane and the Open Command from the toolbar it showed the Open Dialog and did not open the selected file immediately.

    After fiddling around a bit I got it to work by redocking my Content Library pane to a different part of the application (on the left where I have my Smart Content pane) < This opens the already selected scene

    Usually I have the Content Library pane docked in the same area as my Viewport pane (in the middle of the screen)  < This opens the Open Dialog as described above. An additional click is needed after showing the Open Dialog

    This is not a real problem, as it is working, but maybe you can check it on your side...

    Post edited by markusmatern on
  • RiverSoftArtRiverSoftArt Posts: 5,320
    edited May 15

    markusmatern said:

    RiverSoftArt said:

    And it is released!

    This was an instant buy for me. Can't imagine working without Turbo Loader anymore!

    However when I first tried it to load a scene via the Content Manager pane and the Open Command from the toolbar it showed the Open Dialog and did not open the selected file immediately.

    After fiddling around a bit I got it to work by redocking my Content Library pane to a different part of the application (on the left where I have my Smart Content pane) < This opens the already selected scene

    Usually I have the Content Library pane docked in the same area as my Viewport pane (in the middle of the screen)  < This opens the Open Dialog as described above. An additional click is needed after showing the Open Dialog

    This is not a real problem, as it is working, but maybe you can check it on your side...

    This is because I have not figured out the correct way to get the "selected" pane between the Smart Content Pane and the Content Library Pane (and then the selected assets).  The script looks for the Smart Content pane first.  If that is not showing, it goes for the Content Library pane.

    EDIT: Oh, and thank you for the support and kind words.  smiley

    Post edited by RiverSoftArt on
  • markusmaternmarkusmatern Posts: 390

    RiverSoftArt said:

    markusmatern said:

    RiverSoftArt said:

    And it is released!

    This was an instant buy for me. Can't imagine working without Turbo Loader anymore!

    However when I first tried it to load a scene via the Content Manager pane and the Open Command from the toolbar it showed the Open Dialog and did not open the selected file immediately.

    After fiddling around a bit I got it to work by redocking my Content Library pane to a different part of the application (on the left where I have my Smart Content pane) < This opens the already selected scene

    Usually I have the Content Library pane docked in the same area as my Viewport pane (in the middle of the screen)  < This opens the Open Dialog as described above. An additional click is needed after showing the Open Dialog

    This is not a real problem, as it is working, but maybe you can check it on your side...

    This is because I have not figured out the correct way to get the "selected" pane between the Smart Content Pane and the Content Library Pane (and then the selected assets).  The script looks for the Smart Content pane first.  If that is not showing, it goes for the Content Library pane.

    EDIT: Oh, and thank you for the support and kind words.  smiley

    You are welcome!

    And also your comment helps me out! Instead of redocking my Content Library Pane I now just make sure the Smart Content pane is not selected when trying to load from the Content Library!

  • RiverSoftArtRiverSoftArt Posts: 5,320

    markusmatern said:

    RiverSoftArt said:

    markusmatern said:

    RiverSoftArt said:

    And it is released!

    This was an instant buy for me. Can't imagine working without Turbo Loader anymore!

    However when I first tried it to load a scene via the Content Manager pane and the Open Command from the toolbar it showed the Open Dialog and did not open the selected file immediately.

    After fiddling around a bit I got it to work by redocking my Content Library pane to a different part of the application (on the left where I have my Smart Content pane) < This opens the already selected scene

    Usually I have the Content Library pane docked in the same area as my Viewport pane (in the middle of the screen)  < This opens the Open Dialog as described above. An additional click is needed after showing the Open Dialog

    This is not a real problem, as it is working, but maybe you can check it on your side...

    This is because I have not figured out the correct way to get the "selected" pane between the Smart Content Pane and the Content Library Pane (and then the selected assets).  The script looks for the Smart Content pane first.  If that is not showing, it goes for the Content Library pane.

    EDIT: Oh, and thank you for the support and kind words.  smiley

    You are welcome!

    And also your comment helps me out! Instead of redocking my Content Library Pane I now just make sure the Smart Content pane is not selected when trying to load from the Content Library!

    Great!  I am glad that works for you.

  • TATSU 3DTATSU 3D Posts: 214

    Ok, so I got all the new icons installed correctly.  However, if I load a character file the usual way (having TL open their config file, then opening character file through usual menu) - 0 mins 22 seconds. If I use 'Turbo Loader Open File': 4 mins 14 seconds??  Am I missing something?  This is now slower to open a character file than before I installed TL? Furthermore, once the character opened, every single morph had also been loaded, not just the ones used to create the character.

    It's quicker to use basic TL to load the character config file, then open the character, if this is anything to go by?  I tried doing this with the same character, and sure enough, under 30 seconds, amd only the used morphs loaded.

    Obviously I'm going wrong somewhere, but I can't seem to figure out where.  I suspect more playing about with it is required.

  • TATSU 3DTATSU 3D Posts: 214

    Further to my last post, I have been trying all ways to get this to show a benefit of having it installed.  These are the fastest times I have recorded:

     

    Using the Booster Utilities add-on...

    I opened Studio, disabled all morphs using the TL config script, let that do it's thing.  Then I clicked on the 'Enable required morphs and open file', navigated to the character file, and clicked it to open.  Time before character loaded: 2 mins 12 secs.

     

    I closed Studio, let it close itself down, then reopened.

     

    NOT using the Booster Utilities add-on...

    This time I again made sure all morphs were disabled, but loaded the character's config file first via the TL Loader Manager, then opened the character file the old way - 'File, Open' etc. Time before character loaded: 0 mins 39 secs.

     

    The main draw to get the booster script was to take out the step of having to load the config file before the figure. However seeing as it takes so much longer to do that, I'm genuinely at a loss as to what this upgrade will bring to my workflow?  It's actually slowing it down.

    Don't get me wrong, I absolutely LOVE Turbo Loader, I wouldn't be without the base script now!  Also, I have to commend @RiverSoftArt for being so helpful with the setting up and general support. But having said that, I genuinely fail to see (at the moment) what my extra money spent on the Booster Utilities has actually brought to the table...?

  • RiverSoftArtRiverSoftArt Posts: 5,320
    edited May 15

    TATSU 3D said:

    Further to my last post, I have been trying all ways to get this to show a benefit of having it installed.  These are the fastest times I have recorded:

     

    Using the Booster Utilities add-on...

    I opened Studio, disabled all morphs using the TL config script, let that do it's thing.  Then I clicked on the 'Enable required morphs and open file', navigated to the character file, and clicked it to open.  Time before character loaded: 2 mins 12 secs.

     

    I closed Studio, let it close itself down, then reopened.

     

    NOT using the Booster Utilities add-on...

    This time I again made sure all morphs were disabled, but loaded the character's config file first via the TL Loader Manager, then opened the character file the old way - 'File, Open' etc. Time before character loaded: 0 mins 39 secs.

     

    The main draw to get the booster script was to take out the step of having to load the config file before the figure. However seeing as it takes so much longer to do that, I'm genuinely at a loss as to what this upgrade will bring to my workflow?  It's actually slowing it down.

    Don't get me wrong, I absolutely LOVE Turbo Loader, I wouldn't be without the base script now!  Also, I have to commend @RiverSoftArt for being so helpful with the setting up and general support. But having said that, I genuinely fail to see (at the moment) what my extra money spent on the Booster Utilities has actually brought to the table...?

    You could be running into the Daz Studio cache.  I can load the exact same figure (not using TLBU) and the first time can take twice or more longer.  EDIT: It also depends on how the character was saved.  If the character preset has every morph in it for some stupid reason, it WILL be slower.  But that is a mistake of the PA who saved the character, not TLBU.

    That said, it should not be pulling in all morphs.  What is your "Enable Morph Detected Behavior?"  The fastest will be to pull in only the "Detected Morphs."  How many morphs do you have total (enabled and disabled?)  What is the figure?  And what does the log say?

    Post edited by RiverSoftArt on
  • HatBHatB Posts: 71

    Is there a quick way to remove items from the toolbar? With the new program, I don't see that I still need the icons for each of the generations so would like to take them off the tool bar.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    HatB said:

    Is there a quick way to remove items from the toolbar? With the new program, I don't see that I still need the icons for each of the generations so would like to take them off the tool bar.

    1. F3 (Customize Daz Studio)
    2. Tool bars tab on right
    3. Expand Main
    4. Right click item and select delete
  • MouserMouser Posts: 563

    Any chance of a Turbo Loader bundle or are there more related products in production?

  • evacynevacyn Posts: 806

    So I'm having issues with enabling Unknown morphs when using the filter - it appears to be adding a lot more than the morphs I'm selecting. 

    I filtered by "SASE", ended up with 15+ morphs, then selected them all an hit the space bar. My checked morphs number went from like 13K to 18K even though in total it's probably a few hundred morphs (even with dependencies). It doesn't appear to be an issue with non-Unknown morphs and it also doesn't seem to be an issue when I don't use the filter.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    Mouser said:

    Any chance of a Turbo Loader bundle or are there more related products in production?

    Sorry, Daz does not do bundles on already released products.  And at this point, there are no more Turbo Loader products in the pipeline.

  • RiverSoftArtRiverSoftArt Posts: 5,320

    evacyn said:

    So I'm having issues with enabling Unknown morphs when using the filter - it appears to be adding a lot more than the morphs I'm selecting. 

    I filtered by "SASE", ended up with 15+ morphs, then selected them all an hit the space bar. My checked morphs number went from like 13K to 18K even though in total it's probably a few hundred morphs (even with dependencies). It doesn't appear to be an issue with non-Unknown morphs and it also doesn't seem to be an issue when I don't use the filter.

    The filter just hides the list items, but they are still there.  Doing a shift select on them WILL select the hidden list items as well even though they are not visible.  This is a limitation of the list view control provided to the script interface.  Hitting the space bar will toggle visible and invisible items.

Sign In or Register to comment.