Converting Daz Props to Poser

I'm trying to convert several Daz props to Poser pp2 files using the Winterbrose PP2 exporter, but even though I follow the instructions precisely, I always get an error message saying that the prop could not be created. Unfortunately, the pop-up window for the log file disappears so quickly I can't read it, so I have no idea what the specific error is, and there is no information in the manual about what to do if your prop is not created successfully. I tried reaching out to Winterbrose support and got no reply, so now I'm opening it up to the Daz community at large. Does anyone know what I can do to fix this problem? Or is there another way to create pp2 files I can try? 

PP2 Exporter Screenshot 1.jpg
1920 x 1080 - 343K
PP2 Exporter Screenshot 2.jpg
1920 x 1080 - 343K

Comments

  • PerttiAPerttiA Posts: 9,734

    Have you checked what the logfile says?

  • Help>Troubleshooting>View Log File

  • jorindajorinda Posts: 6
    edited February 2021

    Richard Haseltine said:

    Help>Troubleshooting>View Log File

    Thanks, Richard! I'm somewhat new to Daz and couldn't find the log file. Here's what it said about the error:

    2021-02-10 12:41:20.781 WARNING: Script Error: Line 449

    2021-02-10 12:41:20.781 WARNING: TypeError: Result of expression 'Mat.findPropertyByLabel( "Ambient Color" )' [null] is not an object.

    2021-02-10 12:41:20.781 WARNING: Stack Trace:

    <anonymous>()@C:/Users/Public/Documents/My DAZ 3D Library/Scripts/PP2 Exporter DS4+/PP2 Exporter 2-1a.dsa:449

    2021-02-10 12:41:20.846 Error in script execution: C:/Users/Public/Documents/My DAZ 3D Library/Scripts/PP2 Exporter DS4+/PP2 Exporter 2-1a.dsa

    Post edited by jorinda on
  • If you look in the Editor tab of the Surfaces pane, with the object selected, what shader does it say is applied when you select the item from the list on the left of the pane?

  • Initially, I didn't see any shader in particular applied. The object was just a solid green color. (Screenshot 1) Then I tried applying one the materials that came with the product to the object, made sure all the maps were filled in with the right image (Screenshot 2), and tried to run the PP2 exporter again. It gave me the same error. I feel like I'm missing something obvious...

    screenshot1.jpg
    1910 x 1078 - 622K
    Screenshot 2.jpg
    1920 x 1080 - 310K
  • Yes, it's using the Iray Uber shader - that doesn't haev Ambiebnt Occlusion. It looks as if the script is hard-coded to handle the Daz Default (3Delight) shader and doesn't have suitable error trapping. Try applying a 3Delight shader preset to the model (hold own the ctrl key while doing so and choose ignore for maps so that you don't have to reapply the textures in all cases) and with luck it will then work.

  • Thank you so much! That worked perfectly! :D

  • For those interested, the Winterbrose PP2 exporter (v. 2.1a, 2018) is free at Renderosity. A search there for winterbrose pp2 will not pick it up on either the Marketplace or Freestuff, for some reason, but general Google Search currently lands you at the page.

  • lukon100lukon100 Posts: 773
    edited May 2022

    Martirilla said:

    For those interested, the Winterbrose PP2 exporter (v. 2.1a, 2018) is free at Renderosity. A search there for winterbrose pp2 will not pick it up on either the Marketplace or Freestuff, for some reason, but general Google Search currently lands you at the page.

    So the Winterbrose expoter cannot handle iRay shaders?

    I want to make Poser versions of a Daz rigged car model I just made. So I gather I could do so with the Winterbros exporter as long as I convert the surfaces to 3Delight. Is this so?

     

    ------------- Edit addendum -----------

    I just looked at theRenderosity page for that.

    It converts .obj's to PP2, not .duf to PP2.

    So, to convert my car, I must first export my car to the .obj format. Then use the Winterbrose converter.

    But will this procedure preserve the car's rigging and morphs?

    I do not know whether the .obj format supports rigging and morph information.

    Post edited by lukon100 on
Sign In or Register to comment.