Problems Installing Plugins - VWD bridge, HD Morph, GMIC

DiomedeDiomede Posts: 9,961
edited December 4 in Carrara Discussion

Copied files to extension folders as per instructions.  Getting the following errors.

- Carrara on my new machine is installed on the C: SSD drive, which requires adminstrator privileges.  So I had to give permission to copy the files to the extension folder.

The VWD error occurs when starting Carrara.  Says can't load mcx file.

The HD morph error occurs when inserting a vertex object.  Says can't load mcx file.

GMIC filter appears in scene menu but the list of GMIC libraries is empty

vwd mcx failed to load.jpg
1001 x 545 - 145K
hd morph mcx failed to load.jpg
1854 x 866 - 171K
gmic filter no libraries.jpg
1877 x 922 - 231K
Post edited by Diomede on

Comments

  • UnifiedBrainUnifiedBrain Posts: 2,309

    Woes!  I still don't have a Win 10 machine.  Crossing my fingers that Win 10 gurus can help you solve this.

  • DiomedeDiomede Posts: 9,961

    Many other plugins seem to be working.  For example, I have successfully tested Philemo's dynamic hair converter.

  • StezzaKararaStezzaKarara Posts: 5,008

    that's why I don't install any 3D software to the Program Files folder in Windows cool

  • UnifiedBrainUnifiedBrain Posts: 2,309

    that's why I don't install any 3D software to the Program Files folder in Windows cool

    Where do you install your programs?

  • DiomedeDiomede Posts: 9,961
    edited December 4

    VWD required Python to be installed.

    Still getting the error for the HD morph plugin, and the GMIC filter library remains empty.

     

    After installing Python, was able to start Carrara without the VWD mcx error and do a simple VWD test with a plane and a cube.  yesyes

     

    vwd test.jpg
    1892 x 1008 - 283K
    Post edited by Diomede on
  • DiomedeDiomede Posts: 9,961

    that's why I don't install any 3D software to the Program Files folder in Windows cool

    Yeah, I really should install on my other drive, but in theory the programs are supposed to be installed to the SSD.  angry

     

  • MystarraMystarra Posts: 32,677

    i install to a logical partition on my single 2tb drive.  i've always set rhe partition as E:
    in case something i saved,  saved with a literal path, rather than a relative path. learned the hard way, in poser 4, lol

    do you launch carrara with the run as administator set?

     

    run as admin.JPG
    375 x 528 - 46K
  • DiomedeDiomede Posts: 9,961
    edited December 5

    Yay - GMIC Plugin is Now Working

    I downloaded the zip file again.  I must have had an outdated version in my zip archives.

    Here is the page to download some of Philemo's plugins.  After getting a new computer, I guess I should have known to check for current updates.  blush

    https://sourceforge.net/projects/carrara-time-savers/files/

    gmic working must have been an old version.jpg
    1530 x 838 - 192K
    Post edited by Diomede on
  • DiomedeDiomede Posts: 9,961

    The HD plugin is not working yet.  Have to pause now.  Will check if it is another version problem tomorrow.  

  • DiomedeDiomede Posts: 9,961
    Mystarra said:

    i install to a logical partition on my single 2tb drive.  i've always set rhe partition as E:
    in case something i saved,  saved with a literal path, rather than a relative path. learned the hard way, in poser 4, lol

    do you launch carrara with the run as administator set?

     

    Good advice.  I had tried the administrator thing but that wasn't the problem.

  • StezzaKararaStezzaKarara Posts: 5,008

    that's why I don't install any 3D software to the Program Files folder in Windows cool

    Where do you install your programs?

    Programs on a 2nd internal drive and Poser/Daz/Other content on a 3rd internal drive :-)

  • WendyLuvsCatzWendyLuvsCatz Posts: 22,702

    yeah I let everything install to default on this PC too and cannot use most my third party plugins

    I didn't worry as much as still have the other PC but in hindsight it was likely the main issue

  • UnifiedBrainUnifiedBrain Posts: 2,309
    edited December 5
    Diomede said:

    Yay - GMIC Plugin is Now Working

    I downloaded the zip file again.  I must have had an outdated version in my zip archives.

    Yay!

    I'm hoping that all of your plugins will install fine on the C drive.  Appreciate you sharing your experience, as I will be going there soon.

    Post edited by UnifiedBrain on
  • Diomede said:

    Yay - GMIC Plugin is Now Working

    I downloaded the zip file again.  I must have had an outdated version in my zip archives.

    Here is the page to download some of Philemo's plugins.  After getting a new computer, I guess I should have known to check for current updates.  blush

    https://sourceforge.net/projects/carrara-time-savers/files/

    Hi Diomede,

    What kind of issue do you have with the HD plugin ?

     

  • DiomedeDiomede Posts: 9,961
    Diomede said:

    Yay - GMIC Plugin is Now Working

    I downloaded the zip file again.  I must have had an outdated version in my zip archives.

    Here is the page to download some of Philemo's plugins.  After getting a new computer, I guess I should have known to check for current updates.  blush

    https://sourceforge.net/projects/carrara-time-savers/files/

    Hi Diomede,

    What kind of issue do you have with the HD plugin ?

     

     

    When I insert a vertex object in a scene, I get a message telling me that the HD morph mcx file failed to load.  This occurs even if I am inserting a blank vertex object into a blank scene, without any HD morphs.

  • That's weird. This one doesn't have any dependencies, like GMIC or VWD do.  

    The only reason I can think of is some kind of identifier conflict with an other plugin.

    What plugins have you installed apart from mine ?

     

  • DiomedeDiomede Posts: 9,961

    So far, I've installed

    - some Fenric packs, including the ERC, Baker, Unlock Figure, Shader Tools

    - some DCG plugins, including Cognito, Anything Grows, Anything Grooves

    - some of yours, including the bridge to VWD, Phong Tessalation, Hair Converter, GMIC

     

    Examples of what I have not installed yet

    - YAToon

    - Fluidos

    - Some Sparrowhawke such as the replication shader randomizer or chains circle.

  • I've got ERC, the complete DCG pack  and Fluidos, and, of course, all of mine.No issue there.

    I've uploaded a new version with different identifiers. It should solve any conflict if this was the problem.

    Please keep me posted.

  • UnifiedBrainUnifiedBrain Posts: 2,309

    Good seeing you back Philemo.  Been worried about you.sad

  • DiomedeDiomede Posts: 9,961
    edited December 5

    Must be a different problem.  I downloaded and replaced the HD Morph plugin files in the extensions folder.  Still get an error when I enter the vertex modeling room.

    Maybe it is a Windows Administrator permissions thing.

    Thanks for the incredibly fast response, Philemo.  

     

    hd morph fail to load again.jpg
    635 x 373 - 29K
    Post edited by Diomede on
  • WendyLuvsCatzWendyLuvsCatz Posts: 22,702
    edited December 5

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Post edited by WendyLuvsCatz on
  • DiomedeDiomede Posts: 9,961

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Hmm, maybe I'm placing the files in the wrong place?

    I unzipped the HD Morph download.  I copied the results to my extensions folder in Carrara.  I also copied the scripts folder to my Daz Studio installation.  Could that be it?  Some sort of double script reference?

  • Good seeing you back Philemo.  Been worried about you.sad

    I had some good reasons to be away from Carrara for a while. Went on holydays, got married, went on honeymoon, worked like mad to make up for the time I spent doing all this.

    I'm back now :-)

  • WendyLuvsCatzWendyLuvsCatz Posts: 22,702

    Good seeing you back Philemo.  Been worried about you.sad

    I had some good reasons to be away from Carrara for a while. Went on holydays, got married, went on honeymoon, worked like mad to make up for the time I spent doing all this.

    I'm back now :-)

    congratulations heart

  • Would you mind doing this little experiment:

    Insert a sphere primitive

    if no issue, go to modifier tab for that sphere and try to add the HD plugin modifier.

    Diomede said:

     

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Hmm, maybe I'm placing the files in the wrong place?

    I unzipped the HD Morph download.  I copied the results to my extensions folder in Carrara.  I also copied the scripts folder to my Daz Studio installation.  Could that be it?  Some sort of double script reference?

     

    Diomede said:

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Hmm, maybe I'm placing the files in the wrong place?

    I unzipped the HD Morph download.  I copied the results to my extensions folder in Carrara.  I also copied the scripts folder to my Daz Studio installation.  Could that be it?  Some sort of double script reference?

     

    Diomede said:

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Hmm, maybe I'm placing the files in the wrong place?

    I unzipped the HD Morph download.  I copied the results to my extensions folder in Carrara.  I also copied the scripts folder to my Daz Studio installation.  Could that be it?  Some sort of double script reference?

     

  • WendyLuvsCatzWendyLuvsCatz Posts: 22,702
    Diomede said:

    I remember having this happen way back and have forgotten what caused it, it was if I recall user error in my case but what it was eludes me now

    whats worse is I actually found the post and I had edited it and said NM user error 

    Hmm, maybe I'm placing the files in the wrong place?

    I unzipped the HD Morph download.  I copied the results to my extensions folder in Carrara.  I also copied the scripts folder to my Daz Studio installation.  Could that be it?  Some sort of double script reference?

    I have utterly no idea except it was something extremely  stupid I did, so stupid I edited my post and chose to forget it blush

    my brain now refuses to recall it

  • UnifiedBrainUnifiedBrain Posts: 2,309

    Good seeing you back Philemo.  Been worried about you.sad

    I had some good reasons to be away from Carrara for a while. Went on holydays, got married, went on honeymoon, worked like mad to make up for the time I spent doing all this.

    I'm back now :-)

    Awesome!  Very happy to hear.yesyesyes

  • DiomedeDiomede Posts: 9,961
    edited December 5

    Congrats, Philemo!!!!!  Such great reasons to be away from Carrara.

     

    I did the test with the primitive sphere.  The menu option for your HD Morph is there in the modifiers tab, but I get an error message when applying it to the primitive sphere.

    primitive sphere fail.jpg
    1234 x 751 - 133K
    Post edited by Diomede on
  • WendyLuvsCatzWendyLuvsCatz Posts: 22,702

    i think I simply forgot to import my object first

  • DartanbeckDartanbeck Posts: 14,846

    Good seeing you back Philemo.  Been worried about you.sad

    I had some good reasons to be away from Carrara for a while. Went on holydays, got married, went on honeymoon, worked like mad to make up for the time I spent doing all this.

    I'm back now :-)

    Awesome! Congratulations!!!

Sign In or Register to comment.