Hexagon Smoothing Normals.

useroperatoruseroperator Posts: 247
edited January 2014 in Hexagon Discussion

Any way to get around this? It seems every export, no matter the setting, smooths the normals of an object. I can literally import a non hexagon model, export it without doing anything to it, and the normals will be smoothed, altering the rendering of the objects. For example, gem models that require facets to calculate things like refraction, appear incorrectly.

1920 x 1080 - 2M
1920 x 1080 - 2M
Post edited by useroperator on


  • ds-mail_2e0cb9c256ds-mail_2e0cb9c256 Posts: 70
    edited December 1969

    I don't remember Hex doing this by itself (tho I could be wrong).

    Can you try a simple object like a cube; does it do the same?

    Can you post a sample file for others to try to see if we get same result?

    I don't remember any auto smoothing....but check the export settings to be sure nothing is set to alter the object.

  • useroperatoruseroperator Posts: 247
    edited December 1969

    you can't really smooth the normals on a cube. I've tried all export settings, and lack of settings, and formats.

  • cdordonicdordoni Posts: 583
    edited December 1969

    Unfortunately Hexagon does not give you any control of smoothing normals. There are a few work arounds.

    One option is to export your model as a dxf. Usually, DXF importers in many applications allow you to set the smoothing angle. If you use "0", I believe that typically result in NO smoothing applied.

    A second option is to use the extract edge tool to create a very thin border of polys near the edge you want to remain sharp. The thin polys in the border will receive smoothing but it won't be as noticeable because they are thin.

    A third option is to use the dissociate tool, to break the connection between polys on the edges you want to be sharp.

    The second and third options might introduce issues downstream with shading and UVs in other apps, so the first option may be your best choice, since the object geometry is not altered.

  • mjc1016mjc1016 Posts: 15,001
    edited December 1969

    you can't really smooth the normals on a cube. I've tried all export settings, and lack of settings, and formats.

    You can if your cube is more than one poly per side...example, a cube of 24 quads instead of 6...4 per side.

  • RoygeeRoygee Posts: 2,247
    edited December 1969

    Hexagon does not smooth without without you instructing it to. For instance, in this pic an icosohedron made in Hex, showing sharp edges, imported into Carrara - the top one shows the typical Carrara "marshmellow" softening of the edges - the bottom has had the edges sharpened in Carrara and has gone back to how it originally looked in Hex.

    Blender imports it with sharp edges - so, it depends on how your rendering app handles it.

    You can control the sharpness of edges in Hex ( or more correctly, their degree of resistance to smoothing) with the "breaks" tool

    640 x 480 - 10K
Sign In or Register to comment.