Can't delete "unassigned faces"

ValKyrieValKyrie Posts: 126
edited March 2019 in Hexagon Discussion

Hi All! 

I'm making my first foray into Hexagon, and although I'm a power user of 2D programs like Illustrator, I'm a 3D newbie! I'm finding even the availale tools to be a challenge.

Brought in the hat stand prop from the Expedition camp for DS. My goal is to separate the pith helmet from the stand in order to use as a wardrobe element as there are no pith helmet available that I can find.

The scene tab shows just the hat stand. But the surfaces tab shows the individual elements, and I was able to delete everything except "Unassigned faces". Screen shot attached. I've tried hiding them, but they show up again in DS. Cannot hide separately there, also, they make it really hard to rotate the hat, because the center of the selection is god knows where.

Any advice? Use a different 3D program to disassemble? I only have Hexagon and Blender.

Screen Shot 2019-03-29 at 11.39.58 AM.png
838 x 1004 - 69K
Post edited by ValKyrie on

Comments

  • WendyLuvsCatzWendyLuvsCatz Posts: 30,348

    use the geometry editor to hide then delete them in DS?

  • ValKyrieValKyrie Posts: 126

    use the geometry editor to hide then delete them in DS?

    Thanks for your suggestion. Did not seem to work, although I may very well not be doing it properly. Fortunately, because I was able to select the separate parts in the surfaces panel, I just copied them into a new file one by one. That worked! 

  • Wee Dangerous JohnWee Dangerous John Posts: 1,385
    edited March 2019

    Here's a screengrab of how I have my import/export setting when doing this sort of thing.

    One thing you can check is to click each object in the Scene Tree and check that there are no item in the Shading Domains, if there is (keep the ones you want) - remove it. Also check that the materials change to the correct colour/texture as you scroll through.

    One the reason you can get the undefined material error is if you have a group inside a group.

    Tip - When you're done you will want to position the hat at 0.0.0 then save it as an obj.

    Have a play with the Import/Export options to see what happens :)

    import-export.jpg
    965 x 578 - 103K
    Post edited by Wee Dangerous John on
  • ValKyrieValKyrie Posts: 126

    Thank-you WDJ. I have those same settings for import. I will try using your export settings. The "unassigned plane" was there in the Shading Domains but wouldn't let me delete it. Not sure why. At least my workaround gave me what i wanted for now. So much to learn!!!

  • Does not matter but did you try the "Remove" option ?

    How did you get on with the hat, where you able to fit it to a character and render it - We like seeing renders here :)

  • FirstBastionFirstBastion Posts: 5,333

    Just select those unassigned polies using the "faces" tool in hexagon and delete them.

     

Sign In or Register to comment.