reproducable crash

now, lets state, it's something I can do to Hexagon that crashes it. I've been able to do this now on 3 computers, 5 different graphics cards, both AMD and Nivida, XP, Win 7 and now Win10. 

the only common denominator is .. well .. me.

 

so lets tell you how I do it.

 

pop a cube.

take one side, extrude it out, resize how I want it.

extrude another face. 

turn on smoothing.

turn off smoothing

work another face

crash.

 

the only new thing in the beta is, I now go straight to desktop, no error message.

 

may the head scratching commence, cos it seems this does not happen to anyone else!!

 

Comments

  • oh should note, I've been able to reproduce this curse since I got version 2. I fully expect I'm the only one...

     

  • AscaniaAscania Posts: 494

    Okay, just tried it. Can confirm, it's crashing here too.

  • Just tried it myself (added more exclusions and smoothed/un-smooth) but Hexagon is working fine for me.

    But I think you should contact the support team and let them know what is happening -

    https://www.daz3d.com/help/help-contact-us

    Personally, when I can re-produce a problem I screen record it and attach the video.

  • AscaniaAscania Posts: 494
    edited January 1

    Just tried it myself (added more exclusions and smoothed/un-smooth) but Hexagon is working fine for me.

    But I think you should contact the support team and let them know what is happening -

    https://www.daz3d.com/help/help-contact-us

    Personally, when I can re-produce a problem I screen record it and attach the video.

    Have you actually followed the outlined procedure - select a face, use the extrude tool - NOT the Quick Extrude - validate, do the same again, do smoothing, then turn the smoothing off, not just set it to zero? Merely setting the smoothing level to zero or setting it to zero and then turning smoothing off and it won't crash.

    Post edited by Ascania on
  • Acania, yes I did. And did not have a problem.

  • mariannermarianner Posts: 42

    Crashes for me too, but only if I click on the word "smoothing" to turn it off again and not if I click on the button "0" to the right of the button "Smoothing".

    Using the the beta, 64-bit.

  • What I tried was, select a face extude it, add 1 level of smoothing - click on the lightning bolt. CTRL Z to undo, back arrow in DG to undo smoothing. Then select another face and repeat. Tried it with the CTRL + Manipulator, Fast Extrude, Extude Surface & Sweep Surface tools with no problems.  May-be I'm just lucky 

    I'm also using beta 64 version.

  • AscaniaAscania Posts: 494

    What I tried was, select a face extude it, add 1 level of smoothing - click on the lightning bolt. CTRL Z to undo, back arrow in DG to undo smoothing. Then select another face and repeat. Tried it with the CTRL + Manipulator, Fast Extrude, Extude Surface & Sweep Surface tools with no problems.  May-be I'm just lucky 

    I'm also using beta 64 version.

    But that is NOT actually the procedure the OP described.

  • de3ande3an Posts: 802

    This seems to be another symptom related to the "Local redraw" Preference (Preference Editor/3D Display/Advanced/Local redraw).

    If Local redraw is unchecked, then Hexagon doesn't seem to crash when performing the described steps.

    I'm using the Mac version of 2.5.2.137, so still 32 bit. So, your milage may vary.

     

  • mariannermarianner Posts: 42
    de3an said:

    This seems to be another symptom related to the "Local redraw" Preference (Preference Editor/3D Display/Advanced/Local redraw).

    If Local redraw is unchecked, then Hexagon doesn't seem to crash when performing the described steps.

    I'm using the Mac version of 2.5.2.137, so still 32 bit. So, your milage may vary.

     

    Yes, it is the same for me: when I uncheck "Local redraw" Hexagon doesn't crash. Windows 10, 64-bit.

  • Ascania, do you mean add 1 level of smoothing, then extrude a face then change the smoothing back to 0.

    Not colapsing the DG etc, I tried that and I'm still working as per normal. I do have the Local Redraw unticked, but I do not know whay that would make any difference.

    I think my main point stands, if Hexagon crashes on you - fill out a bug report.

  • AscaniaAscania Posts: 494
    edited January 2

    Ascania, do you mean add 1 level of smoothing, then extrude a face then change the smoothing back to 0.

    No, I mean turn OFF the smoothing - click on the word "Smoothing", not set ot to level zero, not collapse it - use the function that doesn't change any of your settings, it just turns them off until you're ready to turn them on again.

    And this thread isn't about reporting a bug, it is about pinning down why it happens to the OP but is not experienced by anybody else. Which we now can see quite clearly is because his workflow differs from everyone else's and he uses some functionality that gets generally ignored.

    Post edited by Ascania on
  • Ascania said:

    Ascania, do you mean add 1 level of smoothing, then extrude a face then change the smoothing back to 0.

    No, I mean turn OFF the smoothing - click on the word "Smoothing", not set ot to level zero, not collapse it - use the function that doesn't change any of your settings, it just turns them off until you're ready to turn them on again.

    And this thread isn't about reporting a bug, it is about pinning down why it happens to the OP but is not experienced by anybody else. Which we now can see quite clearly is because his workflow differs from everyone else's and he uses some functionality that gets generally ignored.

    exactly. I did'nt even think of this as a bug but something I was doing wrong. I thought it was normal to turn Smoothing on / off as you work by hitting the Smoothing button, leaving the smoothing level set as required.. 

    and yup. so far, unchecking Local Redraw seems to fix it so we've got somehwere! 

  • Thank Ascania, I have never tried that. I've always used the back arrow in the DG (learnt something new).

    Again, I've given it a go, using all the extrude tools and it still does not crash for me, then I ticked the Local Redraw box and tried again - there it goes, first crash this year.

  • JonnyRayJonnyRay Posts: 887

    Nice to know the root cause for this (local redraw). I had just gotten into the habit that whenever I turned off smoothing, I also used the undo/reset button in the dynamic geometry window to remove it. That also seems to avoid the crash for some reason.

  • MaxHancockMaxHancock Posts: 162

    Khai-J-Bach

    There are several ways you can extrude, and there are several ways you can turn off smoothing, and there are several types of smoothing. I can not reproduce your error, but maybe you can tell us exactly what button you are pressing, etc.

     

  • de3ande3an Posts: 802

    There are several ways you can extrude, and there are several ways you can turn off smoothing, and there are several types of smoothing. I can not reproduce your error, but maybe you can tell us exactly what button you are pressing, etc.

     

    This is what I did to reproduce the crash.

    First, to reproduce the crash, make sure that the "Local redraw" Preference (Preference Editor/3D Display/Advanced/Local redraw) is active (checked). If not, the crash will not occur.

    Create a cube.

    Extrude a surface with the "Extrude Surface" tool. Use the "Extrude" mode, since that seems to be the default.

    "Accept" the extrusion.

    Toggle "Smoothing" ON, and set a level of 1, then toggle "Smoothing" OFF.

    Extrude a different surface of the cube with the "Extrude Surface" tool. Hexagon will crash when you click to finish the extrusion, but before you get a chance to "Accept" it.

    Including extra steps or actions might cause the crash not to occur.

  • MaxHancockMaxHancock Posts: 162
    edited January 10

     

    Ok,  Yes, this time I can reproduce the crash. I see what's happening now. That type of extrusion is dynamic, and the smoothing is dynamic as well, and if you want that off you shouldn't use the button but instead turn it off with the little remove button in the DG panel. Also, to do basic extrusions, like the one in this example, you should command-drag a surface instead. That way you are not piling DG operations and running the risk of crashing. I like to do one DG operation at a time, that is to apply the operation then solidify it with the bolt icon in the DG panel.  And yeah, I never have local redraw on because that does cause a few errors here and there. 

     

     

    Post edited by MaxHancock on
  • AscaniaAscania Posts: 494

    The problem with that - that is what DG's job is supposed to be! Being able to build up a stack of operations and the going back and dynamically modify any of the operations within that stack without having to undo and redo the subsequent steps every time.

  • A friend reminded me today about something I had forgotten...

     

    I did actually file a bug report with video for this... in 2008. I found it in my diary!

    then due to "stuff" I kinda left it.. *shameface*

     

    it don't help that when I got Hex it was on a DVD, no manual etc.. and I was doing my normal way of learning. "whats this do? oooh ok. now how do I use that in a model...?"

     

    hey.. it worked for trueSpace and Sketchup.... 

  • AscaniaAscania Posts: 494

    Talking of trueSpace... did you ever finish that Tardis project of yours?

  • been working on transfering it into Sketchup.. and found soooo many errors in the model so its import and rebuild. 

    not easy since I no longer have my prefered trueSpace (4.3) and have been trying to get 7 to run (I can see why Caligari/MS canned it) to export it out... 

    but it's still alive :D thanks for asking :D

     

Sign In or Register to comment.