C85 Adjust Min/Max on Adjustment Morphs

3dOutlaw3dOutlaw Posts: 2,470
edited August 2013 in Carrara Discussion

I loaded Aiko Long Hair, and was going to lower the ADJ-FronUpDown, but the min is 0 and the max is 1, only allowing me to go up. I double checked in DS, and the min is -1 and the max is 1, going both up and down. I can type in -1, but no effect in C85?

Is there a way to change the Min/max setting on something like this? They show up on the General Tab.

EDIT: Looks like PT-UpDown (ponytail updown) has the same issue.

Post edited by 3dOutlaw on


  • DartanbeckDartanbeck Posts: 21,076
    edited December 1969

    Yes. the little icon directly to the left of the slider allows you to set the min/max yourself ;)

  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    Hi dartanbeck, what icon are you talking about. There is a little circle, but clicking or right-clicking does not work?

    245 x 503 - 41K
  • BrianP21361BrianP21361 Posts: 784
    edited September 2013


    You're in the wrong tab. You need to be in the Parameters tab to access the setting. Click the small gear to the left of the name and you will get a window to change the limit.

    513 x 525 - 66K
    Post edited by BrianP21361 on
  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    I do appreciate the assistance, but this is why I mentioned I was on the General tab.

    The adjustments for this are not on the parameters tab, they are on the General tab.

    Just so we are all on the same page, here is a screenshot of the parameters tab.

    So when the morph adjustments for an object (not a figure) are on the General tab, is there a way to adjust the min/max?

    250 x 531 - 19K
  • FenricFenric Posts: 351
    edited September 2013

    Unfortunately, I don't have the A4 Long Hair so I can't check it directly.

    As far as I know, Carrara doesn't enforce limits on its own Morph Targets - if you type in 170, it should do whatever horrible thing that would do.

    I wrote a scene command a long time ago to change the min/max limits, but it's never done anything for me. Let me know which system (win/mac - 32/64) and where to send it, I can send it to you to try.

    Post edited by Fenric on
  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    64 bit. 3doutlaw (at) gmail.com, thanks

  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    Unfortunately the script didn't work, so I submitted a ticket. Thanks all for the help!

  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    OK, so my ticket was closed, since "It shouldn't need to be fixed in Carrara since it only affects a very limited set of Content."

    I am able to replicate this on any "prop" that has a morph which has a +/- morph adjustment (i.e. in/out, up/down, front/back, etc) Seems to affect a lot of hair props, since hair can adjust both ways.

    I attached an example I submitted.

    Anyway, does anyone have a workaround for this?

    1371 x 826 - 263K
  • evilproducerevilproducer Posts: 9,040
    edited December 1969

    Those are usually older products that aren't conforming (rigged) in my experience. As Fenric suggested, you can manually type in a value that is greater than the apparent slider maximum. So, if it goes to 1, you can type in 2 or 4 or even more. You should even be able to type in the decimal values, such as 1.2 or 5.6 or whatever.

  • 3dOutlaw3dOutlaw Posts: 2,470
    edited December 1969

    Hmmm...I just re-tried it, and typing in works. I am flabbergasted. I tried it back in post #1 ("I can type in -1, but no effect in C85"), and it was not working. I wonder if I was running the beta at that point? I guess if you keep pounding that same square peg, it will eventually get round! LOL!

    Oh well, my bad, works! Woohoo!

Sign In or Register to comment.