Major problems with Daz -- [Resolved]

Herald of FireHerald of Fire Posts: 3,504
edited February 2013 in Daz Studio Discussion

For some as yet unknown reason, Reality has failed on me. Completely. Now not only does it fail to load when I call it, but disabling and re-enabling it gave me an access violation error. I also noticed this same issue when I tried to delete the file for reinstallation, as it was considered to be in use.

This is a major setback, and one which I'm left scratching my head about. As far as I can tell, there should have been nothing to cause this problem, but rebooting the PC hasn't helped clear up the trouble, and nor has erasing and replacing the plugin files. I can only assume the problem is with Daz Studio, but I can't figure out what.

Below is an example of the error message I get when trying to enable Reality after I had disabled it through the installed plugins menu. Note that this error ONLY shows up when I enable it, not when I try to access it via normal means. In the latter situation, Daz simply does nothing at all.

Capture.PNG
550 x 523 - 89K
Post edited by Herald of Fire on

Comments

  • JimmyC_2009JimmyC_2009 Posts: 8,891
    edited December 1969

    I don;t know what is happening there. There is a new version of Reality out, Reality 2.5.1.122 , I got an email about it the other day, maybe you could try that.

    I haven't used Reality for a long time, and I have been reinstalling all of my content with the DIM, I got rid of the My Library folder altogether, and I just tried Reality, and it still works for me in 4.5.1.56. Paolo is very good at helping with errors, you could try his website.

    Have you tried uninstalling and reinstalling, and do you also have the Freeimage dll available as well. I think it has to be there for Reality to work.

  • Herald of FireHerald of Fire Posts: 3,504
    edited December 1969

    Well, it seems I've found the problem, but not a solution. Reality doesn't like the Millenium Dragon for some reason, at least one with added normal maps, and gets into an infinite recursive loop loading in the head textures, at least that's what it seems to be given the error message the log file shows.

    Sounds like a major bug to me.

  • Herald of FireHerald of Fire Posts: 3,504
    edited February 2013

    I need to force a re-install of Daz Studio, due to some serious file corruption. However, one of the files damaged was the uninstaller, so the install program is unable to run it and force-quits before re-installing the data.

    What registry settings can I remove to force it to reinstall over the existing files without trying to uninstall?

    Edit: Removed all references to Daz from the registry after backing them up and re-installed. The problem with Reality vanished at the same time. Everything seems as smooth as before.

    Oddly, my virus scanner hasn't picked up any infections, and I had only just closed Reality prior to it failing on me. I still have no idea what the cause of the corruption was, or how it spread to vital files including the uninstaller, but suffice to say it left several important files empty spells (0 bytes in size).

    I'll be keeping a watchful eye over it.

    Post edited by Herald of Fire on
  • SimonJMSimonJM Posts: 5,959
    edited December 1969

    Could you 'just' rename/move the DS uninstaller .exe to forestall the uninstall?

  • Herald of FireHerald of Fire Posts: 3,504
    edited December 1969

    I had tried that and also deleted the entire folder. In the end, it was a registry setting somewhere. Not sure which one, but everything is back to normal for now, so I'm not going to dwell on it. At least I know how to fix it should the issue rear its ugly head once more.

  • mjc1016mjc1016 Posts: 15,001
    edited December 1969

    Ummm...something like that, with unexplained file corruption...grab the manufacturer's diagnostics for your hard drive...and run them. Stuff like that is usually one of the first signs of a failing hard drive.

Sign In or Register to comment.