"Jumping" viewport problem is driving me insane! (EDIT: SOLVED, fix on page 1)

brettnucklesbrettnuckles Posts: 71
edited February 15 in Daz Studio Discussion

EDIT: The original content of this thread is below, BUT I wanted to let everyone know that I have essentially figured out a complete fix in the form of an AutoHotkey script that you can run on your PC. Sorry if the title edit is misleading, it doesn't give you enough space to be very specific. I suppose the glitch is not really "solved" by this script but I consider this workaround to be so good that it's close enough to a solution for me!

This easy-to-install script completely fixes the jumping issue by forcing the mouse to freeze in place for 100 millisecond (0.1 seconds) after whenever you Alt+Right Click or Alt+Left Click in Daz Studio. This basically simulates the action of clicking and pausing for a split second before you move the mouse, which keeps the view from jumping erratically, but which is also exhausting and nearly impossible to do manually every time you want to move the camera around. The script below is only in effect in Daz Studio so it won't affect your other programs you might use. And by the way mouse freeze is basically imperceptible in my opinion -- you will barely even notice, but it's there.

Instructions:

1) Download the program AutoHotkey at https://autohotkey.com
2) Go to your Documents folder on your PC
3) In the Documents folder, select the file Autohotkey.ahk and open it with notepad. If there isn't one there already, create a simple text Notepad document (right click > New > Text Document and name it Autohotkey.ahk.
4) If you use the default viewport controls of Ctrl+Alt+Click to navigate, open the document and paste the following into it:

SetTitleMatchMode, 2

#IfWinActive, ahk_exe dazstudio.exe

~$^!LButton::
blockInput, mouseMove
sleep, 100
blockInput, mouseMoveOff
return

~$^!MButton::
blockInput, mouseMove
sleep, 100
blockInput, mouseMoveOff
return

OR if you're like me and have remapped the viewport controls to Alt+Click instead of Ctrl+Alt+Click for ease of use, use this code insteaad:

SetTitleMatchMode, 2

#IfWinActive, ahk_exe dazstudio.exe

~$!LButton::
blockInput, mouseMove
sleep, 100
blockInput, mouseMoveOff
return

~$!MButton::
blockInput, mouseMove
sleep, 100
blockInput, mouseMoveOff
return

5) Now you want to set it so this script starts automatically whenever you boot up your PC, so do this:

-Hit WindowsKey+R on your keyboard

-Type Shell:Startup into the text field and hit enter.

-Paste your Autohotkey.ahk document in here.

And there you go! Please let me know if anyone has any questions. I am wondering if maybe I should make a new thread to alert everyone to this fix?

Original text of this post below:

----------------------------------------------------------------------------------

 

So I've only been using Daz Studio for about a month, and I love it, but this one weird issue is making the program a nightmare to use. Basically it has to do with the view jerkily "jumping" while I'm panning and rotating around my scene. If I ctrl+alt+click inside the viewport, wait just a moment (like a split second), and THEN move the mouse to rotate or pan, everything works fine. But if I ctrl+alt+click in the viewport and try to move the mouse to rotate/pan WITHOUT waiting a moment, about half the time the view suddenly jerks quickly in the opposite direction from how I am moving my mouse. 

Here's a gif of the problem while attempting to rotate the view. (gif starts with me zooming in on the character). You can see the first leftward rotation works fine, because I move the mouse slowly and deliberately, then release the mouse button. But when I move the cursor back to the right and try to do another leftward rotation (without waiting a moment) then the view suddently JERKS to the right (and weirdly upward over the top of his head as well).

http://i.imgur.com/JAkPFPc.gifv

Here's a gif of the problem while trying to pan (gif starts with me zooming). You can see it's basically the same. The first pan attempt  shows the issue, it results in the view quickly jerking down and to the right, despite the fact that I'm trying to pan the character up and to the left.  The second pan works just fine because I am slower and more deliberate about how I move my mouse.

http://i.imgur.com/eu1fhKH.gif

This issue is INCREDIBLY frustrating, not to mention extremely visually jarring when the view is shifting around in such a jerky motion, and in the opposite direction of my inputs.I tried wiping Daz completely off of my computer and did a fresh install, and I found that I'm having the EXACT same issue. I tried updating my graphics card drivers, that didn't help either. What in the world could be causing this??? 

Post edited by brettnuckles on
«13456

Comments

  • One thing to try is changing the Display Optimisation setting in Edit>Preferences>Interface

  • brettnucklesbrettnuckles Posts: 71
    edited March 2017

    Tried None, Better and Best in the display optimization dropdown -- the issue persists :(

    Thank you for taking the time to comment however!

    Post edited by brettnuckles on
  • I have seen similar effects, I don't know what causes them.

  • I get an effect similar to this after I lock one of the Camera rotation axes and then try to move the camera manually.

  • brettnucklesbrettnuckles Posts: 71
    edited March 2017

    Interesting... It happens even when I don't have a camera in the scene though and I am just looking in perspective view. Hmmm....

    Post edited by brettnuckles on
  • brettnucklesbrettnuckles Posts: 71
    edited March 2017

    So this is interesting. While searching around the forum I found this thread. I seem to be experiencing this exact issue described on page 2 of this thread: http://www.daz3d.com/forums/discussion/36288/daz-studio-4-6-pro-and-mouse-sensitivity-mouse-focus-jumps

    Here's the thing that I'm seeing: 

    "Try this: clear your desktop so you can see the mouse cursor on the left part of the screen. Open DS and resize it to a small window. Now click the controls in the preview window and notice how the cursor jumps to a certain position of the screen every time you click. You can probably figure out the rest for yourself. See picture here:

    http://taosoft.dk/temp/ds_cursor_jump.jpg"

    So weird. My mouse cursor definitely jumps to a specific spot on the screen. I wonder if that's what's causing the issue with the viewport jumps? I don't see any solution in that thread unfortunately...

    Post edited by brettnuckles on
  • You might try replacing mouse if you have a spare.

  • Definitely not the mouse -- I've tried three different mice, one bluetooth, one wireless USB, and one wired USB. I'm getting the same thing. 

    Anyway I just installed a new SSD in my PC so I'm going to try setting up a fresh install of Windows and seeing if the problem persists sometime this week. If that solves it then I'll probably just go ahead with that install of Windows because I REALLY want to use Daz Studio but this is wrecking the experience for me. Thanks for responding everyone!

  • You do not by any chance have the "Clicklock" or "Snap to" options turned on in the mouse settings ? have no idea if it would cause problems, just wild guesses.

     

  • Oh, if you are using win7 hit control alt delete key and bring up Task Manager. Next see if there are any programs in the background using up memory or cpu cycles and turn them off. On laptops I've had something similar happen when I had browser and daz studio fighting over memory and cpu. Just a thought.

  • EsemwyEsemwy Posts: 490

    Are you using optical mice on a glass or otherwise featureless surface? If the laser gets no real feedback from the surface the sensor tends to freak out. 

  • VisuimagVisuimag Posts: 208
    edited October 2017

    Ever solve this issue? I've been having it since 4.8, and although I just deal with it most of the time, it's become a bit of a pain now that more advanced features are available (like Iray Preview Mode and dforce). I can assure anyone asking about Mouse type/system specs that none of those things are the issue, since I've been through at least three full desktop builds that have all suffered from this (and in different versions of Studio - Beta/Pro, 4.8/4.9/4.10 - you name it).

    Post edited by Visuimag on
  • marblemarble Posts: 3,038

    If I'm understading correctly, I've always had this problem (originally on Windows 7, then a Mac, then again on Windows 10). Eventually I decided it must be my wireless mouse so I bought a fairly expensive wired USB mouse. It didn't fix it. After all these years I still get confused about the direction sliders because the mouse often starts moving things in the opposite direction and then corrects if I continue. Instinctively, though, I automatically correct the direction myself before the viewport has had time to get it right which, like this post, ends up in more confusion. 

    Maybe worth noting that if there is something polygon heavy - like fibre hair - on the figure being manipulated, the problem is much worse.

  • Definitely not the mouse -- I've tried three different mice, one bluetooth, one wireless USB, and one wired USB. I'm getting the same thing. 

    Anyway I just installed a new SSD in my PC so I'm going to try setting up a fresh install of Windows and seeing if the problem persists sometime this week. If that solves it then I'll probably just go ahead with that install of Windows because I REALLY want to use Daz Studio but this is wrecking the experience for me. Thanks for responding everyone!

     

    I'm have this problem too. It must be a bug. Did you find a fix? Every time I click on the zoom, or rotate in the upper right conrner to move my scene around, the view port suddenly jumps placing my character off to the extreme side and I have to line it up again. 

  • jason.lin22jason.lin22 Posts: 92
    edited November 2017

    Definitely not the mouse -- I've tried three different mice, one bluetooth, one wireless USB, and one wired USB. I'm getting the same thing. 

    Anyway I just installed a new SSD in my PC so I'm going to try setting up a fresh install of Windows and seeing if the problem persists sometime this week. If that solves it then I'll probably just go ahead with that install of Windows because I REALLY want to use Daz Studio but this is wrecking the experience for me. Thanks for responding everyone!

     

    I'm have this problem too. It must be a bug. Did you find a fix? Every time I click on the zoom, or rotate icon in the upper right corner to move my scene around, the view port suddenly jumps placing my character off to the extreme side and I have to line it up again. 

     

    Post edited by jason.lin22 on
  • This is an unresolved problem made worse with Windows 10 creator fall update. Some one had success by rolling back this update.
  • rames44rames44 Posts: 164

    I've found that it helps to depress the mouse, hesitate and then move the mouse.  Feels like it allows Daz to catch up with the initial position of the mouse so that it then processes the deltas correctly.

  • VisuimagVisuimag Posts: 208

     

    rames44 said:

    I've found that it helps to depress the mouse, hesitate and then move the mouse.  Feels like it allows Daz to catch up with the initial position of the mouse so that it then processes the deltas correctly.

    I have too, but it's still a major inconvenience, especially when you're trying to do some quick changes to a character (particularly Posing).

  • rames44rames44 Posts: 164

    Oh, no argument there...

  • jason.lin22jason.lin22 Posts: 92
    edited December 2017
    Visuimag said:

     

    rames44 said:

    I've found that it helps to depress the mouse, hesitate and then move the mouse.  Feels like it allows Daz to catch up with the initial position of the mouse so that it then processes the deltas correctly.

    I have too, but it's still a major inconvenience, especially when you're trying to do some quick changes to a character (particularly Posing).

    I installed Daz Studio Ver 4.10, but the bug still exists. If you click a couple of times on either the magnify or move icon it will cause the scene to jump  (Here is a video demonstarting this https://jasonF22yahoo.tinytake.com/sf/MjE2NjUwMl82NzQ1ODg4 ) I also added some pictures explaining the issue as well. This makes it very difficult to set up scenes or for posing. Where do I report this bug at?

    I'm using Windows 10, 64 Bit, with two EVGA GTX 1080 Ti's, and AMD Threadripper 12 core

    Move Icon Bug.png
    1067 x 912 - 287K
    Magnify Icon Bug Jump to right.png
    1045 x 945 - 269K
    Magnify Icon Bug.png
    1120 x 956 - 315K
    Magnify Icon Bug Scene Jumps Back.png
    1023 x 928 - 213K
    Post edited by jason.lin22 on
  • Visuimag said:
    I'm using Windows 10, 64 Bit, with two EVGA GTX 1080 Ti's, and AMD Threadripper 12 core

    Great rig!  Even that can't cure the jumpy viewport.  I have the same problem with my cheap laptop.

  • nonesuch00nonesuch00 Posts: 9,497

    Well it's definately became a worse problem. It's like the event handler code in DAZ Studio is now too busy to handle events properly. I guess more DAZ Studio features equals a longer time to check them in the event handler loop.

  • jason.lin22jason.lin22 Posts: 92
    edited December 2017
    Fletcher said:
    Visuimag said:
    I'm using Windows 10, 64 Bit, with two EVGA GTX 1080 Ti's, and AMD Threadripper 12 core

    Great rig!  Even that can't cure the jumpy viewport.  I have the same problem with my cheap laptop.

     

    Thanks! It cost a lot and I'm in debt because of it, but it works ok. I'm hoping to use it with Daz professionally but all these bugs are really slowing me down.

    So it must be a bug then, and not hardware related.

    There is a third bug to add to this. The rotator cube also quickly and randomly jumps to this one position looking from under the character, it happens to me constantly (See the video, it demonstrates what’s happening https://jasonF22yahoo.tinytake.com/sf/MjE2ODk1MF82NzUxNzE1

    Bug 3, Cube Scene Jump.png
    1012 x 924 - 243K
    Bug 3 Scene Jumped after clicked.png
    1010 x 912 - 186K
    Post edited by jason.lin22 on
  • Well it's definately became a worse problem. It's like the event handler code in DAZ Studio is now too busy to handle events properly. I guess more DAZ Studio features equals a longer time to check them in the event handler loop.

     

    I submitted a tech support ticket with a bug report to Daz, hopefully they will fix it soon.

    Recently I have been steadily buying at least 200 to 500 dollars plus in content a month, and pay for a monthly Platinum Club subscription. If that's not worth enough to get a simple bug fix I will be very disappointed. So I sure hope Daz doesn’t let us down and say or do nothing and fixes this issue.

  • jestmartjestmart Posts: 3,496

    It is hard to fix a bug that only a small percentage of users are experiencing.  Try closing the Aux Viewport pane.

  • jestmart said:

    It is hard to fix a bug that only a small percentage of users are experiencing.  Try closing the Aux Viewport pane.

     

    Thanks I tried that, but it didnt work. Here is video of me closing the Aux Viewport and demonstarting all three bugs still happening. https://jasonF22yahoo.tinytake.com/sf/MjE3MzI1MF82NzYxNDc2

  • FletcherFletcher Posts: 63
    edited December 2017
    Fletcher said:
    Visuimag said:
    I'm using Windows 10, 64 Bit, with two EVGA GTX 1080 Ti's, and AMD Threadripper 12 core

    Great rig!  Even that can't cure the jumpy viewport.  I have the same problem with my cheap laptop.

     

    Thanks! It cost a lot and I'm in debt because of it, but it works ok. I'm hoping to use it with Daz professionally but all these bugs are really slowing me down.

    So it must be a bug then, and not hardware related.

    There is a third bug to add to this. The rotator cube also quickly and randomly jumps to this one position looking from under the character, it happens to me constantly (See the video, it demonstrates what’s happening https://jasonF22yahoo.tinytake.com/sf/MjE2ODk1MF82NzUxNzE1

    Post edited by Fletcher on
  • The jumpy rotating cube is all part of the problem. This is the most irritating one since I use it the most.
  • What security software are you using? Have you updated your driver for your pointing device? Apparently conflicts, or anything else that interupts the communication between pointer, the OS, and an application, can cause issues like this. It isn't affecting all users so that does suggest there is at least one other factor involved.

  • jason.lin22jason.lin22 Posts: 92
    edited December 2017

    What security software are you using? Have you updated your driver for your pointing device? Apparently conflicts, or anything else that interupts the communication between pointer, the OS, and an application, can cause issues like this. It isn't affecting all users so that does suggest there is at least one other factor involved.

    I only use the default Windows Defender for Windows 10 Pro 64 Bit, and it's a recent OS install with all the latest updates, and every setting is at default.

    The Daz 4.10 is a clean install with all the default settings too. I also reinstalled Daz many times both manually and from DIM to see if it had any effect. And also tried a deep uninstall where you remove all the left over files and stored settings from the previous install (Described here: https://direct.daz3d.com/forums/discussion/102906/how-to-do-a-deep-uninstall-of-daz-and-daz-im ) And the problems still remains.

    Checked my mouse drivers and all are up to date. Tested a range of settings by moving my Mouse Properties “Double-click speed" slider form slow to fast and 'Lines to scroll" in the setting panel from high to low and I still get the same problem.

    The viewport problem happens consistently when using a character like Genesis 3 or Genesis 8, and happens less frequently when using something like a small prop.           Also confirmed all three bugs and issues happens when using the viewport shortcut keys “Ctrl + Alt” with mouse as well.

    This jumpy viewport problem was also happening in Daz 4.9 version too. I was hoping when I updated to 4.10 it would go away but it has not.

    Post edited by jason.lin22 on
Sign In or Register to comment.