Poser pro 2014 crashes on Windows 10

marchell0023marchell0023 Posts: 25
edited October 2016 in Poser Discussion

Hello. I got this problem a while ago, when I try to open it, it shows "poser pro 2014 executable file has stopped working".

My system is Windows 10 Pro(x64), and I have tried every solutions I can find, and none of them works.

I've changed the poser.ini to "LIBRARY_IS_AIR 1", I re-installed the Poser content, however I can't uninstall the update KB3132372, because I couldn't find it. I've uninstall evey update that I can uninstall, hidden them with  "Show or Hide update trouble shooter", and I still got the same problem.

I'm really desperate right now, I will be very grateful if someone can help me fix it.

 

Post edited by marchell0023 on

Comments

  • I am absolutely no expert on Poser.  Your thread title mentions Poser Pro 2016 and the error message refers to Poser Pro 2014.

    I understand that the Game Dev upgrade to Poser Pro 2014 (and Poser 11 and 11 Pro) are all designed to expire after a period of not being used.

    There is a way to disable this and prevent it from happenning - it seems to me to be an awful feature to include in paid-for software and really puts me off upgrading.

    If this is not the problem then I'm afraid I don't know what else it it can be.  A Windows upgrade?  Drivers update?  It seems you've checked all these. 

  • Ah, sorry I mean Poser pro 2014, not 2016. It's a typo.

  • MorkonanMorkonan Posts: 215
    edited October 2016

    I don't have Win 10, so some suggestions may not apply and I may not be able to help you with certain OS tasks.

    First, make sure that no other executables of Poser are running. Typically, "Poser.exe" but I think it also runs a couple of others. To be safe, just do a clean reboot if you don't know how to check to be sure there aren't any orphaned processes running.

    Is this a brand new install? If so, did you install everything? Check with the SM Installer app to be sure everything is installed and all patches are applied.

    If it's not a brand new install, then I'd first suggest that you delete all of your preferences files. This will reset Poser back to its factory-installed default state. You'll lose any custom UI changes and will have to re-associate your content directory, but other than that it's fine. Here are all the "preferences" files that I would recommend removing. "Cut" them from their directories and "Paste" them into a directory were you can later copy them back over if you'd like to troubleshoot the issue and restore some of your settings. (I'd recommend just pasting them there and working from scratch if you get Poser up-and-running.)

    The files Smith Micro recommends deleting to restore factory defaults, and clear up some issues, can be found here along with their locations: https://support.smithmicro.com/customer/portal/articles/1982174-solving-weird-issues-with-poser-by-removing-the-preferences I will list them below:

    Poser Prefs(MAC)/Poser.ini(WIN)
    LibraryPrefs.xml
    Poser UI Prefsxxxxx.xml

    However, I would also recommend deleting (cut/paste somewhere) some others:

    PoserUI *x*.xml (custom resolution UI settings), LibraryState.xml (contains your library display prefs) and the RenderFirefly.cfg (or any other Render*.cfg currently generated) and the preferredstate.pz3 file, which is the customized prefered pz file scene loaded when you start Poser, if you've made one besides the default "Andy" scene. (Taken from my post, here: http://www.daz3d.com/forums/discussion/106366/poser-10-library-pane-error#latest )

    All of these will be regenerated once Poser starts up.

    That should return Poser to its default state. If so, run it, re-associate any non-default content directories, load up something with textures/mats on it, and do a test render. Then, close Poser, wait for a few seconds (It takes a few seconds for Poser to fully close its processes, depending upon the computer.) and then restart it to see if it restarts appropriately.

    In the thread linked above, there are some notes I made on some Win10 updates that could effect Poser. I see you wrote that you had attempted rollbacks/removals of some updates. That shouldn't be necessary, but I wouldn't know much about Win10.

    Make sure that Poser has access to the Port Settings it needs. A lot of users will reaction-click off of that warning when it comes up for the first time. However, Poser, like many programs, uses those Ports internally, only, in order to help organize all of its required tasks - I will not try to gain internet access unless you specifically tell it to. Poser even uses the Installer/Updater app to check for updates, not from within the program, itself.

    If you have denied Poser access to the ports it needs when the warning pops up, then you'll need to give it permission to access those ports through either your Anti-virus software or Windows Firewall or both, depending upon any third-party AV/Firewall software. If you've recently updated the program, Win10 or your anti-virus/firewall software, you may have to reconfigure them. IIRC, Poser requires both TCP and UDP permissions. Can't recall the ports used, offhand, but it's safe. Also, the Que Manager will likely require its own firewall settings.

    If Poser can't get adequate read/write permissions to necessary directories, which is often a problem with many programs in Win10, it could cause it to hang. For instance, if it can't even write to or read the default content directories, it may just stop working. It may also stop working if, for example, it can't read a custom starting scene you've created or there's a customized Menu item that is supposed to load, but won't. (Like with a Reality renderer install, but that uUsually gives a script error, though.) You'll have to make sure that Poser has access to the directories it needs to access. Usually, that's accomplished (In Win 7, for instance) by right-clicking on the executable, choosing the "Compatibilty" tab and then selecting the Run as Administrator box. (Doing a "right-click-run-as-administrator" is generally only a one-time permission and may not allow subroutines/companion apps to get to what they need to).

    You may also wish to try running it in compatibility mode for Win 7 to see if that helps.

    Make sure that your AV software is not preventing Poser from running, too. Some AV/Firewall/Anti-Malware software can be very difficult on programs that are as complicated and require so much access to your directory structure/system as Poser.

    The official Poser forums are here: https://forum.smithmicro.com/category/9/poser There's a bunch of knowledgeable types, there. Also, you can contact SM support and search the knowledge base here: https://support.smithmicro.com/

    A thread on a similar issue that might be of use to you: https://forum.smithmicro.com/topic/741/poser-pro-11-executable-file-has-stopped-working

     

     

    Post edited by Morkonan on
  • Thank you so much for such thorough suggest!

    But I already have tried re-install it more than once, and I did clean up all preferences files too. And I have tried disable internet during the whole process, still the same.  The AV software shoudln't be a problem, I only use the windows defender, and it will notice me if it's blocking a program.

    I think the problem is about the OS, not Poser itself. When I first update my Win7 to Win10, the Poser Pro 2014 was working fine, it started to crash after some windows update.

     

     

     

Sign In or Register to comment.