How to prevent part of a geograft following figure morphs?

I've made a geograft that replaces the lower body of G8M (from halfway down the hip to the ground).

I obviously need the part joined at the hip to follow G8M's morphs, but I also need anything below that to NOT follow the morphs (as it causes weird distortion). So not following the leg/feet morphs (or those parts of FBMs).

I have a feeling it's to do with rigid-follow nodes but I can't figure out how to make it work.

Is there a tutorial (or a nice simple step-by-step answer) that can help me?

Cheers,
SW smiley

Comments

  • Richard HaseltineRichard Haseltine Posts: 64,667

    A Rigidity Group, not Rigid Follow Nodes. Adding a Rigidity Group with the Geometry Editor will stop the selected areas from taking projected morphs, though you can set one or more reference polygons so that it would follow overall changes in sale or the like.

  • Syrus_DanteSyrus_Dante Posts: 983

    The Rigidity Groups are a bit hidden because they can only be created with the Geometry Editor in Vertex Selection mode. GeoGrafting is a very advanced part of Daz Studio and not covered in tutorials but I try to explain what I learned about it. I try to keep this a "nice simple step-by-step answer" you where asking for. I hope this is easy to understand and I wish you the best with your GeoGrafting project.

    1. activate the Geometry Editor, in Face Selection mode select the part of the GeoGraft that should stay completly rigid
    2.  right-click the Viewport and choose Geometry Selection>Convert Selection>Convert to Vertex Selection
    3. open the Tool Settings pane, in Vertex Selection mode you will see the Rigidity Groups, right-click Create Rigidity Group From Selected (can also be accesed by the Viewport right-click menu)
    4. enter a Name for the Group and it gets created, a Rigidity Group consists of Participans and References
    5. the References are optional vertices that try to keep the Participans in the same distance to the hidden host figure surface, to create them I tend to simply press Ctrl+NumpadPlus to grow the selection, press the minus icon behind Participans to get a ring of vertices around and right-click the References group Assign Selected Vertices to Group
    6. once the Rigidity Group is created you have acces to the Rigidity Groups Editor in the Viewport right-click menu Geometry Assignment>Rigidity Group Editor where you can define a reference bone the Rigidity Group should follow with scaling and you can Mask Morphs With Types, the Rigidity Groups Editor settings are a bit of a mystery but I read somwhere that you should have only one axis for scaling set to Primary
    7. now that you have a Rigidity Group based on vertices the transition between the rigid GeoGraft and the morphed figure can be very harsh, to get a smoother shape transition you can switch to the Node Weight Map Brush tool and in the Tool Settings pane there now will be a Unused Map called Rigid, press the Add Map button behind
    8. the Rigid weight map initialy is empty but you should still have the Rigidity Group Face Selection from the Geometry Editor that you can use in the Node Weight Map Brush tool, right-click the viewport Weight Editing>Fill Selected 100%
    9. a good advice is to save the Rigidity Group selection now with a Selection Set in the Geometry Editor Tool Settings pane
    10. next Grow Selection Ctrl+NumpadPlus, remove Rigidity Group selection to get a few faces around your 100% weight map
    11. then back in the Weight Map Brush tool right-click the viewport Weight Editing>Smooth Selected to get a smooth transition in the selected area depending on the smoothing iterations and strength, this Ridgid weight map will help to get a smooth transition between the figure morph and the Rigidity Group
    12. test your GeoGraft by fitting it to the morphed genesis figure, the active morphs gets autogenerated by the time you fit the GeoGraft, if you are not happy with the results and you want to further tweak the Rigid Weights or try different Rigidity Group Editor settings, unfit the GeoGraft again and choose Edit>Figure>Clear Generated Morphs to get rid of the autogenerated morphs and have new ones created by the next Fit To
    13. maybe also go back to the Geometry Editor in Vertex Selection mode and try different Rigidity Group Participans and References to get decent results, a few less Reference points may be better
    14. you may find that even with the Rigidity Group and the Rigid Weight you can't get a perfect fit, in this case the Generated Morphs from the GeoGraft can serve you as a starting point to export the morph to smooth and tweak it further with a sculpting app like Blender or ZBrush

     

     

  • Silent WinterSilent Winter Posts: 2,687

    Thanks to both of you for the answers :)
    That step by step is perfect Syrus_Dante - thanks for the time and effort yes

    I'm used to using the geometry editor, but I'd never have guessed I'd need to select the verts instead of the polys - it all makes sense now!

    I'll give this a go at weekend.

    Thanks again,
    SW

  • Silent WinterSilent Winter Posts: 2,687

    Worked perfectly - thanks again :) :)

  • Silent WinterSilent Winter Posts: 2,687

    Ok - now I have a related problem:

    I have a geograft 'armoured helmet' (is best I can describe it) - It's attached to the head and has solid-metal with eye-slits over the face (obviously I need that to not deform much). I can do the rigidity group as above, but then that part seems to stick in place - if I add a morph to the figure that makes it taller, the top of the helmet (not in the rigidy group) goes up but the face-plate stays where it is (stretching the mesh).

    Any ideas? It's fitted to and parented to the head. The follow-group can reference the head bone or not with no change.

  • Syrus_DanteSyrus_Dante Posts: 983
    edited May 2019

    Maybe it is not the best idea to create a geograft 'armoured helmet'. How do you want a solid-metal helmet adapt to a character shape? I would parent the helmet to the head and then scale it until the head fits inside. OK I guess its some creature head shape that the helmet isn't inteded to fit to. In this case you could also use a 3D sculpting app to create a fitting morph.

    Otherwise to fix the issue you have, I would have a second look at the Rigidity Groups Editor settings and also at the morph that makes the figure taller. I don't know maybe you need to unfit the geograft once before the altered Rigidity Groups Editor settings gets applied. There may be an issue with the taller morph itself that it dosn't adjust the head bone - hint Joint Editor: Adjust Rigging to Shape.

    Unfit the helmet and in the Parameters pane find the generated "autofollow" morph that makes the figure taller and turn it up manualy to see if there are distortions. And don't forget you have to Clear Generated Morphs everytime you've adjusted the settings. I also had situations where the Clear Generated Morphs for some reason didn't work and I had to delete the generated morphs manualy.

    Maybe also have a second look at the Geometry Editor - Rigidity Group: References. For the References in this case I would select maybe only two vertices somewhere on the forehead area of the helmet and see if your "face-plate" Rigidity Group follows that. With the vertices marked as References you basicly pin the Participans in the Rigidity Group to follow the shape of the "host" figure in this case the forehead of the genesis figure. It could be practical to add almost all the rest of the helmet to the Participansnot just the face-plate. Otherwise I have no idea why this shouldn't work.

    Post edited by Syrus_Dante on
  • Silent WinterSilent Winter Posts: 2,687

    Thanks - I'll give that a try :)

Sign In or Register to comment.