Stretching Studio Across Multiple Monitors

When I first set my new system up with two monitors, I wanted to stretch Sudio across both screens.  So, I undocked the Viewport and slid it over to the second screen.  I also have my system set up to shut the monitors off after 5 minutes primarly so I can sleep in the same room while it renders for five hours.  At first, everything worked fine.  Recently, though, when the monitors shut off and I wake them back up again, the viewport and main app are shuffled to one monitor so that I have to reposition them.  Is this a recent Windows or Nvidia update doing this?  Has it happened to anyone else?  Am I doomed to just turning off the monitors by the power button when I want dark like some kind of bloody savage?

For reference, I'm using Windows 10, Studio 4.11 Beta, a geForce 1070ti, and an Intel UHD 630.  I thought about plugging both monitors into one card, but both monitors are HDMI only and neither GPU has two HDMI ports.

Comments

  • eshaesha Posts: 2,461

    I also have DS stretched over 2 monitors. It works fine for me. But I do not use a timed shutoff; it would drive me crazy if the screens went dark while I'm waiting on a dForce sim or a render. When I leave my desk for a longer stretch of time I switch off the monitor hardware. I've plugged them into a remote-controlled plug so I only need to press one button, and only once or twice a day because the rest of the time I'm working anyway.

    But it might be a Win 10 bug. I've certainly seen a lot of weird things since I switched to Win 10.

  • Griffin AvidGriffin Avid Posts: 2,897

    Am I doomed to just turning off the monitors by the power button when I want dark like some kind of bloody savage?

    I've never used any other method. I don't like ANYTHING going to sleep when my computer is working. 

     

  • QuasarQuasar Posts: 94
    edited January 5

    Ever since I've had my current PC, I have had the same problem with my duel monitor setup. Every time my monitors go to sleep, the computer acts as if one (or maybe both) of them was disconnected and moves everything on the second monitor to the main monitor. It is so annoying that I turned off the monitor sleep timer. Instead, I set up the screen saver to go on blank. That's the best and only solution I've found after searching the internet many times. Unfortunately, that solution doesn't turn off the monitors' back lights so they still give off some glow light. This doesn't happen very often when the computer itself goes to sleep but once in a while that triggers it too.

    What type of connectors do you have on your card and your monitors? 

    Post edited by Quasar on
  • JeffGJeffG Posts: 85

    Windows 7, 1080 Ti, three moniters. No problems.

  • kyoto kidkyoto kid Posts: 30,109
    edited January 5

    ...W7 here and two monitors. One for just the viewport and render settings tab, with the other for the tabs I frequently use. 

    Post edited by kyoto kid on
  • outrider42outrider42 Posts: 1,558

    You could test if this happens to other apps besides DS. But it sounds like it is related to the sleep state.

    Slightly less related, but how about a single 5120x1440 monitor? That is equal to two 1440p monitors. https://wccftech.com/samsung-crg9-49-ultrawide-gaming-monitor/

  • LosingSignalLosingSignal Posts: 353
    Quasar said:

    What type of connectors do you have on your card and your monitors? 

    My Nvidia card has an HDMi port, a DVI port, and what looks like three DisplayPorts.  The onboard Intel chip has 1 HDMi port and what looks like a USB video port.  Windows 10 is mentioning something about a wireless display, so I suppose I could use Bluetooth, as well.  The monitors, unfortunately, have 1 HDMi and 1 VGA port each (went cheap on those guys to score the 27" size).  I could shell out for two new monitors with DisplayPorts, but at that price, I'd rather pick up a second Nvidia card.

  • Griffin AvidGriffin Avid Posts: 2,897

    I don't think it has anything to do with your connectors/connections.

    It's your SLEEP settings. Windows is obviously losing the awareness of your two monitors and switching the config to just one.

    Stop with the sleeping monitors and manually turn them off when not is use for long periods.

  • nicsttnicstt Posts: 7,928

    I use the Aux Viewport on one of the other monitors; other than that I have everything on the same monitor.

    I never have issues; What Griffin Avid said is likely/possibly the issue.

  • kyoto kidkyoto kid Posts: 30,109

    You could test if this happens to other apps besides DS. But it sounds like it is related to the sleep state.

    Slightly less related, but how about a single 5120x1440 monitor? That is equal to two 1440p monitors. https://wccftech.com/samsung-crg9-49-ultrawide-gaming-monitor/

    ...no pricing yet, but I suspect it would cost more than two 1440p displays, even more than two 1080p ones.  Also I read somewhere that curved monitors, while great for cinematic video viewing and games, tend to have a distortion issue towards the edges when running production oriented software.

  • NorthOf45NorthOf45 Posts: 822
    Quasar said:

    What type of connectors do you have on your card and your monitors? 

    My Nvidia card has an HDMi port, a DVI port, and what looks like three DisplayPorts.  The onboard Intel chip has 1 HDMi port and what looks like a USB video port.  Windows 10 is mentioning something about a wireless display, so I suppose I could use Bluetooth, as well.  The monitors, unfortunately, have 1 HDMi and 1 VGA port each (went cheap on those guys to score the 27" size).  I could shell out for two new monitors with DisplayPorts, but at that price, I'd rather pick up a second Nvidia card.

    I got two 27" monitors at a price I could not pass up, and they also only had HDMI and VGA (who uses VGA these days?). Anyway, there's an adapter for Display Port to HDMI, for about $20, less if you hunt around. Just a passive dongle with a Display Port plug on one side and an HDMI socket on the other. Cheaper than (more) new DP monitors, and never had a problem with them going to sleep.

  • ArtiniArtini Posts: 3,707
    edited January 7

    What are the resolution of your screens?

    I have seen similar behavior, when one of the screens was Full HD and the second was 4K.

    After replacing Full HD screen with 2.5K everything is back to normal (but it was on Windows 8.1).

    And yes, it even works when the screens go to sleep and then, wake up.

     

    Post edited by Artini on
  • ChezjuanChezjuan Posts: 302

    I have the same DAZ setup (viewport on a different monitor) and my system exhibits the same behavior. I currently am using the built-in Intel to drive the 2 smaller monitors, and my 1070 to drive my 4k monitor (where I keep the viewport). I do this so I can disconnect the 4k monitor to give the 1070 as much Vram as possible for a render if needed (It usually goes from about 650 MB used when it is running the display to about 250 MB used when I do this since Windows always reserves some VRAM).

    When they sleep, everything jumps to one monitor. This also happened when I was only using the 1070 to drive all of the monitors. It happens with other programs as well. I believe that what happens is that all the monitors don't sleep at the exact same time, and Windows moves the items from the first one to sleep to an active monitor. This is probably to combat the issue that can happen when disconnecting a monitor where windows that were on that monitor would not move and then basically be inacessible until you manually move it with the shift-right click trick.

    I like my monitors to sleep (but I set them to wait an hour), and have gotten used to going to Window ->  Workspace -> Select Layout when they do sleep while I have DAZ open.

  • LosingSignalLosingSignal Posts: 353

    After a bit of digging, I guess this is a long standing Windows problem, stretching back to Windows 7. Windows puts the first monitor to sleep, thinks you disconnected it and forces everything to the other desktop, then sleeps the second monitor. Microsoft apparently has no intention of fixing this problem, so the solution is, as Griffin Avid said, disable sleep and shut the monitors off manually.

    Darn it.

  • Griffin AvidGriffin Avid Posts: 2,897

    The ONLY possible wrinkle I can think of is

    -which monitor is set as your primary.

    When you set up your dual monitors, I wonder if 1 and 2 are reversed and it's the MAIN MONITOR that's going to sleep.

    That could explain why it happens 'sometimes' and since you changed your set up....

    might be worth looking into.

    --

    I've had trouble in the past where the computer wouldn't wake up and I had to hard reboot.

    Plus, lots of programs don't like sleep mode so I never used it - once I started pushing the machines.

  • When I first set my new system up with two monitors, I wanted to stretch Sudio across both screens.  So, I undocked the Viewport and slid it over to the second screen.  I also have my system set up to shut the monitors off after 5 minutes primarly so I can sleep in the same room while it renders for five hours.  At first, everything worked fine.  Recently, though, when the monitors shut off and I wake them back up again, the viewport and main app are shuffled to one monitor so that I have to reposition them.  Is this a recent Windows or Nvidia update doing this?  Has it happened to anyone else?  Am I doomed to just turning off the monitors by the power button when I want dark like some kind of bloody savage?

    For reference, I'm using Windows 10, Studio 4.11 Beta, a geForce 1070ti, and an Intel UHD 630.  I thought about plugging both monitors into one card, but both monitors are HDMI only and neither GPU has two HDMI ports.

    Where you want the main interface to be, needs to be your main monitor. If you want it on your left monitor right click your desktop and choose Display settings. Highlight the monitor you want to be your main monitor. Scroll down and check the tick box that says Make this my main display and close the dialog. This is in Windows 10 Pro. Was similar in Windows 7 Pro as well. Hope this helps.

    Tom

  • Dreamland ModelsDreamland Models Posts: 383
    edited January 8

    In your  power settings you can set your displays to never go to sleep. Same with your computer. That does not mean never turn off, which is separate setting in the same place.

    Tom

    Post edited by Dreamland Models on
Sign In or Register to comment.