Swatting fireflies in iRay renders

I'm having a slight problem with white pixels appearing in several scene, sometimes scattered seemingly at random, sometimes more concentrated. Other scenes render OK, so I'm wondering what might be causing this and how to cure it.

I've tried moving cameras and changing the lighting, tried playing with render and environment settings, but still they persist. Could it be the textures I'm using in this particular scene? Something else?

Removing them in post-processing would be a dreary chore, so I'm hoping there are some general (or specific) tips for reducing fireflies.

Comments

  • y3kmany3kman Posts: 570
    edited August 2017

    Have you tried raising the render quality? I set the render quality to 10 (probably overkill) for my black and white renders. Fireflies are more annoying and visible in those renders.

    I just set the max time to zero, samples to 15000 and convergence to 99%. Then I go do something else while I wait for the render to finish or cancel it if I'm already happy with the image.

    You can also try rendering in a higher resolution and then downscale the image to your desired resolution.

    Post edited by y3kman on
  • Blind OwlBlind Owl Posts: 488

    Thanks. I've tried both methods you suggested--changing the resolution and the render quality--but I'm still getting fireflies.

    Oh, well. Guess I'll have to get out the eyedropper and remove them manually.

    Cheers!

  • fastbike1fastbike1 Posts: 3,109
    edited August 2017

    @Blind Owl

    Do you have the Firefly filter enabled?

    Capture.JPG
    520 x 419 - 43K
    Post edited by fastbike1 on
  • Blind OwlBlind Owl Posts: 488

    I always leave the firefly filter enabled, since I see no reason to turn it off. The problem scene is brightly lit with quite a few white reflective textures, which may be a contributing factor. Still, I've seen other renders that were just as bright and contrasty but showed no signs of fireflies.

    Maybe they were removed in post, or more likely the renders were done at max quality on dual Titan Xs, which I ain't got. *sob* *sniff* sad

  • You, need more light on your figure to get less fireflies. Is the figure or subject outside or inside? If inside make multiple lights to shine on figure or buy ghost lights and use them. If figure or subject is outside use a HDRI and make turn the subject to face the light source.

  • Blind OwlBlind Owl Posts: 488

    It's an outdoor parking lot scene and I'm using the TerraDome 3 skydome for lighting. I've attached a crop (about 1/4) of the original 1920 X 1080 render showing the worst problem areas: the tires & brake disks on the lead bike, and the flecks on the rider's white leathers. The scattered fireflies are easy enough to deal with in post, but I'll probably have to re-texture those problem areas and try again. I can't really change the lighting by much since this is part of a sequence.

    Too bad, because the six Genesis 3 figures in the scene (one offscreen) maxed out my 8-gig 1080 GTX so it handed the job over to the CPU. It was a l-o-o--o n-g time rendering.

    Part of Scene.jpg
    918 x 593 - 88K
  • fastbike1fastbike1 Posts: 3,109

    @Blind Owl "Too bad, because the six Genesis 3 figures in the scene (one offscreen) maxed out my 8-gig 1080 GTX so it handed the job over to the CPU. It was a l-o-o--o n-g time rendering"

    One thing you can try for the figures is to hide the body geometry that can't be seen outside the car or the leathers/helmets. If there is geometry inside the car, that may be worth hiding.

    I would also consider changing / eliminating the rendering SubD on the G3F characters to address the parts that aren't hidden.

  • Blind OwlBlind Owl Posts: 488

    Thanks, fastbike1. Funny you should mention it, because I was just about to load up the scene and try exactly what you're suggesting. smiley

    While I'm at it I'll try different shaders on the leathers, brake disks, and tires. See if that helps at all. I might also try shifting the skydome a little this-way-and-that (i.e. not enough to affect the sequence). If I had known I'd run into this kind of problem, I would have done the sequence in reverse order instead of chronologically. Live & learn...

  • Blind OwlBlind Owl Posts: 488

    Well, I re-shaded this & that, but it turns out the main culprits were the car headlights. Once I deleted those, the blotchy fireflies on the lead bike & rider cleared right up.

    I wonder if something about the Roland's headlight shader is a trifle wonky, but then I know less than nothing about such things.

    ...and yes, simply switching to base resolution allows me to post this while the scene renders yet again. cool

  • fablemanfableman Posts: 16

    Hi.
    (Iam totally noob with Daze3D but.....)

    Have you tried this (I found it after I almoste gave up)

    Render Settings/ Enviroment to Dome and Scene
    And now the important setting that will remove all dots, Set Draw Dome = ON

    Happy rendering...

  • fableman said:

    Hi.
    (Iam totally noob with Daze3D but.....)

    Have you tried this (I found it after I almoste gave up)

    Render Settings/ Enviroment to Dome and Scene
    And now the important setting that will remove all dots, Set Draw Dome = ON

    Happy rendering...

    It actually works! Thanks man!

    It kinda make sense, if you don't set Draw Dome to on, the reflective surface maybe ray traced to some unknown variables causing the firefly.

  • Not sure how old this is, so if it's necro, my appologies, but since I have firefly issues on rare occasion, like today just on the face, I went to see if there was a quick fix I may have missed. I'm pretty seasoned with Iray but as things always pop up and you can't find a fix, well, here I am.

    I was trying to avoid turning on the dome as the light from the HDR is fantastic, but it's not outdoor-suitable to be seen in the render. Normally I'd pipe in a curved background for projecting something more apt, but in this case, only the top left would be visible. 

    At any rate, I'll throw in a few freebie tricks while I'm here. Unless your figure(s) are front and center, having subdivided surfaces won't add much to your render, save your fabrics will have nicer curves and folds if such things are very apparent in your scene. Geometry in general only adds at most, and I'm talking huge scenes like I make, maybe 200mb to your scene data for the video ram. What DOES add up quick is textures. As 4k is pretty standard with our models, and they usually hover around 20mb each, do a quick bit of math =D If one wants to make a big scene and have it fit, mostly, within GPU limitations, head into the Advanced tab in Render settings and lower your compression thresholds to something like 512 low and 1024 high (or if you've got the hardware, double each number). Your render's will still look quite nice and render fairly speedily.

     

  • JonnyRayJonnyRay Posts: 1,540

    One thing that can be sometimes confused is when we say "more light" we really mean "more light coverage". Basically Iray prefers to have light directly hitting surfaces as much as possible. Sure it will bounce light around the room for you, but the more it has to do this the more likely you're going to end up with "fireflies" which are really spots where there isn't any light hitting (or sometimes too much). The more surfaces receive direct light from some sorce, the lest Iray has to depend on light bouncing around enough times to strike the surface of your geometry.

Sign In or Register to comment.