hide spotlight, but still emit light?

mcorrmcorr Posts: 497
edited June 2016 in The Commons

Hello All ... how do I hide a spotlight in front of the camera (so that it won't be rendered), but still have the light from the spotlight emitted?

Thanks

Post edited by mcorr on

Comments

  • KnittingmommyKnittingmommy Posts: 7,789
    edited June 2016

    In Iray, one would turn the opacity cutout of the light (in the surfaces tab) down to something like 0.0001 or some rediculously low number.  I have no idea if it works the same in 3Delight.

     

    edit: to add where cutout opacity is located.  just in case.

    Post edited by Knittingmommy on
  • mcorrmcorr Posts: 497

    I was wondering about that. Thanks! Seems like something Daz should just have a button for.

  • ToborTobor Posts: 2,300

    For a a spotlight you turn off the Render Emitter option. The light disc won't appear, but it will still produce light for the render.

  • mcorrmcorr Posts: 497

    That's awesome ... I thought I tried that, but will try it again. Thanks!!

  • macleanmaclean Posts: 2,249
    Tobor said:

    For a a spotlight you turn off the Render Emitter option. The light disc won't appear, but it will still produce light for the render.

    That only seems to work sporadically for me. It's a 'Now you don't see it, now you do' kind of thing.

  • mcorrmcorr Posts: 497

    I've had the same experience and, therefore, thought I was missing something, or had done something wrong.

  • ToborTobor Posts: 2,300

    The Render Emitter setting will always work as long as the light is in *direct* view of the camera. The emitter will render if in reflection, or when seen through a volume. This is simply how Iray works. If these can't be avoided, you can reduce the spotlight emitter to Point, which makesit very tiny, but then you get harsher shadows.

    For a spotlight, there's no Opacity setting -- this works only for emissive objects.

Sign In or Register to comment.