Strange, but not serious, error message from Hexagon

edited December 1969 in Hexagon Discussion

I occasionally get the following strange Error Message from Hexagon:

"Can't load image from file 'E\3D\buste\buste.jpg': file does not exist."

Dismissing the Error doesn't cause any problems so it doesn't matter but it is odd.

I've never used a placed image in Hexagon or ever had a JPG called "buste.jpg" on my hard disk.

I can always reproduce the Error if I start with a new file and then drag any primitive into into the work area and then delete it. The error message pops up every time.

This happens at work with a Mac running Leopard or at home with my Mac running Mountain Lion.


  • RoygeeRoygee Posts: 2,247
    edited December 1969

    That is an old error from way back. If you use a reference image in the background Hex remembers that every time you open a new scene and wants to load it. Best way to get rid of it is to set the grid to default.

    Possibly at some stage you downloaded a file from somewhere that had that image as a reference and the author didn't reset the grid to default before exporting it?

  • edited December 1969

    Roygee said:
    Best way to get rid of it is to set the grid to default.

    Thanks for that. I still don't know where the file name came from but setting the grid to default has cured the problem.

  • RoygeeRoygee Posts: 2,247
    edited December 1969

    Glad it worked - Hex can get up to some funny tricks!

  • AscaniaAscania Posts: 1,845
    edited December 1969

    Have you recently opened a downloaded .hxn file in Hexagon?

  • edited December 1969

    Ascania said:
    Have you recently opened a downloaded .hxn file in Hexagon?

    Thanks for the clue.

    When you instal Hexagon there are some sample files in a folder called "Models" inside a "Content" folder that installs as well. I opened one called "Alien Face" and the mysterious file name loads with it.

    I opened the same file on Macs at home and at work so that's why I was getting the same error on different Macs.

    Mystery solved!

  • edited September 2012

    Jon-3D said:
    Mystery solved!

    For YOU, maybe... :)

    But for me, it just uncovered one! >:(

    And, once again..."strange".

    I checked my "content\models\character" directory as you described just to see what you were talking about.

    I opened "alien_face.hxn" - and crashed. 8-/

    I tried another model and then another, and all crashed on the same module: frameworkdll.dll

    I then went into all the other subdirectories under models, opening 2 or 3 in each one without any problems.

    I returned to the "characters" directory and tried every single model, and every single one crashed on frameworkdll.dll (Checking my dot net versions, I see I have 2.0, 3.0 and 3.5 installed - should be okay)

    I then did a content search on all files in all subdirectories under the "models" directory for files containing the string "jpg"

    ALL the files, and ONLY those files, in the "characters" directory showed up.

    All but 2 had the string "E:\3D\buste\buste.jpg" in them. The remaining two (quadrangulator and teteronde) referenced "C:\Mes documents\Eovia\envoi\wallpaper17.jpg"

    I even created those directories and stuck a moxnix jpg in them renamed according to the strings above. Then I retried opening the files but they still crashed.

    Not all is lost, though - I've never looked through that directory until now. There's a lot of pretty cheesy crap in there, but a few of them looked interesting for later perusal.

    And to Ascania: KUDOS!!! That was a very intuitive suggestion you gave that turned out to be dead on! :)

    Post edited by emfederin_9bc0c524c8 on
Sign In or Register to comment.