Cannot click on figure body parts -- can only select items from Scene tab

I cannot click on figure body parts in viewport -- can only select items from list of body parts in Scene window. I do not understand why I cannot just point my mouse at a body part and click to select it. Normally, that is what I do. I must have set something by accident. Not sure why this is happening.

Comments

  • You may have switched to a tool that doesn't support node selection - check the Tools menu. The default is the Universal tool.

  • rnollmanrnollman Posts: 113

    Universal tool is selected. I went to render the scene and only the head and hair was rendered. The rest of the body was not. I quit out of Studio and rebuilt the scene - a woman in a dress with hair and the same thing happened. At first I could select individual body parts with the mouse, but when I rendered the scene, I only got the head and not the rest of the body. Then I could not longer select individual parts of the body with the mouse. I had to select it from the Scene tab. Everything was working fine all day and then this happened. I have no clue what is wrong.

  • rnollmanrnollman Posts: 113

    Here is the latest render after exiting Studio, resetting my view to City Limits advanced. Much more of the figure shows up but there are huge gaps.

    GirlInDressRunning_02.PNG
    1920 x 1080 - 2M
  • That's weird. Could you upload a copy of the sceen file, along with a note of the content used?

  • rnollmanrnollman Posts: 113

    Not sure what you mean by the screen file. Do you mean a screenshot of what was in the viewport?

    The content was:

    Genesis 2 Female, Eduardian Suit for Genesis 2 Females/ES Shoes, Tulip Hair

    GirlInDressRunning_03.PNG
    1920 x 1080 - 682K
  • Sorry, I meant scene file.

  • KevinHKevinH Posts: 805

    I'm having this same issue, at least it sounds like it. I added Theo for Genesis 3 Male to a scene. The universal tool is selected, but if I click on an arm or a leg to pose the charcter, the body part does not get selected. The only part of the body that I can select with the universal tool is the head. If I click anywhere else on the figure, nothing gets selected. There is also a chair in the scene. I can select it with the universal tool without any problem. The only way I can pose the figure is to select the body part in the scene list and then use the dials. I haven't tried to render the scene yet as I'm haven't gotten that far. Hopefully body parts won't disappear.

  • KevinHKevinH Posts: 805

    I went back and tried a quick render, but everything is visible. I just can't select any body parts like I normally can in other to pose them other than using the scene list.

  • GlennFGlennF Posts: 81

    Point to the body part then right click. scroll down to select said part.

  • KevinHKevinH Posts: 805

    If I close Daz Studio and then restart and reload the scene, I still can't click on the body parts. I will try what you suggest, GlennF and see if that works.

    But I closed that scene and started fresh. I loaded the same figure and hair and a different chair, but this time everything works normal.

    So I'm baffled about the orignal scene. I thought maybe I had somehow locked most of the body even though I don't know how to do that. But if that was the case, then selecting the leg from the scene list and then turning the dial shouldn't work either, I wouldn't think.

  • LayLo 3DLayLo 3D Posts: 256
    edited March 2016

    I circled a button in red on the image, this icon toggles the ability to select items within the scene. It needs to be clicked so that it changes to look like the icons below it, which should fix your selection problem.

    The icon in blue toggles visibility, right click the "Hip" (circled in green) and select expand from selected. Makes sure all the body parts are set to visible.

    Hope this helps. Best of Luck!

    46268ea70d624d2c6b4ed65554e1d0.png
    1920 x 1080 - 568K
    Post edited by LayLo 3D on
  • KevinHKevinH Posts: 805

    Thanks, LayLo 3D! That fixed my issue. I never even noticed that little check mark beside the pointer. In my scene it was an x next to the figure but everything else had a check mark. When I clicked on it, it switched to a check mark and I was able to select the body parts to pose.

    I must have accidentally clicked on it when I went to expland the figure.

  • rnollmanrnollman Posts: 113

    Unfortunately it did not solve my problem.

  • KevinH said:

    If I close Daz Studio and then restart and reload the scene, I still can't click on the body parts. I will try what you suggest, GlennF and see if that works.

    But I closed that scene and started fresh. I loaded the same figure and hair and a different chair, but this time everything works normal.

    So I'm baffled about the orignal scene. I thought maybe I had somehow locked most of the body even though I don't know how to do that. But if that was the case, then selecting the leg from the scene list and then turning the dial shouldn't work either, I wouldn't think.

    I've had the same thing happen to me, I did the same with the same results - close Daz Studio, re-load the scene same thing.  Start up a new scene, same figures and it's OK.  So the scene gets funked somehow.  I'll have to try what LayLo 3D suggested next time to see if it's that.  I kind of have doubts, because it's not the whole figure, and the location seems off.  I move the mouse around a bunch, trying to click on any body part eventually I'll select some body part.

  • scott762_948aec318ascott762_948aec318a Posts: 824
    edited March 2016
    LayLo 3D said:

    I circled a button in red on the image, this icon toggles the ability to select items within the scene. It needs to be clicked so that it changes to look like the icons below it, which should fix your selection problem.

    The icon in blue toggles visibility, right click the "Hip" (circled in green) and select expand from selected. Makes sure all the body parts are set to visible.

    Hope this helps. Best of Luck!

    Happened to me again.

    That is it!  Thanks LayLo 3D. 

    I have no idea how I apparently clicked on it.  frown

    Post edited by scott762_948aec318a on
  • GlennFGlennF Posts: 81

    This is what I was talking about.Point at body part right click and you should see this box pop up.

    Test.jpg
    591 x 770 - 34K
  • So this has...not been resolved? Daz 4.9. It was all so sudden...

  • So this has...not been resolved? Daz 4.9. It was all so sudden...

    ...and probably doesn't have anything to do with this, it's not a widespread issue as far as I can tell. If you are suffering, please open a support ticket describing your work process to get to the point of an unselectable item (what tool you are using, how you load the content and what content you load0.

  • Try clicking on tool settings active tool: Node Setecion

    Node Selection Mode:

    Node 

    If node selection mode is "Root Node Only" you may have this problem.

  • JQPJQP Posts: 373
    Probably not the issue, but worth mentioning: expand the object's hierarchy in the scene tab and make sure selectability isn't disabled for the parts (i.e., make sure you have a check and not an x next to the parts). I've had weird issues with old saves, or with scripts that manipulate selectability, and sometimes this was the issue.
  • (V4.10 pro) I had this same problem. I found my own cure. The cause was the "Scene Navigator Tool" was active at the top. I changed it to something else i.e: "Translate tool", then body parts became clickable again. And When I clicked them, it auto-selected right part in the scene pane. Hope this solves some people's problem. 

  • RottenhamRottenham Posts: 485
    edited January 1

    This is what I found. Solid Bounding Box shows the unselectable G2 on the left, normal G2 on the right. How did this happen?  Got me!

    select.jpg
    911 x 867 - 55K
    select2.jpg
    1604 x 944 - 69K
    Post edited by Rottenham on
Sign In or Register to comment.