4.9 categories

124»

Comments

  • jodycourjodycour Posts: 107
    MBusch said:

    Thanks for this info this really helped me in my situtation! "Update Meta data then re-import!"

     

    If you created a product, that doesn't match any product in the daz store, then the migration should work and there shouldn't be any issues on updates.  (4.9 prevents you from adding metadata to a product without jumping through some serious hoops.) 

     

    But, this just occurs if you are using DAZ Connect. Is it correct? I am not using DAZ Connect, and get some problems. After reset the database and re-import all my custom and DIM installed metadata, all seems to be working fine. I am getting some problem creating new custom metadata for third party content, but in an inconsistent way.

     

  • SpottedKittySpottedKitty Posts: 5,745

    Migration can take a while, especially since it runs in the background. There is a progress bar on the bottom right.

    Is this progress bar clearly labelled as something to do with the progress of the database migration? Is it clearly written down somewhere (preferably somewhere obvious) that database migration automagically happens on first launch after update to 4.9 and "can take a while"? If the progress bar is anything like the one used for Mesh Smoothing, I keep losing track of that because it's unobvious sitting right at the bottom of the screen where I'm not looking. Could we be seeing a lot of people not realising the migration is chugging along in the background and hasn't finished yet?

  • Migration can take a while, especially since it runs in the background. There is a progress bar on the bottom right.

    Is this progress bar clearly labelled as something to do with the progress of the database migration? Is it clearly written down somewhere (preferably somewhere obvious) that database migration automagically happens on first launch after update to 4.9 and "can take a while"? If the progress bar is anything like the one used for Mesh Smoothing, I keep losing track of that because it's unobvious sitting right at the bottom of the screen where I'm not looking. Could we be seeing a lot of people not realising the migration is chugging along in the background and hasn't finished yet?

    The background progress bar is just that.  In the background.  It is intentionally out of the way...because it's working in the background...not blocking use of the application.

  • Where exactly is this " migration" bar? I never saw a notice to check it to make sure the migration was complete. I would think this would be important to note. Perhaps a lot of the issues are caused by this not finishing and people just put backups back because they think the product doesn't work. Perhaps that happened to me when my categories didn't go in or others are reimporting metadata too soon. Could someone explain where this is and clarify this part of the process. I would assume one should wait until the migration is finished to import metadat if necessary.

  • FixmypcmikeFixmypcmike Posts: 17,300

    The first time you launch DS4.9 it shows up in the Status Bar at the bottom, it says "Migrating xxx of yyy entries" on the left and there's a progress bar to its right.

  • RuphussRuphuss Posts: 2,170

    Where exactly is this " migration" bar? I never saw a notice to check it to make sure the migration was complete. I would think this would be important to note. Perhaps a lot of the issues are caused by this not finishing and people just put backups back because they think the product doesn't work. Perhaps that happened to me when my categories didn't go in or others are reimporting metadata too soon. Could someone explain where this is and clarify this part of the process. I would assume one should wait until the migration is finished to import metadat if necessary.

    its very very tiny

     

  • DAZ_SpookyDAZ_Spooky Posts: 3,100

    Looks like we found a couple things the migration is doing wrong. Working on fixing those.

  • barbultbarbult Posts: 9,242

    Looks like we found a couple things the migration is doing wrong. Working on fixing those.

    Thanks for the status update.

  • 3Ddreamer3Ddreamer Posts: 705

    DRM aside, my biggest problem with 4.9 (from what I am reading on the forum) is it will seriously mess up my workflow categorising my content.

    In 4.8 I download via DIM or other site zip, go into Content Library, categorise my new content (highlighted in Blue) from Poser Format and Daz Studio Format into a Folder per product in my Categories with the base model, and materials folders beneath, etc. Logical to me. Clear the blue highlight. Rinse and repeat. This works for DAZ Content, Other sites content, Freebies, Obj I import and save as DUF files, and clothes I transfer from one generation to another and save.

    From what I am reading I would download via DIM (I don't want my content spread over yet another folder structure). I have to go into Smart Content (which I never use) or Content Library\Products find the new stuff by name, categorise from there. I went into Products for nearly the first time the other night and there is an unholy mess in each folder of every file for that product, and went into Smart Content in 4.8 last night and found pretty much the same. So (currently) I would have to copy the folder, then go into my Categories and make additional folders and then categorise Materials out of the top folder into the Materials folder etc. And I think I read somewhere that 4.9 doesn't do the New=Blue highlight I use all the time.

    I also saw something about not being able to easily move Content and Categories between two computers without logging into Connect each time - not happening. I need to move back a forward as I have a Desktop for Rendering and a Laptop for Setup. I am not downloading separately on two computers and blowing my download limit - went down that road changing over to DIM - never again.

    Originally I was going to install 4.9 last weekend, even backed up my Categories and Content to my external drive in preparation. But reading the forums and people losing their categories, that soon became 'I'm on holiday in 2 weeks...' and I'm currently at 'my Zonealarm licence runs out on my second computer in 2 months’ time.' I may yet get to 'I'll stay with 4.8, however much I would like the Iray and 3DL fixes, because content management isn't working for me'.

    So tell me how I can categorise my content my 4.8 way in 4.9 and I might take the chance on updating an old computer. And move content back and forward between computers seamlessly, I'll suffer logging into Connect once on each but that is it.

  • I'm not following - if you isntall with DIM your workflow should still broadly work, only the new flagging has changed.

  • 3Ddreamer3Ddreamer Posts: 705

    From what I have been reading in 4.9 you catagorise from Content Library\Products and just now I use Daz Studio Formats/Poser Formats, but I am not seeing mention of anyone using that in 4.9.

  • Richard HaseltineRichard Haseltine Posts: 41,928
    edited January 2016

    Both of those still work in 4.9 - it's only Connect-installed content that doesn't appear under the ... Formats headings, you can still use DIM for most things - so far there are only nine encrypted, Connect-only, products.

    Post edited by Richard Haseltine on
  • 3Ddreamer3Ddreamer Posts: 705

    Okay Thanks Richard, that puts my mind to rest a little about catagorising in 4.9.


     Does that apply to transfering content back anf forth between computers too - no change to 4.8 - I saw Daz-Rawb (I think) talk about needing to log in to Connect each time you moved data - that that only applies to Connect-only products that doesn't bother me so much.

  • RuphussRuphuss Posts: 2,170

    what i am realy missing is that you cannot drag and drop a folder from smart content to content librarie

    only items

  • 3Ddreamer3Ddreamer Posts: 705

    I think I'll hold off installing until the new features talked about in another thread come out

  • Just in case this helps anyone here having problems, I couldn't categorize new stuff in 4.9 for a while but I went into content DB maintennance and ran re-import metadata and it mostly fixed the problem. Before I did this I could create new category folders but couldn't put anything in them. After re-importing the metadata I can categorize most stuff OK. The only things I still can't categorize are things that are in a Poser runtime and not in the Studio library.

    I didn't have any problems with the initial migration and I didn't lose my old categories, this only fixed problems with new categories.

     

  • Gr00vusGr00vus Posts: 253

    Given how much stuff I have in my Poser runtimes, that makes 4.9 categories useless to me right now. I hope they can fix that - did you submit a support ticket about this? 

    The only things I still can't categorize are things that are in a Poser runtime and not in the Studio library.

     

     

  • Peter WadePeter Wade Posts: 983
    edited February 2016
    Gr00vus said:

    Given how much stuff I have in my Poser runtimes, that makes 4.9 categories useless to me right now. I hope they can fix that - did you submit a support ticket about this? 

    The only things I still can't categorize are things that are in a Poser runtime and not in the Studio library.

     

     

    I submitted ticket for the original problem and updated it to say the metadata import was a patial fix.

    The stuff in Poser runtimes that I categorized before 4.9 is still there OK, and I only added 5 new Poser products since, and they were all in the same bundle, so I don't know if this is a big enough sample so say it is a problem for all Poser runtime installs.

     

    Latest update, I just categorized a product that is in a Poser runtime. The problem only affects some items in Poser runtimes, I just happened to pick on some that were affected last time. I've no idea why, the one I just categorized I've had for some time, I just never got around to putting it in a category. The ones that failed are things I bought this week.

     

    Yet another update - While most of my original categories migrated to 4.9 OK I did just find a few things that didn't. They are Daz Studio items in a Daz Studio library, the category folders were there but empty, and when I re-categorised them they went back OK. It looks as if most of my old categories are OK but I don't know how many other things may have gone missing.

     

     

    Post edited by Peter Wade on
  • 3Ddreamer said:

    DRM aside, my biggest problem with 4.9 (from what I am reading on the forum) is it will seriously mess up my workflow categorising my content.

    In 4.8 I download via DIM or other site zip, go into Content Library, categorise my new content (highlighted in Blue) from Poser Format and Daz Studio Format into a Folder per product in my Categories with the base model, and materials folders beneath, etc. Logical to me. Clear the blue highlight. Rinse and repeat. This works for DAZ Content, Other sites content, Freebies, Obj I import and save as DUF files, and clothes I transfer from one generation to another and save.

    From what I am reading I would download via DIM (I don't want my content spread over yet another folder structure). I have to go into Smart Content (which I never use) or Content Library\Products find the new stuff by name, categorise from there. I went into Products for nearly the first time the other night and there is an unholy mess in each folder of every file for that product, and went into Smart Content in 4.8 last night and found pretty much the same. So (currently) I would have to copy the folder, then go into my Categories and make additional folders and then categorise Materials out of the top folder into the Materials folder etc. And I think I read somewhere that 4.9 doesn't do the New=Blue highlight I use all the time.

    I also saw something about not being able to easily move Content and Categories between two computers without logging into Connect each time - not happening. I need to move back a forward as I have a Desktop for Rendering and a Laptop for Setup. I am not downloading separately on two computers and blowing my download limit - went down that road changing over to DIM - never again.

    Originally I was going to install 4.9 last weekend, even backed up my Categories and Content to my external drive in preparation. But reading the forums and people losing their categories, that soon became 'I'm on holiday in 2 weeks...' and I'm currently at 'my Zonealarm licence runs out on my second computer in 2 months’ time.' I may yet get to 'I'll stay with 4.8, however much I would like the Iray and 3DL fixes, because content management isn't working for me'.

    So tell me how I can categorise my content my 4.8 way in 4.9 and I might take the chance on updating an old computer. And move content back and forward between computers seamlessly, I'll suffer logging into Connect once on each but that is it.

    That's what I do also and it's all gone.  Generation 5 stuff from Daz & later categorises well by default but any order or poser content is now a real mess.

  • Wouldhe said:

    That's what I do also and it's all gone.  Generation 5 stuff from Daz & later categorises well by default but any order or poser content is now a real mess.

     

    That is why I not planning on updating to 4.9 until I am confident my Categories are safe, and the update will go as seamlessly as all the previous updates. :-(

  • DAZ_SpookyDAZ_Spooky Posts: 3,100

    After looking we discovered that our initial code was based on Coconut. But as everyone knows Coconuts are only found in tropical climes and don't migrate. 

    The next bit of code was based on Swallow, but we later found out that we were using the African and not European version. And African Swallows are non-migratory. 

    We finally found the European Swallow version, so the next build should fix many of the migration issues. 

    In all seriousness, if you have been experiencing a migration issue with your custom categories or other user data and don't have a ticket in, please do so. We will be releasing a new public beta soon that should resolve most of the issues, and we have a script that will force a migration from the 4.8 tables to the 4.9 ones. However if you haven't filed a ticket so we can determine that is indeed the problem you are having, you won't get the script. (Not because we don't want to, but because it fixes a specific problem, but if you don't have that problem it will waste your time. :) ) 

  • barbultbarbult Posts: 9,242

    After looking we discovered that our initial code was based on Coconut. But as everyone knows Coconuts are only found in tropical climes and don't migrate. 

    The next bit of code was based on Swallow, but we later found out that we were using the African and not European version. And African Swallows are non-migratory. 

    We finally found the European Swallow version, so the next build should fix many of the migration issues. 

    In all seriousness, if you have been experiencing a migration issue with your custom categories or other user data and don't have a ticket in, please do so. We will be releasing a new public beta soon that should resolve most of the issues, and we have a script that will force a migration from the 4.8 tables to the 4.9 ones. However if you haven't filed a ticket so we can determine that is indeed the problem you are having, you won't get the script. (Not because we don't want to, but because it fixes a specific problem, but if you don't have that problem it will waste your time. :) ) 

    You gave me your previous script. Do I need to file a new ticket to get the new script?

  • DAZ_SpookyDAZ_Spooky Posts: 3,100
    barbult said:

    After looking we discovered that our initial code was based on Coconut. But as everyone knows Coconuts are only found in tropical climes and don't migrate. 

    The next bit of code was based on Swallow, but we later found out that we were using the African and not European version. And African Swallows are non-migratory. 

    We finally found the European Swallow version, so the next build should fix many of the migration issues. 

    In all seriousness, if you have been experiencing a migration issue with your custom categories or other user data and don't have a ticket in, please do so. We will be releasing a new public beta soon that should resolve most of the issues, and we have a script that will force a migration from the 4.8 tables to the 4.9 ones. However if you haven't filed a ticket so we can determine that is indeed the problem you are having, you won't get the script. (Not because we don't want to, but because it fixes a specific problem, but if you don't have that problem it will waste your time. :) ) 

    You gave me your previous script. Do I need to file a new ticket to get the new script?

    Same script.

     

  • hphoenixhphoenix Posts: 1,168

    After looking we discovered that our initial code was based on Coconut. But as everyone knows Coconuts are only found in tropical climes and don't migrate. 

    The next bit of code was based on Swallow, but we later found out that we were using the African and not European version. And African Swallows are non-migratory. 

    We finally found the European Swallow version, so the next build should fix many of the migration issues. 

    In all seriousness, if you have been experiencing a migration issue with your custom categories or other user data and don't have a ticket in, please do so. We will be releasing a new public beta soon that should resolve most of the issues, and we have a script that will force a migration from the 4.8 tables to the 4.9 ones. However if you haven't filed a ticket so we can determine that is indeed the problem you are having, you won't get the script. (Not because we don't want to, but because it fixes a specific problem, but if you don't have that problem it will waste your time. :) ) 

    Hopefully it's the version of Swallow that doesn't use multiple threads to just carry Coconut as a background process......

     

  • Ahhh, but what's your favorite color?  That's the real question!  :-P

  • This appears to have made no difference.  Have logged a ticket as suggested in case a solution can be found but give the software is free and I didn't back up before to install I can't really complain :D

  • reelyorreelyor Posts: 212

    I just did a database reset per the above suggestions, holding my breath. I then re-imported my Metadat and User_Data1, and Lo and befold, I have my content categorized! Feeling much better about this now.

    Thank you all for your suggestions.

     

  • reelyor said:

    I just did a database reset per the above suggestions, holding my breath. I then re-imported my Metadat and User_Data1, and Lo and befold, I have my content categorized! Feeling much better about this now.

    Thank you all for your suggestions.

     

    Thanks for this - even though i didn't backup befre the upgrade, when I exported the user data could see the categories in the xml so not lost during install.  For anyone as challenged as I am, the steps are:

    1. export user data
    2. reset database
    3. re-import metadata

     

     

  • kitakoredazkitakoredaz Posts: 3,526

    Reset DB means, delete all records once. Carrara 8.5 Pro smart content only see, records for ds 4.8. 

    then Carrara smart content can not find them any more. (though I reset DB ^^;)

     

     

Sign In or Register to comment.