DAZ Studio 4.9 Pro, General Release, Now Available!

11415161719

Comments

  • AndySAndyS Posts: 1,397
    namffuak said:
    AndyS said:

    Against all concerns and all the problems of a big number of customers they now released 4.9.

    I have still open bugs which are not solved since several months.

    Please tell all those customers, whose security system is one of the most popular (ZA) how to get PostgrSQL running.

     

    Thank you

    I'm afraid that is a ZA issue, and you need to thump on them.As it has been an open issue for over 5 years, the feeling is that they just don't care.

    Here's Rob's post on ZA and PostgreS http://www.daz3d.com/forums/discussion/comment/593430/#Comment_593430 - I've done a minor bit of research on this, and (personal opinion here) I think the issue is intentional. I have no idea why, but the problem has been outstanding for years with no fix from the ZA people.

    I already told you, that ZA is aware of it and they proposed a solution.

    http://www.daz3d.com/forums/discussion/71516/postgrsql-za#latest

    And I don't want to ask you, why thoses platforms like facebook, ebay, etc. got hacked but those using ZA aren't.

  • jimmulvaneyjimmulvaney Posts: 338
    edited February 2016

    My biggest issue with the smart content pane is that the way it is categorized is just not intuitive nor is it conducive to my work flow. Since I was pretty much able to define my own categories with the advent of Daz Studio Advanced (name drop) I have gotten very comfortable with a specific layout and flow for finding content. I see how DAZ has it set up and it seems logical at first but not so much in practise. Thanks to my experience with the old school "Dressing Room" tab from way back when, if I was to look for say Sky Princess for Morphing Fantasy Dress. It would look something like this...

    People > Genesis (or Victoria 4.2) > Wardrobe > Morphing Fantasy Dress (I didn't bother to put it in a "Dresses" category since I used it often, Same with the "Basic Wear") > Expansion Pack 2 (for example) > Materials

    Granted it seems like a lot of clicking but what you would have us do is Wardrobe > Dresses > Morphing Fantasy Dress > Expansion Pack 2.. followed by
    Materials > Wardrobe > Morphing Fantasy Dress > Expansion Pack 2. That just seems so redundant and with my setup, you can get both the Dress and the Expansion and the Textures in one forward movement.

    Personally, I would like to see a similar pane to the Smart Content pane that allows us to create our own Categories. Not sure if it works that way now as I have not tried yet but you get the point.

    On a side note, show of hands, who here has completely obliterated and reset their database in order to try and understand the Smart Content pane, and are now not only being distracted by the intricacies and lack of documentation but discouraged from making the art you really want to? Am I the only one? I doubt it. frown

    Post edited by jimmulvaney on
  • FixmypcmikeFixmypcmike Posts: 18,344

    My biggest issue with the smart content pane is that the way it is categorized is just not intuitive nor is it conducive to my work flow. Since I was pretty much able to define my own categories with the advent of Daz Studio Advanced (name drop) I have gotten very comfortable with a specific layout and flow for finding content. I see how DAZ has it set up and it seems logical at first but not so much in practise. Thanks to my experience with the old school "Dressing Room" tab from way back when, if I was to look for say Sky Princess for Morphing Fantasy Dress. It would look something like this...

    People > Genesis (or Victoria 4.2) > Wardrobe > Morphing Fantasy Dress (I didn't bother to put it in a "Dresses" category since I used it often, Same with the "Basic Wear") > Expansion Pack 2 (for example) > Materials

    Granted it seems like a lot of clicking but what you would have us do is Wardrobe > Dresses > Morphing Fantasy Dress > Expansion Pack 2.. followed by
    Materials > Wardrobe > Morphing Fantasy Dress > Expansion Pack 2. That just seems so redundant and with my setup, you can get both the Dress and the Expansion and the Textures in one forward movement.

    Personally, I would like to see a similar pane to the Smart Content pane that allows us to create our own Categories. Not sure if it works that way now as I have not tried yet but you get the point.

    On a side note, show of hands, who here has completely obliterated and reset their database in order to try and understand the Smart Content pane, and are now not only being distracted by the intricacies and lack of documentation but discouraged from making the art you really want to? Am I the only one? I doubt it. frown

    You can still create your own categories -- that's what I do, and my system works better for me that the defult categories.  Smart Content still works with custom categories.

  • jimmulvaneyjimmulvaney Posts: 338
    edited February 2016

    You are right, this does work! when using the Files tab, but with one (or two) caveats... see image. That whole recursive, see everything in the child categories function should be optional. Can you imagine having thousands of objects, not to mention the materials that go with them!? Is there a way to turn that off? That way I can create "favorites" using the empty categories like "Wardrobe" or "Poses". The other thing is finding non-daz content that gets installed via zipped folders. The content library can function exactly as it is, just give us back the new item highlights (Scan known Directories style) please for the love of gawd... crying

    Post edited by jimmulvaney on
  • MydsMyds Posts: 96

    Hmmm, I apologize in advance if this has been addressed.  I tried to skim all 19+ pages for it.  I think I might have a slightly different problem than some.  My user-defined categories show up in 4.9, but they are empty for any products that aren't from the DAZ store.  The worst thing is, I can't always remember what the filenames were to find the content again.  This will likely take several days.  So for example, looking for a set of expressions that the creator didn't name the files in a sensible manner.  The category, which used to be my way of finding them, is empty, leaving me to search for something Ic an't even remember how it was named.

  • edited February 2016

    BUG REPORT: dzApp->getContentMgr()->findFile() does not appear to be working correctly in DAZStudio 4.9 (but it is in DAZStudio 4.8).  For example, the code below returns "".  The walnut.png file is present in C:\Program Files\DAZ 3D\DAZStudio4 Public Build\shaders\iray\resources\walnut.png.

    Thanks

    Paul

     

    png
    png
    walnut error.png
    5K
    walnut error.png
    628 x 37 - 5K
    Post edited by pkinnane_44e978d933 on
  • FixmypcmikeFixmypcmike Posts: 18,344
    Myds said:

    Hmmm, I apologize in advance if this has been addressed.  I tried to skim all 19+ pages for it.  I think I might have a slightly different problem than some.  My user-defined categories show up in 4.9, but they are empty for any products that aren't from the DAZ store.  The worst thing is, I can't always remember what the filenames were to find the content again.  This will likely take several days.  So for example, looking for a set of expressions that the creator didn't name the files in a sensible manner.  The category, which used to be my way of finding them, is empty, leaving me to search for something Ic an't even remember how it was named.

    If you Exported User Data in 4.8, does Re-importing Metadata for the User Data fix the problem?

  • BUG REPORT: dzApp->getContentMgr()->findFile() does not appear to be working correctly in DAZStudio 4.9 (but it is in DAZStudio 4.8).  For example, the code below returns "".  The walnut.png file is present in C:\Program Files\DAZ 3D\DAZStudio4 Public Build\shaders\iray\resources\walnut.png.

    Thanks

    Paul

    Bug reports need to be made via a support ticket, but you might want to post to the DS SDK forum first. http://www.daz3d.com/forums/categories/daz-sdk-developer-discussion

  • linvanchenelinvanchene Posts: 1,303
    edited February 2016

    BUG REPORT: dzApp->getContentMgr()->findFile() does not appear to be working correctly in DAZStudio 4.9 (but it is in DAZStudio 4.8).  For example, the code below returns "".  The walnut.png file is present in C:\Program Files\DAZ 3D\DAZStudio4 Public Build\shaders\iray\resources\walnut.png.

    Thanks

    Paul

    Bug reports need to be made via a support ticket, but you might want to post to the DS SDK forum first. http://www.daz3d.com/forums/categories/daz-sdk-developer-discussion

    As far as I was able to observe

    - an enquiry was made in the daz-sdk-developer-discussion forum

    http://www.daz3d.com/forums/discussion/72624/bug-report-dzapp-getcontentmgr-findfile-not-working#latest

    - a ticket was submitted

    - - -

    Until this is adressed OctaneRender for DAZ Studio plugin users will have to live with the very annoying "bug" that saved scenes load with empty texture slots and corresponding error messages that textures cannot be found.

    As far as I was able to follow the code means the call to ask for the proper path is not answered correctly and instead it is reverted back to the default path.

    - - -

    walnut example:

    C:\Program Files\DAZ 3D\DAZStudio4 Public Build\shaders\iray\resources\walnut.png

    The error message reads:

    Could not find file:

    D:\USERNAME\Documents\DAZ 3D\Studio\My Library\resources\walnut.png

     

    image

    image

    image

    - - -

    vase example:

    The path used for the textures when creating the scene and saving the duf was:
    D:\CG Stuff

    The library name was:
    Connect

    D:\CG Stuff\Connect\

    When loading the scene OcDS was looking for a path that was not used when creating the scene:
    D:\USERNAME\Documents\DAZ 3D\Studio\My Library\

     

    image

    image

    Basically this means all the work you did setting up materials is lost when you load scenes.

    Users were able to confirm that this works fine in DAZ Studio 4.8 and seems to have been changed in one of the DAZ Studio 4.9 builds.

    - - -

    Users have tested what they could from their end.

    Now it is up to the developers to figure out what exactly needs to be adressed where.

    - - -

    USERNAME-Documents-DAZ3D-Studio-My Library v1002.jpg
    527K
    walnut in DAZ3D file structure - saved state.jpg
    451K
    walnut in DAZ3D file structure -missing after loading scene.jpg
    461K
    stone 1 and walnut error.jpg
    483K
    Path CG Stuff - Library Connect.jpg
    440K
    Post edited by linvanchene on
  • Mage 13X13Mage 13X13 Posts: 358

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

  • jimmulvaneyjimmulvaney Posts: 338
    edited March 2016

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    Not a definitive answer, but there are three places you need to be aware of now when installing content. Using the DIM you have download settings where you can define a path, then in DS you have directory listings for DAZ, Poser and Other content, finally with the DAZ Connect it creates it's own library called MY DAZ CONNECT LIBRARY or something like that. Not to mention that the default location for the new version of Studio to install items in is a seperate folder of your documents library. Whre as it used to be under DAZ 3D, now it too is called something like MY DAZ LIBRARY. The first thing I do is check to make sure all of my folders are in order and that all the paths are pointing to them. For example my particular set up is more akin to the old way, the way I got used to it with previos versions..

    ... [user]/Documents/Daz 3D/InstallManager/Downloads
    ... [user]/Documents/Daz 3D/Studio/Content Library/[Runtime]
    ... [user]/Documents/Daz 3D/Studio/My Daz Connect Library

    The only way I was able to get this to work is by installing the DIM and DS 4.9 > changing all of my file paths and settings > then uninstalling both DS and DIM > Reboot > Reinstall both DIM and DS. Now because my settings were already in the registry, it used my settings as if they were the default ones upon installation.

    Post edited by jimmulvaney on
  • FixmypcmikeFixmypcmike Posts: 18,344

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

  • Mage 13X13Mage 13X13 Posts: 358

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

     

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

    OK, thanks for the link. I've posted a detailed comment there explaining my problem, and hope to get an answer I can make use of soon. I do not want to start moving files around in DAZ Studio in order to make them accessible. If I would have to do that, I would uninstall those products and go to the DIM to install them properly.

     

  • inquireinquire Posts: 1,258

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

    Oh, oh. This looks to me like a big mess. It should not be necessary to analyze a program as if I were a writer of computer code or a technical support specialist. Good luck and my admiration to those who are. But I'm going to wait until these these things are fixed and downloading and installing the new version are all that are necesary.

  • inquire said:

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

    Oh, oh. This looks to me like a big mess. It should not be necessary to analyze a program as if I were a writer of computer code or a technical support specialist. Good luck and my admiration to those who are. But I'm going to wait until these these things are fixed and downloading and installing the new version are all that are necesary.

    The big mess already has begun with introduction of DIM. Installation of content should get easier, but IMHO partly it got only more complicated. And Studio 4.9 with its connect is now only a increase of this mess. But I don't care, I stay with Studio 4.8 and definitely I will not upgrade. A product that needs connect is not interesting for me, also not if it would be free. It's my machine and I decide where and how my content will installed and managed. I don't need "features" that make just disorder, instead to be useful. I want to work with a software and not waste my time with fixing problems.

  • KeryaKerya Posts: 10,106
    inquire said:

    My DAZ Connect downloaded content is not showing in the normal Content Library. I am trying to figure out how to tell DAZ Studio where to find it, but have come up with nothing thus far. There are files that cannot be accessed using the Smart Content. Morph INJ/REM files do not show in the Smart Content pane. For Millennium figures I need those files in order to inject the character morphs I wish to use.

    So I am asking how do I get the Content from DAZ Connect to show in the normal Content Library?

    http://www.daz3d.com/forums/discussion/72724/how-to-make-connect-installed-content-show-in-content-library-tab

    Oh, oh. This looks to me like a big mess. It should not be necessary to analyze a program as if I were a writer of computer code or a technical support specialist. Good luck and my admiration to those who are. But I'm going to wait until these these things are fixed and downloading and installing the new version are all that are necesary.

    The big mess already has begun with introduction of DIM. Installation of content should get easier, but IMHO partly it got only more complicated. And Studio 4.9 with its connect is now only a increase of this mess. But I don't care, I stay with Studio 4.8 and definitely I will not upgrade. A product that needs connect is not interesting for me, also not if it would be free. It's my machine and I decide where and how my content will installed and managed. I don't need "features" that make just disorder, instead to be useful. I want to work with a software and not waste my time with fixing problems.

     

    Well ... you can use DS4.9 without ever connecting Connect ...

  • KharmaKharma Posts: 2,888

    Older files don't seem to work well with Connect and Reality 4.2. I installed Helena's tomb with connect but when trying to render with reality it shows in the log report that it can't find the texture files, so I uninstalled through connect and reinstalled with DIM both the DS file and StudioCF file and then Reality rendered it just fine. I don't know how connect installes both files but it doesn't work properly.

  • jimmulvaneyjimmulvaney Posts: 338

    There also seems to be a disconnect (no pun intended) between items available to download via DIM and via Connect. Meaning that when I download something via Connect it shows as uninstalled in the DIM, but not when installed via the DIM. Like I said in several threads before, 4.9 just was NOT READY to be rolled out. At this point I really just want to use the DIM as much as possible, but it is impossible to find files that have no meta data. So I am at an empass and stuck in limbo for the time being. Hey Daz, what ever happened to giving all your content metadata? Looks to me like you just stopped rolling out those updates all together?

    On a side note, how can I go about reinstalling DS 4.6 along side 4.9? and If I categorize everything using 4.6 will I be able to migrate those categories over to 4.9?

  • Mustakettu85Mustakettu85 Posts: 2,709

    Hi everyone,

    I'm sorry if it's been discussed before - but is there a "hot fix" for a situation when all those Postgresql processes refuse to unload themselves from memory after DS has been shut down? Or is it strictly bug report material and can only be dealt with case-by-case?

    I don't know if it's a related issue, but I can't get the encrypted files to install at all, either. Neither by directly downloading from within DS or by using the "offline" method.

  • Silver DolphinSilver Dolphin Posts: 1,351

    Yeah, I've got my trusty 4.8 still and every new 4.9 beta installed side by side so I can play with shiney new stuff while still working with my old non connect workflow. The database and smart content, connect and library is too complicated a animal to get working for so many different styles of use. Daz may have to rethink the content library portion of studio and make it a seperate program all together. That way studio does not break when daz want's to try something new.

  • jimmulvaneyjimmulvaney Posts: 338

    Yeah, I've got my trusty 4.8 still and every new 4.9 beta installed side by side so I can play with shiney new stuff while still working with my old non connect workflow. The database and smart content, connect and library is too complicated a animal to get working for so many different styles of use. Daz may have to rethink the content library portion of studio and make it a seperate program all together. That way studio does not break when daz want's to try something new.

    How can I get 4.8 once I have upgraded to 4.9? I cant find it anywhere. Also, is there anything I have to do differently to have them side by side?

  • Yeah, I've got my trusty 4.8 still and every new 4.9 beta installed side by side so I can play with shiney new stuff while still working with my old non connect workflow. The database and smart content, connect and library is too complicated a animal to get working for so many different styles of use. Daz may have to rethink the content library portion of studio and make it a seperate program all together. That way studio does not break when daz want's to try something new.

    How can I get 4.8 once I have upgraded to 4.9? I cant find it anywhere. Also, is there anything I have to do differently to have them side by side?

    If you didn't back up the installer I'm afraid you can't now get 4.8 - however, if you have downloaded only the betas for 4.9 your main installer should still be 4.8 and you should back it up (and the plug-ins' packages) before downloading 4.9 if you want to keep your options open - though, especially if you've been using PostgreSQL with 4.8, moving to 4.9 should not be problematic.

  • jimmulvaneyjimmulvaney Posts: 338

    So let's say I have a 4.8 installer still, I already used the DIM to upgrade to 4.9, how would I go about getting them side by side? Basically what I want is to install my content via 4.8 (for the scan known directories function) Then transfer those categories I created over to 4.9 because I do have Connect only items to install too. Sorrry if my train of thought derails a bit, I am coping with a flu rigth now.

  • Man, just bought Olympia 7 Pro Bundle (Fantastic prduct by way guys, Thank You!!) and found out in the DIM that DAZ 4.9 is released. I thought that is awesome until I read all the feedback. DRM/Cloud?! Yeah.. I'll hold off on that install button till there is more clarity what is going on here. I read the update notes but as a none tech savvy person I don't see any clear lamen description of DAZ 4.8 vs DAZ 4.9 in terms of DRM/Cloud. That alone is quite worrying.

    Does anyone know where I can get an offline installer for DAZ 4.8?

    Seems only 4.9 is standard now. If I need to re-install my pc because of a crash or something then at least I have a way of getting everything working instead of having to fall in the DRM/Cloud trap.

  • jimmulvaneyjimmulvaney Posts: 338

    I found a place to get 4.8 for Win 32, 64 and Mac OSX. Not pirated, rather a free to download service that DAZ licensed to or partnered with in the past, who just happen to have the download still available. Similar to CNet but not CNet per say. If I can get some moderator permission to post it, I will. Just tell me when and where.

  • inquireinquire Posts: 1,258

    If you can back up a bit, the installer for 4.8 (on a Mac, anyway) is in Users/Shared/DAZ 3D/Install Manager/Downloads. You may be able to re-install 4.8 from that, using DIM.

  • DAZ_RawbDAZ_Rawb Posts: 644

    Man, just bought Olympia 7 Pro Bundle (Fantastic prduct by way guys, Thank You!!) and found out in the DIM that DAZ 4.9 is released. I thought that is awesome until I read all the feedback. DRM/Cloud?! Yeah.. I'll hold off on that install button till there is more clarity what is going on here. I read the update notes but as a none tech savvy person I don't see any clear lamen description of DAZ 4.8 vs DAZ 4.9 in terms of DRM/Cloud. That alone is quite worrying.

    Does anyone know where I can get an offline installer for DAZ 4.8?

    Seems only 4.9 is standard now. If I need to re-install my pc because of a crash or something then at least I have a way of getting everything working instead of having to fall in the DRM/Cloud trap.

    4.9 has many bug fixes, in both the main application, a new version of IRay and a new version of 3Delight. If you never sign in to Daz Connect (which is an improved version of DIM directly in Studio) all of your content will work just like it does in 4.8.

  • KharmaKharma Posts: 2,888
    DAZ_Rawb said:

    Man, just bought Olympia 7 Pro Bundle (Fantastic prduct by way guys, Thank You!!) and found out in the DIM that DAZ 4.9 is released. I thought that is awesome until I read all the feedback. DRM/Cloud?! Yeah.. I'll hold off on that install button till there is more clarity what is going on here. I read the update notes but as a none tech savvy person I don't see any clear lamen description of DAZ 4.8 vs DAZ 4.9 in terms of DRM/Cloud. That alone is quite worrying.

    Does anyone know where I can get an offline installer for DAZ 4.8?

    Seems only 4.9 is standard now. If I need to re-install my pc because of a crash or something then at least I have a way of getting everything working instead of having to fall in the DRM/Cloud trap.

    4.9 has many bug fixes, in both the main application, a new version of IRay and a new version of 3Delight. If you never sign in to Daz Connect (which is an improved version of DIM directly in Studio) all of your content will work just like it does in 4.8.

    I wouldn't say quite yet that Connect is an improved version of DIM, it still has a few kinks to work out,the main one I think is that it cannot install every product properly just yet, and a few other bugs, but it will be once its had all the bugs worked out :)

  • inquireinquire Posts: 1,258
    DAZ_Rawb said:

    4.9 has many bug fixes, in both the main application, a new version of IRay and a new version of 3Delight. If you never sign in to Daz Connect (which is an improved version of DIM directly in Studio) all of your content will work just like it does in 4.8.

    Yes, it has bug fixes, but look at the new bugs which have been introduced. 

  • barbultbarbult Posts: 14,746

    Daz Connect seems to have problems with some scripts. I just installed PD Iray Shader Kit 2 with Daz Connect, and the images that should appear in the LIE Script do not show up in the script interface. I wrote a bug report. I wonder if Daz QA tests to see how products work with Daz Connect before the product is released.

Sign In or Register to comment.