RSSY G8-G9 Hair Converter not working

wildbillnashwildbillnash Posts: 713

Okay, I finally sat down and tried using this program. As usual, the instructions assumes the buyer is knowledgeable in the instructions so it leaves things out.

I tried to convert the Cute Bob hair from my G8 folder. The info the instructions gave left out 'where' to find it. I had to back track the hair and browse to its folder. So, I got the location, I think. As you can see in the pic I found the folder, but the info neglected in telling us to use that folder, or go deeper.The pic shows what I have gotten after 10 minutes of waiting for it to execute.

So, what did I miss?

 

Screenshot (144).png
1920 x 1080 - 594K
Post edited by Richard Haseltine on

Comments

  • crosswindcrosswind Posts: 4,901
    edited April 15

    Is that hair an SBH? IIRC, it cannot convert strand-based hairs... or if there is a sub-node of hair under the "cap node"...

    PS: For using such a hair (esp. a short hair) on G9, you really don't have to use such a script to convert it... Instead, just simply load the hair into the scene, move it to the right position and parent it to the head node of G9.

    Post edited by crosswind on
  • wildbillnashwildbillnash Posts: 713

    Crosswind. I have no idea what kind of hair it is. How can I tell if it's a strand-based hairs? Alsoi, I have done what you suggested and it usually works, except sometimes I don't get the materials easily.

    Ebash..., thanks for the info and link. I'll look into it.

    Thanks to the both of you for your help.

  • crosswindcrosswind Posts: 4,901
    edited April 15

    wildbillnash said:

    Crosswind. I have no idea what kind of hair it is. How can I tell if it's a strand-based hairs? Alsoi, I have done what you suggested and it usually works, except sometimes I don't get the materials easily.

    Ebash..., thanks for the info and link. I'll look into it.

    Thanks to the both of you for your help.

    I checked the product page of Cute Bob hair, it is not a strand-based hair. You can check it in this way:

    In Scene pane, under that "CuteBob_HairCap..." node, there must be a sub hair node. You select that hair node, in Parameters pane, type in "preview" in filter field. If there's nothing filtered out, it's not a strand-based hair, as the example shown in attached screenshot 1. If there's a property "Preview PR Hairs" filtered out, it's a strand-based hair... as shown in screenshot 2 .

    And what do you mean by "don't get the materials easily" ?  If you mean it's not easy to select the parented hair for applying a material preset, you can just easily move the mouse curse to that hair in Viewport, double click on it, you'll get it selected, then apply a material preset as needed.

    SNAG-2024-4-15 006.png
    518 x 1294 - 52K
    SNAG-2024-4-15 007.png
    518 x 1294 - 46K
    Post edited by crosswind on
  • wildbillnashwildbillnash Posts: 713

    Crosswind, what I meant by not getting materials is if I have the 'Filter by Content' checked, then the hair color options don't appear. I have to unckeck it to get to the colors.

    Also, it seems a converted dforce hair won't work, meaning I can't 'Simulate' it.

    I also have a problem with RSSY's clothes converter, but that's for another post.

  • crosswindcrosswind Posts: 4,901

    wildbillnash said:

    Crosswind, what I meant by not getting materials is if I have the 'Filter by Content' checked, then the hair color options don't appear. I have to unckeck it to get to the colors.

    Also, it seems a converted dforce hair won't work, meaning I can't 'Simulate' it.

    I also have a problem with RSSY's clothes converter, but that's for another post.

    In this case, "Filter by Context" is subject to the condition that the hair's Compatibility Base is defined in Compatibilities of each Material Preset, as metadata. There should be no problem when you use the original G3/G8's versions of this hair... while ticking "Filter by Context".

    So, if it doesn't work with Filter by Context when you select the hair cap node, try selecting the sub hair node instead ... see if "Filter by Context" works or not...

  • wildbillnashwildbillnash Posts: 713

    Thanks, Crosswind, I'll try it.

This discussion has been closed.