Please can someone tell me what are "data/auto_adapted/etc/etc/etc" files?

 

This link thoroughly describes how I am missing these files or not getting them apon loading a certain project but not all projects over my network.

http://www.daz3d.com/forums/discussion/66858/fairly-complicated-network-rendering#latest

I can't figure out why these files are needed, and why all the other parts of certain scenes will load over the network, but DS says these "auto_adapted" files are missing.

The item which doesn't load on the network computer but does load perfectly on the original computer, is a part of a Null. Might this be causing the problem? But I have to say there is a Genisis figure which is also part of the null which does load. So?

Again I am trying to load the project over the network on a different computer from the computer it was created on. Most projects load perfectly but not this one. I'm using Macs on DS 4.6

Thanks

Steve

 

Comments

  • mjc1016mjc1016 Posts: 15,001

    Nope...auto_adapted is the folder that houses items that are converted to Daz native format by Studio...all those raw objs, that aren't saved as a prop asset, the cr2, pp2, hr2 (the Poser format files).  They are converted to DS native and stored there.  You either need to copy that folder to the render computer OR make sure it is accessible over the network by it.

  • StevieDStevieD Posts: 103

    Thank you,  I just now noticed that there are some 200 or so files supposedly in the "auto_adapted" folder that the render computer says are missing when I open the scene up.  So I go back to the host computer and open up the project. It opens no problems. Then I did a search for some of the files that the other computer told me are missing. I found that there are 2 "auto_adapted" folders. Both are withing the path that is specified in the the content directory that DS should look for assets. In my other discussion post I stated that I did copy over to the new computer the "auto_adapted" folder but I did the other one not the one that contains those specific missing files BUT I still don't understand why if the "auto_adapted" folders, both of them, are within the same path as the assets, DS doesn't find it.

    I have something else rendering on that machine, So I will try it tomorrow and see what happens. In the mean time, do you think there is something about the "Null" that might cause this problem? Or what is so different about the "auto_adapted" folder from the regular assets that might confuse DS? I'll let you know what happens when I transfer that folder.

    Thanks again

    Steve

  • mjc1016mjc1016 Posts: 15,001

    Not sure why you have 2 folders...can you give the full path to each?

    And the render machine (Windows, right?), you just copied one of the auto_atapted folders?

  • StevieDStevieD Posts: 103

    This is the right one with the missing files

    Macintosh HD/Users/sdinyer/Documents/DAZ 3D/Studio/My Library/Runtime/Libraries/Data/auto_adapted

    This is the other one. none of the files are there but there are other files. This is the one I copied.

    Macintosh HD/Users/sdinyer/Documents/DAZ 3D/Studio/My Library/Data/auto_adapted

    All the machines I am using are Macs.  I may even put in this aditional path in the content manager, even though it is with in the path where Daz assets are specified anyway. I can't do it right now though because I have something rendering, now

    Thanks, Steve

  • StevieD said:
    Macintosh HD/Users/sdinyer/Documents/DAZ 3D/Studio/My Library/Runtime/Libraries/Data/auto_adapted

     Not sure how you managed to do that, but it's wrong. The /data/ folder is a D|S native file format thing, it must never be inside the Poser /Runtime/ folder. The other path is right.

    StevieD said:
    I may even put in this aditional path in the content manager, even though it is with in the path where Daz assets are specified anyway.

    Don't do that — it's called having nested content folders, and it will (not "might", not "could") eventually cause Something Nasty™ to happen. The problem is that D|S won't be able to tell the difference between the two content paths, and things won't load or save reliably.

  • mjc1016mjc1016 Posts: 15,001

    The Runtime/Libraries folder is a Poser format folder and probably shouldn't have a Daz format folder in it...data is a Daz format folder.  The problem is, once Studio finds that upper level data folder, it quits looking, so yes the one in Runtime isn't being found.  It would probably be better to merge the contents of the auto_adapted in the Runtime with the one above it.

    I'll drop a note to one of the Mac gurus and have him check...

  • TotteTotte Posts: 10,355

    OK, 

    Here is ther basic info for network rendring using DAZ Studio, keep it simple.

    - Never use any items that are in the .daz format, never ever. Only use items in .duf or the old poser .cr2/.pp2/.hr2 formats. Use the Poser item but then apply the DS materials is OK.

    I've done this daily since 4.5 came out and the only problems I have is when I accidently use a .daz item, as they have hardcoded autoadapt information in them.

    This is the beauty of the .duf format, it save references internally, not object data.

     

  • StevieDStevieD Posts: 103

    Thanks, everyone for responding. I'm still trying to check out all the advice.  The good news is that all the scenes I have been using lately are .duf files. I have some scenes that I haven't worked on in a while that are saved as .daz but I suspect that they are files that I saved before I installed DS4.6 because I don't consciously save it as anything particularly, I just go to save as scene and “save” the way it defaults. If I go back and work on any of these old files I will make sure they are saved as .duf.  Like I said all of the other scenes I have loaded so far work perfectly but this one is a really complicated scene with many elements and many animations.

    I must admit. I am not a computer person. I have worked with and on computers for many years but I’m not really schooled on the deep workings of these both wonderful and terrible machines.

    As far as file structure, I tend to try not to upset the order of things as already set up, especially things I am unsure of. Chances are that the file order was either like this at some point or was constructed like this within some model or something that I purchased.  At this point, I don’t know enough about the way DS works to either adjust things or fix things when they go wrong.

      I don’t use the Install Manager because I purchase assets from many different places. Not every model, or light, or texture that you can buy every where on the market can be set up for the Install Manager and I want only one way of installing these assets. So as a result, I install everything manually. I put models and things in the directories in the same order that they are presented when you unzip them. They are usually, I assume, in the file order that they need to be and if a certain directory is not present on my computer, I create it as it is given in the package. This is what not enough knowledge will do for you.   So as far the “auto_adapted” folder, I didn’t put that in there. Some how DS must have inserted it that location and as far the project goes DS does find it when on the original machine.  It’s only when I try to open it over the network, does it not find it. That sort of confuses me.

     

    Here’s a question: Many of the scenes I do have merged scenes and with animations. This is how I animate. I animate a model, as it’s own project then bring it in, or merge, with the main scene it will be in. That way I can actually work on it with out system over load to get the animations correct. This is how I do it successfully, I must say, most of the time “on the original machine”.  I might have 20 or more objects/animations going into the final scene and eventually lots more as I get to a more intense phase of my projects.

        This is the first scene however of this type that I am having this “missing file” problem. (again when rendering on a remote machine over the network)  Do you think this might the problem or like I said before the missing files were in a “null” in the scene. Think that might be the problem?

    Thanks for now,      Steve

  • mjc1016mjc1016 Posts: 15,001

    No to both...it's just that for some reason the proper 'auto_adapted' folder isn't being found.  In all likelihood, it's a path problem...some where in the scene file there is an absolute path or something like that.  And if that path is forcing it to look locally, Studio won't even think about looking over a network. 

    My first choice as to what I would do, would be to merge the contents of both auto_adapted folders to the data folder in My Library and then delete the one in the Runtime (of course making a compressed backup of it, first). 

    Of course you could just copy that 'other' one to the render machine...

  • StevieDStevieD Posts: 103

    Thanks. I'll try one or both of those but I can't do it until tomorrow. I'll let you know how it goes.

    Thanks again Steve

  • StevieDStevieD Posts: 103

    YOU,,, MY FRIEND, ARE A GENIOUS!!   I want to thank you so much for getting this.

     Yes, this was exactly what it was. I NEVER would have gotten this. I must tell you that I was nervous deleting the Runtime/Data folder but when I merged the contents of that folder with the DAZ Data folder the project still opened up on my computer, That looked good. Then I went to the Network computer and without doing anything else it just opened up and rendered perfectly.  Seems ok.  I'm not ready to do the animation but It loads up and renders one frame perfectly. I am a happy camper.

    Again thank you for lurking in the forums.

Sign In or Register to comment.