Initial plugin Compile problem with VS 2010 - SOLVED

Finally found a copy of VS2010 Pro. (I of course had up to 2008 then 2012, never had used 2010)
Just trying to get a sample plugin to build so I'll have a working project to start from.

Tried a couple - all fail. Just running the 'A First Plugin' (in release mode since I don't see the debug QT libs, in both 32 bit and 64 bit.) I get: (same result for 32 bit)

1>------ Build started: Project: A First Plugin, Configuration: Release x64 ------
1>Build started 12/3/2015 8:07:42 PM.
1>  Creating "Release\x64\A First Plugin\A First Plugin.unsuccessfulbuild" because "AlwaysCreate" was specified.
1>  Mocing "afirstpluginaction"...
1>  Mocing "afirstplugindlg"...
1>  afirstpluginaction.cpp
1>  afirstplugindlg.cpp
1>  pluginmain.cpp
1>  afirstpluginaction_moc.cpp
1>  afirstplugindlg_moc.cpp
1>  Generating Code...
1>     Creating library ..\..\..\..\..\exec\Release\x64\plugins\sdk_afirstplugin.lib and object ..\..\..\..\..\exec\Release\x64\plugins\sdk_afirstplugin.exp
1>sdk_afirstplugin.exp : warning LNK4070: /OUT:firstplugin.dll directive in .EXP differs from output filename '..\..\..\..\..\exec\Release\x64\plugins\sdk_afirstplugin.dll'; ignoring directive
1>LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt
1>Build FAILED.
1>Time Elapsed 00:00:04.53
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


Further runs just have one difference, since file is already there

1>  Touching "Release\x64\A First Plugin\A First Plugin.unsuccessfulbuild".


Thaniks for any assistance getting started,


Post edited by Greenbriar Studio on


Sign In or Register to comment.