Light rendering

Why don't I see the light effects that I see in the preview when I render?
In the viewport and in the aux viewport you can see the shadows and the play of light but not in the rendering. it is as if there is a general light
Given that in the rendering option:
GENERAL>AUTO HEAD LAMPS I tried to set "when no scene light" and also "never" but I got no changes.

Thanks

Comments

  • felisfelis Posts: 3,854

    Have you removed the environment map, or set it to scene only?

  • Can you explain me better please?
    I'm new and I'm practicing.
    My problem arises when I use in RENDER SETTING>ENGINE>EDITOR> NVIDIA Iray (Mdl)
    If instead I set 3Delight (RSL) the problem is solved.

    Thk Felis

  • A screen shot and a render to comapare (please make sure theya re ToS-compliant) might help us to understand exactly what you are seeing. 3Delight and Iray are different methods to get from the scene to a final image - they take, more-or-less, the same geometry but use very different materials to determine how the surfaces 9and volumes) of thae geometry act and how light behaves.

  • ChoppskiChoppski Posts: 454

    In the camera setting you can also turn headlamp completely off. When I was learning iray, the headlamp often washed things out. Also, by default, I think, there is an hdri file in the environment section of the rendering tab unless you remove it or select Scene Only in the environment tab.

  • Choppski said:

    In the camera setting you can also turn headlamp completely off. When I was learning iray, the headlamp often washed things out. Also, by default, I think, there is an hdri file in the environment section of the rendering tab unless you remove it or select Scene Only in the environment tab.

    The headlamp can be turned off completely in the General section of the Editor tab in Render Settings, no need to do it per camera.

  • Thank you Mr. Richar Haseltine for your support.
    I hope I understood your request correctly.
    Here are the images you requested.

    the first picture was taken with 3delight
    the second is the workspace and the third is IRAY

    I also have these problems:
    1) I can't get items that contain candles to work. These do not emit light despite having the parameters at maximum.

    2) Objects such as mirrors do not reflect images

    Thanks all of you for the help.

    3delight.png
    996 x 683 - 319K
    daz3d.png
    1920 x 1080 - 541K
    iray.png
    996 x 683 - 619K
  • In the Environment group in Render Setings>Editor, or in the environment Settings node's Parameters, make sure that Environment Mode iss et to Scene Only. You will most likely have to adjust the Tone Mapping settings too. At the moment you render in Iray is being flooded with light from the default HDRI or Sun/Sky dome.

Sign In or Register to comment.