Memory allocation failed when rendering in Iray

Hi all,

I'm having an issue with a scene that I'm trying to render.| The scene is fairly simple with a Ultrascenery background and a Gen8 Female on the front on one of the little piers in one of the Ultrascenery sets.

When rendering, I get the message:

2023-02-14 19:56:09.324 [WARNING] :: ..\..\..\..\..\src\pluginsource\DzIrayRender\dzneuraymgr.cpp(369): Iray [FATAL] - API:MEMORY :: Memory allocation failed.
2023-02-14 19:56:10.772 [WARNING] :: ..\..\..\..\..\src\pluginsource\DzIrayRender\dzneuraymgr.cpp(369): Iray [WARNING] - API:DATABASE ::   1.0   API    db   warn : Transaction is released without being committed or aborted. Automatically aborting.

I tried this on 2 computers, one of them using 32 Gigs of RAM that I see go up to about 65% before going down again and using a RTX 4080 with 16 Gigs of Vram.

HW monitor reports max usage of Video Memory  of 17%

Any idea why Daz Studio appears to have issues with this scene? Other scenes render correctly.

Many thanks in advance ;)



  • felisfelis Posts: 2,673

    In Render Settings, is Instance Optimization set to Memory?

  • Thank you Felis, that seems to have done the trick ;)

    It was put to Speed :D

    Now rendering

  • ZelrishZelrish Posts: 18

    I'm running into the exact same issue every time I use dforce hair.

    I just cannot render with those... I keep getting the same error with the exact same log and the memory optimization didn't help in my case. (rtx 3090 24GB VRAM and 32GB DDR5)


  • Richard HaseltineRichard Haseltine Posts: 90,068

    dForce hair can use a lot of memory, deducing segments will help (you can go right down adn use Iray curves instead of segments), as will reducing the hair density.

  • ZelrishZelrish Posts: 18
    edited April 4

    Yeah After some more testing, I'm starting to think the 32GB ram are not enough.

    I thought Daz was supposed to load the scene in the VRAM of the graphics card, but it's only loading like 2GB maybe and the ram seems to spike until all of it is reserved then crashes.

    I will try your suggestion (if I find how it works)

    Post edited by Zelrish on
  • ZelrishZelrish Posts: 18

    So just to confirm. It was really a RAM issue. And my main issue here is that I disabled the pagination file some time ago...

    I reenabled it and the render commited RAM usage spiked to 39.5GB.... I didn't imagine those fiber hair could eat so much of it.

    So the pagination file explains why I ran into the issue now although I did not in the past (with the same amount of RAM)

    Learn stuff everyday

  • PadonePadone Posts: 3,123
    edited April 9

    If the asset doesn't fit your hardware you can ask for refund. This way you also let DAZ and the PA know that some optimization is needed.

    Post edited by Padone on
Sign In or Register to comment.