The Streets of Steampunk and gloss level

I think I understand iRay shader settings, but:

I am trying to make the surfaces wet / reflective

With this model, The Streets of Steampunk, I turn Glossy Reflectivity all the way up to one, Glossy Roughness to 0 and the surfaces still do not seem reflective

Is there something in the shader or render settings I am missing?

test 6 exp at 11 use 13 for dark.jpg
984 x 787 - 389K

Comments

  • crosswindcrosswind Posts: 5,237
    edited February 2023

    It depends on the angle of view and if there's a light that the surface can reflect... If keep using current angle of view, just put a light in the opposite direction, tweak its position and beam angle...

    And glossy reflectivity and roughness etc. need to be furter tweaked. It's already overexposure on the right side...just because you can see those surfaces reflecting a light source

    Post edited by crosswind on
  • StonemasonStonemason Posts: 1,172
    The glossy color might be off, should be white
  • crosswind said:

    It depends on the angle of view and if there's a light that the surface can reflect... If keep using current angle of view, just put a light in the opposite direction, tweak its position and beam angle...

     

    And glossy reflectivity and roughness etc. need to be furter tweaked. It's already overexposure on the right side...just because you can see those surfaces reflecting a light source

    thanks for your reply, not a lighting issue, you should see the wall reflected in the flat pavement, and I turned the exposure up to show the issue, so the overexposure is not what I am looking at

  •  

    Here is a screen shot showing the settings for the pavement, the flat surface as in the circled area in the previous

    Gloss color is white, reflectively set to .54 which should make it pretty reflective, I also tired 1.0 still nothing

    surface shdr settings.jpg
    1920 x 1080 - 588K
  • In this screen shot, I set Reflectivity on the far wall to 1.0 and set a cube next to it

    I would think I would see the cube almost in a mirror

    On a previous try I set the Normal map amount to 0 (off), didn't seem to have any effect

     

    far wall with reflectivity set to 1.0.jpg
    984 x 787 - 739K
  • crosswindcrosswind Posts: 5,237
    edited February 2023

    I roughly did like these:

    The principle and mechanism are all the same, not just in iray ~~ BTW, placing some puddles there might be even better ~

    Post edited by crosswind on
  • crosswind said:

    I roughly did like these:

    The principle and mechanism are all the same, not just in iray ~~ BTW, placing some puddles there thanks might be even better ~

    thanks for trying to help, I appreciate it, still does not look glossy though, if glossy you would see the reflection of the wall in the pavement

  • here is an image I made, the deck has a fairly high glossy roughness and medium low Reflectivity, and you still se quite a bit of reflection, for example the boot of the foreground figure

    2k from front r1.jpg
    2000 x 1600 - 1M
  • crosswindcrosswind Posts: 5,237
    edited February 2023

    That's a pavement with bumps on it, you wanna make it like a mirror ??  Of course you can, but will it be realistic? Unless it's covered by water or frozen sth. like that~~

    Normally 2 types of reflection, specular refl and diffuse refl. This pavement is typically the latter 'cause it's not that glossy in reality. It's not like that deck which does not have a 'bumpy surface' on it.  If you wanna make the pavement much more glossy and reflective, as you said, zero the Normal and Bump values if there's any or sharply decrease them...

    Post edited by crosswind on
  • That is almost what I am looking for, to make it look wet, not quite so smooth of course, I have set reflectivity to 1 and glossy roughness to 0 and deleted the normal map, still not like your image, what am I missing? Is it possible there are settings in Render settings?

    I will model some puddles

     

  • crosswindcrosswind Posts: 5,237
    edited February 2023

    I used default HDRI with 90 degree of Dome Rotation, nothing special ~ I attached the scene file below.

    duf
    duf
    SteamP.duf
    2M
    Post edited by crosswind on
  • Thanks, strange, I will compare tomorrow

  • Have you tried using a ground plane as your reflective surface.

    My settings for this is

    Rendered in Iray,

    Base Mixing, PBR Metallicity/Roughness, set Metallicity to 1.00.

    Glossy color to White, Glossy Reflectivity to 0.87, Cutout opacity to 0.25.

    Image 1.jpg
    1280 x 720 - 389K
  • bdell_53_4baf2b3d9b said:

    Have you tried using a ground plane as your reflective surface.

    My settings for this is

    Rendered in Iray,

    Base Mixing, PBR Metallicity/Roughness, set Metallicity to 1.00.

    Glossy color to White, Glossy Reflectivity to 0.87, Cutout opacity to 0.25.

    yes, I will make some puddles to set on top of the pavement

    why would you set the metallicity to 1?

     

  • Well, this is still not adding up

     

    If I render the file you (crosswinds) sent me, I get exactly the same image

    I turned off the added like, looks the same except removes the specular reflection, looks basically the same

     

    As far as I can tell, you (crosswinds) made 3 changes to the shader values for the pavement:

     

    Glossy layered weight set to 1.0 from .22

    Glossy reflectivity set to 1.0 from .5

    Glossy roughness set to .001 with map from 1.0 with the map

     

    Here is where it gets odd, first experiment:

    The product, Streets of Steampunk, comes with a material setting: Lights On Iray

    If I apply that, and then change those 3 shader settings to crosswinds values I do not get the same look, not as glossy!

     

    Second experiment:

    I save out crosswinds render settings and camera

    I load a fresh instance of Streets of Steampunk

    I render the scene, it is as one expects, not glossy

    I change the settings to crosswinds

    The render is glossier, but like my previous, not like crosswinds

    How can this be?

    cross winds without added light and added iRay w lights and changed values.jpg
    789 x 1052 - 496K
    new - with crosswinds cam and rendersettings - orgnl mats - cmp.jpg
    789 x 1052 - 511K
  • StonemasonStonemason Posts: 1,172
    edited February 2023

    just had a look at this and there's a few things you could do...try turning the normal map strength down,unplug the roughness map. turn up glossy layered weight, turn down glossy roughness...or turn up top coat weight.

    Post edited by Stonemason on
  • mark_z2487 said:

    bdell_53_4baf2b3d9b said:

    Have you tried using a ground plane as your reflective surface.

    My settings for this is

    Rendered in Iray,

    Base Mixing, PBR Metallicity/Roughness, set Metallicity to 1.00.

    Glossy color to White, Glossy Reflectivity to 0.87, Cutout opacity to 0.25.

    yes, I will make some puddles to set on top of the pavement

    why would you set the metallicity to 1?

    Sorry about that, I raise it up to 1 just because I think it looks more glossy and that is usually what I like. When I leave it to low then it just looks like bleached out white ground.

  • crosswindcrosswind Posts: 5,237
    edited February 2023

    mark_z2487 said:

    Well, this is still not adding up

     

    If I render the file you (crosswinds) sent me, I get exactly the same image

    I turned off the added like, looks the same except removes the specular reflection, looks basically the same

     

    As far as I can tell, you (crosswinds) made 3 changes to the shader values for the pavement:

     

    Glossy layered weight set to 1.0 from .22

    Glossy reflectivity set to 1.0 from .5

    Glossy roughness set to .001 with map from 1.0 with the map

     - You missed one... pls double-check lah - Normal Map was set to 0.025...  as we talked about it for times in above post.

     

    Here is where it gets odd, first experiment:

    The product, Streets of Steampunk, comes with a material setting: Lights On Iray

    If I apply that, and then change those 3 shader settings to crosswinds values I do not get the same look, not as glossy!

    - Just in case,  you better save a material preset of  'sopStairs'  from my file first,  then apply it to yours. I believe you'll get the same result.

     

    Second experiment:

    I save out crosswinds render settings and camera

    I load a fresh instance of Streets of Steampunk

    I render the scene, it is as one expects, not glossy

    I change the settings to crosswinds

    The render is glossier, but like my previous, not like crosswinds

    How can this be?

    - Still,  should save Render Settings preset, Camera preset, and Material preset of  'sopStairs' (or a Shader preset of 'Paving01' surface of 'sopStairs').  Then apply them accordingly, the result should be the same... 

    Post edited by Richard Haseltine on
  • bdell_53_4baf2b3d9b said:

    mark_z2487 said:

    bdell_53_4baf2b3d9b said:

    Have you tried using a ground plane as your reflective surface.

    My settings for this is

    Rendered in Iray,

    Base Mixing, PBR Metallicity/Roughness, set Metallicity to 1.00.

    Glossy color to White, Glossy Reflectivity to 0.87, Cutout opacity to 0.25.

    yes, I will make some puddles to set on top of the pavement

    why would you set the metallicity to 1?

    Sorry about that, I raise it up to 1 just because I think it looks more glossy and that is usually what I like. When I leave it to low then it just looks like bleached out white ground.

     

    that is interesting on the Metallicity, all it should do is change the color of the reflection, from the color of the reflected objects, to tinted by the material color

  • mark_z2487mark_z2487 Posts: 112
    edited February 2023

    crosswind said:

    mark_z2487 said:

    Well, this is still not adding up

     

    If I render the file you (crosswinds) sent me, I get exactly the same image

    I turned off the added like, looks the same except removes the specular reflection, looks basically the same

     

    As far as I can tell, you (crosswinds) made 3 changes to the shader values for the pavement:

     

    Glossy layered weight set to 1.0 from .22

    Glossy reflectivity set to 1.0 from .5

    Glossy roughness set to .001 with map from 1.0 with the map

     - You missed one... pls double-check lah - Normal Map was set to 0.025...  as we talked about it for times in above post.

     

    Here is where it gets odd, first experiment:

    The product, Streets of Steampunk, comes with a material setting: Lights On Iray

    If I apply that, and then change those 3 shader settings to crosswinds values I do not get the same look, not as glossy!

    - Just in case,  you better save a material preset of  'sopStairs'  from my file first,  then apply it to yours. I believe you'll get the same result.

     

    Second experiment:

    I save out crosswinds render settings and camera

    I load a fresh instance of Streets of Steampunk

    I render the scene, it is as one expects, not glossy

    I change the settings to crosswinds

    The render is glossier, but like my previous, not like crosswinds

    How can this be?

    - Still,  should save Render Settings preset, Camera preset, and Material preset of  'sopStairs' (or a Shader preset of 'Paving01' surface of 'sopStairs').  Then apply them accordingly, the result should be the same... 

     

    will try again, in one of my trials I removed the normal map completely, I don’t want to save and apply a shader because I want to change all of them in the model

     

    Post edited by Richard Haseltine on
  • that was it, in all my trials I missed reducing the normal map amount and the last round, now works! Thanks

     

Sign In or Register to comment.