Import *obj models to Twinmotion problems with textures

NovaNova Posts: 129
edited July 25 in Hexagon Discussion

We have noticed since the new version of Twinmotion that importing models in *.obj format works without problems, also the hierarchy levels are displayed, but if you put a texture on it, the whole model is assigned this texture.

 

 

00.JPG
1388 x 702 - 102K
01.JPG
1654 x 891 - 142K
Post edited by Nova on

Comments

  • WendyLuvsCatzWendyLuvsCatz Posts: 34,200

    what Daz export settings are you using?

    make sure paths with quotations not checked

  • NovaNova Posts: 129

    The following export settings are used.

    These have worked in older versions of Twinmoton, they also work with Twinmotion ?

     

    0000.JPG
    1726 x 786 - 194K
  • Catherine3678abCatherine3678ab Posts: 6,898

    Sounds like the matter of UVmapping and assigning Shading Domains with matching named materials, was missed.

  • WendyLuvsCatzWendyLuvsCatz Posts: 34,200
    edited July 26

    I have TM 2022.2.0 Preview 2

     and these settings in DAZ Studio work for me, I suggest send to DAZ studio over the bridge

     

     

     

    Capture.JPG
    451 x 504 - 51K
    Post edited by WendyLuvsCatz on
  • NovaNova Posts: 129
    edited July 27

    OK Thanks,
    we will impose it to DAZ and export from there.
    We must say that it used to work without problems, since Twinmotion version : 2022.2 it no longer works.
    Also we could export from Blender.

    We wanted Hexagon to do this, but unfortunately Hexagon has not been developed for years.
    But we will have a closer look at Blender when we have more time.

    It's really a pity that the developers of Hexagon don't continue to develop it! crying

    Post edited by Nova on
  • NovaNova Posts: 129

    Vincent.B (Epic Games)

    Hello @B&A (Customer)​ ,

     

    Thank you for posting your issue in the community and there seems to be a bug related to the display of textures. Here are things you can try to restore the texture.

     

        Navigate to the Preferences > Quality settings and change it to something different such as Medium and then the texture should refresh. Then you can revert the setting back.
        Closing and reopening the file could restore the texture as well.

     

    If that did not help please report a bug by following this link so we can further investigate this issue:

Sign In or Register to comment.