Two Tier DForce Error in DAZ 4.16

Hey,

I've got this error using DForce that I've never seen before.  It cropped up with 4.16, when it worked before without issues in 4.15.  This is a very puzzling error to me not just because it worked before, but nothing changed hardware wise.  It happens with everything DForce.  Clothes, hair, don't matter, it pops up each and every time.  It does not crash the program, it just doesn't do DForce anymore.  Here they are as captured on my desktop.  I get the big error first and without hesitation.  Then it starts to 'rebuild' and like 4 to 5 seconds later, gives the final shorter error message.  I've reinstalled the drivers to the latest, all to no benefit.  

My computer specs:

 Processor: AMD Ryzen 7 2700X Eight-Core Processor          (16 CPUs), ~3.7GHz
 Memory: 32768MB RAM
 Card name: Radeon RX 5500 XT

Windows 10 Home 64 Bit

This computer and hardware setup has always run DAZ and it's capabilities with no trouble.  Any input on this would be helpful.  Uploading screen shots.  

 

error1.jpg
1920 x 1080 - 814K
error2.jpg
1920 x 1080 - 826K

Comments

  • cgidesigncgidesign Posts: 220

    https://bastibe.de/2021-12-04-fixing-amd-opencl-on-windows.html

    might help (that link was posted by @PerttiA in December 2021).

    Be aware the tip in there tells you to edit the Windows registry.

  • Apologies for the length of time.  But I finally found out what causes this, why and how to fix it.  Fair warning, the fix will make some folks unhappy.

    First of all, the real problem lies in two different places.  The drivers and the program as well.  Why is that?  When AMD updated their drivers from 21.3.2 to any version higher, they changed the GPU ID from gfx1012 to gfx1012:xnack- for the 5500XT.  In fact, many GPUs got renamed across the board.  Some even have the xnack+ instead of xnack-.  

    Programs looking for the gfx1012 will not find it.  It will try and recompile and it will fail.  Why?  The program only has code to recompile for gfx1012 and nothing else, so the recompile will fail as the OpenCL code in that program doesn't understand the xnack qualifier.  The company who developed the program needs to update their program and compiler to rebuild for the xnack thing, or it will never work with dforce again.

    Until the Studio programmers decide this is important enough to fix, there is a fix you can do on your end.  All you have to do is get the Radeon 21.3.2 drivers (2020 drivers, I know...) and install it.  Then your error changes to gfx1012 and this time, the compiler doesn't fail.  Once it compiles, reload Studio and anything dForce, and it works once again.  

    Sorry it took this long for me to find it, I nearly ripped my hair out looking for a solution.  Editing the registry for OpenCL and other stuff will not work at this time.  Only the older drivers will get dForce to function again.  

    Good luck out there folks.  

  • Richard HaseltineRichard Haseltine Posts: 80,567

    I doubt the compiler is looking for a specific name, but I suppose it might be thrown by the colon - or maybe the driver isn't entirely consistent in what ti reports, cuasing the process to fail thinking it isn't getting valid input. It's certainyl worth sending all this to Daz, even if the fine detail is not fully correct.

Sign In or Register to comment.