GET DAZ STUDIO 4.5! See why you should do it today!

1131416181933

Comments

  • WilmapWilmap Posts: 2,813
    edited December 1969

    I have several free clothing items for Genesis at ShareCG. They are all .dsf format. Will these still work in DS4.5?

  • SpyroRueSpyroRue Posts: 5,014
    edited December 1969

    OK...I'm confused what you guys are saying. I upgraded from 4.0 to 4.5 and the only thing I had to do to get everything working was:

    #1 - Install the Genesis Starter Essentials
    #2 - Insert new serial number for 4.5
    #3 - Update the PLUG-INS that have been updated (Like Reality)

    I didn't have to reinstall all my Genesis content or any other content.

    All my stuff works.

    Same here, every thing I had seems fine.

  • ChoholeChohole Posts: 28,450
    edited August 2012

    wilmap said:
    I have several free clothing items for Genesis at ShareCG. They are all .dsf format. Will these still work in DS4.5?


    Yup DS4.5 will read .dsf fil;es, it just won't write them.

    Some may need updating, to fix Duplicate IDs or to add region info to morphs, but essentially they work

    Edited to add it's a question of making sure you stick to the rules (everything must have a unique name, which 4.0 didn't enforce, and morphs must have a region assignement)

    It's mainly not having the geoemtry, nodes or materials having a name in common, or matching the figure name

    I am getting fed this info as I type lol
    Post edited by Chohole on
  • HaslorHaslor Posts: 394
    edited December 1969

    3. Do all my Genesis extras also have to be reset and downloaded?

    3. a lot of them, yes,

    Richard,
    Is there anyway for us to know which products have been updated?

    Is there a list some place that we can do a compare against what we have?

    Could we get a "Last Downloaded" "Last Updated" added to the "Itemized Order History" so we can tell which products have been updated? (Sorting the "Itemized Order History" by something other than product name would be Great!)

    I reset two products that say they have been updated, but the Versions of the available Files are the same as the Version I have, which I think came out before 4.5 was release in Beta. So you might understand my confusion.

    Do we only need to reinstall if it is the same version?

    The last time I started from scratch it took a month of sundays to reload.
    Halsor

  • Norse GraphicsNorse Graphics Posts: 0
    edited August 2012

    I'm having problems loading DAZ-files saved in DS3A version 32 (last version). But I can load everything else as set up in DS3A. The issue is that it can't find DSO-files.

    Anyway, a first render in DAZ Studio 4 Pro, using Sparky's Anubis for M4, and DreamLight's Egypt City. Touched up with some Gaussian blur in PS.

    http://www.flickr.com/photos/norse_graphics/7850562768/sizes/l/in/photostream/

    7850562768_8cc1ce5cea_b.jpg
    819 x 1024 - 352K
    Post edited by Norse Graphics on
  • inquireinquire Posts: 591
    edited August 2012

    Don't forget there is the warning in the "Updated Genesis Products" thread to the effect that

    "One or more of the older uninstallers will remove some of the Genesis files and some Studio 4 files that it wasn’t supposed to I discovered a few days ago when I couldn’t launch Studio with out error messages after doing updates."

    In other words THE RECOMMENDED UNINSTALL AND THEN REINSTALL UPDATES PROCESS MAY ITSELF CAUSE ERRORS THAT PREVENT DAZSTUDIO 4.5 FROM RUNNING.

    Still reading this thread. Still NOT updating to 4.5. But, I believe, after musing about this for hours, that there needs to be a warning list posted to the effect that "IF you bought any of these Genesis products, they will cause problems in 4.5. Remove them from 4.0 and do not reinstall until you get an email saying that one of them has been updated and is ready for version 4.5."

    And there should be a second part to this list, saying "Here are Genesis products that have been updated and are SAFE to install in version 4.5."

    Perhaps it would better to uninstall the "likely-to-cause-problems-Genesis-products" from version 4.0 BEFORE updating to version 4.5? Then, if the uninstallers removed files that they weren't supposed to remove, perhaps the installation of version 4.5 would replace those files? I don't know that this would work, but I think it's worth having the DAZ administrators considering and informing us about.

    This present policy of "hassle it out for yourself" is egregiously indecent, horrendously obtuse, and ineffably plutocratic.

    Post edited by inquire on
  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    It seems to me that anyone that has only got DS 4.0 Advanced have been both left in the dark and forgotten about. The lack of information for us is conspicuous by it's absence and that does not endear me to the current DAZ protocols.

    Reading through this forum has lead me to conclude that apart from excluding a lot of information for the rest of us 'Advanced' owners, the whole installation process for anyone else is convoluted, fraught with issues and generally a complete and utter screw up.

    I consider myself by no means IT illiterate.... this Lady built this machine, configured it and resolves issues. Typical of many people directly involved in writing/creating software, they leave out the details when passing it on to us mere mortals. Without a thought, because they understand things having wrote/created the software, they unwittingly assume that the rest of us are mind readers.

    A lot more dotting of the 'I's' and crossing of the 'T's' would by no means be amiss.

    For now I am not even going to attempt installing DS 4.5 until or even if! there is a version that simply updates my version without all the ridiculous convolutions and dancing around the may pole.

    I don't understand the issue - download the current free Pro version and install it, enter the serial number, and use it.

  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    anikad said:
    anikad said:
    Help! Geometry error. How do I fix it?

    The item with a problem should be replaced with a stack of bounding boxes - that looks like something in .dsf format, rather than a Poser format item, for what it's worth.

    Sorry I don't understand this statement at all. The item is not loading, I'm getting error boxes. Why am I getting error boxes? The item is something in .dsf format.

    What is in the file? I was thinking it was a .duf scene file from a previous beta, in which case whatever it couldn't find would have loaded as a staack of boxes big enough to enclose each part, but if it's a .dsf file from 4.0 that won't happen.

  • inquireinquire Posts: 591
    edited December 1969


    I don't understand the issue - download the current free Pro version and install it, enter the serial number, and use it.

    Richard: You do NOT understand the issue?

  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    Haslor said:

    3. Do all my Genesis extras also have to be reset and downloaded?

    3. a lot of them, yes,

    Richard,
    Is there anyway for us to know which products have been updated?

    Is there a list some place that we can do a compare against what we have?

    Could we get a "Last Downloaded" "Last Updated" added to the "Itemized Order History" so we can tell which products have been updated? (Sorting the "Itemized Order History" by something other than product name would be Great!)

    I reset two products that say they have been updated, but the Versions of the available Files are the same as the Version I have, which I think came out before 4.5 was release in Beta. So you might understand my confusion.

    Do we only need to reinstall if it is the same version?

    The last time I started from scratch it took a month of sundays to reload.
    Halsor

    There isn't an automatic way - if you get Duplicate IDs when loading the item, check to see if there's an update (most should have one) or run my script; if morphs don't appear in the Shaping pane, check for an update (or see the post in the FAQ, which lists most of the sets which have been updated). If you don't get either of those issues the thing probably doesn't need updating.

  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    inquire said:

    I don't understand the issue - download the current free Pro version and install it, enter the serial number, and use it.

    Richard: You do NOT understand the issue?

    Why there's confusion for users of DS4Advanced in particualr, no. Pro includes all the features they currently have, so they just download that and carry on.

  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    For the most part you shouldn't need to uninstall the old content to add the updated versions, as long as you place them in the same folder. the very old Genesis Evolution Expressions did need to be uninstalled as the folder with the morph files has changed, so simply installing the updated would leave both in place, but I'm not aware of anything else that absolutely needs the older version removed before putting the new version on.

  • Scott LivingstonScott Livingston Posts: 4,277
    edited December 1969

    OK...I'm confused what you guys are saying. I upgraded from 4.0 to 4.5 and the only thing I had to do to get everything working was:

    #1 - Install the Genesis Starter Essentials
    #2 - Insert new serial number for 4.5
    #3 - Update the PLUG-INS that have been updated (Like Reality)

    I didn't have to reinstall all my Genesis content or any other content.

    All my stuff works.

    Same here, every thing I had seems fine.
    I've been getting those duplicate ID errors, but they don't prevent me from using the content. For me, the duplicate ID errors are perhaps less annoying than having to reset, re-download, and reinstall dozens of items, especially since there doesn't seem to be an easy way to check to see if I have the latest version or not. Just starting that process now, but I'm taking my time about it...

  • BobvanBobvan Posts: 2,305
    edited December 1969

    One positive I do have to give it. Its not so sluggish while working inside the scene pane.

  • SassyWenchSassyWench Posts: 601
    edited December 1969

    OK...I'm confused what you guys are saying. I upgraded from 4.0 to 4.5 and the only thing I had to do to get everything working was:

    #1 - Install the Genesis Starter Essentials
    #2 - Insert new serial number for 4.5
    #3 - Update the PLUG-INS that have been updated (Like Reality)

    I didn't have to reinstall all my Genesis content or any other content.

    All my stuff works.

    Same here, every thing I had seems fine.


    I've been getting those duplicate ID errors, but they don't prevent me from using the content. For me, the duplicate ID errors are perhaps less annoying than having to reset, re-download, and reinstall dozens of items, especially since there doesn't seem to be an easy way to check to see if I have the latest version or not. Just starting that process now, but I'm taking my time about it...

    This is just what I did. DS says duplicate error, I click ok, item loads, and we move on with the scene. :)


    When the auto-downloader thing comes out I've read it will also check for updates and I'll deal with it then.

  • HaslorHaslor Posts: 394
    edited December 1969

    Just wanted to thank you guys for making misbehaving Poser Models work in Studio.
    These are two construction set I got at RNA which didn't behave in Studio 3.0 of 4.0.
    Now in Studio 4.5 they are behaving nicely.
    So thanks again.
    Haslor

    its_fixed_3.png
    640 x 360 - 162K
    its_fixed_3a.png
    640 x 360 - 306K
    Bad_Models.png
    607 x 449 - 534K
  • HaslorHaslor Posts: 394
    edited December 1969

    Haslor said:

    3. Do all my Genesis extras also have to be reset and downloaded?

    3. a lot of them, yes,

    Richard,
    Is there anyway for us to know which products have been updated?

    Is there a list some place that we can do a compare against what we have?

    Could we get a "Last Downloaded" "Last Updated" added to the "Itemized Order History" so we can tell which products have been updated? (Sorting the "Itemized Order History" by something other than product name would be Great!)

    I reset two products that say they have been updated, but the Versions of the available Files are the same as the Version I have, which I think came out before 4.5 was release in Beta. So you might understand my confusion.

    Do we only need to reinstall if it is the same version?

    The last time I started from scratch it took a month of sundays to reload.
    Halsor

    There isn't an automatic way - if you get Duplicate IDs when loading the item, check to see if there's an update (most should have one) or run my script; if morphs don't appear in the Shaping pane, check for an update (or see the post in the FAQ, which lists most of the sets which have been updated). If you don't get either of those issues the thing probably doesn't need updating.

    Richard,

    I have to say I really like Studio 4.5, the improvements and speed, not to mention the Round Tripping of FBX will be extremely helpful.
    That said, I have to shake my head and say your suggested solution above is a poor resolution of the issue.
    It could be months before you hit a misbehaving product, then you do it could be crunch time and you don't have time to deal with it.
    I guess another solution would be to step through every item in your library to find the items which need to be replaced.
    It would be much easier if we just just see which of our installers/products are out of date, before we have the issue.
    Even a "Last Updated" or "Version Number" on the product's page would be a better solution.
    Then we could look to see when we could check the purchase date against the Update date, or check our installer against it.
    But the best solution is a sortable "Itemized Order History" with the "Date Updated" or "File Version" added to the item's row.

    I know the Web Site Team has been busy making improvement to the site since it's redesign.
    I also know the requests for improvements to the "Itemized Order History" started the day it was debuted.
    This may be the perfect time to act on some those requests, to help us all through the transition of Studio 4 to 4.5.

    Just a suggestion
    Haslor

  • LeggyBlondLeggyBlond Posts: 124
    edited August 2012

    inquire said:

    I don't understand the issue - download the current free Pro version and install it, enter the serial number, and use it.

    Richard: You do NOT understand the issue?

    Why there's confusion for users of DS4Advanced in particualr, no. Pro includes all the features they currently have, so they just download that and carry on.

    OK! So may I ask, rather than pour through the whole forum again, apart from installing DS 4.5, and I presume 'Genesis Starter Essentials 1.3' which I understand updates Genesis in some way or other, what else amongst the plethora of files I have downloaded do I also need to install.

    Such things as 'Decimator', 'GoZ; I'm not too sure about although having checked them out, they do seem to simply be extra plugins.


    Addenda:- This business of only having one version on your system is actually Tosh! Whilst admittedly I have multiple drives and partitions, I have had for some time:- DS2, DS3 32 & 64, DS4 32 & 64 all working without any conflicts.

    Post edited by LeggyBlond on
  • kj_54e8eded70kj_54e8eded70 Posts: 19
    edited December 1969

    What the heck is this ".duf" format - and how come I can't save scenes in the old format?

    I recently "upgraded" to DS Pro 4.5. I can open my scene files okay, and I can access all my old content - and the auto-fit feature even seems to have been improved.

    However, I CANNOT save these scenes in the old .daz file format. The ONLY option I'm given is ".duf." When I relaunch the application, I can't even see these when I select "open." The only way I am able to access them is when I open a scene and choose "Save As" (which I can only do in this dysfunctional format), then click on it, choose "Open" - which launches a 2nd instance of DS - and close out of the first one.

    When it comes up, I get the following message: "Some assets needed to load the file were missing. The content may not work as expected. The following files could not be found:"

    Then it lists the Genesis .dsf files.

    When the scene finally loads, this is what I get (see attached screenshot).

    Why do you people keep trying to fix things that aren't broken? 4.0 had some glitches, but at least it worked.

    Screenshot.jpg
    1680 x 1050 - 163K
  • HaslorHaslor Posts: 394
    edited August 2012

    kayma said:
    What the heck is this ".duf" format - and how come I can't save scenes in the old format?

    I recently "upgraded" to DS Pro 4.5. I can open my scene files okay, and I can access all my old content - and the auto-fit feature even seems to have been improved.

    However, I CANNOT save these scenes in the old .daz file format. The ONLY option I'm given is ".duf." When I relaunch the application, I can't even see these when I select "open." The only way I am able to access them is when I open a scene and choose "Save As" (which I can only do in this dysfunctional format), then click on it, choose "Open" - which launches a 2nd instance of DS - and close out of the first one.

    When it comes up, I get the following message: "Some assets needed to load the file were missing. The content may not work as expected. The following files could not be found:"

    Then it lists the Genesis .dsf files.

    When the scene finally loads, this is what I get (see attached screenshot).

    Why do you people keep trying to fix things that aren't broken? 4.0 had some glitches, but at least it worked.

    Ah, You need to download an install the "14812_GenesisStarterEssentials" that is why Genesis is missing.
    Once you start using it I think you will find you will like most parts of the 4.5.
    Genesis loads in a fraction of the time and saves are faster. (Seconds rather than minutes)
    if you use the built in render engine, I think you will find it much faster. (cut 75% of the rendering time off)
    Yes there is some updating you will have to do, but for the most part it fixes a lot of the issue with 4.0, (My experience)

    I hope that helped.
    Haslor

    Post edited by Haslor on
  • Richard HaseltineRichard Haseltine Posts: 45,449
    edited December 1969

    OK! So may I ask, rather than pour through the whole forum again, apart from installing DS 4.5, and I presume 'Genesis Starter Essentials 1.3' which I understand updates Genesis in some way or other, what else amongst the plethora of files I have downloaded do I also need to install.

    Such things as 'Decimator', 'GoZ; I'm not too sure about although having checked them out, they do seem to simply be extra plugins.

    Yes, those are optional plugins - Decimator is there for people with the paid-for DS4Pro, it won't work with the free serial number (if you want it you can buy a serial number from the store - it's for making lower-polygon count versions of items). GoZ and the Photoshop Bridge are useful, if you have the other application - if not, ignore them. All of the items in the Advanced version are in the main DAZ Studio installer so I think you would need only the base installer and the Genesis installer.


    Addenda:- This business of only having one version on your system is actually Tosh! Whilst admittedly I have multiple drives and partitions, I have had for some time:- DS2, DS3 32 & 64, DS4 32 & 64 all working without any conflicts.

    Ds 1, 2, 3 and 4 can coexists, and you can have 32 and 64 bit versions at the same time. What you can't safely do is have two different versions of DS4/4.5, even if one is 32 bit and the other 64 bit.

  • HaslorHaslor Posts: 394
    edited December 1969

    People have asked why do I care if I can now share my Scenes with someone?

    What about sharing scenes with yourself?
    Have you ever had your system crash and had to reload Studio and everything else?
    And then you try to open one of your Scenes and you get all sorts of errors?
    This was caused by the differences between the two installs of Studio for each install gets a specific code attached to it.
    I have reloaded studio twice and come up against this very issue twice.

    So while you may not work in a group or share your scene files with others, you do want to be able to open the files your create after you recover from a system crash. Yet another good reason to upgrade to 4.5.

  • DisparateDreamerDisparateDreamer Posts: 1,992
    edited December 1969

    At first I WAS impressed with teh speed of 4.5

    Until i tried to use something other than genesis that is. took over 10 minutes to load V4. TEN FRICKIN MINUTES. And there's a lot of lag trying to open non-genesis stuff.

    Do we need to reinstall GenX? will it still work with 4.5?
    If its broken I'm throwing Daz out the window until its fixed. I *NEED* genX. There's just not enough Genesis content yet without it. Do we also need to reinstall the iconic shapes for converting clothes?

  • kj_54e8eded70kj_54e8eded70 Posts: 19
    edited December 1969

    Haslor said:
    kayma said:
    What the heck is this ".duf" format - and how come I can't save scenes in the old format?

    I recently "upgraded" to DS Pro 4.5. I can open my scene files okay, and I can access all my old content - and the auto-fit feature even seems to have been improved.

    However, I CANNOT save these scenes in the old .daz file format. The ONLY option I'm given is ".duf." When I relaunch the application, I can't even see these when I select "open." The only way I am able to access them is when I open a scene and choose "Save As" (which I can only do in this dysfunctional format), then click on it, choose "Open" - which launches a 2nd instance of DS - and close out of the first one.

    When it comes up, I get the following message: "Some assets needed to load the file were missing. The content may not work as expected. The following files could not be found:"

    Then it lists the Genesis .dsf files.

    When the scene finally loads, this is what I get (see attached screenshot).

    Why do you people keep trying to fix things that aren't broken? 4.0 had some glitches, but at least it worked.

    Ah, You need to download an install the "14812_GenesisStarterEssentials" that is why Genesis is missing.
    Once you start using it I think you will find you will like most parts of the 4.5.
    Genesis loads in a fraction of the time and saves are faster. (Seconds rather than minutes)
    if you use the built in render engine, I think you will find it much faster. (cut 75% of the rendering time off)
    Yes there is some updating you will have to do, but for the most part it fixes a lot of the issue with 4.0, (My experience)

    I hope that helped.
    Haslor

    Thanks - I hope so. Where do I find this file? Do I have to pay for it?

  • BobvanBobvan Posts: 2,305
    edited December 1969

    kayma said:
    Haslor said:
    kayma said:
    What the heck is this ".duf" format - and how come I can't save scenes in the old format?

    I recently "upgraded" to DS Pro 4.5. I can open my scene files okay, and I can access all my old content - and the auto-fit feature even seems to have been improved.

    However, I CANNOT save these scenes in the old .daz file format. The ONLY option I'm given is ".duf." When I relaunch the application, I can't even see these when I select "open." The only way I am able to access them is when I open a scene and choose "Save As" (which I can only do in this dysfunctional format), then click on it, choose "Open" - which launches a 2nd instance of DS - and close out of the first one.

    When it comes up, I get the following message: "Some assets needed to load the file were missing. The content may not work as expected. The following files could not be found:"

    Then it lists the Genesis .dsf files.

    When the scene finally loads, this is what I get (see attached screenshot).

    Why do you people keep trying to fix things that aren't broken? 4.0 had some glitches, but at least it worked.

    Ah, You need to download an install the "14812_GenesisStarterEssentials" that is why Genesis is missing.
    Once you start using it I think you will find you will like most parts of the 4.5.
    Genesis loads in a fraction of the time and saves are faster. (Seconds rather than minutes)
    if you use the built in render engine, I think you will find it much faster. (cut 75% of the rendering time off)
    Yes there is some updating you will have to do, but for the most part it fixes a lot of the issue with 4.0, (My experience)

    I hope that helped.
    Haslor

    Thanks - I hope so. Where do I find this file? Do I have to pay for it?

    No it should be included in your downloads

  • BobvanBobvan Posts: 2,305
    edited December 1969

    Quote

    if you use the built in render engine, I think you will find it much faster. (cut 75% of the rendering time off)

    Haslor[

    Sept Reality / Lux is the SH*t DS 4.5 Reality 2.5 Lux render... It takes longer but I have been working with it for a while and quite like the results...

    The Dressing Room

    7851853544_2290ae75c3_c.jpg
    800 x 426 - 261K
  • JasmineSkunkJasmineSkunk Posts: 1,245
    edited December 1969

    At first I WAS impressed with teh speed of 4.5

    Until i tried to use something other than genesis that is. took over 10 minutes to load V4. TEN FRICKIN MINUTES. And there's a lot of lag trying to open non-genesis stuff.

    Do we need to reinstall GenX? will it still work with 4.5?
    If its broken I'm throwing Daz out the window until its fixed. I *NEED* genX. There's just not enough Genesis content yet without it. Do we also need to reinstall the iconic shapes for converting clothes?

    GenX is a plug-in, and all plug-ins needed to be updated to work in 4.5. Many are already updated, but I don't know how the GenX one is coming along.

    I think this the thread with the current updated plugins:

    http://www.daz3d.com/forums/discussion/5976/

  • erostewerostew Posts: 214
    edited December 1969

    I swear I'm getting so fed up that I might NEVER update to 4.5! There is so much conflicting information about how/how not to install and what works and doesn't work that I'm almost ready to dump Genesis and go back to Poser and that wierd looking Antonia weight mapped figure from that other outfit. And I HATE Poser!!!

    The really sad thing is that the knuckleheads in charge of this D|S 4.5 boondoggle could have made it a painless process. All it would take is an Official "How to Install or Upgrade to D|S 4.5" thread. But you know what? THERE ISN'T ONE!!!

    The very first post in this thread has a link to the installation instructions for D|S 4 on Windows (or Mac). So I click the stupid useless link and what do I get? A friggin empty post! There is nothing in that thread except a table of contents for the instructions that do NOT exist and 2 images to help me find out where to install my serial number. Not only was this post not updated for 4.5 it doesn't even have any content for 4.0. Epic Fail!

    WTF Daz??? I KNOW you can do better than this!

  • FixmypcmikeFixmypcmike Posts: 17,301
    edited December 1969

    Haslor said:

    3. Do all my Genesis extras also have to be reset and downloaded?

    3. a lot of them, yes,

    Richard,
    Is there anyway for us to know which products have been updated?

    Is there a list some place that we can do a compare against what we have?

    Could we get a "Last Downloaded" "Last Updated" added to the "Itemized Order History" so we can tell which products have been updated? (Sorting the "Itemized Order History" by something other than product name would be Great!)

    I reset two products that say they have been updated, but the Versions of the available Files are the same as the Version I have, which I think came out before 4.5 was release in Beta. So you might understand my confusion.

    Do we only need to reinstall if it is the same version?

    The last time I started from scratch it took a month of sundays to reload.
    Halsor

    A list of the latest version number of all Genesis add-ons can be found here:
    http://www.daz3d.com/forums/discussion/3885/

    Both improvements to the Itemized Order History and the Install Manager are being worked on; in the interim, Jay Nola is kindly maintaining that list.

  • FixmypcmikeFixmypcmike Posts: 17,301
    edited December 1969

    OK...I'm confused what you guys are saying. I upgraded from 4.0 to 4.5 and the only thing I had to do to get everything working was:

    #1 - Install the Genesis Starter Essentials
    #2 - Insert new serial number for 4.5
    #3 - Update the PLUG-INS that have been updated (Like Reality)

    I didn't have to reinstall all my Genesis content or any other content.

    All my stuff works.

    Same here, every thing I had seems fine.


    I've been getting those duplicate ID errors, but they don't prevent me from using the content. For me, the duplicate ID errors are perhaps less annoying than having to reset, re-download, and reinstall dozens of items, especially since there doesn't seem to be an easy way to check to see if I have the latest version or not. Just starting that process now, but I'm taking my time about it...

    Latest version numbers of Genesis add-ons: http://www.daz3d.com/forums/discussion/3885/

Sign In or Register to comment.