Poser Pro 2014 install issue

Setting up a new PC. Have a DVD copy of Poser Pro 2014 which I purchased a few years ago. 

I have been through the entire install process 4 times and cannot get the program to run.

It installs fine. No errors. 64 bit only install. When I double click the program icon

the splash screen appears for about 20 seconds, and then disapperars, and nothing

No errors, just won't run ?????  Can anyone help???

Comments

  • MartirillaMartirilla Posts: 172

    There is a thread elsewhere suggesting Poser 2014 has difficulties running under Windows 10. Some ideas otherwise:

    1. Reboot PC and try again.
    2. Apply all update patches.
    3. Run in Windows 7 compatability mode, if that's possible on Windows 10.
    4. Run as Administrator.
    5. Apparently "adequate read/write permissions to necessary directories, which is often a problem with many programs in Win10". No idea how to fix that one, as I was never part of the Win10 nightmare.

  • WandWWandW Posts: 2,759

    SR4 for Poser Pro 2014 can be downloaded from the link in this thread:

    https://www.renderosity.com/rr/mod/forumpro/?thread_id=2949609#msg4394414

    I presume it is regular PP2014 and not the Game Dev version?  The latter requres online activation from Smith Micro's servers, which is of course no longer possible.  However, the PP Game Dev serial will work to activate Poser 11 ...
     

  • Ghost_TrainGhost_Train Posts: 24
    edited February 8

    joelsegalgraphics_81fdc44770 said:

    Setting up a new PC. Have a DVD copy of Poser Pro 2014 which I purchased a few years ago. 

    I have been through the entire install process 4 times and cannot get the program to run.

    It installs fine. No errors. 64 bit only install. When I double click the program icon

    the splash screen appears for about 20 seconds, and then disapperars, and nothing

    No errors,just won't run ?????  Can anyone help???

    I slightly recall possibly having an issue after installing Poser 2014 on win 10 some years back.  (hoping my memories are not getting corrupted though) and I think for me it only started working after completely shutting down the PC and booting it up again.  like even restart wasn't enough.  Its been a while.  pp2014 is still working great on my computer even in 2024.

    EDIT: Ahh.  i didn't see the date.  this thread is a bit old. haha

    Post edited by Ghost_Train on
Sign In or Register to comment.