Props merge together or disappear after loading a scene

I been having a problem with a SFM map that I exported as an collada file for some days, whenever I try to distribute it as a freebie using the support asset>Scene Asset(s) it bugs some of the props, when I reload that scene, some props all load merged together for some reason and some of them dissapear, the prop is still in the scene tab but it's invisible, and it's clearly not hidden.

The map in question is a public restroom, there are stalls and urinals and this only happen with both of them, and this sadly only happens when I try to distribute it, if I save it as a scene, it loads without any problems, not sure why this happens, this might be super easy to fix but any help would be greatly appreciated.

Posting this here as I'm a total newbie and I don't know what I'm doing.

Comments

  • Richard HaseltineRichard Haseltine Posts: 74,108

    I'm not entirely following, but are you sure that, when saving as assets, each item gets a unique name?

  • LiphisbusLiphisbus Posts: 3

    Richard Haseltine said:

    I'm not entirely following, but are you sure that, when saving as assets, each item gets a unique name?

    Hi Richard,

    Not really, the stalls and urinals have the same name, but I put a number in each one of them to separate them, is that why this is happening? Because if yes that would be dumb of me xD

    Also, there are 10 stalls in total, 5 stalls that are open and another 5 that are closed, just pointing this out as it might help a little somehow.

  • Richard HaseltineRichard Haseltine Posts: 74,108

    The name isn't the same as the label, which is what shows in the Scene pane, so yes it may well be a naming conflict. If you go to Edit>Object>Scene Identification you will be able to see 9and if need be change) both the name and the label.

  • LiphisbusLiphisbus Posts: 3

    Richard Haseltine said:

    The name isn't the same as the label, which is what shows in the Scene pane, so yes it may well be a naming conflict. If you go to Edit>Object>Scene Identification you will be able to see 9and if need be change) both the name and the label.

    Sorry, I didn't understand what you said, not sure if I'm a newbie or because of my engrish... What are you saying is that I need to change the Node Name and Node Label the same for every item (stall and urinal)?

    Also, could I use the same name as before (like, Stall 01, Stall 02...) or do I need to make every stall with a different name?

    Thanks a lot for your reply!

  • Richard HaseltineRichard Haseltine Posts: 74,108

    Each different item should have a different Node Name. If they are already different then that isn't the issue.

  • WendyLuvsCatzWendyLuvsCatz Posts: 30,850

    are you loading it at zero on the timeline?

    maybe you translated your duplicates into place further along the timeline and they are on top of each other at zero.

  • LiphisbusLiphisbus Posts: 3

    It took some time to readjust everything back in place but it seems that what Richard said worked, I just have to change the name for the name that I put and it worked perfectly, well, it worked for me, not sure if it will work for other people, I have to continue readjusting things here and see if it works or not for others, thanks a lot both of you!

Sign In or Register to comment.