Perspective View Camera Casting Shadow From Sun ::SOLVED:: (Headlamps Off)

TDBAGZTDBAGZ Posts: 134

When I navigate a scene in Iray and the Perspective View Camera is back lit by the "Sun"/Dome it cast a shadow. Didnt notice this issue before the G8.1 Update. Other Cameras dont appear to be casting any shadow. Is there a setting I missed that I can change or is this a bug?

Thanks 

Post edited by TDBAGZ on

Comments

  • GordigGordig Posts: 4,346

    Have you tried hiding the camera?

  • TDBAGZTDBAGZ Posts: 134
    edited June 15

    How do I hide the already invisible Perspective View Camera?

    ::Cylinder is 1ft tall in image.::

     

    SR4__20210615015740-0001.jpg
    480 x 270 - 64K
    Post edited by TDBAGZ on
  • It's weird, never seen that before. If the shadow bothers you, try creating a new camera with the Perspective Camera selected. Activate the "same options" setting (or similar?). Then move the view of your perspective camera to the other side of the cylinder or far away and use the new camera for navigating through your scene. Hope that works...

  • TDBAGZTDBAGZ Posts: 134

    Turns out the Regular Cameras shadow as well though not as bad. 

    Workaround is to have a New Camera at a farther distance but with a longer focal length. Works well enough I guess, not ideal though.

    Was hoping there was a settings dial I missed or a line of code that could be changed to turn off camera shadowing or increase focal length on the perspective view camera. 

    Dont even know for sure if everyone has this issue, or if its something I picked up with various look at camera scripts.

    Im also usually working in a higher light intensity environment (2), and without any dome map so I could still try just white mapping the dome and see if that changes anything (It does kills the shadow but also kills the hard shadow from the object).

    Ugh, oh well.

    Thanks again anyways guys.  

  • chris-2599934chris-2599934 Posts: 1,451

    Your scene seems to include only primitives, so could you save it and attach it to a forum post so people here could see if they get the same behaviour? I've never seen that happen in any of my scenes, but there must be a reason for it.

  • TDBAGZTDBAGZ Posts: 134

    chris-2599934 said:

    Your scene seems to include only primitives, so could you save it and attach it to a forum post so people here could see if they get the same behaviour? I've never seen that happen in any of my scenes, but there must be a reason for it.

    (ADDENDUM: Discovery after post, Its the cameras' headlamps doing the shadowing, turn the headlamps off and no more shadows.laugh DOH!) 

     

    It's easy enough to recreate (If you will have the same issue).

    1. Open DS

    2. Set viewport to IRAY.

    3. Select Environment Options in the Scene Tab 

    4. Use the Aim (Zoom to) widget in the viewport to get a close up of the Environment Node at World Center.

    In the Envirmonment Settings Parameters

    5. Remove the domes environment map. 

    6. Note if your default Sun Sky SS Day/Time is also 03/10/2015 06:00:00 PM

    7. Rotate the Dome via the Dome Rotation Dial to, ironically, 266.60

    The Viewport Cameras Shadow should now be alligned center screen.

    This is the case in any Sun Sky Scene for me with the camera backlit. Maybe not to best practice but sucks when you want to get harsh shadows on a close up portrait or tweak makeups.

    !!!! surpriseOMG DERPblush ::embarrassed::.... Addendum to top. Forgot to turn Headlamps off on most recent custom default scene setup.      

      

Sign In or Register to comment.