walk animation, clothing morphs not able to keep up when going frame by frame

Hi,

 

I'm working on a simple walking animation.  If i'm reading the UI correctly its only 38 subseconds long.  Dont know if thats the same as a frame or different from a frame.  Anyways the figure has stockings and clothes and at the start of the anim i had to expand the clothes so it wouldn't clip the figure.  When i animate it to preview it the clothes clip into the figure.  If i advance the anim a frame at a time the preview takes time to refresh and then it shows the figure with no clipping.  I advance one frame, the clothes are shown clipping, the scene finishes updating and the figure refreshes with no clothes clipping.  This keeps repeating when i move it forward frame by frame.  But again if i just hit play on the anim the clothes are shown clipping through the figure the whole time because it doesnt have time to refresh each frame.

 

Hope i described that well enough, but i dont know what is going on here.  I did some searching and i think i might have seen a few similar posts but i'm not sure if its the same thing or something slightly different or something completely different from what i'm experiencing.

Comments

  • PhatmartinoPhatmartino Posts: 180
    edited May 29

    @glossedsfm I only have limited experience with trying to animate, but I do know that in the current version of DS, when you press Play to preview in the Viewport, some things are temporarily turned off to try and make it run as smooth as possible... One of these things is Mesh Smoothing, which is what "catches up" when you advance a Frame Manually. If you were to actually Render the sequence, you wouldn't see the clipping.

     

    You can try to do a "Preview Render" using Texture Shaded DrawStyle to check this and any other possible issues in a fraction of the time it would take to render all the frames in Iray, by going to Render Settings and at the top of that Panel where it says Engine: NVIDIA Iray, click and choose Viewport. Now whatever DrawStyle you're currently using in the Viewport will be what's Rendered.

     

    Also worth mentioning, just in case, that it's worth rendering an Image Sequence instead of a Movie (change this in Render Settings> General> Render Type), as the Images in a Rendered Sequence will be perfect quality, where a "Movie" will already have an Encoder Compression that can't be undone.

     

    If you don't already have an easy way to assemble an Image Sequence into a Video File, look into the Free Open Source tool VirtualDub. It's crazy lightweight, will by default save as an uncompressed .avi so that again, at that point you have a perfect copy of your video with no compression, then you can use any other tool under the sun to choose what file format you want to convert it to for a manageable filesize vs. quality.

    On the off chance that you do try this, when you open VirtualDub, choose File> Open Video File... then browse to your Image Sequence files and double click the first file in the Sequence. It will automatically load the rest of the Sequence as frames.

    Post edited by Phatmartino on
  • cridgitcridgit Posts: 1,314

    There could be any of a number of different things you're seeing. I'm not sure how new you are to DAZ Studio so forgive if I oversimplify anything too much.

    1. Make sure clothes are fit to the figure (right click Fit To ...). That means they'll follow the figure regardless of pose and the only poke-through (clipping) you should see is if the clothes weren't made for the figure (e.g. G2 pants on G8) or where you've applied morphs to the figure which the clothing doesn't recognize.

    2. To solve poke-through as mentioned above you can add a smoothing modifier to the clothes. That should generally take care of most cases but if you're still seeing a little poke-through, you can increase the Collision iterations or Smoothing iterations by 1 or 2. Go easy on these because adding 1 iteration to either of them ups the number of calculations needed to update the frame in the viewport (more on that next).

    3. If you've done the above correctly then when you render a single frame or frame range (animation) you shouldn't see any poke-through.

    4. What you seem to be noticing is poke-through in the Viewport and yes this can occur, or be laggy because Studio is calculating all the collision/smoothing stuff. If you make any pose/morph changes to your character you will notice it recalculating by the lag in updating the view, and you will see the same thing playing the animation. The tool isn't designed to render animation in the viewport in real time unless you have a monster GPU. There are other tools for that.

     

  • glossedsfmglossedsfm Posts: 307

    I think what phatmartino mentioned with things getting turned off is what i'm seeing, and not an autofit or pokethrough issue.  The pokethrough isn't there on the t-pose or any of the animations still frames.  But it does pokethrough when i hit play in the preview.  Since it was a short anim i did a render with no background and there was no pokethrough at all in the completed rendered video.  So it looks like if i need to make sure pokethrough isn't happening i just need to advance one frame at a time.  Not sure how facial morphs or dforce is affected by this stuff so i'll have to see when i get around to doing that.

Sign In or Register to comment.