"Mapped Folders" is not working

For some reason, and I think this was after the last update, my ability to right click on an item in the Content Library and make it go to "Show Asset in - > Mapped Folders" does not work. Nothing happens. Was it the update or did I screw something up?  

Comments

  • Richard HaseltineRichard Haseltine Posts: 72,689

    Mine is mostly Show in Virtual folder, and thats eems to be working normally. It may be an issue with the metadata or it may be a path issue - are you sure the files are still there to show?

  • RKane_1RKane_1 Posts: 2,970

    Yes. It's not working on ANY of my files. :|

  • Richard HaseltineRichard Haseltine Posts: 72,689

    Are other aspect that rely on the Content Managment System working? Does the Browse to File Location command still work?

  • RKane_1RKane_1 Posts: 2,970
    edited April 25

    That does, yes. But I found oddly, that other items such as "Shows assets in Smart Content Folder yields this error ...  folder 

     

    Sart Content Error.png
    1180 x 648 - 235K
    Post edited by RKane_1 on
  • RKane_1RKane_1 Posts: 2,970

    I don't know if the two items are related but I wanted to mention it in case it helps. In my DAZ Studio Formats there were TWO "My DAZ Libraries" listed since I moved to my new computer. I reloaded all my content but I deleted one of them so as not to have a duplicate. 

  • Richard HaseltineRichard Haseltine Posts: 72,689

    Well, the Smart Content error would not be surprising if the filter option is on and the item you want to show is not compatible with the item you have selected in the Viewport - those look like shader presets, so you would need to have an object and one or more of its surfaces selected.

  • RKane_1RKane_1 Posts: 2,970

    How do I change the filter option?

     

  • RKane_1RKane_1 Posts: 2,970

    And it won't work with shaders nor props nor figures, etc.

     

  • barbultbarbult Posts: 16,791
    edited April 26

    RKane_1 said:

    How do I change the filter option?

     Open the Smart Content pane. Select the Files tab (not the Products tab). Uncheck the Filter by Context checkbox. My Workspace is customized. Your layout will be a bit different, but the instructions are the same.

    Screenshot 2021-04-25 142213.jpg
    222 x 1006 - 43K
    Post edited by barbult on
  • RKane_1RKane_1 Posts: 2,970
    edited May 15

    Thanks. Okay that solved one problem but not the show files in mapped folder issue. :(

    Post edited by RKane_1 on
  • barbultbarbult Posts: 16,791

    Show detailed screenshots of a specific example of a recent Daz original figure (e.g. Genesis 8 Female) and what happens when you select her and choose show in mapped folder. Just saying it doesn't work for anything is too vague for anyone to spot the problem. The more details you can provide, the more likely you will get useful advice.

  • RKane_1RKane_1 Posts: 2,970

    barbult said:

    Show detailed screenshots of a specific example of a recent Daz original figure (e.g. Genesis 8 Female) and what happens when you select her and choose show in mapped folder. Just saying it doesn't work for anything is too vague for anyone to spot the problem. The more details you can provide, the more likely you will get useful advice.

    Windows 10 Screen snip won't allow you to take a pic of a menu you opened via right clicking. Do you have a recommendation of an app that will?

    The folder I for years have opened by right clicking on an item and selecting "Show Asset In..." and then selecting "Mapped Folder" is simply not working. No action is taken (At least not obviously) and the same screen I was in is still there. It is something I have used for years.

    I transported my files from one location to another. I was actually using it for a while on the new computer. There was a time where I actually saw an additional selection in the folder list of "My DAZ Library" and because it seemed identical, I deleted it. I can access the files and folders BUT I just cannot use the functions under "Show Asset in..." at all.

  • barbultbarbult Posts: 16,791

    Windows 10 Snip and Sketch (built in replacement for old snipping tool) can capture open right click menus. Just access Snip and Sketch from the shortcut Windows-Shift-S. It even lets you draw on the snipped area to annotate it if you want to. Then just save the snip from the Snip and Sketch window options.

     

    Screenshot 2021-05-27 Snip and Sketch Right Click annotation.jpg
    569 x 721 - 123K
  • NorthOf45NorthOf45 Posts: 3,253

    Mind if I join in? RKane_1, you said early on that you had "TWO My DAZ Libraries" and that you deleted one. What exactly did you delete, and where? Did you note where the two were (i.e., which drive/folder was mapped in Content Directory Manager)? Is the remaining Library the one that is mapped, or are there two mapped folders? Something tells me that CMS is confused...

  • RKane_1RKane_1 Posts: 2,970

    Can you reset CMS?

  • RKane_1RKane_1 Posts: 2,970
    edited June 5

    barbult said:

    Windows 10 Snip and Sketch (built in replacement for old snipping tool) can capture open right click menus. Just access Snip and Sketch from the shortcut Windows-Shift-S. It even lets you draw on the snipped area to annotate it if you want to. Then just save the snip from the Snip and Sketch window options.

     

    I just resorted to the old CTRL + Print Screen and cropped it out. Here it is.

    As I said before ... For some reason, and I think this was after the last update, my ability to right click on an item in the Content Library and make it go to "Show Asset in - > Mapped Folders" does not work. Nothing happens. Was it the update or did I screw something up?
    Problem.jpg
    1001 x 720 - 232K
    Post edited by RKane_1 on
  • NorthOf45NorthOf45 Posts: 3,253

    What does the Additional Information area say about the file? File path, Product? Does it match the actual installation?
    From the Content Library, you should be able to go in the other direction, i.e., Show in Products. Does the Additional Information match that from the one in Products?

    Yes, you can reset the database, but that is the nuclear option. Save your User Data if you made changes would alter metadata. From Content DB Maintenance, select Reset Database, then, when it is done, select Re-import Metadata (everything), including your User Data files (in the list that will appear). Could take a while if you have a lot of stuff.

  • RKane_1RKane_1 Posts: 2,970

    NorthOf45 said:

    What does the Additional Information area say about the file? File path, Product? Does it match the actual installation?
    From the Content Library, you should be able to go in the other direction, i.e., Show in Products. Does the Additional Information match that from the one in Products?

    Where do I find what you are asking for?

    NorthOf45 said:

    Yes, you can reset the database, but that is the nuclear option. Save your User Data if you made changes would alter metadata. From Content DB Maintenance, select Reset Database, then, when it is done, select Re-import Metadata (everything), including your User Data files (in the list that will appear). Could take a while if you have a lot of stuff.

    Only 9400+ items all affixed where they should go. :( Oh man, what have I done. *cry*

  • NorthOf45NorthOf45 Posts: 3,253

    Click the little pair of rectangles in the middle of the bottom divider, like I have indicated in the first attachment. It will open another panel underneath the Asset List. You will probably need to resize the other panels above it to get enough room using their own control buttons or dividers. It will display all sorts of relevant info about the selected item in the Asset List, including path and Product, among other things which you may or may not find interesting.

    The idea there is to check that the actual installed path matches the folder you have mapped in the Content Directory Manager. (There were two, just wanted to see if you are using the proper one).

    Okay, you say "all affixed where they should go". Is this not good? I don't understand. Sad face?

    Additional Info panel control.jpg
    588 x 527 - 76K
    Additional Info panel sample.jpg
    447 x 416 - 49K
  • RKane_1RKane_1 Posts: 2,970
    edited July 5

    It seems to match...

     

    DAZ Issues.jpg
    1551 x 648 - 159K
    Post edited by RKane_1 on
  • NorthOf45NorthOf45 Posts: 3,253

    Thought we lost you...

    Your Content Directory Manager shows an extra  '/' for the DAZ Studio and Poser formats folders, i.e., "D://Applications/Data/..."

    What happens if you change it to simply "D:/Applications/Data/..."?

  • RKane_1RKane_1 Posts: 2,970

    YOU ARE KIDDING ME! IT WORKED! I KNOW HAVE THE SAME ACCESS I HAD BEFORE!!!! BWAHAHAHAHAHAH!!! THANKYOU!THANKYOU!THANKYOU!THANKYOU!THANKYOU!THANKYOU!THANKYOU!THANKYOU!THANKYOU! :)

  • NorthOf45NorthOf45 Posts: 3,253

    Heh, he's ba-a-a-ck...

Sign In or Register to comment.