DAZtoUNREAL: unable to package my project in UNREAL when bridge was used

I installed DAZ and the DAZtoUNREAL bridge. I bought some DAZ assets and sent them to my UNREAL project. Playing the game in teh editor works just fine (only small issues on applying the cloth to animated figures).

When trying to package my project I receive these error messages:

UATHelper: Packaging (Windows (64-bit)):   ERROR: Missing precompiled manifest for 'DazToUnrealRuntime'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in DazToUnrealRuntime.build.cs to override.
PackagingResults: Error: Missing precompiled manifest for 'DazToUnrealRuntime'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in DazToUnrealRuntime.build.cs to override.

UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

I disabled the bridge. No more error messages, but my DAZ assets are no longer working in the packaged build then. So this doesn't help.

What can I do?

Comments

  • David VodhanelDavid Vodhanel Posts: 184

    That was a bug in an older version of the bridge.  You probably need an update.  Are you using UE4.25 or 4.26?

  • hpbrillhpbrill Posts: 6

    I am using UNREAL Engine 4.26.1 and DAZ Central says that the DAZtoUNREAL bridge is Version 4.0, not offering an update.

  • tomtom Posts: 0
    The solution to this is actually pretty simple, however finding the solution to this took me forever. Remove the plug-in from the engine and install the plug-im to the project instead, you can simply drag it over from your engine install location to your project root folder then restart
  • David VodhanelDavid Vodhanel Posts: 184

    You can manually download an update here and replace the plugin in your engine.  https://github.com/daz3d/DazToRuntime/releases/tag/4.1.0-unreal

  • GutoCraftsGutoCrafts Posts: 26
    edited April 9

    You don't need to package the plugin in your game. You can copy the shaders and the skeleton to your project content folder. In your project settings, under the daz to unreal tab, you can set the location of the skeleton and the shaders.

    Use the plugin only to import the characters to unreal. You can disable the plugin without any issues if you set the skeleton and shaders in your project folder.

    I also tried to build the game with the plugin only in the engine folder (not in the project folder) and it worked:

    UATHelper: Packaging (Windows (64-bit)): BUILD SUCCESSFUL
    UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=0 (Success)

    I'm using the latest plugin version available at github and UE4.26.1

    Post edited by GutoCrafts on
  • GutoCraftsGutoCrafts Posts: 26
    edited April 9

    Anyway, I think the solution to move the plugin content to the project folder is the way to go. Otherwise, any change you do to the skeleton will be shared between projects.

    Post edited by GutoCrafts on
Sign In or Register to comment.