Removing def_surf_mat when sending Hexagon object to DAZ Studio

Mythic3DMythic3D Posts: 1,489
edited December 1969 in Hexagon Discussion

Hi all,

I have modeled and UV mapped a couple simple objects in Hexagon and am sending them to DAZ Studio to use. When I go to add and adjust textures in studio, in addition to the material I added there is another material called "def_surf_mat." There are no polygons included in this texture so it's not actually affecting anything, but it offends my sense of neatness.

Is there any way to remove this so it doesn't show up? Is there something I have to do in Hexagon before sending it over so only my material shows up, or somewhere in studio I can edit this?

Thank you!
Mark

MaterialsQuestion.jpg
827 x 882 - 115K

Comments

  • Wee Dangerous JohnWee Dangerous John Posts: 1,285
    edited December 1969

    Can you do a screen grab of the object in Hexagon with the object selected so we can see the materials and shading domain.

    It looks like something has gone wrong with the shading domains, or has the prop been given a texture ?

    If you've given the top and bottom a shading domain, then changed your mind and remove the material rather than the domain then you could end up with the Def-Durf-Mat error. If this is the case, just remove the domain and Save & Export the prop again.

  • Mythic3DMythic3D Posts: 1,489
    edited December 1969

    Can you do a screen grab of the object in Hexagon with the object selected so we can see the materials and shading domain.

    Here's the screenshot:

    HexagonCapture_01.PNG
    977 x 1037 - 191K
  • GhostmanGhostman Posts: 215
    edited December 1969

    This is something I get all the time with my objects. I just open the obj in a text editor and delete the def_surf_mat line.

    I'm using Hex 2.1 but I think they fixed this in the latest version.

  • Wee Dangerous JohnWee Dangerous John Posts: 1,285
    edited December 1969

    Not sure, but try ungrouping the prop then exporting it. If that does not can you send me the HXN file.

  • ben98120000ben98120000 Posts: 463
    edited December 1969

    In DAZ Studio, select your object and switch to Geometry Editor (Tools - Geometry Editor). Than in Tool Settings tab (Window - Panels (Tabs) - Tool Settings) select the Surface you wish to remove and click with right mouse button on it to get the menu and use Remove Selected Group(s). Save your object as figure/prop (file - save as - support assets - figure/prop assets).

  • Mythic3DMythic3D Posts: 1,489
    edited December 1969

    ben98120000 - Thank you! That worked perfectly.

    Wee Dangerous John - Thank you for your help.

    Ghostman - I believe I am using the latest version of Hex (2.5.1.79) so I guess it hasn't been fixed. :)

    Still not sure what caused the problem though. Maybe it is because I am using File->Send to DAZ instead of exporting the prop from Hexagon and then importing in DAZ, but at least I have an easy fix now.

    Now that I have my first (well second really, but the first was just a ramp) ridiculously simple prop done my confidence is soaring and I may attempt something that isn't just a bunch of primitives stuck together. :lol:

  • patience55patience55 Posts: 6,988
    edited December 1969

    This is a very common glitch of some kind.
    Something to do with the communications between programs is how I look at it.

    As sometimes you'll find more than just the mysterious default material appearing:

    After doing the final export from the modeler. Close Hexagon. Open Hexagon and import that same recent export. Make sure the only materials on the material list are the exact ones required by the Shading Domains.
    Export out the .obj file again.
    Even if no extras appeared, export out the .obj.
    I call this washing the .obj file.
    Using needs doing once, sometimes twice.

    Alternatively yes, one can use the geometry selector thing in D/S and remove the "0" item and continue on to make the D/S file.

    Sometimes the extras appear to be coming from Hexagon because yes there may be a reference in the .obj file to be cleared, but it is also that D/S has been adding extras. I made some clothing the other day and wowser! Some extras were temporary, some weren't. Funsville.

Sign In or Register to comment.