PostgreSQL Error on macOS 10.15.3 with Daz 4.12

Did a clean install of Daz today to clear up another problem, but now dealing with the dreaded "PostgreSQL can't connect" message.

Been trying to fix permissions and use other tricks I've seen here on the forums, but to no avail. Log in the "cms" folder reads "FATAL:  data directory "/Users/chris/Library/Application Support/DAZ 3D/cms/ContentCluster" has wrong ownership
HINT:  The server must be started by the user that owns the data directory."

Anyone have any ideas?

«1

Comments

  • It does sound very like a permissions issue - whata re the current settings for that folder, and the cms folder itself?

  • The ContentCluster folder has Read & Write permissions for me and the system, with "No Access" for everyone. The CMS folder has Read & Write permissions for the system, read only permissions for staff, and read only permissions for everyone.

  • TotteTotte Posts: 11,795
    edited February 2020

    Look at the postgres.log file, it use to say if permissions are wrong.

    It's in ContentCluster and is named dblog.txt

    Post edited by Totte on
  • Totte said:

    Look at the postgres.log file, it use to say if permissions are wrong.

    It's in ContentCluster and is named dblog.txt

    Thanks for the tip. Here's what it reads:

    HINT:  The server must be started by the user that owns the data directory.
    FATAL:  data directory "/Users/chris/Library/Application Support/DAZ 3D/cms/ContentCluster" has wrong ownership
    HINT:  The server must be started by the user that owns the data directory.

  • TotteTotte Posts: 11,795

    So that must have you as the owner.

  • Totte said:

    So that must have you as the owner.

    Is there a difference between me being the "owner" and me having "Read & Write" permissions?

  • I think I figured out the answer to my own question and found out where I needed to change/update myself as the owner. Everything seems to be working now. Thanks for all your help.

  • TotteTotte Posts: 11,795

    Great - yes owner is owner, permissions is permissions. The thing is with postgres that the owner should have access and noone else.

     

  • I have the same PostgreSQL issue. I have tried everything I can find to fix it, including uninstall and reinstall, redownloading, beta download, changing port, changing ownership permissions. Still same problem.

  • What you got there looks like you've a 32-Bit version (or more like you have both installed but try to use the 32-Bit one). Apple stopped support for 32-Bit software with Catalina, so that version is not going to work. Not sure what you tried to un- and reinstall. Your problem is not DAZ Studio but the Postgres package. Didn't check for Macs (I only have to deal with them at work) but under Windows the Postgres Server is a separate package. So maybe it helps if you try to just uninstall Postgres and make sure you reinstall a current 64-Bit version of it.

  • TotteTotte Posts: 11,795

    pgAdmin is only for admin of the postgres (GUI)

  • Im having the same problem ive reinstalled and everything nothing is working

  • modekimodeki Posts: 0

    Im having the same problem ive reinstalled and everything nothing is working

    SS 51.png
    1342 x 392 - 119K
  • kdobbekdobbe Posts: 0

    Using Mac 10.15.4 and have tried reloading and looking at varoius threads... Not working!

  • Totte said:

    Look at the postgres.log file, it use to say if permissions are wrong.

    It's in ContentCluster and is named dblog.txt

    Where do i find the dblog.txt?

    in my /user/library/Application Support/DAZ 3d /cms is just one file named cmscfg.json, nothing else. 

  •  

    Totte said:

    Look at the postgres.log file, it use to say if permissions are wrong.

    It's in ContentCluster and is named dblog.txt

    Where do i find the dblog.txt?

    in my /user/library/Application Support/DAZ 3d /cms is just one file named cmscfg.json, nothing else. 

    This is the same problem I have, is there any solution or are we looking in the wrong place? Tried spotlight and finder too also with no results (on 2015 mac running 10.14.6)

  • Ditto for me, no log file. Totally not working in macOS 10.15.4. Bummer.

  • I had this same problem and found multiple issues. First was having IBL Master installed, it was causing the CMS to fail running. Then it was a fresh install of Catalina, because I had it working on an upgrade. As found aboue you need to go into Finder and browse to the CMS Content Fold "/Users/{userid}/Library/Application Support/DAZ 3D/cms/ContentCluster" and click "Get Info" on the bottom you can unlock the settings, then click the settings gear and select the option to make yourself the owner of the foldr then apply. This is what ultimately fixed my issues in a fresh Catalina install to get the CMS running.

  • TotteTotte Posts: 11,795

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

  • composerpcomposerp Posts: 0

    Totte, we just wanted to say thank you. Your tool worked for us in Mojave. I really appreciate your help. The problem was driving me and my husband nuts!

  • Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

    Oh my god this also worked for me, with Catalina10.15.3.

    What I did was, with postgre installed with IM, close daz and used your tool and open again.

    Then the login window showed up.

     

    Thank you so much

  • Your file worked for me as well. Daz should give you a cut of their profits for saving their software.

  • dod_fisherdod_fisher Posts: 0
    Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

    You sir are a STAR!  Thank you!

     

  • Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

    Where do I add these zipped files to fix this program?? I am having the same problem and cannot figure out what the heck to do! I am not a very computer savvy person either!! 

     

    Jess

    error.JPG
    778 x 282 - 36K
  • I have the same PostgreSQL issue. I have tried everything I can find to fix it, including uninstall and reinstall, redownloading, beta download, changing port, changing ownership permissions. Still same problem.

    I have the same PostgreSQL issue. I have tried everything I can find to fix it, including uninstall and reinstall, redownloading, beta download, changing port, changing ownership permissions.

    ...  AND STEEL NO SOLUTION FROM DAzzz! ...zzz ...zzz .zzz!

    Perhaps the best solution is to stop buying things from unstables software!

    Screen Shot 2020-11-17 at 7.41.51 PM.jpg
    476 x 228 - 40K
  • jkc135r said:
    Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

    Where do I add these zipped files to fix this program?? I am having the same problem and cannot figure out what the heck to do! I am not a very computer savvy person either!! 

     

    Jess

    I run that script but couldn't fix all these f*ckn' issues!

    Totally annoying!!!

     

    Screen Shot 2020-11-25 at 12.08.41 AM.png
    796 x 654 - 114K
    Screen Shot 2020-11-17 at 7.41.51 PM.jpg
    476 x 228 - 40K
    Screen Shot 2020-11-17 at 7.20.43 PM.jpg
    664 x 413 - 68K
    Screen Shot 2020-11-17 at 7.47.23 PM.jpg
    597 x 362 - 58K
  • TotteTotte Posts: 11,795
    jkc135r said:
    Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

    Where do I add these zipped files to fix this program?? I am having the same problem and cannot figure out what the heck to do! I am not a very computer savvy person either!! 

     

    Jess

    Yopu unpack and run it.

  • TotteTotte Posts: 11,795
    Daichimax said:

    I have the same PostgreSQL issue. I have tried everything I can find to fix it, including uninstall and reinstall, redownloading, beta download, changing port, changing ownership permissions. Still same problem.

    I have the same PostgreSQL issue. I have tried everything I can find to fix it, including uninstall and reinstall, redownloading, beta download, changing port, changing ownership permissions.

    ...  AND STEEL NO SOLUTION FROM DAzzz! ...zzz ...zzz .zzz!

    Perhaps the best solution is to stop buying things from unstables software!

    pgAdmin is nothng you have to worry about, it comes with pg. 
    Did you try the steps described above?
    And, the issues are that Apple has been changing things in their OS which causes issues like this. The reasons for the changes are good intent, (stop malware), but anything out of the ordinary will sometimes suffer.

  • jkc135r said:
    Totte said:

    To fix the PostgresSQL issues on Catalina, I made this little tool.

     http://4eyes.code66.se/wp-content/uploads/2020/04/Fix-DSCMS.app_.zip

     

    Where do I add these zipped files to fix this program?? I am having the same problem and cannot figure out what the heck to do! I am not a very computer savvy person either!! 

     

    Jess

    I run that script but couldn't fix that postgreSQL issues!

     

  • TOTTE YOU LEGEND!!!! 

Sign In or Register to comment.