Viewport selection tool ignores selection?

This is a very basic question...

I have the Universal Tool selected.

I hover it over the item I want to select in the Viewport. It turns yellow (or something near it turns yellow).

DS goes into its flashy-flashy mode where it cycles through the nearby items turning them yellow one after the other...

When it comes to my item, I click on it, expecting it to be selected. It ignores the click and continues on its flashy-flashy cycle until it comes back to my item. I click again. It ignores the click and continues through the cycle.

So, I think, maybe it needs a double-click?

When it comes around again, I double-click and it ignores the clicks and continues yet again. When it comes around yet again I double-click faster, still no luck.

I finally give up and hunt for it in my long list of scene props, which is very slow compared to clicking (if clicking worked) because you have to hunt hunt, expand, hunt, hunt (filtering is not always faster).

 

Am I doing it wrong? It seems intuitive to hover over the item and click when it turns yellow, but it doesn't seem to work and it's very time-consuming to search through the Scene list. Those extra seconds add up very quickly.

Comments

  • It should keep switching the seelction, unless your hand is shaking the mouse (or stylus) (unless the item you are clicking on is unseelctable (x on the pointer icon next to the eye icon in the Scene pane). What happens if you right-click?

  • jpetersen_a5a5cae9jpetersen_a5a5cae9 Posts: 61
    edited November 2019

    I don't have any of the scene items x-ed out. They all have checkmarks next to them.

    This behavior doesn't happen when there are a small number of large items and they are spaced apart. Then it's possible to click them.

    It happens when there are more items (let's say a dozen or more) and they are closer together (but not entirely overlapping, which means it should be able to tell which one I want) and smaller. The yellow flashy-flashy thing (what is this called in DS?) cycles round and round and no amount of clicking is acknowledged by the Viewport. The only way I can select is in the Scene pane which is a very slow way to grab things. I'm quite sure the stylus isn't shaking.

    Post edited by jpetersen_a5a5cae9 on
  • I can't say I've ever seen this - aiming at small items, such as jewellery props, can be tricky but once I fianlly have the pointer in the right place it's stable. I suppose it might be a mouse driver issue.

  • I'm using a stylus. I haven't used a mouse in more than 15 years.

    I don't have problems like this in the other 20-or-so graphics programs that I use on a regular basis (Photoshop, ZBrush, Terragen, InDesign, Carrara, Shade, Illustrator, and umpteen others), so I don't think it's a driver issue or a cursor shake or position issue. I'm pretty sure this has something to do with how DS interprets clicks in the Viewport when there are multiple items and some of them are close together. The same thing happens on two different computers with two different versions of the OS and two different models of tablets.

    I think I understand what it's trying to do (when things don't work right, sometimes it's hard to discern the intention). When items are close together it needs to determine which item the user wants, so it cycles through the ones close to the cursor, but the actual selection process when the desired item lights up doesn't seem to work as items are added. I'm beginning to wonder if it's a timing issue with the software.

    It's quite frustrating. I have to rely on the Scene Panel and Poser Panel for adjusting things when it would be much faster to click and drag.

  • No, DS does not cycle through the possible selection targets.

  • jpetersen_a5a5cae9jpetersen_a5a5cae9 Posts: 61
    edited November 2019

    Oh! And here I thought it was a feature of the interface to help the user select the right item if some were close together.

    Well if it's not intended to help you select the desired item, then it's very strange behavior, and it does the same thing on Maverick, High Sierra and Mojave (and two different versions of DS).

    The Viewport is active, you reach for an item but haven't clicked it yet, it turns yellow, if you don't click right away, the next item in the cycle turns yellow, then the next and the next and the next, around and around in the circle, and when it is doing this it doesn't even recognize the user selection click if there are a dozen or so (or more) items, it ignores it and continues to flash around in the same cycle. It makes it necessary to select the item in the Scene pane rather than the Viewport when it happens.

    I've never seen this behavior with any other graphics software.

    Post edited by jpetersen_a5a5cae9 on
Sign In or Register to comment.