Victoria 4 in Carrara?

Hello everyone,

Quick question here.

Is Victoria 4 not compatible with Carrara 8.5? I've downloaded a bunch of the assets, including the V4 base, etc, through DIM, but none of it shows up in the Content folder in Carrara.  Everything else I've downloaded through DIM shows up just fine. But the V4 stuff, no dice. Even after updating the folder, etc.

Any kind of known issue? I could swear I'd gotten it to show just fine in the past. It's a Genesis or Genesis 2 model, at latest, right? So there shouldn't be a compatibility problem?

Thanks.

«1

Comments

  • MystarraMystarra Posts: 31,878

    works fine for me

    did you link it to the carrara browser tray as a poser runtime?  v4 is a native poser figure.

  • TCYTCY Posts: 296
    edited September 2

    I did not. I thought it was brought in via adding Content like the others. I'll give that a try. Thanks :)


    EDIT:
    Okay.. Just re-downloaded and added as a Poser Runtime this time. Folders show up in the Content tab, but nothing is in them. Basically the same thing that happened when I added it as Content.

    Hmm.

    Post edited by TCY on
  • UnifiedBrainUnifiedBrain Posts: 2,122

    If your DIM is set up properly with Carrara, you shouldn't have to add other folders.  V4 should load and work fine.

    Are you talking about the content tab, or do you mean the smart content tab?  In the regular content tab, V4.2 shows up under figures>Daz people.

  • DiomedeDiomede Posts: 9,613

    When Victoria 4 was released years ago, the Daz genesis duf format did not exist.  Victoria 4 was released in Poser "cr2" format in the traditional Poser Runtime file structure.  I installed Daz Victoria 4 to my computer using DIM.  I did name my host folder a custom name (Stuff for Studio), but other than that I allowed DIM to install everything to its default location.  If you did also, than the relative locations should be the same (substitute "My Daz Library" for the places where I have "Stuff for Studio")

     

    The V4.2 figure is found in the Runtime \ Figure \ Daz People    subfolder

    The morphs for V4.2 have to be applied.  They can be found in the Runtime \ Poses \ Daz's Victoria 4    subfolder.

    My Carrara came with some Carara-optimized shaders for V4.  Not sure that came with all editions of C8.5, but probably so.  My shaders were found under the shader tab in the Skin subfolder.

    content file structure.JPG
    1552 x 795 - 145K
    content location daz people victoria a.JPG
    1469 x 845 - 213K
    find poses for morphs.JPG
    1504 x 804 - 131K
    find poss folder.JPG
    1549 x 824 - 185K
    find shaders in carrara shader tab skin folder.JPG
    1552 x 765 - 160K
  • TCYTCY Posts: 296
    edited September 2

    I don't have Smart Content "active" (not signed in, etc). So I'm working strictly out of Content. I'm using the same setup I've always used in the past, and it worked fine. Not sure why it isn't this time. Thought maybe I was thinking of a different version and V4 wasn't compatible, but apparently it is.

    Gonna try re-downloading to the default location and see if that makes a difference. Setting this all up for the first time on a new PC. Not sure if that would have anything to do with it. 


    Okay, got it to load in as a Runtime. But now none of the clothes or accessories will attach correctly.

    I think I'll just stick to other figures lol.  Carrara gives me a different headache every time I install/set it up. Looks like it's V4 this time. Ah well.

    Thanks for the help/tips!

     

    Post edited by TCY on
  • I've had the same issue.
    The problem with this is that DIM download all the files in public documents but i couldn't get access from Carrara to public documents, so they didn't appeared in the libary.
    In DIM i've changed the downloaded path to user documents and changed all the content there, than added manually the fully libary in Carrara and than i've got access to all the files.

  • TCYTCY Posts: 296

    I've had the same issue.
    The problem with this is that DIM download all the files in public documents but i couldn't get access from Carrara to public documents, so they didn't appeared in the libary.
    In DIM i've changed the downloaded path to user documents and changed all the content there, than added manually the fully libary in Carrara and than i've got access to all the files.

    That's how I set it up the first time and it didn't work. So I tried setting it up with the default settings, and that didn't work, either. 

    So, I'm at a loss. Like I said before, every time I install Carrara - specifically trying to use DAZ models - something weird happens. The only ones I can get to work consistently are the original Genesis and anything based on that. Very weird.

  • MystarraMystarra Posts: 31,878

    Wont sttach?  Do you mean conforming clothes?

  • MystarraMystarra Posts: 31,878

    You could try the auto detect runtime option?

     

    ive never used dim alwsys installed manually

  • MystarraMystarra Posts: 31,878

    For aiko 4 i load her without deformers. Her shoulders act wonky with some of her char morphs

  • MystarraMystarra Posts: 31,878

    To avoid much of those permissions issues i crested a hdd drive partition and took ownership of it. In windows

  • TCYTCY Posts: 296

    @Mystarra,

    Yeah, they don't attach correctly. And it's clothes made for the specific V4-based figure I'm loading. They kinda "float" inside their body. Really odd.

  • 3DAGE3DAGE Posts: 3,301

    With V4 / M4 , you should first select the figure in the Scene list,. then browse to the figure's clothing and double click to load and "auto-conform" to the figure.

    hope it helps

  • Steve KSteve K Posts: 1,967

    I don't use the DIM, just download the product and create a folder where I can extract the Runtime.  V4 works fine for me, see attached screenshot.  The V4 figure was dropped into the scene from the "Poser 7/Figures/DAZ People" runtime.  The clothing items were then dropped onto the V4 figure and were automatically conformed to the figure.  

    Carrara V4.jpg
    1600 x 900 - 233K
  • TCYTCY Posts: 296
    edited September 2

    Well, I'm at a loss. I've uninstalled and reinstalled a few times now, trying everything from default location via DIM, to custom location via DIM, to manual installation.. Nothing's working for me. 

    It shouldn't be this compllicated to get it working, and I'm running low on patience trying to figure it out. Ideally, DIM would install and set everything up to work properly with Carrara. Alas. Also having trouble with DIM not displaying Bryce 3D as an available download even though I own Pro, and have the proper download filter options selected, so it isn't just Carrara being weird.

    I'm checking out Hexagon with DS and so far so good. Gives me a wider set of figures to use, and transferring between the two works seamlessly. So, fingers crossed.

    Regardless, thanks for your time and feedback, everyone. I appreciate it.
     

    Post edited by TCY on
  • MystarraMystarra Posts: 31,878

    are you starting with a fresh new carrara scene?

    clear of unused objects

    might be a cross talk issue, was a thing in old poser days.
    way back in the day iirc was an issue if you had multiple m4 or v4 installs on the same pc  can't remember the why of it

    does she work in DS?  or Poser if you have it installed?

  • MystarraMystarra Posts: 31,878

    also, there is no autofollow on poser figures.  the clothes need the corresponding morphs you are using on your figure.

  • DiomedeDiomede Posts: 9,613
    TCY said:

    @Mystarra,

    Yeah, they don't attach correctly. And it's clothes made for the specific V4-based figure I'm loading. They kinda "float" inside their body. Really odd.

     

    If you give the specific V4-ased figue and specific clothing item, maybe one of us has it and can test if it works on our system. 

  • MystarraMystarra Posts: 31,878

    Carrara 7 came with hi-res texture map for V4.

  • TCYTCY Posts: 296
    edited September 7

    Hello again,

    So I completely removed and completely reinstalled everything, after doing a Registry clean, etc.

    Victoria 4.2 loads okay,and all the outfits and such I have show in the Content browser, poses work just fine, but I'm still dealing with clothing/accessories not showing up on the character, or not fitting right even after I conform it to Victoria 4.2. I can drag and drop, I can double-click, doesn't matter. They're all items specifically made for Victoria 4. 

    One thing that's changed this time around is, when trying to load clothing items, it's randomly freezing and crashing the program.

    It's understated to say this is at least the 12th attempt at making this work. Every time, some part of it works, but the rest doesn't. I'm convinced it's not that I'm just "doing it wrong", because others in this thread have noted having issues - though different ones - while others say it worked just fine for them. There's gotta be something in how it's all programmed that keeps it from being consistent on all systems.

    I'm installing the content via DIM
    I have all the Genesis 2 content in its own folder so that it's not conflicting with any other generations or related models, etc.
    I'm adding the folder via Content Browser > Content > Add Folder
    I'm selecting Runtime as the folder type.
    The V4.2 Runtime stuff gets its own folder.
    Victoria 4.2 loads fine.
    Poses attach and work fine.
    Clothing/Accessories show up, but won't fit right, if they show up on the character at all.

    So, just to avoid all the headaches, what is the most recent generation/figure combo that "just works" with Carrara? No tweaking, no fussing, no having to add the folder in some special way or recite cryptic incantations over burning candles and incense to make it all magically work the way it's supposed to? I've wasted way too much time on this already and I'd like to actually get to *creating* stuff, instead of trying to divine what's going through DAZ's mind when they're deciding how to make all this stuff work.

    I have Genesis, Genesis 2, Genesis 3 (which I know requires a special user-made mod), Genesis 8 (ditto). I have various figures for each.

    Thanks again for everyone's help and time. Sorry for the ranty-ness.. It's my aggravation talking.

     

    Post edited by TCY on
  • SadKitty_CarraraSadKitty_Carrara Posts: 22,019
    edited September 7

    you also need to click the bat files under  your drive:\My Library\Runtime\Libraries\!DAZ 

    you basically need to do the same thing as Poser

    legacy installers
    http://docs.daz3d.com/doku.php/artzone/pub/software/installingcontentintoposer/start

    this may help 

    https://helpdaz.zendesk.com/hc/en-us/articles/207530443-Adding-Content-installed-by-Install-Manager-to-DAZ-Studio-or-Poser

    Post edited by SadKitty_Carrara on
  • TCYTCY Posts: 296

    Hey there. Thanks, SadKitty.

    I'm actually here to say that I seem to be going smoothly with the Victoria 5/Michael 5 figures. Everything's been "just working" so far. Doesn't look like there's as much stuff available on the store for them, but my understanding is that items can be "fit to" the given base figure (Genesis, Genesis 2, etc). 

    So, I'm happy lol. That's all I wanted to sort out; to reliably and smoothly get characters into Carrara. 

    Apologies again for the ranty stuff. I just really want to get into creating stuff and learning more about this workflow. Not having the characters working correctly was getting in the way and really bumming me out. I went with V4 because I happen to have the most stuff for that (in case anyone's wondering why I was insistant on using 4 instead of 5, etc)

    Maybe I'll try V4 again in the future sometime... Maybe. lol
    But I'm set for the time being.

    Thanks again

  • honestly 4 should work well in Carrara but you don't load them from your content library like Genesis figures

    also if you use morphs the clothes also need those morphs some need extra unimesh fits to do it or something like Morphing Clothes by Dimension 3D which I use

    it is available at Renderosity

  • TCYTCY Posts: 296
    edited September 7

    Yeah, someone in a previous comment mentioned that they have to be brought in as Runtime. I tried that, and it brought them in, but things still didn't work correctly. It's fine, though. I'm perfectly happy using 5 for the time being.

    The part about using morphs and unimesh... -whoosh- lol. That's right over my head. I've just now found a way to reliably get figures into Carrara lol. Figuring out how to morph and such can wait for now. Just figuring out how to apply different hair color to Stalker Girl hair at the moment. Doesn't seem to want to update, so I'm looking for some kind of instructions.

    Was Genesis support sorta cobbled in to Carrara when DAZ bought it (IIRC it was originally made by a different company), and that explains why there's - seemingly - so many different factors and things to consider and account for when importing and using stuff? Like, why is Victoria 5 importing just fine as Content, and previous stuff imports fine as Content.. for Victoria 4 needs to be Runtime. Does DAZ like to just try random things from one figure to the next?

    Part of my frustration in learning this (importing/using Genesis characters) has been that there doesn't seem to be any kind of clear, clean and consistent workflow for it. Seems the process changes, becoming more or less complicated, depending on what you're trying to use. That's really unusual compared to pretty much any other program I've ever used. Most cases, using an installer/manager, you select the content, select "install", and the installer sets everything up for you and you're good to go. You don't even have to know how it's being set up. Manual installations are generally as straight-forward as just downloading and unzipping into a specific addons/plugins/etc folder. Then you restart the program, or click a "rescan addons" option, and the program does the rest. Other programs have the ability to install from zip file right from within the program, which places everything where it needs to be. And so on. In all cases, the user doesn't need to worry about the nuances or particulars of where/how/why. They just need to install and go. Carrara's the first program where it doesn't seem to (consistently) work like that. I'm rather curious why that's the case.

    Post edited by TCY on
  • DiomedeDiomede Posts: 9,613
    edited September 7

    Nothing is fool proof because fools are so ingenious.

    TCY - sorry for your frustration.  I've been there.  I've been there in Poser, in Daz Studio, in Carrara, in Bryce, and in Blender.  Nothing just works. Thus my tag line in my forum signature.  Aaaargh.  Happy to try to help you diagnose and solve your problems.

     

    Victoria 4 and Michael 4 work seamlessly for me in Carrara. What I mean is that Carrara reads their rigging correctly (uses CR2 fles) without any plugin.  Carrara loads their mesh correctly, applies their morphs correctly, and applies their poses correctly.  I don't like the blue tint multiplied to the diffuse maps by default, but I can't really call it an error.  So, some shader tweaking is required.  The conforming clothing/hair figures and smart props designed for V4 and M4 work seamlessly for me in Carrara.

     

    Currently, I use the Genesis 2 figures (or my own custom rigged figures)  for the vast majority my projects.  However, I use V4, M4, or even earlier on occasion.  I also use the Poser 4-7 figures regularly.

     

    At the moment, I can't reproduce the bad results you are getting with generic references to V4.  My V4 stuff works on my system with my installation.  So, perhaps if you post the exact content you are using with V4 maybe I can try to use it on my system and see if there is a problem.  Remember, V4/M4, the Poser figures, etc., do not have the auto-morph projections that the genesis figures have.  The V4 conforming clothing figures have to have matching morphs (or be adjusted).

     

    I know it sounds annoying.  If you still have any patience left, tell us the specifics.  Here is an example of why.  Do the V4 pants found in the "V4 Morphing Clothing" runtime subfolder work with V4?  Although the answer is yes, it is easy to demonstrate an example that appears like they don't work.  Here we go.

     

    - I started a new Carrara scene. 

    - I loaded V4 from my Runtime \ Library \ Figures \ Daz People subfolder.   ( I also applied a Carrara skin shader and loaded some hair but ignore that for now).

    - From the Runtime \ Library \ Poses \ Daz's Victoria 4 \ Morph Injections subfolder, I dragged and dropped the + injection files for Basic, Morph++, Elite, and Aiko 4 on to my V4 figure to load them.

    - From my Figures \ V4 Morphing Clothing subfolder, I loaded the JYTop and the V4Pants.  Please load those specific ones for his demonstration.

    *** I loaded these two clothing items independently.  For now, I did NOT drag and drop them on V4 or double click them with V4 selected.  They are NOT fitted to V4 yet ***

    - With V4 selected, I went to the parameters tab to see a list of morphs.  I dialed Aiko 4 to 1.  I also selected the V4 right thigh and rotated the thigh forward and up.  You can see that neither the top nor the pants look correct.

    - I selected the top and used fit to V4, and selected the pants and used fit to V4.  See that the top now fits fine.  The pants conform to the pose but do not seem to fit the shape.

    - Looking closely at the JYTTop figure parameters, notice it as an Aiko4 morph and it has automatically dialed to 1 to match the V4 figure morph.

    - In contrast to the top, choosing the pants parameters, there is no Aiko 4 morph present in the pants.  That is why the shape looks wrong (and also a tweak for the thigh bend to a lesser degree).

    - Looking more closely at the pants parameters, there are a whole bunch of morphs present, jut not Aiko 4.

    - To test, I selected V4 again, dialed Aiko 4 morph back to 0, but dialed bodybuilder up to 1. 

    - The pants match the V4 morph because there IS a bodybuilder morph in the pants.

     

    *** Although it appears that the V4 morphing pants didn't work with my first test of V4, that wasn't true.  The pants don't happen to have Aiko4 morphs.  The JYTop does.

     

    bb01 v4 loaded with v4 morphing clothes jytop but no fit to yet.JPG
    1594 x 846 - 246K
    bb02 morphed V4 to aiko 4 clothes dont morph cause not fit to yet.JPG
    1329 x 816 - 132K
    bb04 use fit to for top and pants top fits and pants conform to pose but ont fit aiko morph.JPG
    1467 x 829 - 156K
    bb05 see jy top has an aiko morph.JPG
    1591 x 825 - 162K
    bb06 but the pantsdo not have an aiko morph.JPG
    1585 x 825 - 159K
    bb07 pants do have lots of morphs just not aiko.JPG
    1590 x 836 - 174K
    bb08 bodybuilder morph on v4 and pants morph with.JPG
    1600 x 845 - 160K
    bb09 v4 pants have the bodybuilder morph.JPG
    1320 x 847 - 133K
    Post edited by Diomede on
  • SadKitty_CarraraSadKitty_Carrara Posts: 22,019
    edited September 7

    the problem is both DAZ and the original creators of Carrara supported Poser content

    DAZ made content for Poser

    then

    DAZ started making their own DAZ studio content hence the different types of content

    I do hope you are not loading V4 etc from Smart Content either, please just for your own sanity ignore that tab, it was never implimented properly

    Post edited by SadKitty_Carrara on
  • UnifiedBrainUnifiedBrain Posts: 2,122

    I have been using Carrara for 3 years.  I don't want to gloss over your issue, but honestly, I have never had the problem that you are describing.  I've also done a lot of reading of Carrara posts from the past.  I have never seen a problem exactly the same as yours in any of those posts.

    I think that folks here are stumped because the problem is so unusual.  That is why you are getting such a wide array of answers, and not because Carrara has any difficulty importing and using content.  The normal Carrara workflow is very straightforward.  In fact, Carrara has a better-than-normal ability to download and use a wide variety of content.  That is a strength, not a weakness.

    All that said, I feel your pain.  The frustration must be unbelievable, as all artists want to be creating renders and not solving problems all of the time..  Most Carrara issues have very simple solutions, and a high percentage are operator error.  But finding that solution or uncovering that error can be very difficult.  I hope that you keep trying.

    Is there any chance that you can post screen shots of good examples of how the problem is viewed?  For example, you say that V4 clothing sometimes shows up but either "floats" or doesn't fit.  A picture of that might help someone see a possible solution.

  • DiomedeDiomede Posts: 9,613
    edited September 7
    TCY said:



    Was Genesis support sorta cobbled in to Carrara when DAZ bought it (IIRC it was originally made by a different company), and that explains why there's - seemingly - so many different factors and things to consider and account for when importing and using stuff? Like, why is Victoria 5 importing just fine as Content, and previous stuff imports fine as Content.. for Victoria 4 needs to be Runtime. Does DAZ like to just try random things from one figure to the next?

     

     

    The "Runtime" folder structure is the previous standard as part of the posing/rendering program Poser.  The original Daz3D figures (now called Victoria 1 and Michael 1) were created for use with Poser.  Daz Studio and genesis content/duf did not exist. Victoria 1-4, Michael 1-4, etc. were created in the Runtme folder structure and their rigging systems were CR2 files (Poser's rigging).  Daz3D releasing Daz Studio was an alternative to Poser.     

     

    Post edited by Diomede on
  • SadKitty_CarraraSadKitty_Carrara Posts: 22,019
    edited September 7

    just checking this is what you have and are loading from

    Capture.JPG
    465 x 408 - 50K
    Capture1.JPG
    1920 x 1048 - 546K
    Post edited by SadKitty_Carrara on
Sign In or Register to comment.